+ Responder ao Tópico



  1. Fala ae galera coloquei na nova versão no mk 5.x aqui na minha rede, aé agora esta otimo só um seguinte problema que não concegui resolver ainda e o problema de ddns, changeip .
    alguem teria um scrpit que funcionase
    gratooo
    a todoss
    Última edição por deividanselmo; 27-03-2011 às 10:23.

  2. Segue abaixo,

    :global ddnsuser "SEU_USUARIO"
    :global ddnspass "SUA_SENHA"
    :global ddnshost "ENDEREÇO_REMOTO"
    :global ddnsinterface "NOME_DA_PORTA_QUE_ESTA_O_LINK"

    :global ddnssystem ("mt-" . [/system package get [/system package find name=system] version] )
    :global ddnsip [ /ip address get [/ip address find interface=$ddnsinterface] address ]
    :global ddnslastip

    :if ([:len [/interface find name=$ddnsinterface]] = 0 ) do={ :log info "DDNS: No interface named $ddnsinterface, please check configuration." }

    :if ([ :typeof $ddnslastip ] = "nothing" ) do={ :global ddnslastip 0.0.0.0/0 }

    :if ([ :typeof $ddnsip ] = "nothing" ) do={

    :log info ("DDNS: No ip address present on " . $ddnsinterface . ", please check.")

    } else={

    :if ($ddnsip != $ddnslastip) do={

    :log info "DDNS: Sending UPDATE!"
    :log info [ ut [/tool dns-update name=$ddnshost address=[ick $ddnsip 0 [:find $ddnsip "/"] ] key-name=$ddnsuser key=$ddnspass ] ]
    :global ddnslastip $ddnsip

    } else={

    :log info "DDNS: No changes necessary."

    }

    }
    Cadastre-se no Enhanced Dynamic DNS Solutions






Tópicos Similares

  1. Ajuda com script pra desabilitar controle de banda
    Por cleciorodrigo no fórum Redes
    Respostas: 0
    Último Post: 10-06-2007, 07:30
  2. ajuda com script ddns
    Por gotch no fórum Redes
    Respostas: 2
    Último Post: 14-02-2007, 22:23
  3. Ajuda com script (bash)
    Por sarna no fórum Linguagens de Programação
    Respostas: 2
    Último Post: 08-03-2005, 21:42
  4. Ajuda com script para travar programa
    Por gamefe no fórum Linguagens de Programação
    Respostas: 1
    Último Post: 10-02-2005, 16:13
  5. ajuda com script
    Por dboom no fórum Servidores de Rede
    Respostas: 1
    Último Post: 01-02-2004, 22:13

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L