Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Instala o debian sem selecionar nenhum software apenas o sistema funcional...

    http://api.ning.com/files/qZUEvAaY4L...8/syslogng.jpg

    Após instalar faça:

    aptitude purge rsyslog

    aptitude install syslog-ng

    nano /etc/syslog-ng/syslog-ng.conf
    --------------------------------------------------------------------------
    @version: 3.1
    #
    # Syslog-ng configuration file, compatible with default Debian syslogd
    # installation. Originally written by anonymous (I can't find his name)
    # Revised, and rewrited by me (SZALAY Attila <sasa@debian.org>)

    # First, set some global options.
    options { long_hostnames(off); flush_lines(0); use_dns(no); use_fqdn(no);
    owner("root"); group("adm"); perm(0640); stats_freq(0);
    bad_hostname("^gconfd$");
    };

    ###########
    # sources #
    ###########

    # all known message sources
    source s_mikrotik {
    udp();
    };


    ################
    # destinations #
    ################

    destination df_destino_mikrotik { file("/var/log/mikrotik/destino/destino-$YEAR$MONTH$DAY.txt" create_dirs(yes)); };

    destination df_auth_mikrotik { file("/var/log/mikrotik/auth/auth-$YEAR$MONTH$DAY.txt" create_dirs(yes)); };

    ##########
    # filter #
    ##########

    filter f_auth_mikrotik { match("AUTH"); };

    filter f_destino_mikrotik { match("DESTINO"); };

    ######
    # logs
    log {source(s_mikrotik); filter(f_destino_mikrotik); destination(df_destino_mikrotik); };

    log {source(s_mikrotik); filter(f_auth_mikrotik); destination(df_auth_mikrotik); };
    --------------------------------------------------------------------------
    obs: com essa nova versão do syslog-ng ele da uma mensagem de cuida com a função match e value dizendo que é ela esta em desuso por cusar perca de performace...
    Ainda não consegui resolver essa mensagem de aviso... Se alguém tiver alguma idéia será bem vindo a ajuda...


    No Mikrotik

    /ip firewall nat
    add action=log chain=dstnat disabled=no dst-address=!192.168.14.0/24 log-prefix=DESTINO protocol=tcp


    /system logging action
    set remote bsd-syslog=no name=remote remote=192.168.14.101 remote-port=514 \
    src-address=0.0.0.0 syslog-facility=daemon syslog-severity=auto target=\
    remote


    /system logging
    add action=remote disabled=no prefix="" topics=firewall,info
    add action=remote disabled=no prefix=AUTH topics=hotspot,account,info
    add action=remote disabled=no prefix=AUTH topics=hotspot,debug,info
    obs: em set remote bsd-syslog=no name=remote remote=192.168.14.101 remote-port=514...
    remote=[ip do seu debian com o syslog-ng]

    DICA:
    Para maior segurança add essa regra no firewall se seu servidor de log se ele for apenas servidor de log:
    iptables -A INPUT ! -s 192.168.14.10 -j DROP

    192.168.14.10= IP do mikrotik ou seja ele so vai aceirtar entrado apenas do servidor mikrotik para a gravação de log.

    Original:
    http://mk-auth.com.br/forum/topics/t...s-gerar-log-de

    Agradecimentos são bem vindos...
    Última edição por wilkerpaz; 10-04-2011 às 18:29.

  2. Boa vou testar..



  3. Se funcionar tudo direitinho volte para respoder como foi sua implementação...

    Obrigado,

  4. Opa sem problema aqui ta a maior correria mas assim que tiver algo pronto posto..


    abcs



  5. Bem interessante, vou testar. Depois posto resultado.






Tópicos Similares

  1. Respostas: 9
    Último Post: 31-07-2016, 12:00
  2. Respostas: 3
    Último Post: 10-03-2015, 22:14
  3. Ssh do mikrotik para um servidor na rede.
    Por dlabreu no fórum Redes
    Respostas: 3
    Último Post: 09-06-2013, 12:14
  4. Respostas: 0
    Último Post: 06-11-2012, 08:18
  5. Respostas: 3
    Último Post: 17-05-2012, 19:59

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L