Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Selecionar quem sai pelo link 1 e quem sai pelo link 2 no Mikrotik

    Olá amigos, estou com uma pequena dificuldade, não quero usar o load-balance, tenho dois links, um dedicado e outro dsl. Tenho um provedor de internet wireless e vendo link para outros provedores e lan houses. Gostaria de adicionar uma regra no meu servidor para escolher os meus clientes wireless para sairem pelo link dsl e os outros provedores e lan houses pelo dedicado. Como posso fazer isso??

    Antecipadamente obrigado!

  2. #2

    Padrão Re: Selecionar quem sai pelo link 1 e quem sai pelo link 2 no Mikrotik

    Olá kaioacg,

    Uma opção é você colocar ip fixo nos clientes e utilizar o mangle para selecionar a rota de saída.
    Exemplo:

    /ip firewall mangle chain=prerouting action=mark-routing new-routing-mark=link1 passthrough=no src-address=192.168.1.0/24

    /ip firewall mangle chain=prerouting action=mark-routing new-routing-mark=link2 passthrough=no src-address=192.168.2.0/24

    Não esqueça de criar as marcas de rotas em ip/routes.
    Um grande abraço.



  3. #3

    Thumbs up Re: Selecionar quem sai pelo link 1 e quem sai pelo link 2 no Mikrotik

    Uso essas seguintes faixas:
    10.40.0.0/22 - meus clientes (todos com ip fixo)
    192.168.150.0/24 - os outros pra quem vendo link (todos com ip fixo tbm)

    e os link:
    link1: 192.168.2.1 - link dedicado
    link2: 192.168.1.1 - link dsl

    como prosseguir?? se você puder me mandar a regra agradeço!

  4. #4

    Padrão Re: Selecionar quem sai pelo link 1 e quem sai pelo link 2 no Mikrotik

    Defina as rotas:

    /ip route add comment="Rota p/ Link Dedicado" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.2.1 routing-mark=dedicado scope=30 target-scope=10

    /ip route add comment="Rota p/ Link ADSL" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.1.1 routing-mark=adsl scope=30 target-scope=10

    Com as rotas criadas é só você direcionar os clientes para os links através do mangle:

    /ip firewall mangle chain=prerouting action=mark-routing new-routing-mark=dedicado passthrough=no src-address=10.40.0.0/22

    /ip firewall mangle chain=prerouting action=mark-routing new-routing-mark=adsl passthrough=no src-address=192.168.150.0/24

    Atenção: Não se esqueça de que é necessário deixar a rota padrão, e as regras do mangle devem preceder outras regras de redirecionamento.

    Tente entender as regras acima, e não apenas copiar e colar, mas sim adaptar conforme as suas necessidades, com isso você resolve o seu problema e ainda aprende muito mais.
    Um grande abraço,



  5. #5

    Padrão Re: Selecionar quem sai pelo link 1 e quem sai pelo link 2 no Mikrotik

    Fiz como o amigo michaelbr disse só que no meu caso não deu certo =/

  6. #6

    Padrão Re: Selecionar quem sai pelo link 1 e quem sai pelo link 2 no Mikrotik

    Faz o seguinte colega:

    Abra uma janela do terminal e da um print em suas configs e posta aki pra gente dar uma olhada.

    /ip address print
    /ip route print
    /ip firewall mangle print

    Com essas informações fica mais fácil de te ajudar.
    Um grande abraço,



  7. #7

    Padrão Re: Selecionar quem sai pelo link 1 e quem sai pelo link 2 no Mikrotik

    Certo amigo, la vai a configuração...

    Ip Address
    # ADDRESS NETWORK BROADCAST INTERFACE
    0 201.2.96.34/29 201.2.96.32 201.2.96.39 ether1
    1 192.168.168.2/30 192.168.168.0 192.168.168.3 ether3
    2 ;;; ALUNOS
    192.168.1.254/24 192.168.1.0 192.168.1.255 ether2
    3 ;;; ALUNOS
    192.168.2.254/24 192.168.2.0 192.168.2.255 ether2


    Ip Route
    # ADDRESS NETWORK BROADCAST INTERFACE
    0 201.2.96.34/29 201.2.96.32 201.2.96.39 ether1
    1 192.168.168.2/30 192.168.168.0 192.168.168.3 ether3
    2 ;;; ALUNOS
    192.168.1.254/24 192.168.1.0 192.168.1.255 ether2
    3 ;;; ALUNOS
    192.168.2.254/24 192.168.2.0 192.168.2.255 ether2

    Ip Firewall mangle

    0 chain=prerouting action=mark-routing new-routing-mark=oi passthrough=no src-address=192.168.1.0/24

    1 chain=prerouting action=mark-routing new-routing-mark=embratel passthrough=no src-address=192.168.2.0/24

    2 ;;; Marca o com e sem TOS - aluno
    chain=postrouting action=mark-connection new-connection-mark=n-cache2 passthrough=yes protocol=tcp src-port=3128 dscp=4

    3 chain=postrouting action=mark-connection new-connection-mark=s-cache2 passthrough=yes protocol=tcp src-port=3128 dscp=!4

    4 ;;; Libera cache full - ifro alunos
    chain=postrouting action=mark-packet new-packet-mark=Cache-Packet passthrough=no connection-mark=n-cache2

    5 ;;; limita banda p2p
    chain=prerouting action=mark-connection new-connection-mark=p2p_conn passthrough=yes p2p=all-p2p

    6 ;;; limita banda p2p
    chain=prerouting action=mark-packet new-packet-mark=p2p passthrough=yes connection-mark=p2p_conn

    7 ;;; bloqueia ares
    chain=prerouting action=mark-connection new-connection-mark=ares passthrough=no p2p=warez

  8. #8

    Padrão Re: Selecionar quem sai pelo link 1 e quem sai pelo link 2 no Mikrotik

    Olá mauriciojmjr,

    Analisando as suas configurações notei que você não criou as rotas na tabela de roteamento com as marcas de rotas, sendo assim não vai funcionar as regras do Mangle.
    Dá uma olhadinha de novo nas regras que lhe passei no post anterior e revise linha por linha que vai funcionar colega.
    Um grande abraço,



  9. #9

    Padrão Re: Selecionar quem sai pelo link 1 e quem sai pelo link 2 no Mikrotik

    Bom dia, tenho um probleminha parecido. Estou com um loadbalance todando de boa, unica coisa queria que banco roda-se por link 1 junto com MSN e outros que nao permite loadbalance... Se eu achar solucao antes posto aqui. vlw

  10. #10

    Padrão Re: Selecionar quem sai pelo link 1 e quem sai pelo link 2 no Mikrotik

    MichaelBR

    Pode me ajudar,

    Hoje tenho uma rede totalmente em NAT, com 07 links e 1 dedicado, estou usando PCC mais não estou gostando, queria dividir os clientes por links, acho que ficaria melhor assim, mais uso PPPOE, tem como eu fazer essas regras que passou usando autenticação e como seria a topologia fisica disso? cada link uma placa de rede?

    Obrigado



  11. #11

    Padrão Re: Selecionar quem sai pelo link 1 e quem sai pelo link 2 no Mikrotik

    Mas no caso de definir as rotas marcadas ainda é necessario ter a rota deafult do mikrotik aquela 0.0.0.0/0 para o gateway xx:xx:xx:xx ou usa só as rotas marcadas e exclui a default ?

    No caso como tenho dois Links um dedicado e um ADSL as rotas ficariam assim ou posso remover a primeira neste exemplo que seria a rota default ?

    0.0.0.0/0 gateway xx.xx.xx.xx
    0.0.0.0/0 gateawy xx.xx.xx.xx rota marcada link dedicado
    0.0.0.0/0 gateway xx.xx.xx.xx rota marcada link ADSL



    E depois a marcação no mangle pela rota que eu achar melhor.

  12. #12

    Padrão Re: Selecionar quem sai pelo link 1 e quem sai pelo link 2 no Mikrotik

    Eu uso uma Rb450g Separada do servidor
    como usar esta forma de balanço???



  13. #13

    Padrão Re: Selecionar quem sai pelo link 1 e quem sai pelo link 2 no Mikrotik

    Citação Postado originalmente por michaelbr Ver Post
    Defina as rotas:

    /ip route add comment="Rota p/ Link Dedicado" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.2.1 routing-mark=dedicado scope=30 target-scope=10

    /ip route add comment="Rota p/ Link ADSL" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.1.1 routing-mark=adsl scope=30 target-scope=10

    Com as rotas criadas é só você direcionar os clientes para os links através do mangle:

    /ip firewall mangle chain=prerouting action=mark-routing new-routing-mark=dedicado passthrough=no src-address=10.40.0.0/22

    /ip firewall mangle chain=prerouting action=mark-routing new-routing-mark=adsl passthrough=no src-address=192.168.150.0/24

    Atenção: Não se esqueça de que é necessário deixar a rota padrão, e as regras do mangle devem preceder outras regras de redirecionamento.

    Tente entender as regras acima, e não apenas copiar e colar, mas sim adaptar conforme as suas necessidades, com isso você resolve o seu problema e ainda aprende muito mais.
    Um grande abraço,


    ola amigo ,, queria entrar em contato com voce ,, pq quando o hotspot ta ativo parece que essa regra nao funciona direito

  14. #14

    Cool Re: Selecionar quem sai pelo link 1 e quem sai pelo link 2 no Mikrotik

    Ola amigo, peço desculpas em ressucitar o tópico, mas como vc resolveu isso? estou com o mesmo problema, colocar mais um link e selecionar quem sai por ele.

    Porem quando ativo para tudo.

    Atenciosamente



  15. #15

    Padrão Re: Selecionar quem sai pelo link 1 e quem sai pelo link 2 no Mikrotik

    Opa, ressussitando o topico tambem tive o seguinte problema, no meu computador esta usado o link 1, beleza, fiz as regras funcionou mas a rede q eu coloquei para sair do link 2 do meu computador nao consigo mais acesso a rede nem ping funciona mais..

  16. #16

    Padrão Re: Selecionar quem sai pelo link 1 e quem sai pelo link 2 no Mikrotik

    Citação Postado originalmente por maionef Ver Post
    Opa, ressussitando o topico tambem tive o seguinte problema, no meu computador esta usado o link 1, beleza, fiz as regras funcionou mas a rede q eu coloquei para sair do link 2 do meu computador nao consigo mais acesso a rede nem ping funciona mais..
    opa, tb estou com o mesmo problema, as rotas funcionaram ok,mas elas não enxergam o restante da rede,vc resolveu esse problema?



  17. #17

    Padrão Re: Selecionar quem sai pelo link 1 e quem sai pelo link 2 no Mikrotik

    Olá pessoal estou acompanhando esse post e estou com um problema que talvez seja fácil para alguns.
    Tenho 2 links dedicados 2M cada + 1Adsl 5M, e fiz o seguinte configuração:
    link dedicado 1 -> team viewer acesso remoto
    link dedicado 2 -> 192.168.5.170-192.168.5.199 (Sala1)
    link adsl -> 192.168.5.20-192.168.5.160 (Sala2)
    ether1=adsl
    ether2=dedicado1
    ether3=dedicado2

    Bridge-local
    ether5= local
    wireless 2.4= local

    problema= os computadores que estão no link adsl não comunica com os que estão na wireless.

    estou fazendo marcação no mangle para que cada faixa de ip sai separado link.

  18. #18

    Padrão

    meu nobre estou com um problema parecido!


    uso 2 link para 2RBS


    e destinei um link para um ip e outro para outro ip


    link a: 137.2
    link b: 137.4

    só quero que o cada link saia para cada ip


    só que em vez de cada link sair pra cada ip, só funciona um link por vez, pra funcionar um tem que dezativar o outro!



  19. #19

    Padrão Re: Selecionar quem sai pelo link 1 e quem sai pelo link 2 no Mikrotik

    meu nobre estou com um problema parecido!


    uso 2 link para 2RBS


    e destinei um link para um ip e outro para outro ip


    link a: 137.2
    link b: 137.4

    só quero que o cada link saia para cada ip


    só que em vez de cada link sair pra cada ip, só funciona um link por vez, pra funcionar um tem que dezativar o outro!

  20. #20

    Padrão Re: Selecionar quem sai pelo link 1 e quem sai pelo link 2 no Mikrotik

    boa tarde galera alguem resolveu os seus problemas? preciso fazer o seguinte

    link 1 192.xxx.xxx.x 15mg velox
    link 2 192.168.2.100 6mgs radio

    lan 192.168.254.x
    hotspot xxx.xxx.xxx.x

    nao preciso de balançe so preciso que quando um link cair o outro assuma
    a velox aqui cai muito e ultilizo para servidor de tef supermercado nao posso ficar sem net aqui