+ Responder ao Tópico



  1. #1

    Padrão Processador xeon intel 100% oracle vmware server

    Estou com um servidor dell poweredge com as configurações:

    xeon dual core 2.4ghz 4mb l2
    8GB ddr2
    3x146GB scsi em raid 5
    placa de rede 1Gb/s

    migramos esse servidor para linux para rodar o oracle fisicamente no centos 64bits e um winodws 2003 AD virtualizado que estava nessa máquina como servidor de aplicativos de banco de dados oracle.


    Na programação, eu teria que converter o windows atual 2003 com o oracle e depois instalar o centos + vmware 64 bits e colocar o AD em cima para depois o DBA da empresa instalar o oracle 11G no centos e migrar o banco do windows virtualizado para o linux centos que roda fisicamente nessa máquina.

    Hoje foi o primeiro dia com o linux centos 64 puro + ad 2003 virtualizado com o oracle. Como só tenho essa vm, coloquei 2 processadores para ela e o oracle está consumindo 100% dos processadores.

    O que acho estranho, é que quando o AD estava fisicamente nessa máquina, o oracle comsumia somente 10 a 15% dos processadores.

    O que pode ser isso? porque tenho certeza que essa máquina roda o oracle no windows tranquilamente.

    Obs: alguém pode dizer: porque não colocou o citrix ou o exsi...não coloquei porque preciso de portas usb para hadlock(licenças usb em um pendrive) do sistema RM e o citrix testei mas depois de instalado dá pau no boot na controladora scsi da dell e não inicia.

    Sei que vamos colocar o oracle fisicamente no centos e vai resolver e ter até melhor performace do que no antigo windows fisicamente nesse server mas, queria saber o que pode estar ocorrendo pois sei que tem pessoas que usam o oracle virtualizado em vmware server.
    Última edição por lfernandosg; 25-04-2011 às 18:49.

  2. #2
    MODERADOR-CHEFE Avatar de osmano807
    Ingresso
    Aug 2008
    Localização
    Araguari - Minas Gerais
    Posts
    1.985
    Posts de Blog
    5

    Padrão Re: Processador xeon intel 100% oracle vmware server

    Humm, poderia testar com o VirtualBox? Tava mais rápido que os outros nuns benchs recentes (a versão proprietária vem com USB)

    Veja se o VMWare tá ativo as extensões de virtualização via hardware, acho que é nas configurações da VM.



  3. #3

    Padrão Re: Processador xeon intel 100% oracle vmware server

    Opa osmano. Testei o virtual em bancada..não reconheceu o hardlock usb do sistema RM.
    O vmware tools está instalado. O que mais acho estranho, é que ele fica saltando o tipo de uso do processador que quando o Ad 2003 estava na máquina física não acontecia.

    Exemplo, agora o oracle está usando 20% dos processadores mas, o obbplus(sistema off line do banco bradesco) consumia praticamente "0" dos processadores quando estava na máquina física e agora, está consumindo 55%. O processador antes que ficava com média de 35-45% de uso, agora fica com 100% direto.

    Não entendo o porque disso pois tenho outras vmwares rodando em servidores dell menos potente e os aplicativos rodam tranquilo.


    se eu for direto no centos está assim:


    top - 07:29:19 up 2 days, 20:36, 1 user, load average: 0.27, 0.51, 0.50
    Tasks: 119 total, 1 running, 118 sleeping, 0 stopped, 0 zombie
    Cpu(s): 0.7%us, 9.8%sy, 0.0%ni, 89.2%id, 0.2%wa, 0.2%hi, 0.0%si, 0.0%st
    Mem: 8181492k total, 8138356k used, 43136k free, 73400k buffers
    Swap: 10223608k total, 88k used, 10223520k free, 7473576k cached


    e o que mais está consumindo o processador é o vmware que está em média 20%:

    3417 root 18 0 531m 191m 13m S 0.0 2.4 0:41.45 webAccess
    2735 root 5 -10 2068m 165m 136m S 18.6 2.1 873:39.51 vmware-vmx
    8637 root 18 0 642m 63m 9.8m S 0.0 0.8 0:12.18 dsm_om_connsvcd
    3522 root 18 0 190m 57m 20m S 0.0 0.7 2:20.02 vmware-hostd
    2640 root 34 19 250m 15m 2140 S 0.0 0.2 0:00.08 yum-updatesd
    8436 root 19 0 204m 6660 3752 S 0.0 0.1 0:02.04 dsm_sa_datamgrd



    mas que dá picos de 75%. será que se eu colocar somente um processador na vm, melhora?


    acessando via web o vmware center está assim:

    servidor vm: processador: 240mhz de 1x2.4ghz
    memória: 659mb de 8GB

    vmware windows:
    processador: 0.546Ghz de 2x4.687ghz ==>olha que estranho..ele dobrou os processadores.
    memória: 720mb de 5GB

    Acho que o problema está acima...sendo dual core xeon se eu colocar os 2 processadores ele não entende? porque ele está dobrando o clock pois tenho um xeon intel dual core de 2.4ghz.
    mas dentro do vm windows, em propriedades do sistema, me mostra a memória e o processador 2.4ghz corretamente.

    Será que é isso? não posso colocar 2x2.4ghz ? então porque ele nos dá essa opção?

    no centos, o processador está sendo reconhecido normalmente como 1x2.4ghz:


    [[email protected] ~]# cat /proc/cpuinfo
    processor : 0
    vendor_id : GenuineIntel
    cpu family : 6
    model : 15
    model name : Intel(R) Xeon(R) CPU 3060 @ 2.40GHz
    stepping : 6
    cpu MHz : 2400.085
    cache size : 4096 KB
    physical id : 0
    siblings : 2
    core id : 0
    cpu cores : 2
    apicid : 0
    fpu : yes
    fpu_exception : yes
    cpuid level : 10
    wp : yes
    flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm syscall nx lm constant_tsc pni monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr lahf_lm
    bogomips : 4800.17
    clflush size : 64
    cache_alignment : 64
    address sizes : 36 bits physical, 48 bits virtual
    power management:

    processor : 1
    vendor_id : GenuineIntel
    cpu family : 6
    model : 15
    model name : Intel(R) Xeon(R) CPU 3060 @ 2.40GHz
    stepping : 6
    cpu MHz : 2400.085
    cache size : 4096 KB
    physical id : 0
    siblings : 2
    core id : 1
    cpu cores : 2
    apicid : 1
    fpu : yes
    fpu_exception : yes
    cpuid level : 10
    wp : yes
    flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm syscall nx lm constant_tsc pni monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr lahf_lm
    bogomips : 4800.20
    clflush size : 64
    cache_alignment : 64
    address sizes : 36 bits physical, 48 bits virtual
    power management:

  4. #4
    MODERADOR-CHEFE Avatar de osmano807
    Ingresso
    Aug 2008
    Localização
    Araguari - Minas Gerais
    Posts
    1.985
    Posts de Blog
    5

    Padrão Re: Processador xeon intel 100% oracle vmware server

    O CentOS reconhece 2x2.4GHz uai...
    Seguinte, vamos ver...
    Monitora o uso de CPU. Quando tiver alto, posta um print da tela do top/htop no momento.



  5. #5

    Padrão Re: Processador xeon intel 100% oracle vmware server

    vi agora...na hora de picos, no centos o processador chega aos 100% no top:


    PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
    2735 root 5 -10 2068m 165m 136m S 100.0 2.1 1045:41 vmware-vmx
    15296 root 15 0 12764 1100 824 R 0.3 0.0 0:00.27 top
    1 root 15 0 10372 632 540 S 0.0 0.0 0:00.57 init
    2 root RT -5 0 0 0 S 0.0 0.0 0:00.00 migration/0


    então para ver se era problema na máquina, peguei outro server meu dell T105 que tem um processador opteron dual core 1.8ghz + 2GB + 2x500GB sata ram raid e tem o centos 64 bits + vmware e somente um vm que roda somente um aplicativo em oracle + serviço de terminal service

    essa vm do opteron, roda tranquilo como terminal service o aplicativo com 5 usuários conectados ao mesmo tempo..o processador(coloquei somente 1) fica em torno dos 30%.

    Então fui transferir 2GB de arquivos usando o filezilla...e acredite, a vm desse opteron quase trava ficando o processador tanto no centos quanto na vm em 100%.

    Será que o vmware server não aguenta uma simples transferência de arquivos? as placas de rede desses servidores são todas giga...agora somente uma vm em cada server e está assim...queria entender como o pessoal, roda mais de uma vm.


    Não era para aguentar o tranco com esses 2 processadores desses 2 dell

    Outro teste foi mandar analizar o disco pois sei que isso consome o processador...os 2 servidores ficaram em 100% e quase não consigo mexer nele. quando eu mandava fazer isso no intel xeon durante o uso do dia, ele fazia isso tranquilamente e o processador ficava em média 50% de uso. hoje, virtualizado qualquer coisa chega aos 100%.

    é assim mesmo com vmware server?
    Última edição por lfernandosg; 26-04-2011 às 15:47.

  6. #6
    MODERADOR-CHEFE Avatar de osmano807
    Ingresso
    Aug 2008
    Localização
    Araguari - Minas Gerais
    Posts
    1.985
    Posts de Blog
    5

    Padrão Re: Processador xeon intel 100% oracle vmware server

    VMWare server nao tenho muita experiecia, mas nao era pra ser assim nao.
    Primeiro bota pra cada vm um processador so. Tinha um bug, nao sei se foi corrigido.
    Segundo, se nao der certo, ve se no task manager do Windows virtualizado aparece algo de util que esteja consumindo cpu.



  7. #7

    Padrão Re: Processador xeon intel 100% oracle vmware server

    Vou fazer isso no final de semana pois não posso parar o servidor intel xeon. Mas já para ter uma idéia, pois o dell opteron, a vm só está com um processador e isso também acontece.
    vou testar com o outro server e posto o resultado.

    Se alguém que trabalha com vmware server também puder dar alguma idéia, agradeço.

  8. #8

    Padrão Re: Processador xeon intel 100% oracle vmware server

    Amigo, dentro da VM que esta rodando o oracle você viu la qual processo esta puxando esses 100%?



  9. #9

    Padrão Re: Processador xeon intel 100% oracle vmware server

    então...o que mais puxa 100% é o oracle..mas qualquer coisa que abra...até o gerenciador de dispositivos ele fica dando 100%.

    A vm já está somente com um processador.

  10. #10

    Padrão Re: Processador xeon intel 100% oracle vmware server

    bom, deixei a virtual machine windows com 1 processador e o centos com 1 processador.

    melhorou mas o problema continua. o oracle agora não é motivo pois ele está no centos então o windows somente faz o papel de active directory e servidor de arquivos.

    Fica dando picos direto de 100% e quando vou transferir um arquivo do windows vm para outro servidor da rede ele fica direto em 100% e a rede fica lenta.

    O que acho estrando é que o webconsole do vmware mostra assim:

    máquina física centos:

    processador 1.8ghz de 2.4gz.
    memória: 949mb de 8GB.


    vm windows;

    processador: 1.2ghz de 2.4ghz
    memória: 540mb de 6GB(essa é a memória disponível para a vm)


    só que dentro do windows o processador mostra como 100% e a memória está consumindo 4.5GB(isso está correto)
    Clique na imagem para uma versão maior

Nome:	         imagem.jpg
Visualizações:	85
Tamanho: 	74,0 KB
ID:      	24190
    o que pode ser essa diferença do console webconsole e dentro da vm? e tem alguma solução para esse processador com picos de 100% e ao abrir qualquer aplicativo ou ao transferir arquivo ficar direto em 100%???
    Última edição por lfernandosg; 30-06-2011 às 16:05.