+ Responder ao Tópico



  1. #1

    Padrão Falha no VRRP

    PEssoal configurei um VRRP ... porém na interface de entrada ... funcionou legal ... quando um router cai o outro assume ... fica em Master ... funcinou Blzinha ! O problema eh que me parece que eles não estão sincronizando ... quando eu faço alteração no router Master ele não altera no backup .... tentei fazer pela interface Cliente porém não consegui ... não funcionou eu acho que eh pelo fato de as interfaces clientes adotarem o HotSpot !

    Segue as configurações :

    Master

    [[email protected]] /interface vrrp> print
    Flags: X - disabled, I - invalid, R - running, M - master, B - backup
    0 RM name="vrrp1" mtu=1500 mac-address=00:00:5E:00:01:31 arp=enabled
    interface=Link vrid=49 priority=255 interval=1 preemption-mode=yes
    authentication=none password="" on-backup="" on-master=""

    /ip address

    add address=192.168.1.1/24 broadcast=192.168.1.255 comment="" disabled=no \
    interface=Link network=192.168.1.0
    add address=192.168.1.254/32 broadcast=192.168.1.254 comment="" disabled=no \
    interface=vrrp1 network=192.168.1.254

    -----------------------------------------------

    No Slave


    [[email protected]] /interface vrrp> print
    Flags: X - disabled, I - invalid, R - running, M - master, B - backup
    0 B name="vrrp1" mtu=1500 mac-address=00:00:5E:00:01:31 arp=enabled
    interface=Link vrid=49 priority=100 interval=1 preemption-mode=yes
    authentication=none password="" on-backup="" on-master=""

    /ip address

    add address=192.168.1.2/24 broadcast=192.168.1.255 comment="" disabled=no \
    interface=Link network=192.168.1.0
    add address=192.168.1.254/32 broadcast=192.168.1.254 comment="" disabled=no \
    interface=vrrp1 network=192.168.1.254


    -------------------------------------------------------

    O que poderá estar errado ???

    O vrrp trabalha no link de entrada msm ?? ou pode ser no dos clientes ???


    Grato pela a ajuda ...

  2. #2

    Padrão Re: Falha no VRRP

    Verifica se não tem filtro pra multicast

    O VRRP usa 224.0.0.12 pra alinhamento dos VR's.

    O priority, apesar de ele "aceitar" 255, o limite é 254, isso pode te trazer problemas tb no protocolo.



  3. #3

    Padrão Re: Falha no VRRP

    Acontece que quando eu mudo o Priority pra 254 ... os dois entram como Master ... e o vrrp pára de funcionar ... quando eu deixo em 255 funciona normal !

  4. #4

    Padrão Re: Falha no VRRP

    e não tem filtro nao "



  5. #5

    Padrão Re: Falha no VRRP

    Vamos tentar achar o problema

    Se ta usando desta forma ??
    http://www.mikrotik.com/testdocs/ros/2.9/img/vrrp1.jpg

    Seus gateways apontam pra fora ou pra os endereços virtuais ??

    São 2 routers ou so levantou a inteface ??
    Vamos peneirar que isso ai é de muita importância a comunidade como um todo né!

  6. #6

    Padrão Re: Falha no VRRP

    São dois roteadores com o mesmo gateway um do lado do outro ! Porém com ips diferentes ( ips publicos )

    O que acontece: do outro lado eu tenho uma range /30 com hotspot para os meus clientes .... tentei colocar ele pra funcionar pela interface Clientes que eh a do hotspot e não funcionou ... ai segui o exemplo do wiki do mikrotik que eh essa configuração que está ai .... porém o VRRP está rodando na interface de entrada ou seja por onde entra o link ... funciona direitinho ... quando um cai o outro assume ... o problema eh que um nao escreve no outro as alterações .....