+ Responder ao Tópico



  1. Socorro amigos,

    Preciso mesmo de ajuda!

    To faz duas semanas tentando configurar o squid no ubuntu.

    Instalei o squid, e apenas mudei o arquivo padrão "squid.conf" para no lugar de "http_access deny all " "http_access allow all ". E as estações só dão acesso denied. Isso eu fiz na minha ultima tentativa. Vou postar logo abaixo o arquivo "squid.conf" que criei pela penultima vez.

    O que eu quero com esse "squid.conf" abaixo é criar dois niveis de acesso. o Nível1 vai ser tudo bloqueado, sendo liberado apenas alguns sites governamentais que estarão listados no arquivo "liberados". O Nível2 vai ser tudo liberado (full), sendo que apenas alguns sites como orkut, facebook, youtube serão bloqueados e listados no arquivo "bloqueados".

    ________________________________________________________
    acl manager proto cache_object
    acl localhost src 127.0.0.1/255.255.255.255
    acl to_localhost dst 127.0.0.0/8
    acl SSL_ports port 443 563
    acl Safe_ports port 80 # http
    acl Safe_ports port 21 # ftp
    acl Safe_ports port 443 563 # https, snews
    acl Safe_ports port 70 # gopher
    acl Safe_ports port 210 # wais
    acl Safe_ports port 1025-65535 # unregistered ports
    acl Safe_ports port 280 # http-mgmt
    acl Safe_ports port 488 # gss-http
    acl Safe_ports port 591 # filemaker
    acl Safe_ports port 777 # multiling http
    acl CONNECT method CONNECT

    # ACL's para definição de redes
    acl all src 0.0.0.0/0.0.0.0.0
    acl nivel1 src 192.168.1.16-192.168.1.99
    acl nivel2 src 192.168.1.1-192.168.1.15

    # ACL's para controle de acesso
    acl bloqueados url_regex -i "/etc/squid/lists/bloqueados"
    acl liberados url_regex -i "/etc/squid/lists/liberados"

    http_access allow manager localhost
    http_access deny manager
    http_access deny !Safe_ports
    http_access deny CONNECT !SSL_ports
    http_access allow localhost

    # HTTP_ACCESS
    http_access alow nivel2
    http_access deny bloqueados
    http_access deny nivel1
    http_access allow liberados

    http_access deny all
    ___________________________________________________

    Para fazer funcionar, eu iniciei o ubuntu, no terminal dei os comandos:

    * modprobe iptable_nat
    * modprobe ip_nat_ftp
    * echo 1 > /proc/sys/net/ipv4/ip_forward
    * iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE
    * iptables -t nat -A PREROUTING -i eth1 -p tcp --dport 80 -j REDIRECT --to-port 3128

    Logo após, dei "squid restart", sendo o squid iniciado normalmente.

    Mas as estações só estão dando acesso denied.

    Minha eth0 (modem) está configurada assim:
    IP: 10.1.1.4
    Máscara: 255.255.255.0
    Gateway: 10.1.1.1
    DNS: 8.8.8.8

    Minha eth1 (Rede Local) está configurada assim:
    IP: 192.168.1.1
    Máscara: 255.255.255.0
    Gateway: deixei em branco
    DNS: deixei em branco

    A Placa de rede da estação eu coloquei no proxy do navegados o IP 192.168.1.1 e porta 3128, bem como também setei IP Fixo em IP 192.168.1.2, Máscara: 255.255.255.0, Gateway: deixei em branco, DNS: deixei em branco.

    Na eth1 do servidor (rede local) eu também já tentei colocar o gateway 192.168.1.0 e o DNS: 8.8.8.8. Na placa de rede do servidor eu também já tentei colocar fixo o gateway 192.168.1.0 e DNA 8.8.8.8 e nada resolveu.

    O que estou fazendo errado?

    Como última alternativa, deixei o arquivo padrão do squid.conf, não alterei nada, e mesmo assim fica dando access denied. Já não sei mais o que fazer.

    Outra coisa engraçada que acontece é que quando eu reiniciou a estação (client), a mesma já não consegue mais se comunicar com o servidor, não dá ping e nem nada. Já testei isso com duas estações e nas duas aconteceram isso. =/ Fica aparecendo a mensagem de a tela não pode ser exibida, aquela tela padrão do IE.

    Por favor, se alguém puder me ajudar eu agradeço muito.

  2. Colegas,

    Depois de tanta insistência, to conseguindo fazer o squid funcionar.

    Já consegui configurar os acessos do nivel2. O complicado agora está pra configurar os acessos do nivel1. Pro nivel1 tá tudo bloqueado, mas além de ele ter que ficar bloqueado, ele deveria liberar o acesso aos sites listados no arquivo "liberados". Não sei o que estou fazendo de errado. To quebrando a cabeça aqui. Alguém pode me ajudar?

    O arquivo squid.conf está assim:

    _____________________________________________________________
    http_port 3128 transparent
    visible_hostname proxyinfoworld
    hierarchy_stoplist cgi-bin ?
    acl QUERY urlpath_regex cgi-bin \?
    cache_mem 8 MB

    #____________Otimizacao do sistema_________________

    maximum_object_size 64 MB
    minimum_object_size 0 KB
    cache_swap_low 90
    cache_swap_high 95
    cache_access_log /var/log/squid/access.log
    #cache_dir ufs /var/spool/squid 2048 256 512
    refresh_pattern ^ftp: 15 20% 4560
    refresh_pattern ^gopher: 15 0% 4560
    refresh_pattern . 15 20% 4560

    #____________ACL's________________________________

    acl manager proto cache_object
    acl localhost src 127.0.0.1/255.255.255.255
    acl to_localhost dst 127.0.0.0/8
    acl SSL_ports port 443 563
    acl Safe_ports port 80 # http
    acl Safe_ports port 21 # ftp
    acl Safe_ports port 443 563 # https, snews
    acl Safe_ports port 70 # gopher
    acl Safe_ports port 210 # wais
    acl Safe_ports port 1025-65535 # unregistered ports
    acl Safe_ports port 280 # http-mgmt
    acl Safe_ports port 488 # gss-http
    acl Safe_ports port 591 # filemaker
    acl Safe_ports port 777 # multiling http
    acl CONNECT method CONNECT

    # ACL's para definição de redes
    acl all src 192.168.1.0/24
    acl nivel1 src 192.168.1.16-192.168.1.99
    acl nivel2 src 192.168.1.1-192.168.1.15

    # ACL's para controle de acesso
    acl bloqueados url_regex -i "/etc/squid/lists/bloqueados"
    acl liberados url_regex -i "/etc/squid/lists/liberados"

    http_access allow manager localhost
    http_access deny manager
    http_access deny !Safe_ports
    http_access deny CONNECT !SSL_ports
    http_access allow localhost

    # HTTP_ACCESS
    http_access deny nivel1 !liberados
    http_access allow nivel2 !bloqueados
    http_access deny all
    ___________________________________________________________

    Tive que comentar a linha do "cache_dir" porque com ele habilitado, as estações estavam dando "a página não pode ser exibida".

    Valeu e muito obrigado!



  3. Amigos,

    Eu de novo!

    Consegui realizar a configuração acima! Depois de tanta batalha, estou muito contente por ter conseguido!! Obrigado à todos!! Agora vem a seguinte situação.. kkk

    EU gostaria de saber se é possível fazer com que se tenha navegação sem precisar colocar no navegador (configurações de proxy) o IP do servidor e a porta de conexão. E eu também gostaria de saber o que pode estar acontecendo com referência a linha do "cache_dir", visto que quando eu habilito ela, o navegador das estações dão como "a página não pode ser exibida". E se eu tiro essa linha fora, tudo funciona normalmente.

    Obrigado!

  4. Meus caros,
    Tudo resolvido. Só o skema do navegador que acho que não vai ter como. Do cache, o problema era nas permissões da pasta. Dos acessos negados, era a configuração do http_access, eu não estava entendendo muito bem como funcionava. Agora que entendi mais ou menos, o negócio deslanchou. Obrigado a Todos e bora tentar um server de domínio.






Tópicos Similares

  1. Zinwell g220 webpage acesso bloqueado HELP
    Por KILIKIL no fórum Redes
    Respostas: 1
    Último Post: 02-02-2008, 14:03
  2. Servidor Squid Lento !!! Help!
    Por Educpd no fórum Servidores de Rede
    Respostas: 9
    Último Post: 10-05-2004, 16:59
  3. Respostas: 1
    Último Post: 03-06-2003, 18:04
  4. Duvidas Iptables + Squid -----Help-----
    Por A-Marcio no fórum Servidores de Rede
    Respostas: 6
    Último Post: 29-03-2003, 10:26
  5. Help Squid -z
    Por Itise no fórum Servidores de Rede
    Respostas: 5
    Último Post: 11-02-2003, 14:47

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L