+ Responder ao Tópico



  1. #1

    Padrão Problema com CUPS

    Olá, estou montando um servidor de impressão e tenho que colocar a permissões para usuarios, usuarios comuns só podem imprimir e usuario admins e suporte pode gerenciar e cancelar os jobs. Na hora de autenticação do CUPS eu só consigo acessar com o usuario root, mas preciso fazer a autenticação com o admin e o suporte. Já tentei adicionar os usuarios ao grupo lpadmin e não du certo.

    Aque está a minha configuração.

    # Administrator user group...
    SystemGroup lpadmin, admin,suporte
    #SystemGroup lpadmin
    AuthType Basic
    #Require user @Sytem
    #AuthClass Group
    #Group admins
    #User admin
    #====================
    #DefaultEncryption Never
    #====================
    # Only listen for connections from the local machine.
    Port 631
    Listen 192.168.6.2:631
    Listen localhost:631
    Listen /var/run/cups/cups.sock
    # Show shared printers on the local network.
    Browsing On
    BrowseOrder allow,deny
    BrowseAllow all
    # Default authentication type, when authentication is required...
    #DefaultAuthType Basic
    DefaultAuthType Basic
    AuthClass Group
    #AuthGroupName admins
    # Restrict access to the server...
    <Location />
    # Group admins
    AuthType Basic
    AuthGroupName admins
    Allow from all
    Order allow,deny
    </Location>
    # Restrict access to the admin pages...
    <Location /admin>
    AuthType Basic
    AuthClass Group
    Allow from all
    Order allow,deny
    </Location>
    # Restrict access to configuration files...
    <Location /admin/conf>
    Allow from all
    AuthType Default
    Require user @SYSTEM
    Order allow,deny
    </Location>
    # Set the default printer/job policies...
    <Policy default>
    # Job-related operations must be done by the owner or an administrator...
    <Limit Send-Document Send-URI Hold-Job Release-Job Restart-Job Purge-Jobs Set-Job-Attributes Create-Job-Subscription Renew-Subscription Cancel-Subscription Get-Notifications Reprocess-Job Cancel-Current-Job Suspend-Current-Job Resume-Job CUPS-Move-Job>
    Require user @OWNER @SYSTEM
    Order deny,allow
    </Limit>
    # All administration operations require an administrator to authenticate...
    <Limit CUPS-Add-Modify-Printer CUPS-Delete-Printer CUPS-Add-Modify-Class CUPS-Delete-Class CUPS-Set-Default>
    AuthType Default
    Require user @SYSTEM
    Order deny,allow
    </Limit>
    # All printer operations require a printer operator to authenticate...
    <Limit Pause-Printer Resume-Printer Enable-Printer Disable-Printer Pause-Printer-After-Current-Job Hold-New-Jobs Release-Held-New-Jobs Deactivate-Printer Activate-Printer Restart-Printer Shutdown-Printer Startup-Printer Promote-Job Schedule-Job-After CUPS-Accept-Jobs CUPS-Reject-Jobs>
    AuthType Default
    Require user @SYSTEM
    Order deny,allow
    </Limit>
    # Only the owner or an administrator can cancel or authenticate a job...
    <Limit Cancel-Job CUPS-Authenticate-Job>
    Require user @OWNER @SYSTEM
    Order deny,allow
    </Limit>
    <Limit All>
    Order deny,allow
    </Limit>
    </Policy>
    #
    # End of "$Id: cupsd.conf.in 7199 2008-01-08 00:16:30Z mike $".
    #

  2. #2

    Padrão Re: Problema com CUPS

    Tente tirar estas virgulas, acho que isso gera um erro de sintaxe, deixe apenas espaços separando os grupos.
    SystemGroup lpadmin admin suporte

    Ou mesmo você pode deixar apenas o grupo padrão (lpadmin) e adicionar os outros usuarios no grupo lpadmin

    usermod -G lpadmin usuario

    habilite o syslog para *.auth e abra um segundo terminal com tail -f /var/log/message ( ou seu arquivo de log)
    Tente autenticar e veja o que acontece



  3. #3

    Padrão Re: Problema com CUPS

    Acredito que isso possa ser solucionado acrescentando os usuários na lista de printer admin no Samba "/etc/samba/smb.conf" .