Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Gerar LOG de conexoes.

    Estamos vivendo em uma era que praticamente tudo é digital.
    Nao vivemos sem computador.

    Assim como existe crime na vida real, existem tambem os crimes virtuais.
    Que são os delitos praticados através da internet que podem ser enquadrados no Código Penal Brasileiro e os infratores estão sujeitos às penas previstas na Lei.

    Uma forma de rastrear e chegar ao criminoso é atraves do seu IP.
    Acontece que muitos provedores usam NAT, o que dificulta a indentificacao dos criminosos virtuais.

    Alguns provedores fazem uso do Relatorio do Squid, gerando um relatorio de cada site que o cliente acessou.... alem de poder ser considerado uma pratica contra a lei (ja que esta invandindo a privacidade do cliente), ainda tem a questao de nao ter relatorio de tudo... e as conexoes via ssh, telnet, dentre varias outras?

    Mas e agora?
    Como farei para indentificar o cliente caso seja requisitado pela Justiça?

    A melhor forma para quem usa NAT é guardando todo os Logs de conexao do cliente com a Internet.

    Vamos la:
    1. configurar o Firewall do mk para gerar os Logs:
    /ip firewall filter
    add action=log chain=forward disabled=no log-prefix=LogRede in-interface=REDE
    Esteja certo de colocar a Interface interna/rede.
    Imagem da configuracao do firewall:
    Clique na imagem para uma versão maior

Nome:	         firewall log.jpg
Visualizações:	649
Tamanho: 	30,8 KB
ID:      	23018

    2. configurar o MK para enviar os logs remotamente:
    /system logging action
    set remote bsd-syslog=no name=remote remote=IP-do-PC-q-vai-receber-os-logs remote-port=514 src-address=0.0.0.0 syslog-facility=daemon syslog-severity=auto target=remote
    Esteja certo de colocar o IP correto do PC que ira receber os logs
    Imagem:
    Clique na imagem para uma versão maior

Nome:	         log remot1.jpg
Visualizações:	483
Tamanho: 	24,2 KB
ID:      	23019

    3. criar a Regra do log para ser enviado:
    /system logging
    add action=remote disabled=no prefix="" topics=firewall
    imagem:
    Clique na imagem para uma versão maior

Nome:	         log remot2.jpg
Visualizações:	430
Tamanho: 	22,5 KB
ID:      	23020

    4. Faça o Donwload do Mikrotik Daemon no pc que ira receber os logs
    http://www.mikrotik.com/download/MT_Syslog.exe

    Se tudo correu bem, vc nao precisara fazer nenhuma configuracao adicional...
    basta abrir o syslog que automaticamente ira receber os logs

    Esteja certo que o Syslog esta desbloqueado no firewall do windows
    imagem:
    Clique na imagem para uma versão maior

Nome:	         syslog.jpg
Visualizações:	549
Tamanho: 	23,2 KB
ID:      	23021


    Bom, espero ter ajudado.

    Obs: se a dica foi boa, nao esquece de agradecer (basta clicar na estrilinha logo abaixo), ueshueshes
    Última edição por AndrioPJ; 30-05-2011 às 12:01.

  2. #2

    Padrão Re: Gerar LOG de conexoes.

    Ja ia me esquecendo.
    vc devera guardar historico do cadastro dos cliente: Nome Cliente, cpf, rg, endereco, telefones, ip fixo dele ou nome do usuario (caso autenticacao Hotspot ou ppoe).

    Autenticacao IPxMAC
    Para esses logs funcionar, vc devera enviar para seu cliente IP fixo... aquele cliente tera que ter sempre aquele IP.

    Autenticacao Hotspot ou PPOE
    podem enviar IP fixo tbm, dessa forma vc devera guardar apenas o historico do cadastro e o log de conexao.
    Caso envie IP dinamico, vc devera guardar tbm log da autenticacao (onde é informado que o Usuario X se autenticou em tal hora e pegou tal IP)



  3. #3

    Padrão Re: Gerar LOG de conexoes.

    Bom dia Mascaraapj.
    Tenho a seguinte duvida, na imagem vc diz que é "In-Interface", ja na regra por escrito vc diz que é "out-interface.
    Qual é a forma correta?

  4. #4

    Padrão Re: Gerar LOG de conexoes.

    obrigado pela contribuição



  5. #5

    Padrão Re: Gerar LOG de conexoes.

    Preciso montar um desses urgentes pois nao consigo durmir sucegado pensando nisso minha pergunta é se o mk deve ser separado do mk que faz o host post.
    Eu tenho um mk fazendo host post devo colocar a regra nele pra enviar os logs a outro mk com o MT_SYSLOG instalado nele?
    Meu mk tem 3 placas de rede preciso colocar mais uma para isso ficando ETHER1 -LINK, ETHER 2 REDE, ETHER 3 - CACHE AI DEVO COLOCAR UM ETHER 4 PRO MICRO DE LOG?

  6. #6

    Padrão Re: Gerar LOG de conexoes.

    Otimo Tópico.... Parabéns
    E disso que o forum precisa....



  7. #7

    Padrão Re: Gerar LOG de conexoes.

    Citação Postado originalmente por abu Ver Post
    Bom dia Mascaraapj.
    Tenho a seguinte duvida, na imagem vc diz que é "In-Interface", ja na regra por escrito vc diz que é "out-interface.
    Qual é a forma correta?
    Bem observado
    devo ter enviado a imagem errada
    o correto é in-interface, vc seleciona a interface da sua rede interna.

    Citação Postado originalmente por salvato Ver Post
    Preciso montar um desses urgentes pois nao consigo durmir sucegado pensando nisso minha pergunta é se o mk deve ser separado do mk que faz o host post.
    Eu tenho um mk fazendo host post devo colocar a regra nele pra enviar os logs a outro mk com o MT_SYSLOG instalado nele?
    Meu mk tem 3 placas de rede preciso colocar mais uma para isso ficando ETHER1 -LINK, ETHER 2 REDE, ETHER 3 - CACHE AI DEVO COLOCAR UM ETHER 4 PRO MICRO DE LOG?
    No mk que esta fazendo hotspot vc cria as regras para enviar o log para o computador que ira receber os logs
    no caso, o syslog é aberto no windows para receber os logs

  8. #8

    Padrão Re: Gerar LOG de conexoes.

    Ola Amigo, parabens pela iniciativa, muito bom seu post.

    este seu post me deu uma ideia, temos aqui uma central de reservas e a galera esta abusando da internet, não to a fim de instalar squid nem algo deste tipo, nos hoteis temos o sistema isgi que gera estes log's mas não quero comprar um sistema só para colocar aqui.

    então assim que vi seu post fui pra bancada fazer testes porem não consegui gerar nenhum informação acontece que ele não passa nenhum pacote pela regra criada, o que posso ter feito de errado?

    meu senario de testes é adsl entrando pela ether1 nat abilitado saindo pela eth5, como pode ver mesmo testando nevegação, ftp, ssh não gerou nenhum pacote.
    Clique na imagem para uma versão maior

Nome:	         nat-log.png
Visualizações:	153
Tamanho: 	12,8 KB
ID:      	23058
    minha ideia é usar esta regra juntamente com hotspot para fazer a identificação.

    só lembrando, a interface esta zerada dei um system reset-configuration antes de começar os testes e só tem estas duas regras no firewall, as maquinas conectadas na eth navegam normalmente, outro detalhe uso MK 4.17 numa 750g que comprei só para testes.

    se puder me ajudar desde ja agradeço.
    Última edição por hotel; 29-05-2011 às 21:26.



  9. #9

    Padrão Re: Gerar LOG de conexoes.

    Citação Postado originalmente por mascaraapj Ver Post
    Estamos vivendo em uma era que praticamente tudo é digital.
    Nao vivemos sem computador.

    Assim como existe crime na vida real, existem tambem os crimes virtuais.
    Que são os delitos praticados através da internet que podem ser enquadrados no Código Penal Brasileiro e os infratores estão sujeitos às penas previstas na Lei.

    Uma forma de rastrear e chegar ao criminoso é atraves do seu IP.
    Acontece que muitos provedores usam NAT, o que dificulta a indentificacao dos criminosos virtuais.

    Alguns provedores fazem uso do Relatorio do Squid, gerando um relatorio de cada site que o cliente acessou.... alem de poder ser considerado uma pratica contra a lei (ja que esta invandindo a privacidade do cliente), ainda tem a questao de nao ter relatorio de tudo... e as conexoes via ssh, telnet, dentre varias outras?

    Mas e agora?
    Como farei para indentificar o cliente caso seja requisitado pela Justiça?

    A melhor forma para quem usa NAT é guardando todo os Logs de conexao do cliente com a Internet.

    Vamos la:
    1. configurar o Firewall do mk para gerar os Logs:
    Esteja certo de colocar a Interface interna/rede.
    Imagem da configuracao do firewall:
    Clique na imagem para uma versão maior

Nome:	         firewall log.jpg
Visualizações:	649
Tamanho: 	30,8 KB
ID:      	23018

    2. configurar o MK para enviar os logs remotamente:
    Esteja certo de colocar o IP correto do PC que ira receber os logs
    Imagem:
    Clique na imagem para uma versão maior

Nome:	         log remot1.jpg
Visualizações:	483
Tamanho: 	24,2 KB
ID:      	23019

    3. criar a Regra do log para ser enviado:
    imagem:
    Clique na imagem para uma versão maior

Nome:	         log remot2.jpg
Visualizações:	430
Tamanho: 	22,5 KB
ID:      	23020

    4. Faça o Donwload do Mikrotik Daemon no pc que ira receber os logs
    http://www.mikrotik.com/download/MT_Syslog.exe

    Se tudo correu bem, vc nao precisara fazer nenhuma configuracao adicional...
    basta abrir o syslog que automaticamente ira receber os logs

    Esteja certo que o Syslog esta desbloqueado no firewall do windows
    imagem:
    Clique na imagem para uma versão maior

Nome:	         syslog.jpg
Visualizações:	549
Tamanho: 	23,2 KB
ID:      	23021


    Bom, espero ter ajudado.

    Obs: se a dica foi boa, nao esquece de agradecer (basta clicar na estrilinha logo abaixo), ueshueshes
    Fiz tudo como descreveu porem não recebi nada nem uma informação no programa.

  10. #10

    Padrão Re: Gerar LOG de conexoes.

    Andrio parabens pelo post, funcionou blz aqui pra mim, agora tenho as mac de quem está conectado legal, fico muito grato por isso, eu uso ppoe com ip dinamico, deixa eu ver se isso mesmo, eu vou passar a ter todas as mac dos usuarios que conectaram nesse horario seria isso, pois o usuario ele não cataloga, outro detalhe onde ele salva essa informação e por quanto tempo fica!

    Fico muito grato pela sua enorme contribuição!

    Muito grato pelo mesmo pela sua grande força!

    Um forte abraço!



  11. #11

    Padrão Re: Gerar LOG de conexoes.

    Coloca essa regra antes da regra do NAT masquerade
    Citação Postado originalmente por hotel Ver Post
    Ola Amigo, parabens pela iniciativa, muito bom seu post.

    este seu post me deu uma ideia, temos aqui uma central de reservas e a galera esta abusando da internet, não to a fim de instalar squid nem algo deste tipo, nos hoteis temos o sistema isgi que gera estes log's mas não quero comprar um sistema só para colocar aqui.

    então assim que vi seu post fui pra bancada fazer testes porem não consegui gerar nenhum informação acontece que ele não passa nenhum pacote pela regra criada, o que posso ter feito de errado?

    meu senario de testes é adsl entrando pela ether1 nat abilitado saindo pela eth5, como pode ver mesmo testando nevegação, ftp, ssh não gerou nenhum pacote.
    Clique na imagem para uma versão maior

Nome:	         nat-log.png
Visualizações:	153
Tamanho: 	12,8 KB
ID:      	23058
    minha ideia é usar esta regra juntamente com hotspot para fazer a identificação.

    só lembrando, a interface esta zerada dei um system reset-configuration antes de começar os testes e só tem estas duas regras no firewall, as maquinas conectadas na eth navegam normalmente, outro detalhe uso MK 4.17 numa 750g que comprei só para testes.

    se puder me ajudar desde ja agradeço.

  12. #12

    Padrão Re: Gerar LOG de conexoes.

    Se vc usa autenticacao (hotspot ou ppoe) com ip dinamico
    te aconselho a guardar os logs da autenticacao tbm... pois ai com o log da autenticacao vc sabera quem estava usando determinado IP
    e com os logs da conexao, vc sabera se ele acessou aquele site em questao.
    Citação Postado originalmente por adepad Ver Post
    Andrio parabens pelo post, funcionou blz aqui pra mim, agora tenho as mac de quem está conectado legal, fico muito grato por isso, eu uso ppoe com ip dinamico, deixa eu ver se isso mesmo, eu vou passar a ter todas as mac dos usuarios que conectaram nesse horario seria isso, pois o usuario ele não cataloga, outro detalhe onde ele salva essa informação e por quanto tempo fica!

    Fico muito grato pela sua enorme contribuição!

    Muito grato pelo mesmo pela sua grande força!

    Um forte abraço!



  13. #13

    Padrão Re: Gerar LOG de conexoes.

    Citação Postado originalmente por RogerBoscatto Ver Post
    Fiz tudo como descreveu porem não recebi nada nem uma informação no programa.
    Alguma coisa foi feita errada
    poderia enviar print das suas configuracoes?

  14. #14

    Padrão Re: Gerar LOG de conexoes.

    Ola, desculpe eu lhe importunar, mas se não for incomodo e puder me ajudar agradeço.

    notei que sua regra:
    /ip firewall nat
    add action=log chain=forward disabled=yes log-prefix=LogRede in-interface=REDE

    cria como desabilitada, é assim mesmo, de qualquer forma tentei das duas formas habilitando e deixando desabilitada.

    coloquei abaixo as regras que adicionei a RB depois de rodar o comando system reset-configuration no-default=yes


    /ip dhcp-client
    add add-default-route=yes comment="" default-route-distance=0 disabled=no \
    interface=ether1 use-peer-dns=yes use-peer-ntp=yes

    /ip address
    add address=192.168.0.1/24 broadcast=192.168.0.255 comment="" disabled=no \
    interface=ether5 network=192.168.0.0
    /ip firewall nat
    add action=log chain=forward comment="" disabled=no in-interface=ether5 \
    log-prefix=LogRede
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=\
    ether1
    /system logging action
    add bsd-syslog=no name=remoto remote=192.168.0.254:514 src-address=0.0.0.0 \
    syslog-facility=daemon syslog-severity=auto target=remote
    /system logging
    add action=remoto disabled=no prefix="" topics=firewall

    segui sua orientação coloquei a regra antes do mascarade mas não adiantou. não passa nenhum pacote pela regra.
    Última edição por hotel; 30-05-2011 às 09:41.



  15. #15

    Padrão Re: Gerar LOG de conexoes.

    A regra esta quase certa, mas tem 2 erros:
    - a regra tem que estar habilitada
    - a interface selecionada é da rede interna, clientes... (conforme eu disse la em cima)
    Citação Postado originalmente por hotel Ver Post
    Ola, desculpe eu lhe importunar, mas se não for incomodo e puder me ajudar agradeço.

    notei que sua regra:
    /ip firewall nat
    add action=log chain=forward disabled=yes log-prefix=LogRede in-interface=REDE

    cria como desabilitada, é assim mesmo, de qualquer forma tentei das duas formas habilitando e deixando desabilitada.

    coloquei abaixo as regras que adicionei a RB depois de rodar o comando system reset-configuration no-default=yes


    /ip dhcp-client
    add add-default-route=yes comment="" default-route-distance=0 disabled=no \
    interface=ether1 use-peer-dns=yes use-peer-ntp=yes

    /ip address
    add address=192.168.0.1/24 broadcast=192.168.0.255 comment="" disabled=no \
    interface=ether5 network=192.168.0.0
    /ip firewall nat
    add action=log chain=forward comment="" disabled=no in-interface=ether5 \
    log-prefix=LogRede
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=\
    ether1
    /system logging action
    add bsd-syslog=no name=remoto remote=192.168.0.254:514 src-address=0.0.0.0 \
    syslog-facility=daemon syslog-severity=auto target=remote
    /system logging
    add action=remoto disabled=no prefix="" topics=firewall

    segui sua orientação coloquei a regra antes do mascarade mas não adiantou. não passa nenhum pacote pela regra.

  16. #16

    Padrão Re: Gerar LOG de conexoes.

    Ótimo post Andrio, parabéns!

    Só uma pequena observação: A regra de NAT aqui só funcionou com a chain=dstnat e não forward como no texto, e vc deixou ela como disabled tbm. No mais, funcionou perfeito, inclusive usando outra porta e emulando o MT_Syslog pelo wine no Ubuntu.

    Ah, outra coisa: Pra quem quer só guardar os logs de autenticação do Hotspot (MAC, IP, data, hora, etc), seleciona "hotspot" como topic da Rule em /system logging.
    Última edição por RockBells; 30-05-2011 às 11:17.



  17. #17

    Padrão Re: Gerar LOG de conexoes.

    Citação Postado originalmente por RockBells Ver Post
    Ótimo post Andrio, parabéns!

    Só uma pequena observação: A regra de NAT aqui só funcionou com a chain=dstnat e não forward como no texto, e vc deixou ela como disabled tbm. No mais, funcionou perfeito, inclusive usando outra porta e emulando o MT_Syslog pelo wine no Ubuntu.

    Ah, outra coisa: Pra quem quer só guardar os logs de autenticação do Hotspot (MAC, IP, data, hora, etc), seleciona "hotspot" como topic da Rule em /system logging.
    Opa, obrigado pela observacao...
    essas regras eu ja havia testado a muitoooo tempo atras.
    na epoca que usava nat.

    ai, quando esse assunto veio ao forum, eu criei as regras rapido para testar.
    e acabei dando export das regras e nao observei que estava desativada.

    bom, alterei as regras la em cima para ficar melhor.
    do nat, passei para o filter
    e ativei elas

  18. #18
    Correndo atrás... Avatar de Leonardo
    Ingresso
    Aug 2009
    Localização
    Próx. a Brasília
    Posts
    152

    Padrão Re: Gerar LOG de conexoes.

    Caro amigo, meu parabéns pelo post, fiz aqui e funcionou 100%

    Mas agora quando eu abro o log do mikrotik, ele fica aparecendo o log de conecçoes, assim nao teria como o log de conecçoes aparecer somente no syslog?

    desde ja agradeço



  19. #19

    Padrão Re: Gerar LOG de conexoes.

    Citação Postado originalmente por Leonardo Ver Post
    Caro amigo, meu parabéns pelo post, fiz aqui e funcionou 100%

    Mas agora quando eu abro o log do mikrotik, ele fica aparecendo o log de conecçoes, assim nao teria como o log de conecçoes aparecer somente no syslog?

    desde ja agradeço
    ele fica aparecendo la, mas nao é guardado la no mk
    nao conheco nenhuma forma de fazer aparecer somente no syslog

  20. #20

    Padrão Re: Gerar LOG de conexoes.

    Valeu pelas dicas esta funcionando corretamente.

    O unico problema é o tamanho dos log's em um dia com 22 usuarios conectados gerou um arquivo de 504M.

    Se bem que tambem com os HD's que temos hoje um de 500Gb da para armazenas informações por uns 3 anos.

    um grande abraço, e mais uma vez parabens pela iniciativa.