+ Responder ao Tópico



  1. #1

    Padrão Squid esta ficando lento...

    Bom dia, pessoal...

    Tenho um servidor de internet rodando o Squid e IpTables a 4 anos sem apresentar nenhum problema, mas a duas semanas ele começou a deixar a internet lenta, tenho uma conexao de 100MB download e 35MB upload, quando reinicio o serviço do squid a conexao fica nos valores acima, mas ao passar do tempo ela vai caindo caindo ate que chega ao ponto por exemplo de 3MB download e 512KBps upload, ai tenho que reiniciar o serviço novamente e assim ta sendo.
    Ao reiniciar o serviço nao apresenta nenhum erro, já excluir e recriei os diretorios de chace e log, mas o problema ainda persisti.
    Alguem tem alguma dica do que poderia ta causando essa lentidão? O squid.conf segue abaixo:
    Código PHP:
    http_port 3128
     
    hierarchy_stoplist cgi
    -bin ?
    acl QUERY urlpath_regex cgi-bin \?
     
    cache deny QUERY
    acl Apache rep_header Server 
    ^Apache
    broken_vary_encoding allow apache
     
    cache_mem 256 MB
     cache_swap_low 90
     cache_swap_high 95
     maximum_object_size 750 MB
     
    cache_dir ufs 
    /var/spool/squid 2048 16 256
    cache_access_log 
    /var/log/squid/access.log squid
    cache_store_log 
    /var/log/squid/store.log
     
    dns_nameservers 8.8.8.8 8.8.4.4
     
    refresh_pattern 
    ^ftp:  1440 2010080
    refresh_pattern 
    ^gopher1440 01440
    refresh_pattern 
    .  0 204320
     
    acl all src 0.0.0.0
    /0.0.0.0
    acl manager proto cache_object
    acl localhost src 192.168.0.0
    /255.255.255.0
    acl to_localhost dst 192.168.0.0
    /24
    acl SSL_ports port 443 563
    acl Safe_ports port 80  
    # http
    acl Safe_ports port 21  # ftp
    acl Safe_ports port 443 563 # https, snews
    acl Safe_ports port 70  # gopher
    acl Safe_ports port 210  # wais
    acl Safe_ports port 1025-65535 # unregistered ports
    acl Safe_ports port 280  # http-mgmt
    acl Safe_ports port 488  # gss-http
    acl Safe_ports port 591  # filemaker
    acl Safe_ports port 777  # multiling http
    acl CONNECT method CONNECT
     
    #ACL LIBERA IP TODOS OS ACESSOS
    acl ipliberado src 192.168.0.5/255.255.255.255 
    acl ipliberado src 192.168.0.14
    /255.255.255.255 
    acl proibe url_regex 
    -"/etc/squid/proibe"
     
    #ACL UTILIZADAS PARA BLOQUEIO DO MSN
    acl msn url_regex -/gateway/gateway.dll
    #acl ipmsn src "/etc/fw.ips.msn"
    acl ips src 192.168.0.5 
     
    http_access allow manager localhost
    http_access deny manager
    http_access deny 
    !Safe_ports
    http_access deny CONNECT 
    !SSL_ports
    http_access deny to_localhost 
    http_access allow msn ips
    http_access deny msn
    http_access allow ipliberado
    http_access deny proibe
    #HTTP UTILIZADAS PARA BLOQUEIO DO MSN
    #http_access allow msn ips
    #http_access deny msn
    # ipmsn
    http_reply_access allow all
    icp_access allow all 

  2. #2

    Padrão Re: Squid esta ficando lento...

    Tem cara de ser vírus na rede..
    Já viu isso: Squid lento (ou caindo) por causa de vírus na rede | Eriberto Blog
    Nunca usei.. Só li mesmo.. Mais pode te ajudar!
    []'s



  3. #3

    Padrão Re: Squid esta ficando lento...

    Faça a observação do processamento do servidor no momento de lentidão, caso esteja sobrecarregado, verifique os processos responsáveis.

  4. #4

    Padrão Re: Squid esta ficando lento...

    O processador fica em media 80% ocioso.
    Se faço uma conexao para internet por fora do Squid a velocidade esta dentro do padrão, mas no squid fica muito lenta, estou verificando a possibilidade de virus mas nao conseguir pegar nada nos log.



  5. #5

    Padrão Re: Squid esta ficando lento...

    Fez teste de velocidade do próprio servidor?

  6. #6

    Padrão Re: Squid esta ficando lento...

    A Velocidade fora do squid ta normal.
    Quando inicio o serviço do squid a velocidade ta normal, e vai caindo com o passar do tempo.
    Nos log nao tem erro, nao conseguir identificar virus no cache.log



  7. #7

    Padrão Re: Squid esta ficando lento...

    Tente eliminar tudo que for básico como, análise de erros no messages, limpar o cache e até mesmo o cache.log, etc.

  8. #8

    Padrão Re: Squid esta ficando lento...

    Definitivamente nao sei o que possa ser, virus na rede ou virus no servidor.
    Ontem fiz um teste tirei todas as maquinas da rede e deixei somente uma maquina conecta, essa maquina nao estava com virus, startei o squid funcionou bem durante 2 min e depois a velocidade foi la embaixo e na verficação dos log cache.log e do access.log tinham diversas saidas para endereços que me parece ser virus, ai a duvida será que é virus no servidor? Mas se fosse virus no servidor deveria afetar tambem a velocidade na internet atraves do firewall o que nao acontece.

    Quando compartilho a internet via firewall a velocidade esta normal, mas quando ativo o squid ele começa bem e depois morre.

    Estou tentando instalar o clamav antivirus, mas ainda nao tive sucesso.



  9. #9

    Padrão Re: Squid esta ficando lento...

    Pouco provável, mas já checou a resolução de DNS no servidor? Quanto a esses endereços que você viu, não consegue identificar as origens?

  10. #10

    Padrão Re: Squid esta ficando lento...

    Tentei sim, nao tive respostas.
    Abrir um novo topico com os log do cache.log e access.log de uma olhada pra voce intender melhor.