+ Responder ao Tópico



  1. Boa Tarde, amigos eu já vi no forum varios exemplos mais não consegui fazer funcionar.
    Eu preciso pasar um site de um programa online que uso aqui na rede interna por todos os usúarios, todos estão limitados no controle de banda para navegação 128/128 , o q eu queria é que esse site passa-se sem controle de banda e o resto da navegação pelo valor atribuido ao usuário. usei a configuração abaixo enviado por um colega do forum, mais sempre que um usuário se conecta a regra de queue vai para o topo e sai da sequencia , deixa de funcionar, algum colega poderia me dizer como posso fazer isso, tenho lido muito material mais não tenho muita esperiência. uso versão 3.3 Hotspot+ webproxy. por ultimo estou começando do zero denovo só abilitei o hotspot só com as regras principais para funcionar, para não haver conflito , depois eu continuo se conseguir ,obrigado a todos.


    http://images.under-linux.net/images...quote_icon.png Postado originalmente por Faieppi http://images.under-linux.net/images...post-right.png
    Olá amigo, isso já foi discutido aqui no forum, ñ lembro quem postou, ñ retiro os créditos, veja essas regras:

    Bom dia respondendo a algumas pessoas que pediram como fazer para que quando o cliente fazer o teste de velocidade em alguns determinados sites que medem a velocidade da internet, deixar ela fora do controle de banda, dessa forma, o cliente
    quando for medir a velocidade ela vai muito mais alto doque a contratado.

    Novamente se sabendo como fazer as marcações de pacotes corretas no /ip firewall mangle, se pode fazer qualquer coisa com o pacote.

    Então vamos la:
    Primeiro:
    Teremos que ter em mãos todos os endereços dos sites que fazem medição de velocidade, imagino que vc deve ter logo levado um susto né pq imagina qts sites tem no mundo que fazar medição de velocidade..... pois é nesse caso o que eu fiz, procurei no google.com.br por sites que fazem medição de velocidade e filtrei os ips das duas primeiras paginas de resultado que ela meu deu, ja da para começar com essa lista, qualquer coisa vc mesmo pode ir aumentando ela ok.

    Iremos criar uma lista com todos os ips dos sites que fazem medição de velocidade e o nome dela vai se chamar "medidor"
    / ip firewall address-list
    add list=medidor address=200.140.120.29 comment="" disabled=no
    add list=medidor address=200.159.128.189 comment="" disabled=no
    add list=medidor address=209.160.32.66 comment="" disabled=no
    add list=medidor address=64.247.18.18 comment="" disabled=no
    add list=medidor address=200.159.160.39 comment="" disabled=no
    add list=medidor address=213.200.107.145 comment="" disabled=no
    add list=medidor address=200.245.0.12 comment="" disabled=no
    add list=medidor address=201.76.32.191 comment="" disabled=no
    add list=medidor address=200.150.160.39 comment="" disabled=no
    add list=medidor address=201.20.64.39 comment="" disabled=no
    add list=medidor address=66.216.44.80 comment="" disabled=no
    add list=medidor address=200.181.108.29 comment="" disabled=no
    add list=medidor address=200.196.233.42 comment="" disabled=no
    add list=medidor address=200.233.43.14 comment="" disabled=no
    add list=medidor address=201.84.0.28 comment="" disabled=no
    add list=medidor address=200.162.192.57 comment="" disabled=no

    Aqui esta um pouco de alguns sites que fazem medição de velocidade caso queira acrescentar, pode acrescentar sem problemas algum.

    Segundo:
    Agora entra a marcação de pacotes desses endereços IPs, e é aqui o segredo de tudo para funcionar perfeitamente, iremos fazer as marcações e dar um nome ao pacote chamado "medidorF"



    / ip firewall mangle
    add chain=prerouting dst-address-list=medidor action=mark-connection new-connection-mark=medidorC passthrough=yes comment="MEDIDOR" disabled=no
    add chain=prerouting connection-mark=medidorC action=mark-packet new-packet-mark=medidorF passthrough=no comment="" disabled=no
    add chain=input dst-address-list=medidor action=mark-connection new-connection-mark=medidorC passthrough=yes comment="MEDIDOR" disabled=no
    add chain=input connection-mark=medidorC action=mark-packet new-packet-mark=medidorF passthrough=no comment="" disabled=no
    add chain=output dst-address-list=medidor action=mark-connection new-connection-mark=medidorC passthrough=yes comment="MEDIDOR" disabled=no
    add chain=output connection-mark=medidorC action=mark-packet new-packet-mark=medidorF passthrough=no comment="" disabled=no
    add chain=postrouting dst-address-list=medidor action=mark-connection new-connection-mark=medidorC passthrough=yes comment="MEDIDOR" disabled=no
    add chain=postrouting connection-mark=medidorC action=mark-packet new-packet-mark=medidorF passthrough=no comment="" disabled=no

    Basta essas marcações apenas para poder funcionar perfeitamente, não esqueça se vc tiver alguma outra marcação em seu firewall mangle, coloque essas acima de tudo para poder funcionar perfeitamente

    Terceiro:
    Agora temos que criar no /queue simple uma regra com a marcação de pacotes que criamos, dizendo a velocidade que vc quer que de na medição dos seus clientes, ou vc deixa ela ilimitado ou vc pode colocar um limite de velocidade, no exemplo vou deixar upload a 64k e download ilimitado.



    / queues simple
    add name="MEDIDOR" target-addresses=0.0.0.0/0 dst-address=0.0.0.0/0 interface=all parent=none packet-marks=medidorF direction=both priority=8 \
    queue=up-0/down-0 limit-at=0/0 max-limit=64000/0 total-queue=default-small disabled=no


    Ou

    / queue simple
    add name="MEDIDOR" target-addresses=0.0.0.0/0 dst-address=0.0.0.0/0 \
    interface=all parent=none packet-marks=medidorF direction=both priority=8 \
    queue=default-small/default-small limit-at=0/0 max-limit=200000/200000 \
    total-queue=default-small disabled=no

    Não esquecer de colocar essa regra acima de todos os outros controles de banda que vc tiver.


  2. Amigo, já tentou adicionar o endereço/site no Walled Garden?



  3. Já tentei sim, só não passa pela tela de login, mais continua atrelado ao controle de banda do webproxy,obrigado!

  4. com a regra acima o site funciona perfeito, mais quando o usuário desloga e loga novamente a regra sai do topo da queue e entra regra do usuário , ai entra de novo no controle de banda...Clique na imagem para uma versão maior

Nome:	         2.jpg
Visualizações:	316
Tamanho: 	31,1 KB
ID:      	23530
    Espero que algum colega possa me ajudar a travar essa regra no queue, ou de eoutra forma,grato!



  5. <RESOLVIDO> bastou adicionar essa regra ao queue tree e o controle já funcionou perfeitinho, só falat mais alguns ajustes..
    add new queue nome=o q quizer
    Parent=global-out
    Packet Mark= selecione o packet da regra do seu mangle
    Queue Type=defaut
    Priority=8
    Limit At=nomeu caso"750k"
    Max Limit=no meu caso 1M






Tópicos Similares

  1. Ajuda para passar Site por fora do proxy
    Por Pedroh no fórum Redes
    Respostas: 3
    Último Post: 30-10-2014, 13:22
  2. Respostas: 8
    Último Post: 16-11-2011, 08:03
  3. Respostas: 0
    Último Post: 17-05-2010, 15:00
  4. deixar vnc ou ultravnc fora do controle de banda
    Por masterbeto no fórum Redes
    Respostas: 3
    Último Post: 29-09-2007, 01:44
  5. Medidor de velocidae fora do controle de banda...
    Por tiagomatias no fórum Redes
    Respostas: 8
    Último Post: 26-09-2007, 21:30

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L