Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Bom dia a todos,


    Estarei ensinando hoje como criar planos personalizados para seus clientes. Através das informações que citarei abaixo, será possível liberar e bloquear a conexão do usuário automaticamente. Os testes foram realizados utilizando a versão 4.5
    Todos as configurações abaixo foram realizadas utilizando o Winbox.

    Então, vamos lá....

    1º Passo – Configuração do NTP Client

    Esta configuração permite que o horário do mikrotik esteja sempre sincronizado com a cidade onde você atende. Mesmo que ocorra falta de energia, assim que o sistema for re-ligado, esta opção permitirá a configuração automática do horário local assim que obtiver acesso a internet.

    No Winbox siga os seguintes procedimentos:

    * System
    * NTP Client
    * Clique em ENABLE
    * Mode: UNICAST
    * Primary NTP Server: 159.148.172.205
    * Secondary NTP Server: 92.240.65.97

    Pronto, agora o Mikrotik já pode atualizar o seu horário automaticamente. Para fazer ajustes de acordo com a sua região vá em:

    * System
    * Clock

    Escolha o horário de acordo com a sua localidade, facilitando assim o seu trabalho posteriormente.

    2º Passo – Criar Scripts que irão Liberar ou bloquear as conexões

    Para que seja possível realizar o bloqueio ou liberação da conexão do seu cliente, será necessário que o mikrotik realize algumas operações que serão mostradas abaixo. Os códigos abaixo podem ser muito bem adaptados de acordo com a sua necessidade.

    Deixo bem claro que o funcionamento do script depende do argumento utilizado no “COMMENT” no processo de cadastramento do usuário (IP >> HOTSPOT >> USERS), por exemplo:

    Se eu colocar no comment do usuário “madrugada”, no script eu irei criar de forma que a alteração seja realizada apenas nos usuário que estejam com o comment igual a madrugada, ficou entendido?

    Bem, abaixo irei demonstrar como liberar os usuário com o comment igual a matutino, permitindo assim que o usuário conecte-se apenas pelo horário da manhã.


    * System
    * Scripts
    * Clique sobre o símbolo +
    * Coloque o nome Liberar_matutino
    * Em policy seleciona “WRITE, READ, POLICE”
    * Em SOURCE cole o seguinte código:

    :log info " "
    :log info "#### Iniciando processo de Ativação de usuários da manhã ####"
    :log info " "

    #Enable
    /ip hotspot user set [find comment=matutino] disable=no

    :log info "---------------------------------------------------"
    :log info "Os usuários da manhã foram Ativados com sucesso!"
    :log info "---------------------------------------------------"

    * Clique em OK

    Certo, nessa primeira parte nós apenas criamos a rotina de liberação do usuário pela parte da manhã. Temos que criar outra de bloqueio.

    * System
    * Scripts
    * Clique sobre o símbolo +
    * Coloque o nome Bloquear_matutino
    * Em policy seleciona “WRITE, READ, POLICE”
    * Em SOURCE cole o seguinte código:


    :log info " "
    :log info "#### Iniciando processo de desativação de usuários ativos da manhã ####"
    :log info " "

    #Disable
    /ip hotspot user set [find comment=matutino] disable=yes

    #Finish
    :foreach user in=[
    /ip hotspot user find comment=matutino] do={
    :local name [/ip hotspot user get $user name];
    /ip hotspot active remove [/ip hotspot active find user=$name];}
    :log info "---------------------------------------------------"
    :log info "Os usuários da manhã foram desconectados com sucesso!"
    :log info "---------------------------------------------------"

    * Clique em OK

    Veja que além de desabilitar o usuário, o mikrotik irá derrubar a conexão imediatamente.


    3º Passo – Agendar a hora que os Scripts serão ativados

    Como se pode ver através dos códigos do passo 2, em nenhum instante foi definido o horário de início e fim para liberação e bloqueio do usuário. Então agora, iremos fazer com que o mikrotik libere o usuário para acessar de 08:00 às 12:00, ou seja, somente pela parte da manhã, deixo claro que esse horário pode ser trocado por você com total liberdade.

    * System
    * Scheduler
    * Clique sobre o símbolo +
    * Coloque o nome Horário_liberamatutino
    * Em policy seleciona “WRITE, READ, POLICE”
    * Em Start Time: 08:00:00
    * Em Interval: 1d 00:00:00
    * On Event: Liberar_matutino

    Certo, neste primeiro momento apenas definimos o horário do início do plano matutino. Temos agora que definir o fim.

    * System
    * Scheduler
    * Clique sobre o símbolo +
    * Coloque o nome Horario_bloqueiomatutino
    * Em policy seleciona “WRITE, READ, POLICE”
    * Em Start Time: 12:00:00
    * Em Interval: 1d 00:00:00
    * On Event: Bloquear_matutino


    Pronto, como se pode notar, agora os scripts serão ativados automaticamente 8 da manhã e ao meio dia, liberando e bloqueando a conexão do usuário automaticamente.

    A dica que fica é sempre verificar se o comment do usuário está de acordo com as instruções do SCRIPT e antes de fazer qualquer alteração no script, sempre pesquise para que não tenha problemas.

    Agradecimentos serão muito bem vindos.
    Qualquer dúvida fico a disposição.

    Wendell Nascimento

  2. Muito bom o post, porem gostaria de lhe pedir para explicar como colocar os scripts, sou novo no mikrotik. muito obrigado



  3. System Scripts "+"

  4. cara muito show de bola seu script!

    uma duvida relacionada a outra coisa, mas acredito que vc saiba...
    eu tenho uma ficha de cadastro no hotspot que quando o cliente altera ele envia para a minha conta do google a alteração, mas para isso é necessário que tenha acesso a internet. Eu gostaria de saber como posso phazer para que os dados atualizados seja salvo no próprio mikrotik para que não precise do acesso a internet para ver a atualização, e como posso phazer para que os dados atualizados pelo cliente pela página de cadastro já altere automaticamente as configurações do mikrotik. Tipo nome do usuário e senha!


    obs. eu vi isso na internet a algum tempo e axei o máximo e a tempo tento descobrir como isso é pheito e não consigo!

    valew awe cara e novamente parabéns!



  5. Bom, já realizei algo parecido no passado, porém precisava de acesso a internet. Fiz dessa forma:
    criei um "google form", e permiti que o link fosse liberado para qualquer pessoa mesmo sem acesso de usuário e senha na tela de hostpot, assim os dados eram acessados somente por mim na minha conta google. Espero ter ajudado






Tópicos Similares

  1. Respostas: 20
    Último Post: 22-01-2014, 18:54
  2. Planos personalizados - Completo
    Por wendell no fórum Redes
    Respostas: 4
    Último Post: 28-06-2011, 23:03
  3. Deixar KAZAA em segundo plano com IPTABLES
    Por rafaelpazcolles no fórum Linguagens de Programação
    Respostas: 0
    Último Post: 07-05-2003, 15:05
  4. wine HQ e da Codeweavers completo
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 03-05-2003, 17:45
  5. lilo personalizado!!!
    Por garan no fórum Servidores de Rede
    Respostas: 1
    Último Post: 16-11-2002, 00:10

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L