Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Olá,

    Instalei o conjunto apache + PHP + MySQL no meu ubuntu 10.04 e não achei o httpd.conf. Procurei melhor e achei ele dentro da pasta /etc/apache2/, só que vazio. Me disseram que se eu colocar qualquer config lá funciona, mas coloquei uma regra lá de htaccess e não notei diferença.

    Obrigado!

  2. Acredito que vc tenha dado pelo menos um ls dentro da pasta e viu que existe varios outros arquivos?!?!?!?!?!
    se for apache 2 que concerteza deve ser existe o arquivo apache2.conf, ports.conf, bla bla bla.....
    existe tambem outras subpastas tais como sites-enabled que dentro contem um link que provavelmente sera 000-default onde tem uma boa parte das conf do apache!
    Experimenta explorar as pastas e verificar o conteudo dos arquivos que vc vai achar o que procura!



  3. Então, eu estava procurando justamente para aplicar umas configurações para fazer o htaccess funcionar, pois ele não está funcionando.

    Preciso substituir o seguinte código:

    <Directory />
    Options FollowSymLinks
    AllowOverride None
    </Directory>
    ou
    <Directory “/var/www/html”>
    Options Indexes FollowSymLinks
    AllowOverride None
    Order allow,deny
    Allow from all
    </Directory>

    Pelo código:

    <Directory />
    Options FollowSymLinks Indexes
    AllowOverride AuthConfig
    </Directory>

    Parece que existem códigos parecidos no 000-defaut, mas quando substituo da 500 Internal Server Error. O que fazer então para aplicar essas configurações?

    Abraços!

  4. Pronto, resolvi esse problema!
    Agora estou com outro, estou tentando executar o seguinte comando na função exec para adicionar um usuário htaccess:

    exec("cd /etc/apache2/auth/ && htpasswd -b /etc/apache2/auth/htpasswd suporte1 senha");

    o mesmo comando funciona se eu digitar direto no SSH.
    Última edição por FarinhadeOsso; 27-06-2011 às 22:54.



  5. Provavelmente quando vc estra pelo ssh deve estar coo usuario root.
    Experimenta usar um sudo antes do cd!






Tópicos Similares

  1. httpd.conf e domínios virtuais
    Por estanisgeyer no fórum Servidores de Rede
    Respostas: 6
    Último Post: 24-11-2003, 14:32
  2. Ejetando uma folha em branco no final da impressão
    Por _edinh0_ no fórum Servidores de Rede
    Respostas: 10
    Último Post: 06-06-2003, 07:53
  3. Como configurar o httpd.conf para rodar scripts cgi?
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 28-05-2003, 10:29
  4. Configurar o Path_sendmail no httpd.conf
    Por Neckratal no fórum Servidores de Rede
    Respostas: 4
    Último Post: 27-12-2002, 10:08
  5. negar remetente em branco
    Por no fórum Servidores de Rede
    Respostas: 0
    Último Post: 28-11-2002, 12:13

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L