+ Responder ao Tópico



  1. #1

    Padrão Mikrotik aceitando apenas clientes com sinal bom

    Bom dia galera, estou com problemas aqui devido não usar encriptação na rede, dai vizinhos com notebook ou pessoas com antenas externa virada errada de outros provedor conectam na rede fazendo a rede toda cair o rendimento... Gostaria de uma solução para o MK só aceitar conexões com sinal bom por ex: no máximo -70 pior que isso ele rejeitasse. Existe está possibilidade? Obrigado.

  2. #2

    Padrão Re: Mikrotik aceitando apenas clientes com sinal bom

    Existe sim amigo, basta usar o Access List, cadastrando todos MAC de seus clientes nela. Quando vc adiciona o mac ao access list ele lhe da a opção de niveis minimos de sinal para aceitação. Feito isso abra a configuração dos cartoes e na guia Wireless e desmarque a opção Default Authenticate. Mas lembre-se, feito isso soh irao se conectar ao AP os clientes que estiverem com seu MAC cadastrado do Access List.



  3. #3

    Padrão Re: Mikrotik aceitando apenas clientes com sinal bom

    Certo amigo, esta ferramente já sei como funciona, mais como uso hotspot gostaria que todos conseguissem conectar na minha rede mesmo não estando no acess list para aqueles que moram perto da torre pegarem e poderem testar a rede... mais apenas os que tenha sinal EX: -75 pra melhor... Hoje em dia uso o script ack time out que elimita a cada 2min clientes com ack maior que 60, mais nao vejo isso como solucao para o caso...

  4. #4

    Padrão Re: Mikrotik aceitando apenas clientes com sinal bom

    A forma que conheço eh essa, pode ate ser que tenha alguma forma de fazer via script, porem essa parte de scripp nao manjo bem hehehe...



  5. #5

    Padrão Re: Mikrotik aceitando apenas clientes com sinal bom

    Cadastre no access-list apenas um usuário sem mac ou com o mac 00:00:00:00:00:00 e coloque o nivel de sinal desejado.

  6. #6

    Padrão Re: Mikrotik aceitando apenas clientes com sinal bom

    bom a parte de script eu sou um zero a esquerda, estudei algumas formas e a única que está funcionando não muito bem, mais quebrando um galho é pelo ACK, deixei dinâmico na placa e um script rodando a cada 2min removendo e marcando aqueles que estão acima de 60. Segue script que achei aqui mesmo no forum.

    #Script ACK-Check v0.1
    #
    #Lista as estacoes que estao com ACK acima do limite com opcao para desconecta-las
    #
    # Autor: Alexandre Jeronimo Correa <[email protected]>
    # 20/11/2009 - 01:03am
    #
    #Instrucoes de uso:
    # -- Adicionar o codigo completo em SYSTEM >> SCRIPTS
    # -- Por padrao o script nao vai derrubar nenhuma estacao, rode o script padrao antes de
    # configurar a variavel cut para 1, tendo certeza que o script esta OK.
    # -- O script pode ser executado pelo botao "run script" ou via linha de comando.
    # "/ system script run <nome do script>
    # -- O script so funciona em interfaces que o modo de operacao seja AP-BRIDGE
    # -- Testado nas versoes 3.25 até 3.30
    #
    #Informacoes:
    #
    #Variavel ack -> deve ter o valor do ack MAXIMO permitido.
    #Variavel cut -> deve ser 0 ou 1, 0 somente mostra, 1 mostra e desconecta a estacao.
    ##################################################################
    #Configuracoes das variaveis
    :local ack 60;
    :local cut 1;


    ############ Script - NAO ALTERAR #####################################
    :local mac "";
    :local uack "";
    :local removido "";
    :log warning ("[ackchk] Procurando clientes com ACK maior que " . $ack);
    #pega a lista de interfaces AP wireless ativas, e que tenham ack dinamico
    :foreach i in=[ / interface wireless find mode="ap-bridge" ack-timeout="dynamic" running] do={
    :local intname [ / interface wireless get $i name ];
    :log warning (" Interface: " . $intname);
    :foreach x in=[/interface wireless registration-table find interface=$intname] do={
    :set uack [/interface wireless registration-table get $x ack-timeout];
    :set removido "";
    :if ($uack > $ack) do={
    :set mac [ / interface wireless registration-table get $x mac-address];
    :if ($cut = 1) do= {
    :set removido " removido...";
    / interface wireless registration-table remove $x;
    };
    :log warning (" mac: " . $mac . "@" . $intname . " [" . $uack . "]" . $removido);
    };
    };
    };
    ############ FIM #####################################



  7. #7

    Padrão Re: Mikrotik aceitando apenas clientes com sinal bom

    Citação Postado originalmente por ipunet Ver Post
    Cadastre no access-list apenas um usuário sem mac ou com o mac 00:00:00:00:00:00 e coloque o nivel de sinal desejado.
    Testarei agora mesmo e posto resultado, vlw.

  8. #8

    Padrão Re: Mikrotik aceitando apenas clientes com sinal bom

    Amigo ipunet, meu MK 4.17 na aba wireless fui em acess list tirei todos que constavam la, adicionei um (usuario) sem mac e coloquei -70..70 deixando somente ele ativo... Mesmo assim antenas com sinal -75 -78 registraram nos paineis... Teria mais algum macete? Vlw



  9. #9

    Padrão Re: Mikrotik aceitando apenas clientes com sinal bom

    Ola,
    Pelo que entendi ,falta vc ir na aba Wireless configurar o rate 5M e 11M se for o caso e desmarcar Defaut Authenticate.

    Obs: Somente clientes com o mac cadastrado na Aba Access List conseguira conectar no seu AP e com sinal que vc cadastrou.

    At.
    Junio Cesar

  10. #10

    Padrão Re: Mikrotik aceitando apenas clientes com sinal bom

    é so vc ativar e configurar o data rates no trafico minimo que vc quer que os clientes com sinal ruim são desconectados



  11. #11

    Padrão Re: Mikrotik aceitando apenas clientes com sinal bom

    Citação Postado originalmente por vie190 Ver Post
    é so vc ativar e configurar o data rates no trafico minimo que vc quer que os clientes com sinal ruim são desconectados
    Bom amigo eu ja coloquei data rates em 5.5 e 11... entando continua clientes com sinal ex: -84 e conecta a 1mb fazendo a bagunça geral na rede
    Clique na imagem para uma versão maior

Nome:	         Configuracao errada data rates.jpg
Visualizações:	233
Tamanho: 	63,4 KB
ID:      	24696
    Última edição por peritinaicos; 15-07-2011 às 11:45.

  12. #12

    Padrão Re: Mikrotik aceitando apenas clientes com sinal bom

    Eu nao quero deixar a rede (fechada apenas para os cadastrados, quero que todos conectem, mais somente os com sinal razoavel).



  13. #13

    Padrão Re: Mikrotik aceitando apenas clientes com sinal bom

    Entendi, mas pelo visto acho que funciona somente com Opção Defaut Authenticate marcado, coisa que vc não quer ,faça o teste marque e veja se funciona, se funcionar ja sabe que este recurso só funciona com esta Opção marcada.

    Att

    Junio Cesar

  14. #14

    Padrão Re: Mikrotik aceitando apenas clientes com sinal bom

    Eu fiz um teste no meu sistema, e não funcionou este recurso na versão 5x.
    mesmo deixando marcado defaut authenticate e no access list o sinal desejado.

    Att

    Junio Cesar



  15. #15

    Padrão Re: Mikrotik aceitando apenas clientes com sinal bom

    Vc desmarcou "Defaut Authenticate" ? No meu funciona ! adiciono apenas um usuário com o mac 00:00:00:00:00:00 e desmarco o "Defaut Authenticate", somente.

  16. #16

    Padrão Re: Mikrotik aceitando apenas clientes com sinal bom

    Citação Postado originalmente por ipunet Ver Post
    Vc desmarcou "Defaut Authenticate" ? No meu funciona ! adiciono apenas um usuário com o mac 00:00:00:00:00:00 e desmarco o "Defaut Authenticate", somente.
    No meu caso nao queria que aceitasse somente os cadastrados, queria que aceitasse todos que tenha um sinal razuavel



  17. #17

    Padrão Re: Mikrotik aceitando apenas clientes com sinal bom

    Conseguiu?

  18. #18

    Padrão

    Oi pessoal, seguinte, tinha o mesmo problema de vocês, e não achava a solução na internet!
    Então sentei e criei esse script, que dropa os clientes com sinal abaixo do definido, espero que ajude vocês, aki salvou a lavoura.

    #Script Sinal Check
    #
    #Lista as estacoes que estao com Sinal Abaixo do limite com opcao para desconecta-las
    #
    # Autor: André Ximenes De Melo Junior ([email protected])
    #
    #Instrucoes de uso:
    # -- Adicionar o codigo completo em SYSTEM >> SCRIPTS
    # -- Por padrao o script nao vai derrubar nenhuma estacao, rode o script padrao antes de
    # configurar a variavel cut para 1, tendo certeza que o script esta OK.
    # -- O script pode ser executado pelo botao "run script" ou via linha de comando.
    # "/ system script run <nome do script>
    # -- O script so funciona em interfaces que o modo de operacao seja AP-BRIDGE
    # -- crie uma regra no Scheduler para auomatizar o uso
    # -- Testado na versão 6.33
    #
    #Informacoes:
    #
    #Variavel Smax -> deve ter o valor do Signal MAXIMO permitido.
    #Variavel cut -> deve ser 0 ou 1, 0 somente mostra, 1 mostra e desconecta a estacao.
    #Script Sinal Check
    #
    #Lista as estacoes que estao com Sinal acima do limite com opcao para desconecta-las
    #
    # Autor: André Ximenes De Melo Junior ([email protected])
    #
    #Instrucoes de uso:
    # -- Adicionar o codigo completo em SYSTEM >> SCRIPTS
    # -- Por padrao o script nao vai derrubar nenhuma estacao, rode o script padrao antes de
    # configurar a variavel cut para 1, tendo certeza que o script esta OK.
    # -- O script pode ser executado pelo botao "run script" ou via linha de comando.
    # "/ system script run <nome do script>
    # -- O script so funciona em interfaces que o modo de operacao seja AP-BRIDGE
    # -- crie uma regra no Scheduler para auomatizar o uso
    # -- Testado na versão 6.33
    #
    #Informacoes:
    #
    #Variavel Smax -> deve ter o valor do Signal MAXIMO permitido.
    #Variavel cut -> deve ser 0 ou 1, 0 somente mostra, 1 mostra e desconecta a estacao.
    ##################################################################
    #Configuracoes das variaveis valor do sinal sem o ( - )
    :local Smax 70;
    :local cut 1;

    ############ Script - NAO ALTERAR #####################################
    :local mac "";
    :local Smed "";
    :local removido "";
    :local Slimp "";
    :log warning ("[Sinal Check] Procurando clientes com Sinal Menor que " . $Smax);
    :foreach i in=[ / interface wireless find mode="ap-bridge" running] do={
    :local intname [ / interface wireless get $i name ];
    :log warning (" Interface: " . $intname);
    :foreach x in=[/interface wireless registration-table find interface=$intname] do={
    :set Smed [/interface wireless registration-table get value-name=signal-strength number=$x];
    :set Slimp [ick $Smed 1 3]
    #:log warning ("SINAL " . $Slimp);
    :set removido "";
    :if ($Slimp > $Smax) do={
    :set mac [ / interface wireless registration-table get $x mac-address];
    :if ($cut = 1) do= {
    :set removido " removido...";
    / interface wireless registration-table remove $x;
    };
    :log warning (" mac: " . $mac . "@" . $intname . " [" . $Smed . "]" . $removido);
    };
    };
    };
    ############ FIM #####################################
    Coloque isto numa regra dentro de Scripts e faça o scheduler a cada 30 segundos ou o tempo que quiser...