+ Responder ao Tópico



  1. Saudações pessoal comprei um tv samsung led un405500 e descobri que ela acessa arquivos upnp media, procurando na internet achei varias tutoriais após varias tentativas consegui configurar o mediatomb para funcionar na rede acesso meus arquivos no computador pela rede beleza .

    1 - passo

    sudo apt-get install mediatomb

    2 - passo
    Altere o arquivo de configuração e deixe como abaixo lembrando que só alterei as linhas : 8,9,26 ,33,34,35 o resto do arquivo é o padrão

    <?xml version="1.0" encoding="UTF-8"?>
    <config version="2" xmlns="http://mediatomb.cc/config/2" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://mediatomb.cc/config/2 http://mediatomb.cc/config/2.xsd"><!--
    Read /usr/share/doc/mediatomb-common/README.gz section 6 for more
    information on creating and using config.xml configration files.
    -->
    <server>
    <ui enabled="yes" show-tooltips="yes">
    <accounts enabled="yes" session-timeout="30">
    <account user="mediatomb" password="mediatomb"/>
    </accounts>
    </ui>
    <name>MediaTomb</name>
    <udn>uuid:8b209ae3-aebc-41aa-a24a-3326a31b194e</udn>
    <home>/var/lib/mediatomb</home>
    <webroot>/usr/share/mediatomb/web</webroot>
    <storage caching="yes">
    <sqlite3 enabled="yes">
    <database-file>mediatomb.db</database-file>
    </sqlite3>
    <mysql enabled="no">
    <host>localhost</host>
    <username>mediatomb</username>
    <database>mediatomb</database>
    </mysql>
    </storage>
    <protocolInfo extend="yes"/><!-- For PS3 support change to "yes" --><!--
    Uncomment the lines below to get rid of jerky avi playback on the
    DSM320 or to enable subtitles support on the DSM units
    -->
    <custom-http-headers>
    <add header="transferMode.dlna.org: Streaming"/>
    <add header="contentFeatures.dlna.org: DLNA.ORG_OP=01;DLNA.ORG_CI=0;DLNA.ORG_FLAGS=017000 00000000000000000000000000"/>
    <add header="X-User-Agent: redsonic"/>
    </custom-http-headers>
    <manufacturerURL>redsonic.com</manufacturerURL>
    <modelNumber>105</modelNumber>
    <!-- Uncomment the line below if you have a Telegent TG100 --><!--
    <upnp-string-limit>101</upnp-string-limit>
    -->
    <extended-runtime-options>
    <ffmpegthumbnailer enabled="no">
    <thumbnail-size>128</thumbnail-size>
    <seek-percentage>5</seek-percentage>
    <filmstrip-overlay>yes</filmstrip-overlay>
    <workaround-bugs>no</workaround-bugs>
    </ffmpegthumbnailer>
    <mark-played-items enabled="no" suppress-cds-updates="yes">
    <string mode="prepend">*</string>
    </mark-played-items>
    </extended-runtime-options>
    </server>
    <import hidden-files="no">
    <scripting script-charset="UTF-8">
    <common-script>/usr/share/mediatomb/js/common.js</common-script>
    <playlist-script>/usr/share/mediatomb/js/playlists.js</playlist-script>
    <virtual-layout type="builtin">
    <import-script>/usr/share/mediatomb/js/import.js</import-script>
    <dvd-script>/usr/share/mediatomb/js/import-dvd.js</dvd-script>
    </virtual-layout>
    </scripting>
    <mappings>
    <extension-mimetype ignore-unknown="no">
    <map from="mp3" to="audio/mpeg"/>
    <map from="ogg" to="application/ogg"/>
    <map from="asf" to="video/x-ms-asf"/>
    <map from="asx" to="video/x-ms-asf"/>
    <map from="wma" to="audio/x-ms-wma"/>
    <map from="wax" to="audio/x-ms-wax"/>
    <map from="wmv" to="video/x-ms-wmv"/>
    <map from="wvx" to="video/x-ms-wvx"/>
    <map from="wm" to="video/x-ms-wm"/>
    <map from="wmx" to="video/x-ms-wmx"/>
    <map from="m3u" to="audio/x-mpegurl"/>
    <map from="pls" to="audio/x-scpls"/>
    <map from="flv" to="video/x-flv"/>
    <map from="mkv" to="video/x-matroska"/>
    <map from="mka" to="audio/x-matroska"/><!-- Uncomment the line below for PS3 divx support --><!-- <map from="avi" to="video/divx"/> --><!-- Uncomment the line below for D-Link DSM / ZyXEL DMA-1000 --><!-- <map from="avi" to="video/avi"/> -->
    </extension-mimetype>
    <mimetype-upnpclass>
    <map from="audio/*" to="object.item.audioItem.musicTrack"/>
    <map from="video/*" to="object.item.videoItem"/>
    <map from="image/*" to="object.item.imageItem"/>
    <map from="application/ogg" to="object.item.audioItem.musicTrack"/>
    </mimetype-upnpclass>
    <mimetype-contenttype>
    <treat mimetype="audio/mpeg" as="mp3"/>
    <treat mimetype="application/ogg" as="ogg"/>
    <treat mimetype="audio/x-flac" as="flac"/>
    <treat mimetype="image/jpeg" as="jpg"/>
    <treat mimetype="audio/x-mpegurl" as="playlist"/>
    <treat mimetype="audio/x-scpls" as="playlist"/>
    <treat mimetype="audio/x-wav" as="pcm"/>
    <treat mimetype="audio/L16" as="pcm"/>
    <treat mimetype="video/x-msvideo" as="avi"/>
    <treat mimetype="video/mp4" as="mp4"/>
    <treat mimetype="audio/mp4" as="mp4"/>
    <treat mimetype="application/x-iso9660" as="dvd"/>
    <treat mimetype="application/x-iso9660-image" as="dvd"/>
    <treat mimetype="video/x-matroska" as="mkv"/>
    <treat mimetype="audio/x-matroska" as="mka"/>
    </mimetype-contenttype>
    </mappings>
    <online-content><!-- Make sure to setup a transcoding profile for flv -->
    <YouTube enabled="no" refresh="28800" update-at-start="no" purge-after="604800" racy-content="exclude" format="flv" hd="no">
    <favorites user="mediatomb"/>
    <standardfeed feed="most_viewed" time-range="today"/>
    <playlists user="mediatomb"/>
    <uploads user="mediatomb"/>
    <standardfeed feed="recently_featured" time-range="today"/>
    </YouTube>
    <Weborama enabled="no" refresh="28800" update-at-start="no">
    <playlist name="Active" type="playlist" mood="active"/>
    <playlist name="Metal" type="playlist">
    <filter>
    <genres>metal</genres>
    </filter>
    </playlist>
    </Weborama>
    <AppleTrailers enabled="no" refresh="43200" update-at-start="no" resolution="640"/>
    </online-content>
    </import>
    <transcoding enabled="no">
    <mimetype-profile-mappings>
    <transcode mimetype="video/x-flv" using="vlcmpeg"/>
    <transcode mimetype="application/ogg" using="vlcmpeg"/>
    <transcode mimetype="application/ogg" using="oggflac2raw"/>
    <transcode mimetype="audio/x-flac" using="oggflac2raw"/>
    </mimetype-profile-mappings>
    <profiles>
    <profile name="oggflac2raw" enabled="no" type="external">
    <mimetype>audio/L16</mimetype>
    <accept-url>no</accept-url>
    <first-resource>yes</first-resource>
    <accept-ogg-theora>no</accept-ogg-theora>
    <agent command="ogg123" arguments="-d raw -o byteorder:big -f %out %in"/>
    <buffer size="1048576" chunk-size="131072" fill-size="262144"/>
    </profile>
    <profile name="vlcmpeg" enabled="no" type="external">
    <mimetype>video/mpeg</mimetype>
    <accept-url>yes</accept-url>
    <first-resource>yes</first-resource>
    <accept-ogg-theora>yes</accept-ogg-theora>
    <agent command="vlc" arguments="-I dummy %in --sout #transcode{venc=ffmpeg,vcodec=mp2v,vb=4096,fps=25,aenc=ffmpeg,acodec=mpga,ab=192,samplerate=44100,channels=2}:standard{access=file,mux=ps,dst=%out} vlc:quit"/>
    <buffer size="14400000" chunk-size="512000" fill-size="120000"/>
    </profile>
    </profiles>
    </transcoding>
    </config>


    3- passo

    Vá em menu , multimidia , mediatomb irá abrir o navegador irá pedir a senha que é mediatomb e mediatomb depois vá em filesystem e adicione os diretorio de filmes , fotos e musicas . ele demorar para criar o indice

    4 - passo

    vá na televisão ligada a rede abra o software allshare voçe verá mediatomb dentro voçe verá os arquivos é eles rodaram e adeus a copia para pendriver .

    Espero que tenha ajudado

  2. Muito bom Welles! Esse Mediatomb pega também as legendas tudo certinho? Eu tenho instaldo no meu servidor de arquivos em casa, o PS3 Media Server, mas nos filmes que tem legendas com o mesmo nome (pra carregar automaticamente), fica bem lento quando eu passo mais de 2x no avanço rápido, às vezes até dá um erro na rede. Acho que força o servidor, pois ele é media streaming.



  3. brother fiz como tu ensinou, meu notebook windows ve os arquivos acessa e tudo mais até meu celular consegue executar os arquivos mas a minha tv enxerga mas diz que o codec não é suportado o video compartilhado foi testado na minha via usb funciona diboa mas pelo mediatomb informa codec nao suportado oq pode ser?? como informei o notebook e o celular ta tudo ok só a tv que acontece isso, se puder me ajudar ficarei muitoooooooooo grato






Tópicos Similares

  1. Smart tv samsung não conecta na internet
    Por didism2 no fórum Redes
    Respostas: 3
    Último Post: 04-02-2015, 16:09
  2. Respostas: 7
    Último Post: 12-02-2008, 07:07
  3. placa play TV mpeg com driver bttv - a saga
    Por sorominhoco no fórum Sistemas Operacionais
    Respostas: 2
    Último Post: 22-08-2005, 18:39
  4. Como fazer um AD-HOC com Samsung SWL 3300 AP
    Por clistenis no fórum Redes
    Respostas: 9
    Último Post: 21-05-2004, 09:35
  5. bridge lucent com placa samsung
    Por ediguedes no fórum Redes
    Respostas: 1
    Último Post: 03-02-2003, 20:19

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L