Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. karos colegas! estou com dificuldade em fazer minha vpn se comunicar, instalei no servidor e na filial o openvpn e iniciei o serviço e não deu erro. nos logs fala que esta ok. mas a filial nao comunica com o servidor.

    segue abaixo os script da matriz.conf e filial.conf

    Matriz:

    # Usar como interface o driver TUN
    dev tun
    # 10.6.0.1 ip que será assumido na matriz
    # 10.6.0.2 ip remoto, ou seja, ip que será assumido na Filial
    ifconfig 10.6.0.1 10.6.0.2
    # Protocollo
    proto udp
    # Porta
    port 1194
    # Chave estatica
    secret /etc/openvpn/chave.key
    # Monitoramento da conexao: primeiro numero ping, segundo restart da vpn em segundos
    keepalive 10 120
    # Compreensao de dados
    comp-lzo
    # Mantem a interface tun carreganda quando a vpn e reiniciada
    persist-tun
    # Mantem a chave carregada quando a vpn e reiniciada
    persist-key
    # Caso o IP mude, o tunel continua estabelecido
    float
    # Nivel do log
    verb 3
    # Informacao de status da conexao
    status /var/log/openvpn/matriz-status.log
    # Arquivo de log
    log-append /var/log/openvpn/matriz.log
    # Criando rotas
    #up /etc/openvpn/rotas.up
    # Apagando rotas
    #down /etc/openvpn/rotas.down


    Filial:

    remote 187.xxx.xxx.xxx
    # Usar como interface o driver TUN
    dev tun
    # 10.6.0.1 ip que será assumido na matriz
    # 10.6.0.2 ip remoto, ou seja, ip que será assumido na Filial
    ifconfig 10.6.0.2 10.6.0.1
    # Protocollo
    proto udp
    # Porta
    port 1194
    # Chave estatica
    secret /etc/openvpn/chave.key
    # Monitoramento da conexao: primeiro numero ping, segundo restart da vpn em segundos
    keepalive 10 120
    # Compreensao de dados
    comp-lzo
    # Mantem a interface tun carreganda quando a vpn e reiniciada
    persist-tun
    # Mantem a chave carregada quando a vpn e reiniciada
    persist-key
    # Caso o IP mude, o tunel continua estabelecido
    float
    # Nivel do log
    verb 3
    # Informacao de status da conexao
    status /var/log/openvpn/filial-status.log
    # Arquivo de log
    log-append /var/log/openvpn/filial.log
    # Criando rotas
    up /etc/openvpn/rotas.up
    # Apagando rotas
    down /etc/openvpn/rotas.down

  2. Boa tarde.

    Neste post[1] tem configurações que estão funcionando corretamente. Veja o script e faça os ajustes necessários para adequar ao seu cenário

    [1] https://under-linux.org/f96/vpn-com-...57/#post565122

    Saudações,

    Trober
    -
    -
    -
    -
    -



  3. fazendo alguns teste verifiquei que ao dar o comando
    # openvpn --config /etc/openvpn/matriz.conf

    Aparece a mensagem e não sai da ultima linha


    Mon Aug 8 11:59:13 2011 OpenVPN 2.1.1 i686-pc-linux-gnu [SSL] [LZO2] [EPOLL] [PKCS11] built on Jul 5 2010
    Mon Aug 8 11:59:13 2011 NOTE: OpenVPN 2.1 requires '--script-security 2' or higher to call user-defined scripts or executables
    Mon Aug 8 11:59:13 2011 LZO compression initialized
    Mon Aug 8 11:59:13 2011 TUN/TAP device tun0 opened
    Mon Aug 8 11:59:13 2011 /bin/ip link set dev tun0 up mtu 1500
    Mon Aug 8 11:59:13 2011 /bin/ip addr add dev tun0 local 10.0.0.1 peer 10.0.0.2
    Mon Aug 8 11:59:13 2011 UDPv4 link local (bound): [undef]:1194
    Mon Aug 8 11:59:13 2011 UDPv4 link remote: [undef]




    Alguém pode ajudar estou com urgênica!!!

  4. Citação Postado originalmente por andrecharamos Ver Post
    fazendo alguns teste verifiquei que ao dar o comando
    # openvpn --config /etc/openvpn/matriz.conf

    Aparece a mensagem e não sai da ultima linha


    Mon Aug 8 11:59:13 2011 OpenVPN 2.1.1 i686-pc-linux-gnu [SSL] [LZO2] [EPOLL] [PKCS11] built on Jul 5 2010
    Mon Aug 8 11:59:13 2011 NOTE: OpenVPN 2.1 requires '--script-security 2' or higher to call user-defined scripts or executables
    Mon Aug 8 11:59:13 2011 LZO compression initialized
    Mon Aug 8 11:59:13 2011 TUN/TAP device tun0 opened
    Mon Aug 8 11:59:13 2011 /bin/ip link set dev tun0 up mtu 1500
    Mon Aug 8 11:59:13 2011 /bin/ip addr add dev tun0 local 10.0.0.1 peer 10.0.0.2
    Mon Aug 8 11:59:13 2011 UDPv4 link local (bound): [undef]:1194
    Mon Aug 8 11:59:13 2011 UDPv4 link remote: [undef]




    Alguém pode ajudar estou com urgênica!!!

    Boa tarde.

    Qual o flavor (distribuição) do seu GNU/Linux?

    Saudações,

    Trober
    -
    -
    -
    -
    -



  5. Utilizo o OpenSUSE 11.3

    testei no 11.1 e também deu o mesmo erro.

    Kara ja tentei de tudo e nada.

    se pudre me ajudar vou ficar muito grato.






Tópicos Similares

  1. VPN...não está funcionando.
    Por __FERNANDO__ no fórum Servidores de Rede
    Respostas: 2
    Último Post: 19-08-2004, 14:04
  2. Squid não esta atualizando
    Por _MANCHESTER_ no fórum Servidores de Rede
    Respostas: 2
    Último Post: 12-04-2003, 18:33
  3. VirtualHost nao esta 100%
    Por no fórum Servidores de Rede
    Respostas: 2
    Último Post: 17-02-2003, 16:06
  4. DNS Nao esta funcionando
    Por earaujos no fórum Servidores de Rede
    Respostas: 3
    Último Post: 12-02-2003, 14:40
  5. acl no squid não está funcionando. O que fazer ?
    Por no fórum Servidores de Rede
    Respostas: 3
    Último Post: 20-12-2002, 16:01

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L