Página 1 de 3 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Load Balance não equilibra carga.

    Pessoal, não tenho muito conhecimento com mikrotik e preciso da ajuda de vocês.
    Tenho uma RB750G com 2 link adsl de 2 mb cada.
    Esta RB750G faz load balance e controle hotspot.
    Só que acontece o seguinte: o Load Balance não equilibra carga. Deixa o link 1 sobrecarregado e o link 2 com baixo tráfego. vejam a imagem:Clique na imagem para uma versão maior

Nome:	         Load Balance.jpg
Visualizações:	286
Tamanho: 	83,6 KB
ID:      	25700
    O que pode estar acontecendo:
    se eu desabilitar o link 1, o 2 assume o tráfego, mas com ambos ativos, não há equilíbrio de carga conforme mostra a imagem.
    Conto com o apoio de vcs.

    Grato!

  2. #2

    Padrão Re: Load Balance não equilibra carga.

    Boa noite amigo, como esta fazendo o balanceamente da carga? vai no terminal e da: ip firewall mangle export e posta aqui pra vermos



  3. #3

    Padrão Re: Load Balance não equilibra carga.

    tem alguma marcação errada no mangle. posta ai o que o amigo peritinaicos pediu que agente ajuda.

  4. #4

    Padrão Re: Load Balance não equilibra carga.

    Citação Postado originalmente por Paturi Ver Post
    Pessoal, não tenho muito conhecimento com mikrotik e preciso da ajuda de vocês.
    Tenho uma RB750G com 2 link adsl de 2 mb cada.
    Esta RB750G faz load balance e controle hotspot.
    Só que acontece o seguinte: o Load Balance não equilibra carga. Deixa o link 1 sobrecarregado e o link 2 com baixo tráfego. vejam a imagem:Clique na imagem para uma versão maior

Nome:	         Load Balance.jpg
Visualizações:	286
Tamanho: 	83,6 KB
ID:      	25700
    O que pode estar acontecendo:
    se eu desabilitar o link 1, o 2 assume o tráfego, mas com ambos ativos, não há equilíbrio de carga conforme mostra a imagem.
    Conto com o apoio de vcs.

    Grato!
    > ip firewall mangle export
    # aug/08/2011 22:24:55 by RouterOS 4.11
    # software id = 8NEL-A835
    #
    /ip firewall mangle
    add action=accept chain=prerouting comment="" disabled=no dst-address-list=\
    sem_balance
    add action=mark-connection chain=prerouting comment="" disabled=no \
    in-interface=bridge1 new-connection-mark=conn_link1 passthrough=yes \
    per-connection-classifier=both-addresses:2/0
    add action=mark-connection chain=prerouting comment="" disabled=no \
    in-interface=bridge1 new-connection-mark=conn_link2 passthrough=yes \
    per-connection-classifier=both-addresses:2/1
    add action=mark-routing chain=prerouting comment="" connection-mark=\
    conn_link1 disabled=no in-interface=bridge1 new-routing-mark=route_link1 \
    passthrough=yes
    add action=mark-routing chain=prerouting comment="" connection-mark=\
    conn_link2 disabled=no in-interface=bridge1 new-routing-mark=route_link2 \
    passthrough=yes

    Tá aí amigos.
    Lhes agradeço pela disposição em ajudar.
    Última edição por Paturi; 08-08-2011 às 22:34.



  5. #5

    Padrão Re: Load Balance não equilibra carga.

    Amigo tenho aki so q na rb450g e esta 1000% se quiser posso passar bkp pra vc ....

  6. #6

    Padrão Re: Load Balance não equilibra carga.

    Citação Postado originalmente por alternativainfo Ver Post
    Amigo tenho aki so q na rb450g e esta 1000% se quiser posso passar bkp pra vc ....
    Opá! Manda aí
    Te agradeço!



  7. #7

    Padrão Re: Load Balance não equilibra carga.

    amigo se vc pode enviar tb pra mim quando vc vi na bahia eu pago una caraje,moqueca uns cravinhos (bebiba afrodisiaca)
    msn [email protected]

  8. #8

    Padrão Re: Load Balance não equilibra carga.

    pra funcionar corretamente zere as conf. e refaça novamente,vc esta usando uma bridge,possivelmente não zerou as conf. de fabrica e configurou o lb por cima delas.



  9. #9

    Padrão Re: Load Balance não equilibra carga.

    Citação Postado originalmente por alternativainfo Ver Post
    Amigo tenho aki so q na rb450g e esta 1000% se quiser posso passar bkp pra vc ....
    amigo vc pode passar uma copia pra mim fio agradecido meu email [email protected]

  10. #10

    Padrão Re: Load Balance não equilibra carga.

    Bom amigo como o amigo disse acima, faz assim reseta a RB depois que iniciar ela vai perguntar se quer tirar tudo as configuracoes de fabrica, dai opta por sim... configura os ips, discadores, hotspot e tudo mais... em seguida faça as marcacoes novamente, mais lembre que funciona assim: 2mb+2mb=4mb... entao o peso sera de 4/0 4/1 4/2 4/3 e nao 2/0 2/1... qualquer coisa estou a disposicao ajudar...



  11. #11

    Padrão Re: Load Balance não equilibra carga.

    Citação Postado originalmente por peritinaicos Ver Post
    Bom amigo como o amigo disse acima, faz assim reseta a RB depois que iniciar ela vai perguntar se quer tirar tudo as configuracoes de fabrica, dai opta por sim... configura os ips, discadores, hotspot e tudo mais... em seguida faça as marcacoes novamente, mais lembre que funciona assim: 2mb+2mb=4mb... entao o peso sera de 4/0 4/1 4/2 4/3 e nao 2/0 2/1... qualquer coisa estou a disposicao ajudar...
    Olha, comprei uma RB750 que veio com backup loadbalance mas não havia testado nela. Daí caiu um raio na minha região e danificou a coitada. Comprei uma RB750G e restaurei este backup nela. Será que não serve. Há problemas em utilizar bachup da 750 para a 750g e vice-versa?

    Pra ser sincero, eu não sei criar este load balance, mas se for a única alternativa, vou lutar até conseguir colocar ele pra funcionar. Estou preocupado porque não tenho outra placa para gerenciar a rede até configurar esta.

    Aproveitando o bonde andando, ontem eu liguei a reb750. Ela funciona, fornece ip mas não consigo acessar ela nem por web nem por winbox da erro de conexão na porta 80. será que não há salvação?

    Perdoe-me se o assunto não é pertinente ao tópico.
    Última edição por Paturi; 09-08-2011 às 15:02.

  12. #12

    Padrão Re: Load Balance não equilibra carga.

    Amigo se ela esta fornecendo IP e rodando sinal que a placa nao está queimada, ja tentou acessa-la pelo webbox? ja resetou?



  13. #13

    Padrão Re: Load Balance não equilibra carga.

    Citação Postado originalmente por peritinaicos Ver Post
    Amigo se ela esta fornecendo IP e rodando sinal que a placa nao está queimada, ja tentou acessa-la pelo webbox? ja resetou?
    Acabei de salvar a bela placa que por pouco não joguei fora há alguns meses.
    deixei o questionamento aqui e fui pesquisar no site da mikrotik. Encontreil o NetInstall, acompanhei o manual, reinstalei o SO com o routeros-mipsbe-4.17.npk e solucionei o problema.
    Estou usando ela neste momento.
    Só está com a interface 4 com problema. Fica como se eloa estivesse conectada, trafegando dados mesmo sem cabo conectado. mas desativei ela e vou usar as demais interfaces.

    Quanto ao assunto principal que é o Loab balance... Vou continuar tentando
    E contando com a ajuda de vcs tbm. kkkk.
    Muito Obrigado!
    Última edição por Paturi; 09-08-2011 às 17:27.

  14. #14

    Padrão Re: Load Balance não equilibra carga.

    rapaz é melhor passar o export que o backup!!



  15. #15

    Padrão Re: Load Balance não equilibra carga.

    Realmente to quebrando a cabeç. O bom é que já consegui ressucitar quem já estava morta.
    Agora é batalhar pra configurar.
    Mas me digam uma coisa: Minha configuração tem uma bridge nas portas 3, 4 e 5. para o loabbalance funcionar elas nao devem existir?
    Abraço!

  16. #16

    Padrão Re: Load Balance não equilibra carga.

    amigo no meu aqui fiz uma ponte entre a porta 4 e 5 com um dhcp ativo na ponte. porta 1 2 3 sao WAN e 4 5 LAN



  17. #17

    Padrão Re: Load Balance não equilibra carga.

    Citação Postado originalmente por peritinaicos Ver Post
    amigo no meu aqui fiz uma ponte entre a porta 4 e 5 com um dhcp ativo na ponte. porta 1 2 3 sao WAN e 4 5 LAN
    Aqui está ponte entre as portas 3 4 e 5 e 2 wan. só que como te falei, não há equilibrio de carga. todo trafego fica no link 1. se eu desconectar ele,aí sim o trafego passa para o link 2. Quando eu reconecto o link 1 o trafego volta pra ele.
    ki batalha!

  18. #18

    Padrão Re: Load Balance não equilibra carga.

    ponte pra que???



  19. #19

    Padrão Re: Load Balance não equilibra carga.

    Bom dia amigos, eu criei uma ponte entre a porta 4 e 5 no meu caso para eu ativar um dhcp nelas dai uma porta sai direto para um switch que distribui para alguns computadores (5 no meu caso), a outra porta a 5 um cabo um pouco maior para outro switch, ligado no PC-MK que faz a autenticação dos clientes e para mais 3 bullets.
    Acredito que esteja acontecendo um problema com a divisão da carga no seu caso amigo... postarei abaixo como faria para funcionar o meu loadbalance com 2 modens de 2MB.
    OBS1: crie os discadores com nome Discador1 e Discador2, preferencia na porta 1 e porta 2 da RB para não confundir depois.
    OBS2: Crie uma ponte entre a porta 3 4 5 ou 4 e 5 ou nao crie se preferir, mais renomeie a porta de saida como "saida"
    /ip firewall nat
    add action=masquerade chain=srcnat comment="MASCARAMENTO" disabled=no \
    out-interface=Discador1
    add action=masquerade chain=srcnat disabled=no out-interface=Discador2
    /ip firewall mangle
    add action=accept chain=prerouting comment="Sem Balance" disabled=no \
    dst-address-list=sem_balance in-interface="saida"
    add action=mark-connection chain=input connection-state=new disabled=no \
    in-interface=Discador1 new-connection-mark=conn_na passthrough=yes
    add action=mark-connection chain=input connection-state=new disabled=no \
    in-interface=Discador2 new-connection-mark=conn_nb passthrough=yes
    add action=mark-connection chain=prerouting disabled=no dst-address-type=!local \
    in-interface="saida" new-connection-mark=conn_ma0 passthrough=yes \
    per-connection-classifier=both-addresses:2/0
    add action=mark-connection chain=prerouting disabled=no dst-address-type=!local \
    in-interface="saida" new-connection-mark=conn_mb1 passthrough=yes \
    per-connection-classifier=both-addresses:2/1
    add action=mark-routing chain=prerouting connection-mark=conn_ma0 disabled=no \
    in-interface="saida" new-routing-mark=to_nra passthrough=no
    add action=mark-routing chain=prerouting connection-mark=conn_mb1 disabled=no \
    in-interface="saida" new-routing-mark=to_nrb passthrough=no

    Caso ainda tenha dúvida estou aqui... Se fui últio clique na estrelinha
    Última edição por peritinaicos; 11-08-2011 às 14:59.

  20. #20

    Padrão Re: Load Balance não equilibra carga.

    Citação Postado originalmente por peritinaicos Ver Post
    Bom amigo como o amigo disse acima, faz assim reseta a RB depois que iniciar ela vai perguntar se quer tirar tudo as configuracoes de fabrica, dai opta por sim... configura os ips, discadores, hotspot e tudo mais... em seguida faça as marcacoes novamente, mais lembre que funciona assim: 2mb+2mb=4mb... entao o peso sera de 4/0 4/1 4/2 4/3 e nao 2/0 2/1... qualquer coisa estou a disposicao ajudar...
    se os dois links forem de 2mb, são links simétricos ou seja 1 pra 1= 2/0 2/1 a marcação esta correta de pesos, só seria diferente se os links fossem assimétricos.