+ Responder ao Tópico



  1. Pessoal,

    Estou com alguns problemas com relação as minhas conexões OpenVPN, vou colocar minha infra para que haja um melhor entendimento.

    Tenho 7 ERBs que tem Mikrotik, eu preciso acessar os equipamentos que estão na LAN desses MKTs, todos os MKTs tem IP Publico, todos MKTs estão como servidores, tenho uma máquina com o XP que seria o cliente para esses servidores OpenVPN.

    Criei os certificados pelo easy-rsa do cliente do windows e importei para os MKTs, cada certificado para o seu devido servidor.

    Tenho os seguintes problemas:
    1. A VPN desconecta toda hora. (Configurar um keepalive ou algo parecido, seria uma solução ?)
    2. Toda vez que vou reconectar tenho que digitar usuário e senha (Gostaria que isso ficasse automatico ou até mesmo desabilitar)
    3. Configuro os arquivos do cliente, testo e tudo OK a VPN fecha sem problemas, após algumas horas a VPN não conecta, de jeito nenhum, da erro de TLS, como se não encontrasse o certificado esse é o erro que aparece ---> TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity

    Abaixo segue as configurações que eu faço nos meus MKTs e nos meus clientes:

    Configuração MKT:

    Configuração de Rede

    /ip address add address=10.15.30.31/24 interface=ether3 comment=Lan (IP Interno)
    /ip address add address=x.x.x.x/x interface=ether2 comment=Internet (IP Publico)
    /ip route add dst-address=10.0.0.0/8 gateway=10.15.30.5 comment=WAN
    /ip route add gateway=x.x.x.x comment=Internet


    Pool dos Hosts VPN:

    /ip pool add name=ovpn-pool ranges=172.21.0.10-172.21.0.20

    Perfil OpenVPN

    /ppp profile add local-address=172.21.0.1 name=ovpn remote-address=ovpn-pool

    Usuário e Senha para Autenticação

    /ppp secret add name=client password=123456 profile=ovpn service=ovpn

    Servidor OpenVPN

    /interface ovpn-server server set default-profile=ovpn enable=yes mode=ethernet netmask=24 require-client-certificate=no

    Configuração Cliente:

    dev tap
    remote x.x.x.x 1194 (IP do Servidor)
    proto tcp-client
    tls-client
    ca ca.crt
    auth-user-pass
    pull
    nobind
    persist-key
    resolv-retry infinite
    verb 3
    script-security 2 system
    route-up "route add 10.15.30.0 mask 255.255.255.0 172.21.0.1"
    auth-nocache

    Agradeço desde já todos que responderem e acredito que isso também possa ajudar outros profissionais

  2. Certificados tls tem validade, portanto eh preciso que data e hora bem como fuso horario estajam configurados. procure por ntp no mikrotik.



  3. Aham amaia, já tinha verificado isso, data e hora estão corretos, tanto no MKT quanto no cliente.

    Verifiquei as propriedades do certificado e esta válido até 2021.

  4. Galera,

    Alguém tem uma infra parecida com a minha ?



  5. Pessoal,

    Nada ?






Tópicos Similares

  1. Respostas: 9
    Último Post: 26-05-2014, 16:21
  2. Server VPN Mikrotik + AD + Client OpenVPN
    Por msk8m no fórum Servidores de Rede
    Respostas: 3
    Último Post: 16-12-2012, 13:01
  3. OpenVPN + Mikrotik com chave de criptografia DES-EDE3
    Por leoservice no fórum Servidores de Rede
    Respostas: 0
    Último Post: 09-08-2012, 22:11
  4. Respostas: 2
    Último Post: 25-06-2012, 08:20
  5. Servidor OPENVPN por trás de Mikrotik.
    Por raphaps no fórum Redes
    Respostas: 0
    Último Post: 05-06-2012, 22:39

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L