Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Question Load balance PCC com RB 750, três links adsl com modens em bridge

    Salve, salve, amigos do Forun, venho a vocês pedir uma ajuda, à um mês atrás consegui craquear o mikrotik 3.2, usei e gostei, mas alguns usuarios do forun me recomendaram compra uma licença ou uma rb 750, comprei de sócio um provedor, porem todo ferrado, links bichados, balanço com problemas, thunder com problemas, então exportei todos os planos e clientes, configurei uma rb 450 basicamente e coloquei apenas um link nela, provisoriamente até conseguir organizar tudo, porem a conexão esta muito lenta, então tenho que fazer pelo menos o LB funcionar o mais rapido possivel veja o que podem fazer por mim:
    Cenário
    1 link de adsl OI com modem em bridge de 5m------,
    1 link de adsl OI com modem em bridge de 5m-------,'--Rb Balanço--Rb administração------clientes
    1 link de adsl OI com modem em bridge de 10m-----' '-,Thunder Cache

    pesquisei e vi que o melhor LB para isso é o PCC, porem não encontrei o LB para esse cenário, modens em bridge, veja o que podem fazer por mim.
    conto com vcs
    att Eudes Ap.
    Última edição por eudesamarelo; 10-08-2011 às 23:54.

  2. #2

    Padrão Re: Load balance PCC com RB 750, três links adsl com modens em bridge

    Use esse programa para gerar o balance!
    http://www.saocarlosnet.com.br/downloads/PCC_1.2.zip



  3. #3

    Padrão Re: Load balance PCC com RB 750, três links adsl com modens em bridge

    cara tenho com 2 link em bridge se quiser passo bkp pra vc com uso oi e so restaura backup trocar usuarios de autenticacao e pronto.....

  4. #4

    Padrão Re: Load balance PCC com RB 750, três links adsl com modens em bridge

    Citação Postado originalmente por alternativainfo Ver Post
    cara tenho com 2 link em bridge se quiser passo bkp pra vc com uso oi e so restaura backup trocar usuarios de autenticacao e pronto.....
    sim amigo toda ajuda é bem vinda, me manda esse bkp, pode ser no e-mail [email protected], posso usa-lo sim, e futuramente talvez altera-lo para 3 links



  5. #5

    Padrão Re: Load balance PCC com RB 750, três links adsl com modens em bridge

    em amigos consegui um programa chamado load balance pcc 1.3 http://www.saocarlosnet.com.br/downloads/pcc_1.3.zip mas não consegui usá-lo, tentem ver se conseguem e me mandem os resultados

  6. #6

    Padrão Re: Load balance PCC com RB 750, três links adsl com modens em bridge

    LOAD BALANCE PCC com 3 ADSL com modens em bridge

    1º Renomei as interface

    ISP1 IP 10.0.10.1
    ISP2 IP 10.0.20.1
    ISP3 IP 10.0.30.1

    Local IP 192.168.88.1



    /interface pppoe-client
    add name=pppoe-out1 user=seuprovedor password=suasenha \
    interface=ISP1 service-name=internet disabled=no
    add name=pppoe-out2 user=seuprovedor password=suasenha \
    interface=ISP2 service-name=internet disabled=no
    add name=pppoe-out3 user=seuprovedor password=suasenha \
    interface=ISP3 service-name=internet disabled=no

    /ip address
    add address=192.168.88.1/30 broadcast=192.168.88.3 comment="" disabled=no \
    interface=Local network=192.168.88.0


    /ip firewall mangle
    add action=accept chain=prerouting comment=\
    "====================================================================" \
    disabled=no dst-address=192.168.88.0/30 src-address=192.168.88.0/30
    add action=mark-connection chain=prerouting comment=\
    "====================================================================" \
    connection-mark=no-mark disabled=no in-interface=pppoe-out1 \
    new-connection-mark=ISP1_conn passthrough=yes
    add action=mark-connection chain=prerouting comment="" connection-mark=\
    no-mark disabled=no in-interface=pppoe-out2 new-connection-mark=ISP2_conn \
    passthrough=yes
    add action=mark-connection chain=prerouting comment="" connection-mark=\
    no-mark disabled=no in-interface=pppoe-out3 new-connection-mark=ISP3_conn \
    passthrough=yes
    add action=jump chain=prerouting comment=\
    "====================================================================" \
    connection-mark=no-mark disabled=no in-interface=Local jump-target=\
    policy_router
    add action=mark-routing chain=prerouting comment=\
    "====================================================================" \
    connection-mark=ISP1_conn disabled=no new-routing-mark=ISP1_trafic \
    passthrough=yes src-address=192.168.88.0/30
    add action=mark-routing chain=prerouting comment="" connection-mark=ISP2_conn \
    disabled=no new-routing-mark=ISP2_trafic passthrough=yes src-address=\
    192.168.88.0/30
    add action=mark-routing chain=prerouting comment="" connection-mark=ISP3_conn \
    disabled=no new-routing-mark=ISP3_trafic passthrough=yes src-address=\
    192.168.88.0/30
    add action=mark-routing chain=output comment=\
    "====================================================================" \
    connection-mark=ISP1_conn disabled=no new-routing-mark=ISP1_trafic \
    passthrough=yes
    add action=mark-routing chain=output comment="" connection-mark=ISP2_conn \
    disabled=no new-routing-mark=ISP2_trafic passthrough=yes
    add action=mark-routing chain=output comment="" connection-mark=ISP3_conn \
    disabled=no new-routing-mark=ISP3_trafic passthrough=yes
    add action=mark-connection chain=policy_router comment=\
    "====================================================================" \
    disabled=no dst-address-type=!local new-connection-mark=ISP1_conn \
    passthrough=yes per-connection-classifier=both-addresses:3/0
    add action=mark-connection chain=policy_router comment="" disabled=no \
    dst-address-type=!local new-connection-mark=ISP2_conn passthrough=yes \
    per-connection-classifier=both-addresses:3/1
    add action=mark-connection chain=policy_router comment="" disabled=no \
    dst-address-type=!local new-connection-mark=ISP3_conn passthrough=yes \
    per-connection-classifier=both-addresses:3/2


    /ip firewall nat
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=pppoe-out1
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=pppoe-out2
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=pppoe-out3


    /ip route
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=pppoe-out1 \
    routing-mark=ISP1_trafic scope=30 target-scope=10
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=pppoe-out2 \
    routing-mark=ISP2_trafic scope=30 target-scope=10
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=pppoe-out3 \
    routing-mark=ISP2_trafic scope=30 target-scope=10
    add comment="" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=pppoe-out1 \
    scope=30 target-scope=10
    add comment="" disabled=no distance=3 dst-address=0.0.0.0/0 gateway=pppoe-out2 \
    scope=30 target-scope=10
    add comment="" disabled=no distance=4 dst-address=0.0.0.0/0 gateway=pppoe-out3 \
    scope=30 target-scope=10


    /ip dns
    set allow-remote-requests=no cache-max-ttl=1w cache-size=20480KiB \
    max-udp-packet-size=512 servers=8.8.8.8,8.8.4.4



  7. #7

    Padrão Re: Load balance PCC com RB 750, três links adsl com modens em bridge

    acabei de responder...
    https://under-linux.org/f227/ajuda-load-balance-pcc-mikrotik-4-10-a-151725/index5.html#post580639
    p
    ra 3 links assimétricos adicione mais 1 marcação de peso para o link de 10 mb, e mude as marcações de peso de 3/0 3/1 3/2 para 4/0 4/1 4/2 4/3.
    boa sorte
    Última edição por sostenes; 17-10-2011 às 18:30. Razão: correção nas marcações

  8. #8

    Padrão Re: Load balance PCC com RB 750, três links adsl com modens em bridge

    Bom amigo no meu caso uso 3mb link + 2mb adsl + 1mb adsl... Dai estou fazendo 3marcacoes para o link + 2 marcacoes para adsl 2mb + 1 marcacao adsl 1MB... Seria isso mesmo, ex:
    6/0 6/1 6/2 dedicado
    6/3 6/4 adsl 2mb
    6/5 adsl 1mb



  9. #9

    Padrão Re: Load balance PCC com RB 750, três links adsl com modens em bridge

    Acho que estou com algum problema com o load balance pois ja vi revi e nada problemas reladados pelos clientes


    1 - facebook nao carrega algumas imagens

    2 - hotmail nao abre nem por reza brava

  10. #10

    Padrão Re: Load balance PCC com RB 750, três links adsl com modens em bridge

    Citação Postado originalmente por peritinaicos Ver Post
    Bom amigo no meu caso uso 3mb link + 2mb adsl + 1mb adsl... Dai estou fazendo 3marcacoes para o link + 2 marcacoes para adsl 2mb + 1 marcacao adsl 1MB... Seria isso mesmo, ex:
    6/0 6/1 6/2 dedicado
    6/3 6/4 adsl 2mb
    6/5 adsl 1mb
    isso mesmo,desde que os adsl estejam batendo essa velocidade.



  11. #11

    Padrão Re: Load balance PCC com RB 750, três links adsl com modens em bridge

    Os adsl batem certinho o contratado... Mais nao sei o porq sempre os adsl ficam saturados e o dedicado fica oscilando entre 500 a 1mb.

  12. #12

    Padrão Re: Load balance PCC com RB 750, três links adsl com modens em bridge

    Citação Postado originalmente por peritinaicos Ver Post
    Bom amigo no meu caso uso 3mb link + 2mb adsl + 1mb adsl... Dai estou fazendo 3marcacoes para o link + 2 marcacoes para adsl 2mb + 1 marcacao adsl 1MB... Seria isso mesmo, ex:
    6/0 6/1 6/2 dedicado
    6/3 6/4 adsl 2mb
    6/5 adsl 1mb
    Amigo,ve se vc pode me ajudar,seguinte,nao consigo intender esse Per Connection Classifier,olha eu tenho 3Mb dedicado,mais 3 Adsl de 4Mb cada,como ficaria estas marcações?



  13. #13

    Padrão Re: Load balance PCC com RB 750, três links adsl com modens em bridge

    Sim amigo posso, ficaria assim 3+4+4+4=15/4=3.75 eu acho rsrssr mais pode fazer por 4... fica mais ou menos como abaixo... claro so mudando o nome das interfaces...

    Amigo ficaria como abaixo:
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no dst-address-type=!local in-interface=ether5 new-connection-mark=ether1_conn passthrough=yes per-connection-classifier=both-addresses:5/0
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no dst-address-type=!local in-interface=ether5 new-connection-mark=adsl_ether2_conn passthrough=yes per-connection-classifier=both-addresses:5/1
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no dst-address-type=!local in-interface=ether5 new-connection-mark=adsl_ether3_conn passthrough=yes per-connection-classifier=both-addresses:5/2
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no dst-address-type=!local in-interface=ether5 new-connection-mark=adsl_ether4_conn passthrough=yes per-connection-classifier=both-addresses:5/3

  14. #14

    Padrão Re: Load balance PCC com RB 750, três links adsl com modens em bridge

    a conta esta errada...,soma-se todos os links e se divide pelo de menor valor, ou seja 15 / 3 =5 marcações lembrando que o link dedicado tem que ser o link default,e sera mais utilizado,e o adsl tem que estar batendo a velocidade correta dos 4mb sem oscilar ,caso contrario esqueça.



  15. #15

    Padrão Re: Load balance PCC com RB 750, três links adsl com modens em bridge

    Valeu pela ajuda amigos....mas estas marcações são dificeis de intender!!!

  16. #16

    Padrão Re: Load balance PCC com RB 750, três links adsl com modens em bridge

    kkk onde estão as dificuldades?



  17. #17

    Padrão Re: Load balance PCC com RB 750, três links adsl com modens em bridge

    Citação Postado originalmente por sostenes Ver Post
    a conta esta errada...,soma-se todos os links e se divide pelo de menor valor, ou seja 15 / 3 =5 marcações lembrando que o link dedicado tem que ser o link default,e sera mais utilizado,e o adsl tem que estar batendo a velocidade correta dos 4mb sem oscilar ,caso contrario esqueça.
    Entao nesse caso vai ficar 1 marcação prá cada adsl e 2 marcações pró dedicado é isso?

  18. #18

    Padrão Re: Load balance PCC com RB 750, três links adsl com modens em bridge

    Amigo com o programa PCC 1.5 e contando que sua rede lan seja na range 10.5.50.0/24 e seu link o ip 10.10.10.10 gateway 10.10.10.1 fica como abaixo... OBS: fiz com programa aqui disponível.
    Configuracao PCC1.5.txt



  19. #19

    Padrão Re: Load balance PCC com RB 750, três links adsl com modens em bridge

    por ser dedicado e outros 3 adsl...seria melhor vc fazer 1 marcação por link.

  20. #20

    Padrão Re: Load balance PCC com RB 750, três links adsl com modens em bridge

    Foi isso mesmo que aconteceu gerando a configuração pelo programa aqui postado PCC 1.5