+ Responder ao Tópico



  1. #1

    Padrão Colocar somente um cliente no link dedicado.

    Bom dia pessoal.

    Preciso o seguinte: fazer c/ que um cliente, sempre que ele conectar no sistema a conexão dele estabecer só no link dedicado.

    Tenho um link 2 MB, e duas ADSL,tudo balanceado por PCC. Meu mikrotik é V. 5.4 e só uso PPPOE.

    Desde já agradeço a todos.

  2. #2

    Padrão Re: Colocar somente um cliente no link dedicado.

    aqui uso assim e funciona normal.

    em mangle (coloca acima de todas as regras)

    add chain=prerouting src-address=ip do cliente action=mark-routing \
    new-routing-mark=Rota-dedicado passthrough=yes comment="elektra" \
    disabled=no



    em ip route

    add dst-address=0.0.0.0/0 gateway=ip do dedicado distance=0 scope=255 target-scope=10 routing-mark=Rota-dedicado comment="" \
    disabled=no

    agora se vc usa um loadbalance joga pra outro servidor e de la manda pro cliente ai ja muda um pouco.



  3. #3

    Padrão Re: Colocar somente um cliente no link dedicado.

    Boa tarde amigão. Uso sim load balance, modo PCC c/ divisão dos links.

    Do jeito que você me passou não funcionou, testei as regras varias vezes e realmente não consegui fazer funcionar.

    Será que tem jeito.

    Agradeço.

  4. #4

    Padrão Re: Colocar somente um cliente no link dedicado.

    tem sim cara.
    no loadbalance vc cria um ip 10.1.1.1/30. ai no mangle vc coloca

    /ip firewall mangle
    add action=mark-routing chain=prerouting comment="" disabled=no new-routing-mark=rota-dedicado passthrough=no src-address=10.1.1.0/30

    em route

    /ip route
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=ip do dedicado routing-mark=rota-dedicado 1 scope=30 target-scope=10


    no sevidor q vc manda p os clientes crie o ip
    10.1.1.2/30

    / ip firewall mangle
    add chain=prerouting src-address=IP DO CLIENTE ex:172.2.100/30 action=mark-routing new-routing-mark=Rota-dedicado passthrough=yes \
    comment="nome do cliente" disabled=no

    em

    route

    /ip route
    add dst-address=0.0.0.0/0 gateway=10.1.1.1 distance=0 scope=255 target-scope=10 routing-mark=Rota-dedicado comment="" \
    disabled=no
    Última edição por cdcm; 23-08-2011 às 17:26.



  5. #5

    Padrão Re: Colocar somente um cliente no link dedicado.

    Opa, obrigado por responder amigão.

    Poisé cara, no meu mikrotik não tenho rota p/ o link dedicado, se eu ativar um IP do link dedicado nele, o balanceamento não funciona. Pode ser tambem que não estou entendendo sua explicação.

    Qualquer coisa ti passo as configs. do meu mk.

    Agradeço.

  6. #6

    Padrão Re: Colocar somente um cliente no link dedicado.

    posta ai tuas config de load balance e do servidor.



  7. #7

    Padrão Re: Colocar somente um cliente no link dedicado.

    Bom dia amigão, cara exportei as configs. inteira e é muito grande p/ postar aqui.

    Tanto do Server Mikrotik quanto do Balance PCC.

  8. #8

    Padrão Re: Colocar somente um cliente no link dedicado.

    manda ele pra um arquivo

    /ip route
    export file=mk-route

    /ip firewall mangle
    export file=mk-mangle

    ou se manda tudo

    export file=mk

    vai em files e manda e copia os arquivos



  9. #9

    Padrão Re: Colocar somente um cliente no link dedicado.

    Poisé amigão, eu fiz isso mesmo, gerei arquivos c/ as configs.

    Só não tava achando como postar aqui.

    Veja se anexei da forma correta, são dois .txt
    Arquivos Anexos Arquivos Anexos

  10. #10

    Padrão Re: Colocar somente um cliente no link dedicado.

    cara tua rede é mt dirente da minha. vc usa mascara 24 e eu uso 30. e pelo que ja testei nao da com mascara 24.


    mais faz um teste se vc fazer da forma q ta aqui aredito q funcione.

    no loadbalance vc cria um ip 10.1.1.1/30. ai no mangle vc coloca

    /ip firewall mangle
    add action=mark-routing chain=prerouting comment="" disabled=no new-routing-mark=rota-dedicado passthrough=no src-address=10.1.1.0/30

    em route

    /ip route
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=187.6.49.59 routing-mark=rota-dedicado 1 scope=30 target-scope=10


    no sevidor q vc manda p os clientes crie o ip
    10.1.1.2/30

    / ip firewall mangle
    add chain=prerouting src-address=IP DO CLIENTE ex:172.2.100/30 action=mark-routing new-routing-mark=Rota-dedicado passthrough=yes \
    comment="nome do cliente" disabled=no

    route

    /ip route
    add dst-address=0.0.0.0/0 gateway=10.1.1.1 distance=0 scope=255 target-scope=10 routing-mark=Rota-dedicado comment="" \
    disabled=no

    lembrando q vc precisa fazer o nat do ip 172.2.100/30
    Última edição por cdcm; 25-08-2011 às 12:02.



  11. #11

    Padrão Re: Colocar somente um cliente no link dedicado.

    Olá amigão, obrigado por responder.

    Poisé cara, essa regra aqui no servidor mk: / ip firewall mangle
    add chain=prerouting src-address=IP DO CLIENTE ex:172.2.100/30 action=mark-routing new-routing-mark=Rota-dedicado passthrough=yes \
    comment="nome do cliente" disabled=no

    Onde coloquei em negrito ! Eu não tenho rota do mk p/ o link dedicado, ou posso estar confundindo alguma coisa. Se eu ativar um IP do link no mk, o balanceamento não funciona.

    Agradeço.