+ Responder ao Tópico



  1. Olá a todos,

    Estou fazendo meu tcc sobre o xen, e cheguei na etapa de instalação onde a idéia é instalar o xen no debian 6.0 e configurar uma vm windows xp.Vou descrever abaixo tudo que já foi feito.

    1º Fiz a instalação do debian 6.0 usando o vmware
    2º Atualizei o debian com apt-get update, apt-get upgrade
    3º Fiz a instalação dos pacotes requeridos para o funcionamento do xen de acordo com :
    http://wiki.xen.org/xenwiki/Xen4.0

    Required packages for Debian Lenny 5.0 & Squeeze 6.0 / Ubuntu 8.x & 9.x & 10.04:

    apt-get install bcc bin86 gawk bridge-utils iproute libcurl3 libcurl4-openssl-dev bzip2 module-init-tools transfig tgif texinfo texlive-latex-base texlive-latex-recommended texlive-fonts-extra texlive-fonts-recommended pciutils-dev mercurial build-essential make gcc libc6-dev zlib1g-dev python python-dev python-twisted libncurses5-dev patch libvncserver-dev libsdl-dev libjpeg62-dev iasl libbz2-dev e2fslibs-dev git-core uuid-dev ocaml libx11-dev bison flex

    4º Fiz a instalação do xen, usando apt-get, ao invés de baixar o .tar do site da xen:

    apt-get install xen-hypervisor-4.0-i386 xen-tools xen-utils-4.0 xen-linux-system-2.6.32-5-xen 2.6.32-35 lvm2

    5º Meu hd está com duas partições uma alocada para o sistema hospedeiro e outra estendida, já que vou usar LVM2 para alocar os discos lógicos:

    Criei uma nova partição com o fdisk "sda2" e defini que ela é do tipo lvm.

    Agora entra a parte de configuração

    1º Usei o pvcreate na partição:

    pvcreate /dev/sda2 <<<habilitei a partição para uso no lvm

    vgcreate xen /dev/sda2<<< criei um grupo lógico xen e add a partição

    2ºCriei o hd virtual para uso da vm

    lvcreate -L 5G -n winxp xen

    3º Fiz a formatação do volume para usar ntfs:

    mkfsntfs /dev/xen/winxp


    Agora montei a iso do cd do xp para fazer a instalação:

    dd if=/dev/CDROM of=/home/teste/winxp.iso

    Agora entra o problema, não estou conseguindo montar o arquivo para botar a máquina e usar a partição lvm que eu criei.Estou usando o tutorial abaixo:

    http://wiki.xen-br.org/index.php?title=Vm-w2k

    Só que não estou intendendo uma coisa, esse arquivo de configuração da vm, existe algum exemplo?pq dentro de /etc/xen existe vários arquivos mas nada parecido, não sei se são eles que tenho que usar,tem algum em específico?ou devo criar?

    Acredito que depois dessa etapa eu consiga fazer o boot do windows?

    Quem puder me ajudar,ficarei muito grato...e assim que pronto irei disponibilizar o passo-a-passo para instalação inclusive com os prints,pois estamos muito carentes de documentação em português.

  2. Alguém pode me ajudar...estou praticamente desesperado kkkkkkkk



  3. Olá Adriano. Infelizmente não tenho sua resposta.

    Mas... fui aluno na 4linux de um cara doidão cujo café da manhã é xen, o Caio Candido.

    Não tenho mais contato com ele mas hoje tudo é facebook, twitter, blog - Conhecimento para todos | Caio Henrique Moura Candido ... tente enviar sua dúvida a ele quem sabe é um pêlo no ovo que está impedindo o seu sucesso?

    Talvez até tenha essa sua resposta neste blog, dê uma olhada e quando conseguir conte pra gente!

    Boa sorte!
    Última edição por pauloaalves; 25-08-2011 às 17:43.






Tópicos Similares

  1. Dificuldades para configurar o Bind
    Por centralservice no fórum Servidores de Rede
    Respostas: 2
    Último Post: 29-04-2006, 09:22
  2. Respostas: 0
    Último Post: 20-10-2005, 08:48
  3. Nao consigo configurar uma conta hotmail no mozilla thunderb
    Por ruysabino no fórum Servidores de Rede
    Respostas: 2
    Último Post: 23-07-2004, 06:56
  4. Help!!!! Como faço para eliminar uma partição windows?
    Por superpc no fórum Servidores de Rede
    Respostas: 4
    Último Post: 01-07-2004, 19:37
  5. Respostas: 2
    Último Post: 24-09-2003, 23:00

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L