+ Responder ao Tópico



  1. Bom dia.

    Estou tentando implementar aqui como teste um controle de download para estudar e não estou conseguindo. Como teste estou colocando o seguinte:

    Se um cliente tem plano de 512k e seu download passa de 4MB eu baixo a velocidade dele pra 400k.

    Tenho aqui mk versão 5.6 e estou usando as seguintes regras:

    Código :
    /ip firewall mangle
    add action=mark-connection chain=prerouting comment=\
        "Controle de Banda" connection-bytes=4194304-0 \
        disabled=yes dst-port=80 new-connection-mark=\
        Controle passthrough=yes protocol=tcp
    add action=mark-connection chain=prerouting \
        connection-bytes=4194304-0 disabled=yes \
        new-connection-mark=Controle passthrough=yes \
        protocol=tcp src-port=80
    add action=mark-connection chain=prerouting \
        connection-bytes=4194304-0 disabled=yes \
        new-connection-mark=Controle passthrough=yes \
        protocol=tcp src-port=53
    add action=mark-connection chain=prerouting \
        connection-bytes=4194304-0 disabled=yes \
        new-connection-mark=Controle passthrough=yes \
        protocol=udp src-port=53
    add action=mark-connection chain=prerouting \
        connection-bytes=4194304-0 disabled=yes \
        new-connection-mark=Controle passthrough=yes \
        protocol=udp src-port=53
    add action=mark-connection chain=prerouting \
        connection-bytes=4194304-0 disabled=yes dst-port=53 \
        new-connection-mark=Controle passthrough=yes \
        protocol=tcp
    add action=mark-packet chain=prerouting connection-mark=\
        Controle disabled=yes new-packet-mark=ControleMark \
        passthrough=yes src-address-list=10.2.0.254

    Código :
     
    /queue tree     
    add burst-limit=0 burst-threshold=0 burst-time=0s \    
    disabled=yes limit-at=0 max-limit=400k name=\     
    Controle512 packet-mark=ControleMark parent=\     
    global-in priority=8 queue=default

    Obrigado.

  2. Bem interessante amigo, cliente que tenha plano de 512k para fazer 4MB é rapidão, acredito que isso fica bem interessante para arquivos grandes tipo 50MB nos horários de pico... Aqui fiz diferentes, coloquei o limite de banda contratada certinho, mais peguei os sites mais acessados como orkut, youtube, globo, uol etc, criei uma queue para eles com 2MB ai ficou muito rápido mesmo com cliente fazendo download com a banda contratada...

    Acompanhando...



  3. Alguém ai pode ver se tem alguma adaptação a fazer para a versão 5.6 ou onde estou errando?

    Obrigado

  4. Alguém por favor pode me ajudar a adaptar esta regra para a versão 5.6?



  5. Consegui. Obrigado






Tópicos Similares

  1. Controle de IP no squid nao funciona !
    Por salckware11 no fórum Servidores de Rede
    Respostas: 2
    Último Post: 21-02-2009, 06:47
  2. Controle de Banda nao funciona mk 3.v
    Por guezth no fórum Redes
    Respostas: 0
    Último Post: 09-01-2009, 10:35
  3. Controle de P2P nao funciona na routerboard 333
    Por Carlos Picioli no fórum Redes
    Respostas: 6
    Último Post: 28-04-2008, 08:39
  4. Wds nao funciona controle de MAC
    Por patrickcanton no fórum Redes
    Respostas: 0
    Último Post: 01-02-2007, 08:52
  5. download com WGET nao funciona no APACHE
    Por no fórum Servidores de Rede
    Respostas: 5
    Último Post: 08-03-2005, 10:58

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L