+ Responder ao Tópico



  1. Bom dia pessoal,

    Estou gradativamente inserindo máquinas da rede que administro para um domínio controlado pelo SAMBA e percebo que o único problema é quanto ao compartilhamento de impressoras. Não usei o CUPS ou outro utilitário no SAMBA para compartilhá-las, e sim, o compartilhamento local via WINDOWS mesmo. Assim, quando o usuário manda a impressão ela fica na fila de impressora na máquina que compartilhou e não imprime. O que pode estar ocorrendo ? Estou usando como servidor o Ubuntu 11.04 e tenho o seguinte arquivo de configuração:

    Código :
     
    # ELEIÇÕES DE REDE, CONFIGURAÇÕES DE NOME E RESOLUÇÃO DOS MESMOS, NÍVEL DE SEGURANÇA E DEFINIÇÃO DE PDC     
    netbios name = samba     
    workgroup = REDE     
    server string = SAMBA versão %v     
    name resolve order = lmhosts host wins bcast     
    domain master = yes     
    local master = yes     
    preferred master = yes     
    os level = 150       
    # CARACTERES DE ARQUIVOS     
    preserve case = no     
    default case = lower       
    # ACESSO PARA ADMINISTRAÇÃO, ACESSO AO SERVIDOR PARA USO     
    hosts allow = 192.168.0.     
    admin users = administrador, root             
     
    # LOG DE ACESSOS A SERVIÇOS - AUDITORIA DO SAMBA     
    syslog = yes     
    log level = 3     
    log file = /var/log/samba/log.%m     
    max log size = 5000     
    vfs objects = full_audit     
    full_audit:success = open, opendir, write, unlink, rename, mkdir, rmdir, chmod, chown     full_audit:prefix = %u|%I|%S     
    full_audit:failure = none     
    full_audit:facility = local5     
    full_audit:priority = notice     
    debug timestamp = yes     
    debug level = 2     
    debug uid = no     
    lock directory = /var/run/samba/locks       
     
    # ESTE É UM SERVIDOR WINS     
    wins support = yes     
    wins proxy = no     
    dns proxy = no     
    max wins ttl = 518400       
     
    # ESTE SERVIDOR É UM SERVIDOR DE HORÁRIO ATRAVÉS DO RECURSO NTPD     
    time server = yes           
     
    # NÍVEL DE SEGURANÇA E USUÁRIOS CONFIGURAÇÃO DE USUÁRIOS E SUAS SENHAS     security = user     
    encrypt passwords = yes     
    passdb backend = tdbsam     
    enable privileges = yes       
    username level = 2       
     
    # ESCUTA DE REDE     
    interfaces = eth1     
    bind interfaces only = yes       
     
    # CONFIGURAÇÃO DE DESEMPENHO     
    read raw = yes     
    write raw = yes     
    oplocks = yes     
    max xmit = 65535     
    dead time = 15     
    getwd cache = yes     
    socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192       
     
    # VETAR CERTOS TIPOS DE EXTENSÃO DE ARQUIVOS     
    veto files = /*.pif/*.mp3/*.wma/*.asf/*.mp4/*.avi/*.scr/*.flv/*.mpeg/*.mpg/*.iso/*.src/*.bat/*.cmd/*.com/*.exe/*.ws/*.vbs/*.dll         
     
    # ROAMING PROFILES     
    logon path = \\%N\profiles\%U     
    logon home = \\%N\%U\.profiles     
    logon script = %G.bat     
    domain logons = yes       
     
    [profiles]     
    path = /home/profiles     
    writeable = yes     
    browseable = no     
    create mask = 0600     
    directory mask = 0700

    Desde já, obrigado pela atenção !

  2. Da uma olhada nesse link me ajudou muito
    Linux: Enrolado para configurar o Samba? Chame o SWAT [Artigo]

    hj minha rede funciona normal com linux no server e em alguns terminais e 2 servers win e alguns outros terminais com win



  3. samuelrealnet, obrigado pela resposta !

    Certamente esse problema é com relação a algum tipo de permissão. Nos dois casos que estão com problemas aqui a configuração de compartilhamento via estação do WINDOWS de forma normal, ou seja, a configuração não exibe nenhum erro. Porém, quando pede-se para imprimir, o sistema informa que o documento foi enviado para a impressora mas não imprime. Na máquina que compartilha a impressora a fila de impressão exibe o documento mas ele não é impresso.
    Quanto ao link que me informou, fora esse problema, o servidor está em produção, funcionamento normal. Prefiro não utilizar o SWAT. Quais os parâmetros ou problemas de segurança (permissões) podem estar ocorrendo que se relacionam com esse problema?

    Valeu pela ajuda.






Tópicos Similares

  1. Respostas: 0
    Último Post: 04-05-2010, 22:28
  2. como acessar um compartilhamento de impressora?
    Por genival no fórum Servidores de Rede
    Respostas: 2
    Último Post: 18-08-2005, 12:05
  3. Compartilhamento de impressoras em estacoes windows
    Por jigabo0 no fórum Servidores de Rede
    Respostas: 2
    Último Post: 19-03-2004, 10:57
  4. Compartilhamento de Impressora
    Por odbc no fórum Servidores de Rede
    Respostas: 1
    Último Post: 03-03-2004, 06:24
  5. Compartilhamento de Impressoras
    Por odbc no fórum Servidores de Rede
    Respostas: 1
    Último Post: 01-03-2004, 15:47

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L