Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Post Regras Speedr para Integração com Mikrotik e Cache Full

    Redirecionando o Speedr Cache Full

    IP do Speedr: 170.31.255.2/30

    IP do Mikrotik ROS: 170.31.255.1/30

    /ip firewall nat
    add action=dst-nat chain=dstnat comment="dst-nat [170.31.255.2 tcp.dst=3128]" \
    disabled=no dst-port=80 protocol=tcp src-address=!170.31.255.2 \
    to-addresses=170.31.255.2 to-ports=3128
    add action=masquerade chain=srcnat comment="Masquerade intranet" disabled=no \
    dst-address=!170.31.255.2 src-address-list=intranet
    add action=masquerade chain=srcnat comment="Masquerade speedr" disabled=no \
    dst-address-list=!intranet src-address=170.31.255.2


    /ip firewall mangle
    add action=mark-connection chain=prerouting comment="if addrlist = speedr-redir
    ct -> mark connection [connmarkspeedr-redirect]" disabled=no \
    dst-address-list=!intranet dst-port=80 new-connection-mark=\
    connmarkspeedr-redirect passthrough=no protocol=tcp src-address-list=\
    speedr-redirect
    add action=mark-packet chain=postrouting comment=\
    "dscp->12) => [packet_speedr_HIT]" disabled=no dscp=12 new-packet-mark=\
    packet_speedr_HIT passthrough=no
    add action=mark-packet chain=postrouting comment=\
    "dscp->10 => [packet_speedr_HIT]" disabled=no dscp=10 new-packet-mark=\
    packet_speedr_HIT passthrough=no
    add action=mark-packet chain=postrouting comment=\
    "dscp->48 => [packet_speedr_HIT]" disabled=no dscp=48 new-packet-mark=\
    packet_speedr_HIT passthrough=no

    /ip firewall address-list
    add address=170.31.255.0/30 disabled=no list=intranet
    add address=170.31.255.0/30 comment="Regra webcache" disabled=no list=\
    speedr-redirect

    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=8M \
    max-limit=8M name="webcache HIT" packet-mark=packet_speedr_HIT parent=\
    global-out priority=8 queue=default
    Última edição por sergio; 14-12-2011 às 21:36. Razão: Melhorar a aparência

  2. #2

    Padrão re: Regras Speedr para Integração com Mikrotik e Cache Full

    amigo tentei pelas suas regras e não consegui fazer funcionar, aqui quando habilito as regras pra redirecionar o trafego, dá acesso negado quando vou navegar ..



  3. #3

    Padrão re: Regras Speedr para Integração com Mikrotik e Cache Full

    amigo mais vc tem q entra dentro dele e coloca a sua rede de acesso, se nao vai dar sempre acesso bloqueado

    Controlhe de Acesso > Redes Autorizadas


    ex: a minha eu add 10.5.50.0/24

    * para os meus Clientes Hotsport

    add 10.2.0.0/24
    add 10.2.1.0/24
    add 10.2.2.0/24
    * para os meu Cliente PPPOE


    OBS: esse é minha rede vc tem q add a range dos seu clientes

  4. #4

    Padrão re: Regras Speedr para Integração com Mikrotik e Cache Full

    Ola amigo, segui suas regras e o servidor conectou a minha rede so que tem alguma coisa errada pois alguns sites nao estao abrindo (globo, terra...). Segue a imagem da minha topologiaClique na imagem para uma versão maior

Nome:	         topologia.JPG
Visualizações:	850
Tamanho: 	12,3 KB
ID:      	28421
    Troquei o ip do servidor de 10.1.1.100 para 10.1.1.254, Minha duvida sabe se essas regras se aplicam no meu caso? Fiz algo errado? Desde ja agradeço pela atenção.
    /ip firewall natadd action=dst-nat chain=dstnat comment="dst-nat [10.1.1.254 tcp.dst=3128]" \
    disabled=no dst-port=80 protocol=tcp src-address=!10.1.1.254 \
    to-addresses=10.1.1.254 to-ports=3128
    add action=masquerade chain=srcnat comment="Masquerade intranet" disabled=no \
    dst-address=!10.1.1.254 src-address-list=intranet
    add action=masquerade chain=srcnat comment="Masquerade speedr" disabled=no \
    dst-address-list=!intranet src-address=10.1.1.254


    /ip firewall mangle
    add action=mark-connection chain=prerouting comment="if addrlist = speedr-redir
    ct -> mark connection [connmarkspeedr-redirect]" disabled=no \
    dst-address-list=!intranet dst-port=80 new-connection-mark=\
    connmarkspeedr-redirect passthrough=no protocol=tcp src-address-list=\
    speedr-redirect


    /ip firewall mangle
    add action=mark-packet chain=postrouting comment=\
    "dscp->12) => [packet_speedr_HIT]" disabled=no dscp=12 new-packet-mark=\
    packet_speedr_HIT passthrough=no
    add action=mark-packet chain=postrouting comment=\
    "dscp->10 => [packet_speedr_HIT]" disabled=no dscp=10 new-packet-mark=\
    packet_speedr_HIT passthrough=no
    add action=mark-packet chain=postrouting comment=\
    "dscp->48 => [packet_speedr_HIT]" disabled=no dscp=48 new-packet-mark=\
    packet_speedr_HIT passthrough=no


    /ip firewall address-list
    add address=10.1.1.0/24 disabled=no list=intranet
    add address=10.1.1.0/24 comment="Regra webcache" disabled=no list=\
    speedr-redirect


    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=8M \
    max-limit=8M name="webcache HIT" packet-mark=packet_speedr_HIT parent=\
    global-out priority=8 queue=default



  5. #5

    Padrão re: Regras Speedr para Integração com Mikrotik e Cache Full

    Ola a todos instalei hoje o servidor e na minha rede tenho duas classes de ip pro host post
    uma 192.168.10.0/24 e outra 192.168.11.0/24 mas no cache so navega a 192.168.11.0/24
    O que sera que acontece?

  6. #6

    Padrão re: Regras Speedr para Integração com Mikrotik e Cache Full

    Consegui descobrir o problema, o masquerade do host post estava bloqueando.



  7. #7

    Padrão re: Regras Speedr para Integração com Mikrotik e Cache Full

    ola , amigo vejo que suas regras aparentemente estão certas.
    mais vejo que o erro esta na sua topologia

    Sugestão:
    1- tente mudar sua topogia para a que vou postaClique na imagem para uma versão maior

Nome:	         topologia.JPG
Visualizações:	424
Tamanho: 	19,0 KB
ID:      	28626
    2- Você add a range dos seus clientes dentro do Speedr

  8. #8

    Padrão re: Regras Speedr para Integração com Mikrotik e Cache Full

    Amigo aqui fico assim, uso hotspot e pppoe
    Só detalhe pg https nao carrega... alguma dica?

    hotspot 10.5.50.0/24
    pppoe 10.0.0./16

    /ip firewall nat
    add action=dst-nat chain=dstnat comment="dst-nat [192.168.1.2 tcp.dst=3128]" \
    disabled=no dst-port=80 protocol=tcp src-address=!192.168.1.2 \
    to-addresses=192.168.1.2 to-ports=3128
    add action=masquerade chain=srcnat comment="Masquerade intranet" disabled=no \
    dst-address=!192.168.1.2 src-address-list=intranet
    add action=masquerade chain=srcnat comment="Masquerade speedr" disabled=no \
    dst-address-list=!intranet src-address=192.168.1.2


    /ip firewall mangle
    add action=mark-connection chain=prerouting comment="k" disabled=no \
    dst-address-list=!intranet dst-port=80 new-connection-mark=\
    connmarkspeedr-redirect passthrough=no protocol=tcp src-address-list=\
    speedr-redirect




    /ip firewall mangle
    add action=mark-packet chain=postrouting comment=\
    "dscp->12) => [packet_speedr_HIT]" disabled=no dscp=12 new-packet-mark=\
    packet_speedr_HIT passthrough=no
    add action=mark-packet chain=postrouting comment=\
    "dscp->10 => [packet_speedr_HIT]" disabled=no dscp=10 new-packet-mark=\
    packet_speedr_HIT passthrough=no
    add action=mark-packet chain=postrouting comment=\
    "dscp->48 => [packet_speedr_HIT]" disabled=no dscp=48 new-packet-mark=\
    packet_speedr_HIT passthrough=no


    /ip firewall address-list
    add address=192.168.1.0/24 disabled=no list=intranet
    add address=192.168.1.0/24 comment="Regra webcache" disabled=no list=\
    speedr-redirect


    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=1M \
    max-limit=2M name="webcache HIT" packet-mark=packet_speedr_HIT parent=\
    global-out priority=8 queue=default



  9. #9

    Padrão re: Regras Speedr para Integração com Mikrotik e Cache Full

    mais quais as paginas https q nao tao abrindo

  10. #10

    Padrão re: Regras Speedr para Integração com Mikrotik e Cache Full

    gmail,yahoo e hotmail só tive tempo de testar essa infelizmente. Outra coisa ele nao esta "puxando" a pg de login do hotspot quem ja esta logado navega normalmente. Mas quem vai logar nao aparece a pg com o campo user e senha

    Grato pela ajuda Rodolfo



  11. #11

    Padrão re: Regras Speedr para Integração com Mikrotik e Cache Full

    amigos isso ta muito estranho ..... nunca tinha visto isso mais vc colocou as regras corretamente ...

  12. #12

    Padrão re: Regras Speedr para Integração com Mikrotik e Cache Full

    As regras estao exatamente na maneira que postei na pg anterior.. add no painel em controle de acesso 10.0.0.0/16 e 10.5.50.0/24 ja é 3° vez que tento add o speedr aqui e nada... entao acabo voltando para o thundercache.

    Gostaria de usar o speed por pelo menos 1 mes pois pretende comprar a licensa e add minhas conta premium MU e 4share

    Ja testei todas as regras postada no site e sempre fica algo pela metade heeh....



  13. #13

    Padrão re: Regras Speedr para Integração com Mikrotik e Cache Full

    amigo me add no msn sei como te ajudar.....

  14. #14

    Padrão re: Regras Speedr para Integração com Mikrotik e Cache Full

    Amigo aqui uso hostpot e funciona perfeitamente, mas pra funcionar tive que desabilitar a regra de masqurade do hostpost e manter apenas a criada para o speedr.



  15. #15

    Padrão re: Regras Speedr para Integração com Mikrotik e Cache Full

    acho q nao precisa nem desabilitar .. as veses so mudando a ordem das regras ela funciona 100%

  16. #16

    Padrão re: Regras Speedr para Integração com Mikrotik e Cache Full

    Pode ser não cheguei a testar, mas aqui estou usando a 3 meses e esta funcionando bem. E a proposito se copiou essa regra de onde, verificou se alguma das regras não ficou com algum erro, pois aqui quando apliquei copiei e colei e uma das regras ficava com erro e tive que add ela digitando para corrigir.
    Eu nao me lembro bem qual mas era uma de maracação de pacotes.



  17. #17

    Padrão re: Regras Speedr para Integração com Mikrotik e Cache Full

    Salvato a regra de tanto de hotspot quanto pppoe sao desligadas e fica apenas ON a padrao citada nas regras acima
    Amigo realmente uma das regras na de add vem com erro, entao coloquei ela manualmente o erro é no comento apos deletar ele a regra vai de boa via script

    Rodolfo Muito obrigado pela ajuda, vou lhe add. Mas infelizmente On apenas amanha

  18. #18

    Padrão re: Regras Speedr para Integração com Mikrotik e Cache Full

    Aqui rodei o script e depois arrumei manualmente a regra interpretanto do script. Voce conseguiu fazer funcionar ou ainda esta dando erros?



  19. #19

    Padrão re: Regras Speedr para Integração com Mikrotik e Cache Full

    Jonas .. o speedr as vezes tem tem plugins para fazer chace de certos site. temos que as vezes introduzir manualmente fique atento nisso

  20. #20

    Padrão re: Regras Speedr para Integração com Mikrotik e Cache Full

    Boa tarde, grato pela ajuda rodolfostayne sano algumas duvidas muito importante grato

    salvato grato pela atençao dispensada amigo, sim agora esta tudo quase la tive apenas que add um mascaremento para a interface em si do speedr que acabo os problema.

    Ps: Vc consegui fazer a regra de escuta da porta 3128? Aqui implementei ela mas mesmo assim a navegaçao para caso o speedr desliguei