+ Responder ao Tópico



  1. #1

    Padrão Com Hotbrick funciona, com Linux funciona, com MK não funciona !

    Amigos, boa noite.

    Estou tentando resolver um problema aqui e não achei solução. Vou tentar descrever. Precisamos fazer um reparo em um equipamento e para substituí-lo provisoriamente, utlizaremos uma RB 750GL. Não estou detalhando configuracoes do tipo no thunderbird deveria ter o dominio e não ip, etc etc. pois o objetivo aqui é compar o funcionamento básico (ip/porta).
    Cenário com Hotbrick - equipamento que será substituído temporariamente.

    wan1=201.45.104.22
    lan= 192.168.1.1
    srv1=192.168.1.10 (servidor dns linux)
    srv2=192.168.1.11 (servidor ftp linux)
    srv3=192.168.1.12 (servidor pop/smtp linux)
    mqs=192.168.1.15 a 192.168.1.40 (notebooks da lan com ips via dhcp) ou seja: IP 192.168.1.15/24 GW 192.168.1.1 DNS: 201.45.104.22

    No Hotbrick que tem IP Válido, existe os direcionamentos: 53->192.168.1.10, 21->192.168.1.11, 110 e 25->192.168.1.12
    Optamos por redirecionar as portas, e deixar que o Hotbrick faça todo o trabalho de processamento, mais tudo funciona normalmente, servidor pop, smtp, apache, etc.

    Na configuração dos thunderbirds dos usuários das mqs, o ip dos servidores pop3 e smtp, são o ip válido, no caso 201.45.104.22, e tudo funciona. O cerne da questão é: consigo conectar com os serviços (portas) srv1, srv2 e srv3, usando o IP VALIDO. Porque o IP válido ? porque lá no pop3 e smtp estão "mail.dominio.com.br" que é exatamente o IP fixo do dominio registrado no servidor de dns srv1).

    Colocamos no lugar do hotbrick um micro Centos 6.0 c/2 placas, com configuração EXATAMENTE IGUAL a que funciona com o Hotbrick, e TAMBÉM funciona sem problemas, ou seja, todos os notebooks, funcionam (conectam-se) com as portas dos respectivos servidores....

    Ao colocarmos uma RB para substituir tanto o Hotbrick como o linux, aí vem os problemas..... Tudo funciona (acesso à internet, da rede externa para a interna os redirecionamentos funcionam) EXCETO, os notebooks da lan se conectarem com os servidores internos.

    OU seja: se em cada notebook dermos TELNET 201.45.104.22 110, ou 201.45.104.22 25, 21, 80 ou 143, etc, RESUMINDO: não há conexão. Alguém pode sugerir: já que está na LAN, porque não colocar o endereço interno ao invés do IP público ? Mais acontece que os notebooks funcionam tanto internamente como externamente, ou seja nos campos pop3 e smtp do thunderbird tem que estar alí o endereço: mail.dominio.com.br, que é o ip 201.45.104.20.

    Finalmente qual regra no firewall estaria faltando para que a RB 750GL funcionasse tal qual o Hotbrick ou qualquer distribuição linux que colocamos usando as regras normais de iptables ?

    Resumindo: A RB que é o gateway da rede, tem IP público em sua WAN, e tem redirecionamentos de algumas portas para servidores na LAN. Os notebooks da Lan precisam acessar as portas destes servidores, só que com o IP público e a porta correspondente.

    Algum palpite ?

  2. #2

    Padrão Re: Com Hotbrick funciona, com Linux funciona, com MK não funciona !

    Estou achando que não funciona mesmo. Lí todos fórums e o cenário acima não encaixa em nenhum caso usando RBs. Só falta submeter ao fórum do MK mesmo.



  3. #3
    Alex Rock Avatar de alexrock
    Ingresso
    Jan 2006
    Localização
    S. J. do Rio Preto-SP
    Posts
    828

    Padrão Re: Com Hotbrick funciona, com Linux funciona, com MK não funciona !

    Vai a dica de ouro brother: adiciona o dominio mail.dominio.com.br no dns do mikrotik apontando para o ip interno. Ex: mail.dominio.com.br para 192.168.1.12.
    Claro que é preciso que vc use o DNS do Mikrotik nas suas máquinas.
    Uso o Mikrotik como firewall de servidores expostos à Internet e quando você "sai" pelo ip fixo ele não consegue voltar.
    Outra dica: ative o Ftp no firewall/service ports, senão o conntrack não funciona e o Ftp interno não é redirecionado.