Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Load Balance Paralelo

    Olá a todos... Pessoal to precisando de ajuda ake... Como faço pra fazer um load balance paralelo ao mk?

  2. #2

    Padrão Re: Load Balance Paralelo

    Tenho um microtick que faz balanceamento por grupos e que atribui o ip aos clientes. Estou com outro mickrotick novo, e quero colocar ele pra fazer o gerenciamento, de forma que ele atribua o ip aos clientes, faça o controle de banda, etc... Então pensei em fazer o balanceamento por portas mas cai em um grande problema... meus lincks são de 1mega adsl, e portanto acho que o tráfego na porta 80 dos 45 clientes não vai dar só pra 1 mega.
    Queria colocar 2x1mega pra porta 80, mas num sei como.

    me de uma força ai... assim que estiver tudo funcionando coloca as regras.



  3. #3

    Padrão Re: Load Balance Paralelo

    Acredito que este link tem as respostas para o que procura, se eu estiver errado tente usar a busca/pesquisa do site antes da próxima pergunta e talvez consiga seu objetivo.

    https://under-linux.org/f227/pcc-bal...r-m4d3-131343/

    Abraço

  4. #4

    Padrão Re: Load Balance Paralelo

    Vou ser mais claro e falar o que quero fazer com meus 2 mk... Me ajudem galera...
    todos adsl são de 1 mega

    mikrotick 1:
    ether 01 -> adsl 01: para a porta 80
    ether 02 -> adsl 02: para a porta 80
    ether 03 -> adsl 03: para outras portas x
    ether 04 -> adsl 04: para outras portas y
    ether 05
    |
    Ether 01
    Mikrotick gerenciador
    Recebe o linck balanceado
    faz servidor dhcp
    faz outro serviços
    Ether 02
    |
    Clientes

    Ou seja, quero fazer o balanceamento mas quero destinar 2 links para assumirem juntos apenas uma porta, pos apenas 1 mega não é suficiente.



  5. #5

    Padrão Re: Load Balance Paralelo

    <__
    Citação Postado originalmente por m4d3 Ver Post
    Acredito que este link tem as respostas para o que procura, se eu estiver errado tente usar a busca/pesquisa do site antes da próxima pergunta e talvez consiga seu objetivo.

    https://under-linux.org/f227/pcc-bal...r-m4d3-131343/


    Abraço
    __>

    Amigo, eu li as regras, e desde já agradeço a ajuda, e faço duas perguntas...
    Vi que as regras não tem nada relacionado ao balanceamento atravez das portas

    Entretanto o que entendi é que elas dividem o tráfego entre os links.
    ou seja, haverá uma divisão de tráfego entre os 4 links de 1mb que eu tenho, estou certo?

    Se eu estiver certo, queria saber o seguinte, como devo proseguir, por que como disse, uso um mikrotick para fazer o balance (usando as regras que me mostrou), e um para gerenciar.
    Nestas regras existe a EtherClientes.

    No meu caso é assim:
    MK Balance - Ether de Saída 01 (No seu caso EtherClientes)
    |
    Ether de entrada - Mk Gerenciador - Ether de Saída para os clientes

    Aplicando estas regras ao MK Balance, os meus clientes que passam pelo MK Gerenciador vão receber o link balanceado? sabendo que é o mk gerenciador que atribui o ip a cada cliente por dhcp?

    Obrigado amigo! Abraço.

  6. #6

    Padrão Re: Load Balance Paralelo

    acompanhando



  7. #7

    Padrão Re: Load Balance Paralelo

    Citação Postado originalmente por m4d3 Ver Post
    Acredito que este link tem as respostas para o que procura, se eu estiver errado tente usar a busca/pesquisa do site antes da próxima pergunta e talvez consiga seu objetivo.

    https://under-linux.org/f227/pcc-bal...r-m4d3-131343/

    Abraço
    Amigo... Eu apliquei as regras do Pcc...
    Apliquei em 4adsl de 1mb... Fiz alguns testes e funcionou beleza... Valew... mas...

    Agora Eis os novos problemas:
    Conectei o cabo que sai do Mk-Balance no Mk gerenciador.
    O ip de saida do mk balance é: 192.168.2.254/24
    Coloquei no mk gerenciador o ip: 192.168.2.200/24 para receber o balance
    Fiz a rota para o gatwey 192.168.2.254 no mk-g
    coloquei um ip para a porta de saida do mk Gerenciador: 192.168.10.254/24
    e fiz o mascaramento da rede 192.168.10.254/24 no nat

    Eu não sei se é esta configuração que devo aplicar no mk gerenciador, se não for me ajudem!

    Percebi que quando uso o mk gerenciador a conexão fica lenta, algumas paginas n abrem e outras abrem. Mas quando ligo o cabo que sai do mk balance direto em uma switch e ligo aos clientes, fica rápido e todas páginas carregam... E eu vejo todos os adsl em uso, provando que o pcc deu certo.
    Então o problema deve está na configuração do gerenciador. Como devo fazer amigo, para resolver essa questão?

    Em relação ao uso do hardware não ficou elevado até porque usei como test apenas 3 computadores simuntaneamente.
    Acredito que sejam as regras...

  8. #8

    Padrão Re: Load Balance Paralelo

    Ei galera que passa pelo post, não deixe de postar, pois quanto mais ajuda melhor... se sabe ou tem idéia do caminho a seguir, deixe pelo menos algumas palavras, valew...



  9. #9

    Padrão Re: Load Balance Paralelo

    Citação Postado originalmente por AlexMK Ver Post
    Amigo... Eu apliquei as regras do Pcc...
    Apliquei em 4adsl de 1mb... Fiz alguns testes e funcionou beleza... Valew... mas...

    Agora Eis os novos problemas:
    Conectei o cabo que sai do Mk-Balance no Mk gerenciador.
    O ip de saida do mk balance é: 192.168.2.254/24
    Coloquei no mk gerenciador o ip: 192.168.2.200/24 para receber o balance
    Fiz a rota para o gatwey 192.168.2.254 no mk-g
    coloquei um ip para a porta de saida do mk Gerenciador: 192.168.10.254/24
    e fiz o mascaramento da rede 192.168.10.254/24 no nat

    Eu não sei se é esta configuração que devo aplicar no mk gerenciador, se não for me ajudem!

    Percebi que quando uso o mk gerenciador a conexão fica lenta, algumas paginas n abrem e outras abrem. Mas quando ligo o cabo que sai do mk balance direto em uma switch e ligo aos clientes, fica rápido e todas páginas carregam... E eu vejo todos os adsl em uso, provando que o pcc deu certo.
    Então o problema deve está na configuração do gerenciador. Como devo fazer amigo, para resolver essa questão?

    Em relação ao uso do hardware não ficou elevado até porque usei como test apenas 3 computadores simuntaneamente.
    Acredito que sejam as regras...
    a configuração eh essa mesmo amigo, mas nao esquece que configurar o DNS tb no "MK Gerenciador"...

  10. #10

    Padrão Re: Load Balance Paralelo

    No mk gerenciador ta o DNs 208.67.222.222 / 208.67.220.220:
    No mk balance ta o mesmo dns

    será que eu tenho que acrescentar mais algum dns estático no mk gerenciador ou devo colocar o ip do mk balance no dns do mk-gerenciador?

    Valew!



  11. #11

    Padrão Re: Load Balance Paralelo

    Ei pessoal que usa pcc pra lincks simetricos com modem em bridge...

    Ajudem os necessitados...

    Postem as regras...

  12. #12

    Padrão Re: Load Balance Paralelo

    nao precisa nao... pq da pergunta, ainda nao funciona?



  13. #13

    Padrão Re: Load Balance Paralelo

    Citação Postado originalmente por braw Ver Post
    nao precisa nao... pq da pergunta, ainda nao funciona?
    Amigos, depois de reaplicar as regras de pcc funcionou... A grande questão é: senti que há uma certa lentidão para a rresposta do pcc...

    ja desmarquei a opção: add defaut route, e ficou 90%, mas comparado a antes, ta um pouco lento...

    Alguém tem sugestão do que possa ser?

    Outra coisa, tem como usar dois modens bridge em uma ether no mk? se não tiver, eu sei que tem como usar um bridge e um roteado, mas não sei qualis regras colocar...

  14. #14

    Padrão Re: Load Balance Paralelo

    dois modens em uma ether? impossivel uma interface responder para dois dispositivos ao mesmo tempo... quanto a dif de usar bridge ou roteado eh que nas regras vc define a interface EtherX para os roteados e pppoe-outX para os que forem em bridge... soh nao entendo o pq de usar assim, use tudo em bridge com a rb discando, funciona muito melhor principalmente pelo fato de deixar os modens livres de boa parte do processamento...



  15. #15

    Padrão Re: Load Balance Paralelo

    Citação Postado originalmente por braw Ver Post
    dois modens em uma ether? impossivel uma interface responder para dois dispositivos ao mesmo tempo... quanto a dif de usar bridge ou roteado eh que nas regras vc define a interface EtherX para os roteados e pppoe-outX para os que forem em bridge... soh nao entendo o pq de usar assim, use tudo em bridge com a rb discando, funciona muito melhor principalmente pelo fato de deixar os modens livres de boa parte do processamento...
    Concerteza... mas o que acontece é que tenho:
    5 adsl de 1 mega (por que aqui na região só vai até um mega)
    uma rb 750
    fica 4 ether pra 4 adsl e uma ether para a saida do link balanceado.
    Então como faço para colocar um modem em router junto com um bridge?

    Vamos supor que eu quera usar a ether 1 para colocar um modem bridge e um roteado...
    Eu vou ligar o modem que eu ja uso como bridge em uma suitch (física) e nesta mesma suitch ligo o roteado funcionando
    ai ligo a suitch na ether 1.
    Quando faço isso o ppoe do modem bridge emcontra o modem e faz o roteamento. Até ai beleza.

    O que n sei é quais regras devo aplicar no mk para ele trabalhar com o modem roteado. Precisa colocar a faixa de ip, isso ou aquilo?

    Me ajuda Brother.

  16. #16

    Padrão Re: Load Balance Paralelo

    nao irmao, vc nao entendeu... nao tem como ligar dois dispositivos a um porta apenas... e nao aconselho a usar modens roteados em paralelo com modens em bridge, passe todos para bridge pois fica bem mais pratico pra tu configurar e gerenciar...



  17. #17

    Padrão Re: Load Balance Paralelo

    Citação Postado originalmente por braw Ver Post
    nao irmao, vc nao entendeu... nao tem como ligar dois dispositivos a um porta apenas... e nao aconselho a usar modens roteados em paralelo com modens em bridge, passe todos para bridge pois fica bem mais pratico pra tu configurar e gerenciar...
    qual sugestão voc me daria para rotear 5 links de 1 mega em uma rb 750 com 5 ether, sabendo que uso uma como saida paara meus clientes.

  18. #18

    Padrão Re: Load Balance Paralelo

    Ae pessoal... gostaria de dizer que já estou usando o pcc, e que com certeza é mais eficiente que o balance por grupos de clientes, aquele do GrupA, GrupB... por ip.

    Então como consegui o que queria em breve vou colocar todas as regras a versão e o que aprendi aki.
    vem de graça, vai de graça...

    Se alguem quiser entrar em contato:
    [email protected] - msn

    Valew



  19. #19

    Padrão Re: Load Balance Paralelo

    Como falei que faria vou postar as regras... se ajudei clik na estrela.

  20. #20

    Cool Re: Load Balance Paralelo

    PCC LOADBALANCE - 5 LINKS SIMÉTRICOS DE 1MEGA
    RB 750 V4.11

    ADSL01 = Interface do primeiro link
    ADSL02 = Interface do segundo link
    ADSL03 = Interface do terceiro link
    ADSL04 = Interface do quarto link
    ADSL05 = Interface do quinto link
    050-Clientes01 = Interface dos clientes

    Vamos as regras e explanações sobre o sistema PCC

    * Regras de Mangle:
    * Esta primera regra aceita as conexões para todos os ips de destino que se encontrarem na lista 'sem_balance' que irão sair pela rota padrão
    * Vemos que ocorre uma aceitação para os clientes e uma dst andress list chamada sem_balance

    / ip firewall mangle
    add action=accept chain=prerouting comment="SEM BALANCE" disabled=no dst-address-list=sem_balance in-interface=050-Clientes01

    * cria as marcas (new_adsl_1, new_adsl_2,...new_adsl_5) para novas conexões em cada uma das interfaces (ADSL01...ADSL05)
    Ou seja, cada interface recebeu uma nova marca de conexão que ocorrerá nas novas conexões.

    add action=mark-connection chain=input comment="PCC SEGUNDO GRUPO DE REGRAS" connection-state=new disabled=no in-interface=ADSL01 new-connection-mark=new_adsl_1 passthrough=yes
    add action=mark-connection chain=input comment="" connection-state=new disabled=no in-interface=ADSL02 new-connection-mark=new_adsl_2 passthrough=yes
    add action=mark-connection chain=input comment="" connection-state=new disabled=no in-interface=ADSL03 new-connection-mark=new_adsl_3 passthrough=yes
    add action=mark-connection chain=input comment="" connection-state=new disabled=no in-interface=ADSL04 new-connection-mark=new_adsl_4 passthrough=yes
    add action=mark-connection chain=input comment="" connection-state=new disabled=no in-interface=ADSL05 new-connection-mark=new_adsl_5 passthrough=yes

    ##USEI AS INTERFACES PPOE denominadas ADSL01, ADSL02... ADSL05
    # Usamos os classificadores (0,1,2,3,4, ou seja, 5 marcas já que são 5 adsl simétricos), e na interface de clientes criamos novas marcas de conexão (cliente1... CLIENTE5):

    * neste caso a interface dos clientes está recebendo uma nova marcação de conexão, mas com classificação diferente.
    add action=mark-connection chain=prerouting comment="PCC TERCEIRO GRUPO DE REGRAS" disabled=no dst-address-type=!local in-interface=050-Clientes01 new-connection-mark=cliente1 passthrough=yes per-connection-classifier=both-addresses:5/0
    add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=050-Clientes01 new-connection-mark=cliente2 passthrough=yes per-connection-classifier=both-addresses:5/1
    add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=050-Clientes01 new-connection-mark=cliente3 passthrough=yes per-connection-classifier=both-addresses:5/2
    add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=050-Clientes01 new-connection-mark=cliente4 passthrough=yes per-connection-classifier=both-addresses:5/3
    add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=050-Clientes01 new-connection-mark=cliente5 passthrough=yes per-connection-classifier=both-addresses:5/4

    # NÃO TEM '!local 'e sim 'local', mas tem uma caixa em baixo de local:"INVENT" que deve ser marcada
    notem que se tivessemos 4 links seria aquie que fariamos as alterações para (0,1,2,3 e portanto são 4) ficando 4/0, 4/1, 4/2, 4/3 ou ainda se tivessemos
    links assimétricos onde por exemplo:

    LinkX de 512k
    LinkY de 1024k
    LinkZ de 2048k

    somariamos todos os links e dividiriamos pelo valor do menor link então teriamos 3584k/512k=7 então teriamos 7 marcações
    de pcc indo de 7/0 até 7/6 das quais devemos direcionar a primeira pro link X, a segunda e terceira pro link Y e as quatro restantes
    para o link Z fazendo nosso sistema perfeitamente equilibrado, vale resaltar que sistemas do tipo ADSL não garantem a banda e
    portanto devemos fazer testes em cada um dos links para aferir as velocidades possíveis em cada um, já vi muitos casos onde um link
    desse tipo de 2Mb era melhor do que o de 4Mb da mesma operadora instalada no mesmo local. Também se deve criar as marcações para input e output.

    * utilizando das novas marcações de conexão da interface cliente (conn_ma0, conn_mb1, conn_mc2) criamos uma nova marcação de rota na interface de clientes como (to_nra, to_nrb, to_nrc)
    add action=mark-routing chain=prerouting comment="PCC QUARTO GRUPO DE REGRAS" connection-mark=cliente1 disabled=no in-interface=050-Clientes01 new-routing-mark=cli_rota1 passthrough=no
    add action=mark-routing chain=prerouting comment="" connection-mark=cliente2 disabled=no in-interface=050-Clientes01 new-routing-mark=cli_rota2 passthrough=no
    add action=mark-routing chain=prerouting comment="" connection-mark=cliente3 disabled=no in-interface=050-Clientes01 new-routing-mark=cli_rota3 passthrough=no
    add action=mark-routing chain=prerouting comment="" connection-mark=cliente4 disabled=no in-interface=050-Clientes01 new-routing-mark=cli_rota4 passthrough=no
    add action=mark-routing chain=prerouting comment="" connection-mark=cliente5 disabled=no in-interface=050-Clientes01 new-routing-mark=cli_rota5 passthrough=no

    # FIZ O MASKARAMENTO POR INTERFACE
    add action=masquerade chain=srcnat comment="NAT PARA ADSL01" disabled=no out-interface=ADSL01
    add action=masquerade chain=srcnat comment="NAT PARA ADSL02" disabled=no out-interface=ADSL02
    add action=masquerade chain=srcnat comment="NAT PARA ADSL03" disabled=no out-interface=ADSL03
    add action=masquerade chain=srcnat comment="NAT PARA ADSL04" disabled=no out-interface=ADSL04
    add action=masquerade chain=srcnat comment="NAT PARA ADSL05" disabled=no out-interface=ADSL05

    *vale resaltar que o mascaramento pode ser feito de várias formas, indicando por exempo o ip da interface em src-nat, pela range de ips dos clientes e pela interface do link como acima.

    * Em rotas
    * definimos 5 rotas padrão sendo que cada uma tem um custo diferente e portanto a primeira terá a preferencia, caso venha a faltar a segunda assume, em seguida a terceira
    Isso é muito últel se um dos adsl's falhar.

    add comment="" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=ADSL01 scope=30 target-scope=10
    add comment="" disabled=no distance=3 dst-address=0.0.0.0/0 gateway=ADSL02 scope=30 target-scope=10
    add comment="" disabled=no distance=4 dst-address=0.0.0.0/0 gateway=ADSL03 scope=30 target-scope=10
    add comment="" disabled=no distance=5 dst-address=0.0.0.0/0 gateway=ADSL04 scope=30 target-scope=10
    add comment="" disabled=no distance=6 dst-address=0.0.0.0/0 gateway=ADSL05 scope=30 target-scope=10


    * ainda em rotas
    * em seguida todas as 5 rotas que utilizam marca de rotas (cli_rota1,...cli_rota5) dividem a carga que foi previamente marcada pelo mangle
    /ip route
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=Velox01 routing-mark=cli_rota1 scope=30 target-scope=10
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=Velox02 routing-mark=cli_rota2 scope=30 target-scope=10
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=Velox03 routing-mark=cli_rota3 scope=30 target-scope=10
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=Velox04 routing-mark=cli_rota4 scope=30 target-scope=10
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=Velox05 routing-mark=cli_rota5 scope=30 target-scope=10

    pronto...

    OBS 01: NAS INTERFACES PPOE SEMPRE DESMARQUE A OPÇÃO: Add defaut rout -> para evitar conflitos entre os ppoe

    OBS 02: Voces devem ter percebido que utilizei 5 ppoe, porem fiz isso numa rb750. Coloquei dois modens em bridge ligados a uma switch de 8 portas. E liguei a switch
    na ether 4 da rb. Os dois adsl foram roteados e funcionaram normalmente sem colocar mais nenhuma regra. Fica ai essa dica, pois muitos falam que 2 adsl n funcionam em uma
    só ether mais aki já está funcionando a mais de uma semana 24h




    ############ SE AJUDEI CLIK NA ESTRELA.