+ Responder ao Tópico



  1. #1

    Lightbulb Acesso remoto a mikrotik ddns sript alguem pode me ajudar ?

    Amigos do under estou quebrando a cabeça faz dias ,para fazer aceso remoto a minha routerboard ja tentei alguns scripts aqui do forum mas não obtive sucesso alguem pode me ajudar porfavor ? Siguinte tenho um servidor BRAZILFW em baixo dando ip para os clientes pois o mesmo esta discando a conexão de um dos modens tenho acesso remoto no servidor pelo no-ip .O modem 01 esta em bridg ,pois possuo laodbalance e minha MK esta em bridg desde ja agradeço

  2. #2

    Padrão Re: Acesso remoto a mikrotik ddns sript alguem pode me ajudar ?

    # Dynamic DNS Update / Simple Edition
    # Written by Sam Norris, ChangeIP.com
    # Copyright ChangeIP.com 2009-2010
    # For support send mail to [email protected]
    #
    # 2009-06-22 RouterOS 3.25 Tested
    # 2009-10-05 RouterOS 4.01rc1 Tested
    #
    # OVERVIEW: %
    # This script will update a ChangeIP.com dynamic dns hostname
    # with an ip address located directly on an interface.
    # %
    # NOTES: %
    # IF THIS SCRIPT DOES NOT PRODUCE ANY OUTPUT PLEASE COPY AND PASTE IT
    # AGAIN. THERE PROBABLY IS A LINE BREAK IN THE WRONG PLACE! Once you
    # have created this script and tested that it works by running it
    # manually you can schedule it to run every few minutes.
    # %
    # CONFIGURATION FIELD DEFINITIONS:
    # ddnsuser: Enter your ChangeIP.com user id.
    # ddnspass: Enter your ChangeIP.com password.
    # ddnshost: Enter the hostname (www.example.com) to update.
    # ddnsinterface: Enter an interface name - case sensative.
    # %
    # %
    # %
    # %
    # % % %
    # % % %
    # % % %
    # %
    # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    # EDIT YOUR DETAILS / CONFIGURATION HERE
    # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    :global ddnsuser "usuario"
    :global ddnspass "senha"
    :global ddnshost "host.h1x.com"
    :global ddnsinterface "interfacepppoe"
    # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    # END OF USER DEFINED CONFIGURATION
    # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    :global ddnssystem ("mt-" . [/system package get [/system package find name=system] version] )
    :global ddnsip [ /ip address get [/ip address find interface=$ddnsinterface] address ]
    :global ddnslastip
    :if ([:len [/interface find name=$ddnsinterface]] = 0 ) do={ :log info "DDNS: No interface named $ddnsinterface, please check configuration." }
    :if ([ :typeof $ddnslastip ] = "nothing" ) do={ :global ddnslastip 0.0.0.0/0 }
    :if ([ :typeof $ddnsip ] = "nothing" ) do={
    :log info ("DDNS: No ip address present on " . $ddnsinterface . ", please check.")
    } else={
    :if ($ddnsip != $ddnslastip) do={
    :log info "DDNS: Sending UPDATE!"
    :log info [ ut [/tool dns-update name=$ddnshost address=[ick $ddnsip 0 [:find $ddnsip "/"] ] key-name=$ddnsuser key=$ddnspass ] ]
    :global ddnslastip $ddnsip
    } else={
    :log info "DDNS: No changes necessary."
    }
    }
    # END OF SCRIPT





    isso aqui pode te ajuda irmao valew



  3. #3

    Padrão Re: Acesso remoto a mikrotik ddns sript alguem pode me ajudar ?

    Amigo não consigui alguem pode me dar uma luz ,ta dificil .

  4. #4

    Padrão Re: Acesso remoto a mikrotik ddns sript alguem pode me ajudar ?




  5. #5

    Padrão Re: Acesso remoto a mikrotik ddns sript alguem pode me ajudar ?

    Amigo ja tentei com esse tutorial ,mas não deu certo ,pois estou com um serv brazilfw na frente da mk ja tentei de varias formas ,pois nesse braazilfw tenho aceso remoto ussando dyndns ,si alguem puder me ajuda pois si tiver que pagar pelo serviço eu pago desde ja agradeço

  6. #6

    Padrão Re: Acesso remoto a mikrotik ddns sript alguem pode me ajudar ?

    Então voce precisa no Servidor Brazilfw fazer um redirecionamento de porta, criando isto na regra de firewall dele.

    Permitindo assim o acesso por winbox a sua RB

    No forum da BrazilFW terá como fazer este redirecionamento http://www.brazilfw.com.br/forum/viewforum.php

    Porta do Winbox: 8291



  7. #7

    Padrão Re: Acesso remoto a mikrotik ddns sript alguem pode me ajudar ?

    amigo tabem nao conseguir com ddns. mas descobrir um outro jeito que talvez vai te ajudar.
    entre no site no-ip e faça um cadastro, depois vc vai criar um host, ex. seunome.sytes.net. depois vc volta no site faça o download do arquivo e instala em uma maquina de cliente que usa bastante ou na sua propria. esse arquivo vai pegar o ip e enviar pro no-ip ai vc acessa usando o host que criou. vc pode instalar em quantas maquinas quizer. obs: mas o modem tem que estar em bridge

    qualquer duvida posta ai que te esplico melhor como fazer. se a dica ajudou click na estrela abaixo.....

  8. #8
    Avatar de sniper
    Ingresso
    Nov 2011
    Localização
    São João de Meriti - RJ
    Posts
    17

    Padrão Re: Acesso remoto a mikrotik ddns sript alguem pode me ajudar ?

    vc tem link dedicado ou ADSL



  9. #9

    Padrão Re: Acesso remoto a mikrotik ddns sript alguem pode me ajudar ?

    Citação Postado originalmente por Mario6631 Ver Post
    amigo tabem nao conseguir com ddns. mas descobrir um outro jeito que talvez vai te ajudar.
    entre no site no-ip e faça um cadastro, depois vc vai criar um host, ex. seunome.sytes.net. depois vc volta no site faça o download do arquivo e instala em uma maquina de cliente que usa bastante ou na sua propria. esse arquivo vai pegar o ip e enviar pro no-ip ai vc acessa usando o host que criou. vc pode instalar em quantas maquinas quizer. obs: mas o modem tem que estar em bridge

    qualquer duvida posta ai que te esplico melhor como fazer. se a dica ajudou click na estrela abaixo.....

    Isso da certo!!! Entretanto consegui fazer com DDNS!!! tenho alem do meu server, um pc que passa 24h ligado com o cliente do DDNS e consigo acessar meu mk pelo winbox ou mesmo por webbox de qualquer lugar.. uso ate para acesso ao user-manager.. dentro ou fora da rede tenho acesso ao MK..

    qualquer duvida!!!

  10. #10

    Padrão Re: Acesso remoto a mikrotik ddns sript alguem pode me ajudar ?

    Citação Postado originalmente por cleberson Ver Post
    Amigo não consigui alguem pode me dar uma luz ,ta dificil .

    olha aqui um facil facil funciona redondo comigo no change ip.com:
    /tool dns-update name=ddns.dns1.us address=127.0.0.255 key-name=fulano key="senha"



  11. #11

    Padrão Re: Acesso remoto a mikrotik ddns sript alguem pode me ajudar ?

    ja te passei na aba 1 ae em sima olha e testa essa q da certo ...