+ Responder ao Tópico



  1. #1

    Padrão VM Debian não inicia após instalação no Xen (CentOS)

    Pessoal, como vão todos?

    Estou tendo problemas para iniciar uma máquina virtual Debian, no Xen 3.0.3 (CentOS 5.6)

    Após a instalação, comento as linhas do arquivo.cfg e o seguinte erro aparece:

    Using config file "./debian_teste".
    Using <class 'grub.GrubConf.Grub2ConfigFile'> to parse /boot/grub/grub.cfg
    WARNING:root:Unknown directive load_video
    WARNING:root:Unknown directive terminal_output
    Traceback (most recent call last):
    File "/usr/bin/pygrub", line 691, in ?
    chosencfg = run_grub(file, entry, fs)
    File "/usr/bin/pygrub", line 545, in run_grub
    g = Grub(file, fs)
    File "/usr/bin/pygrub", line 203, in __init__
    self.read_config(file, fs)
    File "/usr/bin/pygrub", line 407, in read_config
    self.cf.parse(buf)
    File "/usr/lib64/python2.4/site-packages/grub/GrubConf.py", line 401, in parse
    self.add_image(Grub2Image(title, img))
    File "/usr/lib64/python2.4/site-packages/grub/GrubConf.py", line 318, in __init__
    _GrubImage.__init__(self, title, lines)
    File "/usr/lib64/python2.4/site-packages/grub/GrubConf.py", line 84, in __init__
    self.reset(lines)
    File "/usr/lib64/python2.4/site-packages/grub/GrubConf.py", line 102, in reset
    self._parse(lines)
    File "/usr/lib64/python2.4/site-packages/grub/GrubConf.py", line 96, in _parse
    map(self.set_from_line, lines)
    File "/usr/lib64/python2.4/site-packages/grub/GrubConf.py", line 328, in set_from_line
    setattr(self, self.commands[com], arg.strip())
    File "/usr/lib64/python2.4/site-packages/grub/GrubConf.py", line 105, in set_root
    self._root = GrubDiskPart(val)
    File "/usr/lib64/python2.4/site-packages/grub/GrubConf.py", line 54, in __init__
    (self.disk, self.part) = str.split(",", 2)
    File "/usr/lib64/python2.4/site-packages/grub/GrubConf.py", line 79, in set_part
    self._part = int(val)
    ValueError: invalid literal for int(): msdos1
    No handlers could be found for logger "xend"
    Error: Boot loader didn't return any data!
    Usage: xm create <ConfigFile> [options] [vars]

    Alguem já teve algum erro parecido?

    Mtec

  2. #2

    Padrão Re: VM Debian não inicia após instalação no Xen (CentOS)

    Ninguém?!?!?!



  3. #3

    Padrão Re: VM Debian não inicia após instalação no Xen (CentOS)

    Valeu pessoal. Já consegui.