Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão SpeedR em Paralelo com o Mikrotik e TProxy Ativo

    Alguem conseguiu colocar o tproxy do speedr funcionando em paralelo ao mikrotik, colocando ele bridge entre o roteador de borda e o servidor mikrotik foi tranquilo porem dessa forma estou deixando um ponto de falha enorme na rede, tentei configurar em paralelo porem ate o momento sem sucesso.

  2. #2
    Analista de Suporte em TI Avatar de demattos
    Ingresso
    Jul 2011
    Localização
    Criciuma/SC
    Posts
    1.923
    Posts de Blog
    3

    Padrão re: SpeedR em Paralelo com o Mikrotik e TProxy Ativo

    Olha para funcionar me paralelo com mk nao deveria ficar em bridge, nao seia isto



  3. #3

    Padrão re: SpeedR em Paralelo com o Mikrotik e TProxy Ativo

    Em bridge eu tive sucesso na implantação porem teria um ponto grande falha na rede, se para o servidor, reiniciar e tudo mais. Por isso a tentativa de colocar em paralelo com duas interfaces tanto no mikrotik quanto no speedr, sendo uma pro link e uma para os clientes e redirecionar os clientes pelo mangle porem sem sucesso ate agora. Eu usava dessa forma antes com freebsd + thunder detalhe sem usar bridge.

    A documentação é muito simples Speedr - Cacheando a Web 2.0 - www.speedr.com.br

    Se alguem tiver alguma dica agradeço

  4. #4

    Padrão re: SpeedR em Paralelo com o Mikrotik e TProxy Ativo

    Para esta grande falha existe uma solução.

    Uma segunda conexão com o seu llink passando por fora o speedr depois só colocar umas
    regrinhas no mikrotik ai quando o servidor por ventura cair a porta que ele esta perde o IP e passsa este ip para a outra por ligada ao seu link.

    redundância.



  5. #5
    ZOOM NET TELECOM LTDA Avatar de OSNIR
    Ingresso
    Feb 2011
    Localização
    PARIPIRANGA - BAHIA
    Posts
    353
    Posts de Blog
    1

    Padrão re: SpeedR em Paralelo com o Mikrotik e TProxy Ativo

    Funciona sim em paralelo, eu mesmo uso aqui e funfa legal... deve existir algum erro em suas configurações, não só o speedr como todos os outros que conheço rodam.

  6. #6

    Padrão re: SpeedR em Paralelo com o Mikrotik e TProxy Ativo

    osnir pode me passar como fez a configuração do reparesse de pacotes do mikrotik para o speedr e como tratou o retorno.



  7. #7

    Padrão re: SpeedR em Paralelo com o Mikrotik e TProxy Ativo

    osrnir podria confirmar pra mim, como está a sua topologia.

    Clique na imagem para uma versão maior

Nome:	         Untitled-1.jpg
Visualizações:	487
Tamanho: 	82,4 KB
ID:      	30931

  8. #8

    Padrão re: SpeedR em Paralelo com o Mikrotik e TProxy Ativo

    clecio.. no seu gateway vc precisa pegar os pacotes que vem da internet (src-port 80) e dar um mark-routing neles

    criar uma rota defaul, apontando a marca desses pacotes para o ip do seu speedr..

    essa eh a logica do WCCP da cisco... como ha uma interação entre router e proxy, o router faz este desvio automatico.. mas como mikrotik nao tem wccp, precisamos faze-lo "na mao"...

    lembrando tambem que vc deve ter alguma lista branca, onde NAO desviar pacotes, por ex.. CEF, sistemas de EADs, etc etc.



  9. #9
    Patrocinador Avatar de edcomrocha
    Ingresso
    Aug 2007
    Localização
    São Paulo, Brazil, Brazil
    Posts
    840

    Padrão re: SpeedR em Paralelo com o Mikrotik e TProxy Ativo

    Pois é Alexandre, tambem estou na mesma que o Clecio, e ainda nao consegui.

    Fiz a marcaçao de pacotes como você disse, criei a rota default, nas conf do proxy marquei como pediram, so que nada de funcionar.

    Em um comentario em algum lugar falaram que mesmo para estar em paralelo, deveria ser usado 2 interfaces de rede no proxy, so que ai me bati e nao achei o porque de usar 2 interfaces se esta em paralelo.

    Se alguem puder observar as regras do mangle e comentar se tem algo errado ajudaria muito.

    Código :
    /ip firewall mangle
    add action=mark-connection chain=prerouting comment="Conexoes HTTP" disabled=no dst-address-list=!Out-Cache dst-port=80 new-connection-mark=conexoes_speedr passthrough=yes protocol=tcp src-address-list=Clientes
     
    add action=mark-routing chain=prerouting comment="Rota Conexoes HTTP" connection-mark=conexoes_speedr disabled=no dst-address-list=!Out-Cache new-routing-mark=speedr-route passthrough=no src-address=!177.XX.128.XXx src-address-list=Clientes

    Tambem existe uma rota que tem um routing-mak (speedr-route) para o ip do proxy (177.XX).

    Creio que nao estamos conseguindo pelo fato das regras internas do proxy, pois nao temos acesso as mesmas.

    Se alguem puder dar um help.


    Abraços a todos e obrigado pela atenção.

  10. #10

    Padrão re: SpeedR em Paralelo com o Mikrotik e TProxy Ativo

    Alexandre eu fazia dessa forma antes com o freebsd + thundercache, porem o speedr não aceitou, a documentação é fraca



  11. #11

    Padrão re: SpeedR em Paralelo com o Mikrotik e TProxy Ativo

    edcomrocha boa tarde, no freebsd + thundercache eu usava duas placas de rede uma conectada ao link e outra no switch dois clientes, sem a necessidade de bridge como o speedr. Por exemplo

    Interface do link
    IP 187.51.38.19
    Mask 255.255.255.248
    GW 187.51.38.17

    Interface dos cliente
    IP 172.16.0.2
    Mask 255.255.255.252

    Porem adicionava rotas tudo que fosse para os IPs dos clientes apontava para o 172.16.0.1 que era interface do mikrotik no switch dos clientes.

    Usava essa regra e redicionava o trafego entrada e saida para o cache.

    /ip firewall mangle
    add action=mark-routing chain=prerouting comment=ThunderCache disabled=yes \
    dst-address-list=!NoCache dst-port=80 in-interface=!BACKBONE \
    new-routing-mark=thunder-route passthrough=yes protocol=tcp \
    src-address-list=Cache
    add action=mark-routing chain=prerouting comment=ThunderCache disabled=yes \
    dst-address-list=Cache in-interface=BACKBONE new-routing-mark=\
    thunder-route passthrough=yes protocol=tcp src-address-list=!NoCache \
    src-port=80

    Att..

    Clecio Rodrigo

  12. #12

    Padrão re: SpeedR em Paralelo com o Mikrotik e TProxy Ativo

    CONSEGUI PESSOAL ;-)
    speerd rodando em paralelo com mikrotik com tproxy ativo

    vou montar um tutorial e posto aqui....



  13. #13
    Patrocinador Avatar de edcomrocha
    Ingresso
    Aug 2007
    Localização
    São Paulo, Brazil, Brazil
    Posts
    840

    Padrão re: SpeedR em Paralelo com o Mikrotik e TProxy Ativo

    Beleza, mano.

    Fico no aguardo.

    Abraços

  14. #14

    Padrão re: SpeedR em Paralelo com o Mikrotik e TProxy Ativo

    ...



  15. #15

    Padrão re: SpeedR em Paralelo com o Mikrotik e TProxy Ativo

    Como prometido em anexo o tutorial, espero que ajude.

    Clique na imagem para uma versão maior

Nome:	         Tutorial SpeedR.jpg
Visualizações:	448
Tamanho: 	30,0 KB
ID:      	31039Clique na imagem para uma versão maior

Nome:	         Tutorial SpeedR 2.jpg
Visualizações:	422
Tamanho: 	35,6 KB
ID:      	31040

    Att..

    Clecio Rodrigo

  16. #16

    Padrão re: SpeedR em Paralelo com o Mikrotik e TProxy Ativo

    Como prometido em anexo o tutorial, espero que ajude.

    Clique na imagem para uma versão maior

Nome:	         Tutorial SpeedR 2.jpg
Visualizações:	273
Tamanho: 	35,6 KB
ID:      	31041

    Clique na imagem para uma versão maior

Nome:	         Tutorial SpeedR.jpg
Visualizações:	228
Tamanho: 	30,0 KB
ID:      	31042



  17. #17

    Padrão re: SpeedR em Paralelo com o Mikrotik e TProxy Ativo

    Não consegui enviar em pdf.

    Mais enviei no forum do speedr

    http://speedr.com.br/uploads/b006fb3...594fea6548.pdf

    Att..

    Clecio Rodrigo

  18. #18

    Padrão re: SpeedR em Paralelo com o Mikrotik e TProxy Ativo

    Desculpa minha ignorancia, mas o que seria o pppeo ali, o que precisaria era que no cliente final eu colocasse o ip valido e o tal chegasse, clientes pppeo e hotspot nao seria o caso



  19. #19

    Padrão Re: SpeedR em Paralelo com o Mikrotik e TProxy Ativo

    O PPPOE se refere ao método de autenticação utilizado aqui no provedor, definindo o bloco IP que são utilizados, porem nada impede de se usar hotspot, mac x ip.

  20. #20
    Patrocinador Avatar de edcomrocha
    Ingresso
    Aug 2007
    Localização
    São Paulo, Brazil, Brazil
    Posts
    840

    Padrão Re: SpeedR em Paralelo com o Mikrotik e TProxy Ativo

    Clecio, o switch usado ai na sua topologia é normal ou com vlan ?
    A interface que é ligada no switch é feito uma vlan dela pro speedr ? ou ligaçao normal mesmo ?