+ Responder ao Tópico



  1. #1

    Padrão Ajuda com erro no OSPF

    Senhores, estou tendo o seguinte erro em minha rede

    database description packet has init bit set in middle of an exchange
    OSPFv2 neighbor x.x.x.x: state change from Full to 2-Way

    com isso acaba derrubando a conexão por alguns segundo
    Alguém tem alguma idéia do que pode estar acasionando este erro?

  2. #2

    Padrão Re: Ajuda com erro no OSPF

    Seria interessante vc postar os prints da suas confs ou o export para analisarmos.....

    Verificarmos as confs na opção instances.



  3. #3

    Padrão Re: Ajuda com erro no OSPF

    /ip address
    add address=x.x.x.1/32 disabled=no interface=LoopBackOSPF network=x.x.x.1
    add address=x.x.x.1/30 comment="PtP Diplomata" disabled=no interface=ether2 network=x.x.x.0
    add address=x.x.x.1/32 disabled=no interface=LoopBackBGP network=x.x.x.1
    add address=x.x.x.5/30 comment="Bloco IP Servidor Radius MK Solutions" disabled=no interface=ether2 network=x.x.x.4
    add address=x.x.x.146/29 disabled=no interface=ether1 network=x.x.x.144
    add address=x.x.x.5/30 comment="PtP -> AP Diplomata" disabled=no interface=ether2 network=x.x.x.4
    add address=x.x.x.49/30 comment="PtP -> AP Arapongas" disabled=no interface=ether2 network=x.x.x.48
    add address=x.x.x.57/30 comment="PtP Arapongas" disabled=no interface=ether2 network=x.x.x.56
    add address=x.x.x.9/30 comment="Bloco IP ns1.midas.net.br" disabled=no interface=ether2 network=x.x.x.8
    add address=x.x.x.13/30 comment="Bloco IP ns2.midas.net.br" disabled=no interface=ether2 network=x.x.x.12
    add address=x.x.x.74/30 comment="PtP Maringa" disabled=no interface=ether2 network=x.x.x.72
    add address=x.x.x.81/30 comment="PtP -> AP Maringa" disabled=no interface=ether2 network=x.x.x.80

    /routing bgp instance
    add as=xxxxxx client-to-client-reflection=no disabled=no ignore-as-path-len=no name=MidasNet out-filter="" redistribute-connected=no redistribute-ospf=no redistribute-other-bgp=no redistribute-rip=no \
    redistribute-static=no router-id=x.x.x.1 routing-table=""
    /routing ospf instance
    set default disabled=no distribute-default=always-as-type-1 in-filter=ospf-in metric-bgp=auto metric-connected=20 metric-default=1 metric-other-ospf=auto metric-rip=20 metric-static=20 name=default out-filter=\
    ospf-out redistribute-bgp=no redistribute-connected=as-type-1 redistribute-other-ospf=no redistribute-rip=no redistribute-static=no router-id=x.x.x.1
    /routing ospf area
    set backbone area-id=0.0.0.0 disabled=no instance=default name=backbone type=default
    /routing bfd interface
    set all disabled=no interface=all interval=0.2sec min-rx=0.2sec multiplier=5
    /routing bgp network
    add disabled=no network=x.x.x.0/21 synchronize=no
    add disabled=no network=x.x.x.0/24 synchronize=no
    /routing bgp peer
    add address-families=ip as-override=no default-originate=never disabled=no hold-time=3m in-filter=Filtro_BGP_Entrada instance=MidasNet multihop=yes name=CopelTelecom nexthop-choice=default out-filter=\
    Filtro_BGP_Saida passive=no remote-address=x.x.x.145 remote-as=xxxxx remove-private-as=no route-reflect=no tcp-md5-key="" ttl=default update-source=x.x.x.1 use-bfd=no
    /routing filter
    add action=jump chain=Filtro_BGP_Entrada comment="Filtros de Entrada" disabled=no invert-match=no jump-target=Bogon
    add action=discard chain=Filtro_BGP_Entrada comment="Descartar recebimento de seu proprio prefixo /21-32 he a mascara que vai bloquear" disabled=no invert-match=no prefix=x.x.x.0/21 prefix-length=21-32
    add action=discard chain=Bogon comment="Descarta Bogons e recebimento de blocos privados - http://www.team-cymru.org/Services/Bogons/bogon-bn-agg.txt" disabled=no invert-match=no prefix=0.0.0.0/8 prefix-length=8-32
    add action=discard chain=Bogon disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=8-32
    add action=discard chain=Bogon disabled=no invert-match=no prefix=127.0.0.0/8 prefix-length=8-32
    add action=discard chain=Bogon disabled=no invert-match=no prefix=169.254.0.0/16 prefix-length=16-32
    add action=discard chain=Bogon disabled=no invert-match=no prefix=172.16.0.0/12 prefix-length=12-32
    add action=discard chain=Bogon disabled=no invert-match=no prefix=192.0.0.0/24 prefix-length=24-32
    add action=discard chain=Bogon disabled=no invert-match=no prefix=192.0.2.0/24 prefix-length=24-32
    add action=discard chain=Bogon disabled=no invert-match=no prefix=192.168.0.0/16 prefix-length=16-32
    add action=discard chain=Bogon disabled=no invert-match=no prefix=198.18.0.0/15 prefix-length=15-32
    add action=discard chain=Bogon disabled=no invert-match=no prefix=198.51.100.0/24 prefix-length=24-32
    add action=discard chain=Bogon disabled=no invert-match=no prefix=203.0.113.0/24 prefix-length=24-32
    add action=discard chain=Bogon disabled=no invert-match=no prefix=224.0.0.0/3 prefix-length=3-32
    add action=discard chain=Filtro_BGP_Saida comment="Descarta o que nao for minha grade de ips validos" disabled=no invert-match=no prefix=!x.x.x.0/21 prefix-length=!21-24
    /routing mme
    set bidirectional-timeout=2 gateway-class=none gateway-keepalive=1m gateway-selection=no-gateway origination-interval=5s preferred-gateway=0.0.0.0 timeout=1m ttl=50

    /routing ospf instance
    set default disabled=no distribute-default=always-as-type-1 in-filter=ospf-in \
    metric-bgp=auto metric-connected=20 metric-default=1 metric-other-ospf=auto \
    metric-rip=20 metric-static=20 name=default out-filter=ospf-out \
    redistribute-bgp=no redistribute-connected=as-type-1 \
    redistribute-other-ospf=no redistribute-rip=no redistribute-static=no \
    router-id=x.x.x.1
    /routing ospf area
    set backbone area-id=0.0.0.0 disabled=no instance=default name=backbone type=\
    default
    /routing ospf network
    add area=backbone disabled=no network=x.x.x.0/24
    add area=backbone disabled=no network=x.x.x.0/30
    add area=backbone disabled=no network=x.x.x.0/21
    add area=backbone disabled=no network=x.x.x.4/30
    add area=backbone disabled=no network=x.x.x.56/30
    add area=backbone disabled=no network=x.x.x.48/30
    add area=backbone disabled=no network=x.x.x.80/30
    add area=backbone disabled=no network=x.x.x.72/30

  4. #4

    Padrão Re: Ajuda com erro no OSPF

    Quando tenho esse erro aqui, é porque caiu algum seguimento, no meu caso aqui, um /30 feito em um enlace por exemplo, o neighbor deixou de ser acessível.



  5. #5
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão Re: Ajuda com erro no OSPF

    Ative, junto com o LOG do OSPF, o log debug do wireless, pois normalmente estes erros do OSPF, como o Josue citou, é perda de conectividade em L2 do seguimento de rede. Se o wireless está oscilando, com pequenas interrupções, além de ocorrer os erros no OSPF, a quantidade de anúncios tende a aumentar e isso não é bom se desejas uma rede estável.

  6. #6

    Padrão Re: Ajuda com erro no OSPF

    Bom dia, obrigado pelo retorno.
    Os PtP é feito com Ubiquiti NanoBridge de 22DBI, o sinal é bom, -58 mas vou tentar trocar de canal parta verificar.



  7. #7
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão Re: Ajuda com erro no OSPF

    Esses caras são encrenqueiros com Multicast (aliás, wireless é... )

    Configure o OSPF para PtP ao invés de automático e se ainda assim insistirem os erros, vai de NBMA que resolve.

    Citação Postado originalmente por rodrigo_pagani Ver Post
    Bom dia, obrigado pelo retorno.
    Os PtP é feito com Ubiquiti NanoBridge de 22DBI, o sinal é bom, -58 mas vou tentar trocar de canal parta verificar.

  8. #8

    Padrão Re: Ajuda com erro no OSPF

    Eu ja tinha lido sobre NBMA, não sei configurar, mas peguei um exemplo no site da Mikrotik, o OSPF caiu e não levantou mais.
    Voltou quando desfiz a configuração.
    Poderia me dar uma força para configurar?



  9. #9
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão Re: Ajuda com erro no OSPF

    Tentou PtP primeiro? Eu uso em um cenário semelhante ao seu e não tenho problemas. Mas se quiser usar NBMA, coloque suas configurações aqui que eu comento o que fazer.

    Citação Postado originalmente por rodrigo_pagani Ver Post
    Eu ja tinha lido sobre NBMA, não sei configurar, mas peguei um exemplo no site da Mikrotik, o OSPF caiu e não levantou mais.
    Voltou quando desfiz a configuração.
    Poderia me dar uma força para configurar?

  10. #10

    Padrão Re: Ajuda com erro no OSPF

    Bom dia Sérgio, segue minha configuração, se você puder dar uma olha no filtro do BGP, também agradeço.

    /ip address
    add address=x.x.x.1/32 disabled=no interface=LoopBackOSPF network=x.x.x.1
    add address=x.x.x.1/30 comment="PtP Diplomata" disabled=no interface=ether2 network=x.x.x.0
    add address=x.x.x.1/32 disabled=no interface=LoopBackBGP network=x.x.x.1
    add address=x.x.x.5/30 comment="Bloco IP Servidor Radius MK Solutions" disabled=no interface=ether2 network=x.x.x.4
    add address=x.x.x.146/29 disabled=no interface=ether1 network=x.x.x.144
    add address=x.x.x.5/30 comment="PtP -> AP Diplomata" disabled=no interface=ether2 network=x.x.x.4
    add address=x.x.x.49/30 comment="PtP -> AP Arapongas" disabled=no interface=ether2 network=x.x.x.48
    add address=x.x.x.57/30 comment="PtP Arapongas" disabled=no interface=ether2 network=x.x.x.56
    add address=x.x.x.9/30 comment="Bloco IP ns1.midas.net.br" disabled=no interface=ether2 network=x.x.x.8
    add address=x.x.x.13/30 comment="Bloco IP ns2.midas.net.br" disabled=no interface=ether2 network=x.x.x.12
    add address=x.x.x.74/30 comment="PtP Maringa" disabled=no interface=ether2 network=x.x.x.72
    add address=x.x.x.81/30 comment="PtP -> AP Maringa" disabled=no interface=ether2 network=x.x.x.80

    /routing bgp instance
    add as=xxxxxx client-to-client-reflection=no disabled=no ignore-as-path-len=no name=MidasNet out-filter="" redistribute-connected=no redistribute-ospf=no redistribute-other-bgp=no redistribute-rip=no \
    redistribute-static=no router-id=x.x.x.1 routing-table=""
    /routing ospf instance
    set default disabled=no distribute-default=always-as-type-1 in-filter=ospf-in metric-bgp=auto metric-connected=20 metric-default=1 metric-other-ospf=auto metric-rip=20 metric-static=20 name=default out-filter=\
    ospf-out redistribute-bgp=no redistribute-connected=as-type-1 redistribute-other-ospf=no redistribute-rip=no redistribute-static=no router-id=x.x.x.1
    /routing ospf area
    set backbone area-id=0.0.0.0 disabled=no instance=default name=backbone type=default
    /routing bfd interface
    set all disabled=no interface=all interval=0.2sec min-rx=0.2sec multiplier=5
    /routing bgp network
    add disabled=no network=x.x.x.0/21 synchronize=no
    add disabled=no network=x.x.x.0/24 synchronize=no
    /routing bgp peer
    add address-families=ip as-override=no default-originate=never disabled=no hold-time=3m in-filter=Filtro_BGP_Entrada instance=MidasNet multihop=yes name=CopelTelecom nexthop-choice=default out-filter=\
    Filtro_BGP_Saida passive=no remote-address=x.x.x.145 remote-as=xxxxx remove-private-as=no route-reflect=no tcp-md5-key="" ttl=default update-source=x.x.x.1 use-bfd=no
    /routing filter
    add action=jump chain=Filtro_BGP_Entrada comment="Filtros de Entrada" disabled=no invert-match=no jump-target=Bogon
    add action=discard chain=Filtro_BGP_Entrada comment="Descartar recebimento de seu proprio prefixo /21-32 he a mascara que vai bloquear" disabled=no invert-match=no prefix=x.x.x.0/21 prefix-length=21-32
    add action=discard chain=Bogon comment="Descarta Bogons e recebimento de blocos privados - http://www.team-cymru.org/Services/Bogons/bogon-bn-agg.txt" disabled=no invert-match=no prefix=0.0.0.0/8 prefix-length=8-32
    add action=discard chain=Bogon disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=8-32
    add action=discard chain=Bogon disabled=no invert-match=no prefix=127.0.0.0/8 prefix-length=8-32
    add action=discard chain=Bogon disabled=no invert-match=no prefix=169.254.0.0/16 prefix-length=16-32
    add action=discard chain=Bogon disabled=no invert-match=no prefix=172.16.0.0/12 prefix-length=12-32
    add action=discard chain=Bogon disabled=no invert-match=no prefix=192.0.0.0/24 prefix-length=24-32
    add action=discard chain=Bogon disabled=no invert-match=no prefix=192.0.2.0/24 prefix-length=24-32
    add action=discard chain=Bogon disabled=no invert-match=no prefix=192.168.0.0/16 prefix-length=16-32
    add action=discard chain=Bogon disabled=no invert-match=no prefix=198.18.0.0/15 prefix-length=15-32
    add action=discard chain=Bogon disabled=no invert-match=no prefix=198.51.100.0/24 prefix-length=24-32
    add action=discard chain=Bogon disabled=no invert-match=no prefix=203.0.113.0/24 prefix-length=24-32
    add action=discard chain=Bogon disabled=no invert-match=no prefix=224.0.0.0/3 prefix-length=3-32
    add action=discard chain=Filtro_BGP_Saida comment="Descarta o que nao for minha grade de ips validos" disabled=no invert-match=no prefix=!x.x.x.0/21 prefix-length=!21-24
    /routing mme
    set bidirectional-timeout=2 gateway-class=none gateway-keepalive=1m gateway-selection=no-gateway origination-interval=5s preferred-gateway=0.0.0.0 timeout=1m ttl=50

    /routing ospf instance
    set default disabled=no distribute-default=always-as-type-1 in-filter=ospf-in \
    metric-bgp=auto metric-connected=20 metric-default=1 metric-other-ospf=auto \
    metric-rip=20 metric-static=20 name=default out-filter=ospf-out \
    redistribute-bgp=no redistribute-connected=as-type-1 \
    redistribute-other-ospf=no redistribute-rip=no redistribute-static=no \
    router-id=x.x.x.1
    /routing ospf area
    set backbone area-id=0.0.0.0 disabled=no instance=default name=backbone type=\
    default
    /routing ospf network
    add area=backbone disabled=no network=x.x.x.0/24
    add area=backbone disabled=no network=x.x.x.0/30
    add area=backbone disabled=no network=x.x.x.0/21
    add area=backbone disabled=no network=x.x.x.4/30
    add area=backbone disabled=no network=x.x.x.56/30
    add area=backbone disabled=no network=x.x.x.48/30
    add area=backbone disabled=no network=x.x.x.80/30
    add area=backbone disabled=no network=x.x.x.72/30



  11. #11
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão Re: Ajuda com erro no OSPF

    Porque a loopback não faz parte do ospf network? Como estão as interfaces no ospf?

  12. #12

    Padrão Re: Ajuda com erro no OSPF

    Sérgio, te passei minha configuração em MP, só para não mostrar meus IPs



  13. #13
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão Re: Ajuda com erro no OSPF

    Sim, eu vi, mas de qualquer forma lá não tem o que eu perguntei: porque a loopbackOSPF não está no ospf network e envia aqui o export do ospf interfaces

  14. #14

    Padrão Re: Ajuda com erro no OSPF

    Desculpa, eu estava com network na cabeça.
    Em interface eu não declarei nada, ficou dinâmico.
    Eu devo fazer a declaração manual?

    # INTERFACE COST PRIORITY NETWORK-TYPE AUTHENTICATION AUTHENTICATION-KEY
    0 DP LoopBackOSPF 10 1 broadcast none
    1 DP LoopBackBGP 10 1 broadcast none
    2 D <pptp-midasnet> 10 1 point-to-point none
    3 D ether2 10 1 broadcast none
    4 D ether2 10 1 broadcast none
    5 D <pppoe-rita> 10 1 point-to-point none
    6 D ether2 10 1 broadcast none
    7 D ether2 10 1 broadcast none
    8 D ether2 10 1 broadcast none
    9 D ether2 10 1 broadcast none
    10 D <pppoe-midasnetescritorio> 10 1 point-to-point none
    11 D <pppoe-nilson> 10 1 point-to-point none
    12 D ether2 10 1 broadcast none
    13 D ether2 10 1 broadcast none
    14 D ether2 10 1 broadcast none



  15. #15

    Padrão Re: Ajuda com erro no OSPF

    Não sei se está errado, mas em a LoopBackOSPF é /30 e eu declarei no OSPF - network /24

  16. #16
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão Re: Ajuda com erro no OSPF

    Olha só, como declarou redes que, acredito eu, não tem nada a ver com o OSPF estão "subindo" no interfaces.

    Para criar NBMA ou PtP é simples, abra as interfaces que desejar fechar o OSPF de fato, selecione o copy e, na cópia, edite brodcast para NBMA ou PointToPoint. Faça nos roteadores adjacentes a mesma coisa.

    Reveja esta questão das redes, por exemplo, definindo, também na edição das interfaces (copiando, como mencionei acima) o parâmetro passive para as que não irão receber ou enviar tráfego OSPF.




    Citação Postado originalmente por rodrigo_pagani Ver Post
    Desculpa, eu estava com network na cabeça.
    Em interface eu não declarei nada, ficou dinâmico.
    Eu devo fazer a declaração manual?

    # INTERFACE COST PRIORITY NETWORK-TYPE AUTHENTICATION AUTHENTICATION-KEY
    0 DP LoopBackOSPF 10 1 broadcast none
    1 DP LoopBackBGP 10 1 broadcast none
    2 D <pptp-midasnet> 10 1 point-to-point none
    3 D ether2 10 1 broadcast none
    4 D ether2 10 1 broadcast none
    5 D <pppoe-rita> 10 1 point-to-point none
    6 D ether2 10 1 broadcast none
    7 D ether2 10 1 broadcast none
    8 D ether2 10 1 broadcast none
    9 D ether2 10 1 broadcast none
    10 D <pppoe-midasnetescritorio> 10 1 point-to-point none
    11 D <pppoe-nilson> 10 1 point-to-point none
    12 D ether2 10 1 broadcast none
    13 D ether2 10 1 broadcast none
    14 D ether2 10 1 broadcast none



  17. #17
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão Re: Ajuda com erro no OSPF

    Não é comum fazer assim, declare apenas o IP, pois loopback é /32.

    Citação Postado originalmente por rodrigo_pagani Ver Post
    Não sei se está errado, mas em a LoopBackOSPF é /30 e eu declarei no OSPF - network /24

  18. #18

    Padrão Re: Ajuda com erro no OSPF

    Eu escrevi errado, o IP da LoopBackOSPF é /32, mas como disse, declarei /24 em OSPF-Network.
    Vou fazer essas alterações e monitorar se para com o erro, já que o erro acontece a cada 1 ou 2 dias.
    Obrigado pela atenção.
    Sérgio, eu já fiz um curso de roteamento em São Paulo com você, não sabia nada e hoje sei pouco mas consigo me virar.
    Quando você vai fazer algum curso sobre roteamento na Região de Londrina-Pr, pois acredito que eu fazendo outro curso, vou conseguir absorver muita informação.



  19. #19
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão Re: Ajuda com erro no OSPF

    Citação Postado originalmente por rodrigo_pagani Ver Post
    Eu escrevi errado, o IP da LoopBackOSPF é /32, mas como disse, declarei /24 em OSPF-Network.
    Vou fazer essas alterações e monitorar se para com o erro, já que o erro acontece a cada 1 ou 2 dias.
    Obrigado pela atenção.
    Então Rodrigo, refaça a questão das loopbacks, mas faça o teste que mencionei, usando o PtP ao invés de broadcast (deixa o NBMA para último caso). Como mencionei eu uso NanoBridge em um cenário, onde as mesmas realizam os enlaces e em cada ethernet delas está conectado uma RB com o OSPF. A rede das NanoBridge, eu não configuro no network, pois elas não devem receber nem enviar tráfego OSPF (configuro na instância do OSPF para anunciar redes conectadas), devem apenas ser anunciadas para que eu tenha acesso de gerência nas NanoBridge.

    Alguma outra rede, que por ventura exista a necessidade de configurar na mesma interface executando o OSPF, eu prefiro usar VLANs e rodar o OSPF apenas nestas interfaces configuradas em PtP.


    Citação Postado originalmente por rodrigo_pagani Ver Post
    Sérgio, eu já fiz um curso de roteamento em São Paulo com você, não sabia nada e hoje sei pouco mas consigo me virar.
    Quando você vai fazer algum curso sobre roteamento na Região de Londrina-Pr, pois acredito que eu fazendo outro curso, vou conseguir absorver muita informação.
    Desculpe, mas não lembrava, mas é isso mesmo, estudando e lendo bastante conseguimos o conhecimento para colocar em prática em nossas redes.

    Eu não sei como anda a agenda da MD para o Sul, mas acredito que início do ano deve ter algo para Curitiba.