+ Responder ao Tópico



  1. #1

    Padrão Script para Ping e e-Mail

    Ola... Bom Dia a Todos.
    ALguem saberia me dizer como faço um script de ping.
    Por exemplo.
    O script ira fazer 10 pings no host 10.0.0.1
    Se falhar mais de 7 pings ele envia um email avisando.
    Alguem tem alguma ideia de como faço isso ?

  2. #2

    Padrão re: Script para Ping e e-Mail

    Caro Evandrocj da uma olhada nestes dois link's que acredito que deva ajudar a montar seu script.
    https://under-linux.org/f105/script-para-monitoramento-via-ping-watchdog-78127/
    https://under-linux.org/f95/script-para-mandar-email-um-por-um-85907/index2.html

    No primeiro monitora via ping se der erro executa uma açao e no segundo envia e-mail usando Perl e autenticação.

    Ate mais



  3. #3

    Padrão Re: Script para Ping e e-Mail

    Bom dia

    Amigo experimenta usar The dude para monitoramento de sua rede.

    1º Instalação the dude

    2º Mandando email via Gmail the dude

  4. #4

    Padrão Re: Script para Ping e e-Mail

    Sim, mas eu queria que a Mikrotik fizesse isso.
    Pois nao tem computador na rede, nao tem como eu instalar o DUDE
    Sao 2 redes fechadas por EoIP, para uso de telefone IP ( pabx ip ).



  5. #5

    Padrão Re: Script para Ping e e-Mail

    Eu uso está solução a baixo. Envia por email e sms, vc tem apenas que redirecionar no MK um porta para cada IP que quiser monitorar o sistema monitora até 50 IPs em uma unica conta gratuita e vai te informar exatamente qual IP seu não está pingando. Segue link do tutorial que eu fiz

    https://under-linux.org/f311/script-...ia-sms-153136/

  6. #6

    Padrão Re: Script para Ping e e-Mail

    Eu fiz um aqui pra mim... estou até tentando deixar ele melhor utilizando Arrays, mas não estou conseguindo... se quiser me ajudar, aqui => https://under-linux.org/f311/script-para-ping-156112/

    Uma outra coisa que eu gostaria de fazer é capturar os parâmetros de menor tempo/tempo médio/maior tempo do ping. Se alguém souber... agradecidíssimo.

    Meu script atual ( adapte para sua realidade ):

    Código :
    :local online 0
    :local problema 0
    :local informacao ""
    :local data [/system clock get date]
    :local hora [/system clock get time]
    :local tstping
     
    :if ([ping 169.254.143.4 count 4]>0) do={
          :set online ($online+1)
          :set tstping [ping 169.254.143.4 count 10 size=1500 do-not-fragment]
          :if (tstping<9&&tstping>1) do={
          :set problema ($problema+1)
          :set informacao ($informacao."Vilma => ".(10-$tstping)." pct's | ")
                }
           }
     
    :if ([ping 169.254.143.5 count 4]>0) do={
          :set online ($online+1)
          :set tstping [ping 169.254.143.5 count 10 size=1500 do-not-fragment]
          :if (tstping<9&&tstping>1) do={
          :set problema ($problema+1)
          :set informacao ($informacao."Zeh => ".(10-$tstping)." pct's | ")
                }
           }
     
     
    :if ([ping 169.254.143.6 count 4]>0) do={
          :set online ($online+1)
          :set tstping [ping 169.254.143.6 count 10 size=1500 do-not-fragment]
          :if (tstping<9&&tstping>1) do={
          :set problema ($problema+1)
          :set informacao ($informacao."Joao Banca => ".(10-$tstping)." pct's | ")
                }
           }
     
     
    :if ($informacao!="") do={:log info ("PING==>> $problema Cliente(s) de $online Conectado(s) esta(ao) com problemas no Ping [Cliente => Pacotes Perdidos]: " . $informacao)} else {:log info "PING OK!!! ==>>$online Clientes Conectados, Nenhum Apresentou Problemas. Rede 100%"}
    :if (($online/2)<$problema) do={
    :log info "EMAIL==>> Como $problema dos $online usuarios conectados neste instante, portanto, mais da metade da rede apresentou problemas, foi enviado um email de aviso."
    /tool e-mail send to="[email protected]" subject="WL_INSTAVEL: Provedor apresentou instabilidades na wireless em $data as $hora" body="$problema Cliente(s) de $online Conectado(s) esta(ao) com problemas no Ping [Cliente => Pacotes Perdidos]: $informacao. Isto indica que mais da metade da rede esta com o tempo de resposta acima do minimo recomendado para um bom funcionamento, caracterizando assim, problema geral na Wireless."
    }