+ Responder ao Tópico



  1. #1

    Padrão Dois ADSL Saindo por Duas Ethernet

    Olá pessoal to recorrendo aki ao under pq preciso de ajuda de pessoas competents como as q já vi aki, e o seguint, tenho dois links ADSL d 1 maga cada e preciso fazer balanceamento sendo: link 1 na ether 1, link 2 na ether 2, e saindo balanceados nas ether 3 e 4. Se for possível peco e agradeço a ajuda de vcs. Abraço.

  2. #2



  3. #3
    Analista de Suporte em TI Avatar de paullsoftware
    Ingresso
    Apr 2011
    Localização
    Cabo de Santo Agostinho / Pernambuco
    Posts
    530

    Padrão Re: Dois ADSL Saindo por Duas Ethernet

    Seguindo a dica do amigo, leia o tópico e faça uma bridge entre as duas portas que consegue sair tranquilo com o link pelas duas portas, agora se quiser fazer conexões independentes vai ter que entrar na fila e estudar bastante pq eu mesmo quis isso ao um tempo e acabei mudando para o balanceamento PCC.

    Abraços e boa Sorte!

  4. #4

    Padrão Re: Dois ADSL Saindo por Duas Ethernet

    Obrigado amigos vou meter a cara aki. Nos estudos, e ver se consigo. Depois. Volto e dou informações a vcs desd já agradeço!



  5. #5

    Padrão Re: Dois ADSL Saindo por Duas Ethernet

    Olá, maninho03 ai está o que você precisa é só fazer igual está ai e pronto seu loadbalance PCC vai ficar funcionando dai depois é só você criar uma BRIDGE com a ether3 e ether4 e adiciona-las na sua BRIDGE e pronto. LoadBalance 2ADSL PPPoE 100%.txt - 4shared.com - document sharing - download

  6. #6

    Padrão Re: Dois ADSL Saindo por Duas Ethernet

    obrigado vou fazer tudo direitinho e ver como vai fikar satifação! obrigado amigo!



  7. #7

    Padrão Re: Dois ADSL Saindo por Duas Ethernet

    o freitascs esse balance ppc sao pra modens em bridge! correto?

  8. #8
    Analista de Suporte em TI Avatar de paullsoftware
    Ingresso
    Apr 2011
    Localização
    Cabo de Santo Agostinho / Pernambuco
    Posts
    530

    Padrão Re: Dois ADSL Saindo por Duas Ethernet

    Citação Postado originalmente por maninho03 Ver Post
    o freitascs esse balance ppc sao pra modens em bridge! correto?
    tanto faz parceiro, pode ser em bridge ou roteados ou até mesmo links dedicados, o que vai mudar é apenas a maneiras de informar as rotas, dedicados normalmente se informa os gateways enquanto bridges informa as interfaces... espero ter ajudado, abraços



  9. #9

    Padrão Re: Dois ADSL Saindo por Duas Ethernet

    Sim maninho03 essa configuração que te passei de loadbalance é pra modens em bridge valeu.

  10. #10

    Padrão Re: Dois ADSL Saindo por Duas Ethernet

    Ola pessoal.

    Hoje tive que botar a mão na masa aqui para fazer funcionar dois link´s para duas redes.

    Tenho uma RB 1100Ah e dois link´s de internet da Net Virtua de 20 Mb cada um, e tinha que utilizar estes dois link´s para fornecer internet aos clientes do hotel e também para as salas de eventos, então achei melhor colocar um link para hospedes e outro para eventos.
    Como tenho só uma RB para tudo resolvi separar os dois link´s e as duas redes, minha extrutura:

    Coloquei um roteador na saída de cada modem da Net virtua.

    Link 1 = ether11 = 192.168.1.2/24 gatway = 192.168.1.1
    Link 2 = ether12 = 192.168.2.2/24 gatway = 192.168.2.1

    criei duas bridges sendo
    Lan1 = ether1, 2, 3, 4 e 5
    Lan2 = ether6, 7, 8, 9 e 10

    Configurei dois hotspots, tudo padrão
    Hotspot_lan1 = 11.1.0.1/16
    Hotspot_lan2 = 12.1.0.1/16

    até aqui tudo moleza, depois adicionei as seguintes linhas em /ip firewall mangle

    add action=mark-routing chain=prerouting comment="Link-1" disabled=no \
    new-routing-mark=link-1 passthrough=yes src-address=11.1.0.0/16
    add action=mark-routing chain=prerouting comment="Link-2" disabled=no \
    new-routing-mark=link-2 passthrough=yes src-address=12.2.0.0/16

    Depois fui em /ip route

    add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.1.1 \
    routing-mark=link-1 scope=30 target-scope=10
    add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.2.1 \
    routing-mark=link-2 scope=30 target-scope=10

    fiz o teste nos dois hotspot´s autenticando e utilizando o comando tracert -d 8.8.8.8 e ambos estavam saindo pelos link´s corretos, efetuei vários testes de acesso a internet e monitorei os dois link´s de saída tudo funcionou perfeitamente.

    mas como nem tudo é rosas nesta vida me deparei com um problema, eu tive que utilizar dois roteadores nas saídas dos modems da net para poder funcionar pois os link´s da net ao serem desligados e ligados novamente acabam mudando o IP e também o gatway, e ai para funcionar, a unica forma é ir e colocar eles manualmente de novo nas rotas.
    Tentei em vez de usar o IP da rota utilizar a porta tipo ether11 ou ether12 mas ai não navega.
    Alguém tem alguma solução para que eu possa utilizar estes modems conectados diretamente na interface?

    se puderem me ajudar agradeço.



  11. #11
    Analista de Suporte em TI Avatar de paullsoftware
    Ingresso
    Apr 2011
    Localização
    Cabo de Santo Agostinho / Pernambuco
    Posts
    530

    Padrão Re: Dois ADSL Saindo por Duas Ethernet

    Citação Postado originalmente por hotel Ver Post
    Ola pessoal.

    Hoje tive que botar a mão na masa aqui para fazer funcionar dois link´s para duas redes.

    Tenho uma RB 1100Ah e dois link´s de internet da Net Virtua de 20 Mb cada um, e tinha que utilizar estes dois link´s para fornecer internet aos clientes do hotel e também para as salas de eventos, então achei melhor colocar um link para hospedes e outro para eventos.
    Como tenho só uma RB para tudo resolvi separar os dois link´s e as duas redes, minha extrutura:

    Coloquei um roteador na saída de cada modem da Net virtua.

    Link 1 = ether11 = 192.168.1.2/24 gatway = 192.168.1.1
    Link 2 = ether12 = 192.168.2.2/24 gatway = 192.168.2.1

    criei duas bridges sendo
    Lan1 = ether1, 2, 3, 4 e 5
    Lan2 = ether6, 7, 8, 9 e 10

    Configurei dois hotspots, tudo padrão
    Hotspot_lan1 = 11.1.0.1/16
    Hotspot_lan2 = 12.1.0.1/16

    até aqui tudo moleza, depois adicionei as seguintes linhas em /ip firewall mangle

    add action=mark-routing chain=prerouting comment="Link-1" disabled=no \
    new-routing-mark=link-1 passthrough=yes src-address=11.1.0.0/16
    add action=mark-routing chain=prerouting comment="Link-2" disabled=no \
    new-routing-mark=link-2 passthrough=yes src-address=12.2.0.0/16

    Depois fui em /ip route

    add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.1.1 \
    routing-mark=link-1 scope=30 target-scope=10
    add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.2.1 \
    routing-mark=link-2 scope=30 target-scope=10

    fiz o teste nos dois hotspot´s autenticando e utilizando o comando tracert -d 8.8.8.8 e ambos estavam saindo pelos link´s corretos, efetuei vários testes de acesso a internet e monitorei os dois link´s de saída tudo funcionou perfeitamente.

    mas como nem tudo é rosas nesta vida me deparei com um problema, eu tive que utilizar dois roteadores nas saídas dos modems da net para poder funcionar pois os link´s da net ao serem desligados e ligados novamente acabam mudando o IP e também o gatway, e ai para funcionar, a unica forma é ir e colocar eles manualmente de novo nas rotas.
    Tentei em vez de usar o IP da rota utilizar a porta tipo ether11 ou ether12 mas ai não navega.
    Alguém tem alguma solução para que eu possa utilizar estes modems conectados diretamente na interface?

    se puderem me ajudar agradeço.
    Parabéns parceiro é isso mesmo, estava em teste aqui pra postar os resultados pra galera, diferença que no meu caso seria com os modens em bridges, e funcionou tranquilo na empresa.
    Quando aos links da net não sei te informar, mas se os gtw mudam tem que ter um router recebendo antes da rb mesmo... valeu

  12. #12

    Padrão Re: Dois ADSL Saindo por Duas Ethernet

    Paulo no seu caso modem em bridge, você faz a autenticação pelo MK para a sua internet? Outra pergunta se seu link cair não muda os endereços de IP?



  13. #13
    Analista de Suporte em TI Avatar de paullsoftware
    Ingresso
    Apr 2011
    Localização
    Cabo de Santo Agostinho / Pernambuco
    Posts
    530

    Padrão Re: Dois ADSL Saindo por Duas Ethernet

    Citação Postado originalmente por hotel Ver Post
    Paulo no seu caso modem em bridge, você faz a autenticação pelo MK para a sua internet?
    Sim faço a autenticação pelo MK, na empresa onde trabalho fiz os PPPoEs pelo proprio MK.
    Citação Postado originalmente por hotel Ver Post
    Outra pergunta se seu link cair não muda os endereços de IP?
    Muda sim, mas lá no IP>>Routes uso as Interfaces PPPoe e não os Gateways, por isso funcionam, usei a mesma logica que vc usou e uso nos ballances...
    Quando tiver acesso as configurações do MK da empresa, dou export ou print e posto aqui, abraços

  14. #14

    Padrão Re: Dois ADSL Saindo por Duas Ethernet

    o hotel,,,vc poderia explicar um pouco mais detalhado como vc fez? vc me ajudaria muito aki amigo!



  15. #15

    Padrão Re: Dois ADSL Saindo por Duas Ethernet

    Na verdade o que eu fiz não tem muito segredo é bem simples, me informe como é sua extrutura que eu talves possa te ajudar melhor, mas de qualquer forma la vai um resumão.

    1. Passo - Conecte os link´s de entrada de internet normalmente ( no meu caso a internet chega aos modens da net e eu coloquei um roteador na saida de cada modem)

    2. Passo - Teste com ping para ver se esta conseguindo sair para a internet pelos dois link´s, recomendo conectar um testar e depois desconectar e conectar o segundo e repetir o teste.

    3. Passo - Criei dois hotspot´s em portas ether diferentes ( mas poderia simplesmente compartilhar somente com Nat)

    4. Passo - fui no mangle e criei as duas regras
    add action=mark-routing chain=prerouting comment="Link-1" disabled=no \
    new-routing-mark=link-1 passthrough=yes src-address=11.1.0.0/16
    add action=mark-routing chain=prerouting comment="Link-2" disabled=no \
    new-routing-mark=link-2 passthrough=yes src-address=12.2.0.0/16
    Onde new-routing-mark= e o nome que voce quer dar a para o link1 no meu caso "link-1" e src-address= o ip do meu hotspot que no caso foi "11.1.0.0/16"

    5. Passo - fui em routes e criei duas rotas 0.0.0.0 informando alem do gatway também o routing-mark

    pronto uma das rotas 0.0.0.0 vai ficar azul, mas não se preocupe é assim mesmo, depois disso é só testar cada um dos link´s.

    mas posta ai como é sua extrutura quem sabe podemos lhe ajudar mais neste sentido, só lembrando que no meu caso os link´s de entrada são todos oriundos de um roteador, com relação a modens em bridge com ppoe eu ainda não consegui fazer funcionar, nosso colega Paulo assim que conseguir ira colocar estas regras aqui no fórum.





  16. #16

    Padrão Re: Dois ADSL Saindo por Duas Ethernet

    hotel aki é bem simples mas como sou iniciante em mk me perco todo. bom tenho dois modens em bridge. e dois links adsl d 1 mb cada justamente por os links serem pequenos é q quero fazer duas redes diferentes só q com uma diferença quando um link cair uma rede assumisse tambem do link q ainda estiver ativo, como um modo de emergencia fikando as duas redes num so link ate q a outra volte e quando voltar as duas redes fikarem uma em cada link novamente! espero q vc ou alguem tambem de bom coração possa me ajudar!
    no momento to so balancendo normalmente para uma red só!
    no momento tao assim:
    ether1=modem1
    ether2=modem2
    ether3=local

    como no tutorial do geronimo


    *************************************************
    queria q ficasse assim:
    ether1=modem1
    ether2=modem2
    ether3=rede1
    ether4=rede2

    com prioridade
    modem1 para rede1 e modem2 para rede2
    ambas redes balancedas caso um ou outro link caia!


    se puderem me ajudar fikarei muito agradecido amigos!