+ Responder ao Tópico



  1. Boa tarde!

    Tenho na empresa uma rede interna disposta da seguinte maneira:

    O link de internet (ip fixo) é conectado a um roteador wireless, e este é conectado na placa eth0 de um firewall com squid e iptables, que se encontra ativado.
    A porta eth1 do firewall está conectada a um switche, onde estão conectados todos os outros computadores da rede. O endereço do roteador, na rede interna, é 10.0.0.1, o da placa eth0 do firewall é 10.0.0.2, o da placa eth1 é 192.1687.0.118. Os computadores da rede seguem o padrao 192.168.0.x. Estou precisando criar uma vpn, com o openvpn, entre o meu note e um servidor, que se conecta à internet através do firewall. Fiz as configurações do openvpn, porém não consigo me conectar na rede interna.
    Os arquivos ficaram da seguinte maneira:

    CLIENTE (NOTE):

    dev tun
    port 6559
    proto udp
    remote IP_EXTERNO_DA_REDE
    ifconfig 192.168.255.2 192.168.255.1
    ca ca.crt
    cert ti-access.crt
    key ti-access.key
    tls-client
    keepalive 10 120
    comp-lzo
    user TI
    group NOMEDOGRUPO_NO_SERVER
    persist-key
    persist-tun
    verb 3

    SERVIDOR:

    dev tun
    port 6559
    proto udp
    ca keys/ca.crt
    cert keys/matriz.crt
    key keys/matriz.key
    dh keys/dh1024.pem
    server 192.168.255.0 255.255.255.0
    pusg "route 192.168.0.0 255.255.255.0"
    keepalive 10 120
    max-clients 1
    comp-lzo
    user TI
    group NOME_DO_GRUPO_NO_SERVER
    persist-key
    persist-tun
    verb 3

    Fiz as configurações no server, ativei a VPN, fiz as configurações no WINDOWS, mas o openvpn não conecta.
    Fiz o redirecionamento da porta 6559 no firewall, direcionando para o IP 192.168.0.211, que é o IP do SERVIDOR na rede interna. Liberei também o acesso através desta porta, mas nada funcionou. Redirecionei a porta 6559 do roteador para a placa eth0 (10.0.0.2).

    Eu teria que redirecionar mais alguma porta? Existe alguma configuraçõa que fiz errado no servidor? Teria que fazer alguma rotna nofirewall? Se tiver, para qual IP do servidor devo redirecionar (para o do TUN ou para o da ETH0)?

    Obrigado !!!
    Última edição por thiaggo; 11-01-2012 às 09:02.

  2. Não sei se tenho que adicionar rota ou alguma coisa assim. Se caso tiver que adicionar uma rota no firewall, para qual IP devo redirecioar? Para o do TUN ou para o da ETH0 do servidor da VPN?
    Eu consigo me conectar a VPN, mas não consigo mandar o ping nem do WINDOWS para o SERVIDOR LINUX e vice-versa.

    Alguém sabe como resolver isso?

    Desde já, agradeço pela ajuda.






Tópicos Similares

  1. Problemas com VPN
    Por b1N4r1_w0rm no fórum Servidores de Rede
    Respostas: 2
    Último Post: 09-08-2004, 09:50
  2. Problemas com VPN
    Por Kandango no fórum Servidores de Rede
    Respostas: 0
    Último Post: 16-07-2004, 11:47
  3. Problemas no acesso ftp Windows via Linux
    Por doidoht no fórum Servidores de Rede
    Respostas: 1
    Último Post: 11-02-2004, 10:33
  4. Problemas no acesso ftp Windows via Linux
    Por RicardoVS no fórum Servidores de Rede
    Respostas: 1
    Último Post: 10-02-2004, 19:12
  5. problema com Conexões abertas via telnet (Linux/SCO/AIX)
    Por ceinma no fórum Servidores de Rede
    Respostas: 2
    Último Post: 07-01-2004, 10:54

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L