+ Responder ao Tópico



  1. #1

    Padrão duvidas comando de reiniciar o mikrotik uma vez por dia

    esse é o comando para reiniciar o mikrotik uma vez por dia mesmo???

    /system scheduler
    add comment="" disabled=no interval=1d name=exec_reboot on-event=\
    "/system script run reboot" policy=\
    reboot,read,write,policy,test, password,sniff,sensitive start-date=\
    jan/29/2012 start-time=01:00:00

    /system script
    add name=reboot policy=\
    ftp,reboot,read,write,policy,t est,winbox,password,sniff,sens itive source=\
    "/system reboot"

  2. #2

    Padrão Re: duvidas comando de reiniciar o mikrotik uma vez por dia

    sim amigo, este script reinicia uma vez ao dia



  3. #3

    Padrão Re: duvidas comando de reiniciar o mikrotik uma vez por dia

    BOm dia

    sim amigo todo dia a 01:00:00 uma vez por dia..

  4. #4

    Padrão Re: duvidas comando de reiniciar o mikrotik uma vez por dia

    Bom dia tem como mudar para reiniciar a cada 2 dias amigo ?



  5. #5

    Padrão Re: duvidas comando de reiniciar o mikrotik uma vez por dia

    vou testar.....vlw

  6. #6

    Padrão Re: duvidas comando de reiniciar o mikrotik uma vez por dia

    Você não precisa criar um script para "reboot" e executar esse script no scheduler. Você pode fazer o próprio scheduler executar o comando de reboot:

    Código :
    /system scheduler add comment="" disabled=no interval=1d name=exec_reboot on-event="/system reboot" policy=reboot,read,write,policy,test, password,sniff,sensitive start-date=jan/29/2012 start-time=01:00:00

    Onde esta escrito "interval=1d" é o tempo de intervalo entre cada execução, e para 1 dia de intervalo esse método simples vai funcionar porque o script só precisa ser executado uma vez mesmo, e depois de executar, o horário da primeira execução ja vai ter passado e então ele só reiniciará no dia seguinte. Se você colocar em interval 2 dias, 1 semana ou 50 anos, a routerboard vai continuar reiniciando todo dia, pois o intervalo entre execução é de 50 anos, mas a data do inicio da execução ja passou (ta em 2012 ali) e o horário é a 1:00:00. O intervalo é o tempo que ele vai esperar para executar o script pela SEGUNDA vez em diante, e como o comando é de reboot, a próxima execução do scheduler vai ser a PRIMEIRA vez, que acontece logo que alcança o start-time.

    Para poder reiniciar em intervalos maiores, na execução do scheduler, você precisa primeira alterar a data de inicio dele, para depois disso executar o comando de reboot.

    Se não me engano, as datas no RouterOS são expressas em strings e não da pra fazer calculo com elas, e não lembro de nenhum comando que faça calculo com datas. Ficaria um pouco mais complicadinho um script para reiniciar a intervalos maiores que um dia.