+ Responder ao Tópico



  1. #1

    Thumbs up 2 Links - 1 Navegação e outro para download como fazer isso no mikrotik

    Seguinte cenario :

    1 - Link adsl
    1 - Link Dedicado

    Link dedicado - Portas 80 - 53 443
    Link adsl o resto . . .

    Detalhe queria que o download de aquivos saia pela ADSL ou alguma regra que determine que donwload acima de 5 megas saia pela adsl . . .

    Desde ja agradeço a quem possa ajudar nesta solução

  2. #2

    Padrão Re: 2 Links - 1 Navegação e outro para download como fazer isso no mikrotik

    Citação Postado originalmente por rodrigo2005 Ver Post
    Seguinte cenario :

    1 - Link adsl
    1 - Link Dedicado

    Link dedicado - Portas 80 - 53 443
    Link adsl o resto . . .

    Detalhe queria que o download de aquivos saia pela ADSL ou alguma regra que determine que donwload acima de 5 megas saia pela adsl . . .

    Desde ja agradeço a quem possa ajudar nesta solução
    Amigo, no mikrotik não sei te dizer se tem como fazer, provavelmente tenha...Mas se quiser qualidade tenho uma indicação pra te fazer com FreeBSD proxy+cache+balance que fica PERFECT!
    Se quiser o contato me envie PVT que te passo os telefones!
    Abraço



  3. #3

    Padrão Re: 2 Links - 1 Navegação e outro para download como fazer isso no mikrotik

    Citação Postado originalmente por PauloMassa Ver Post
    Amigo, no mikrotik não sei te dizer se tem como fazer, provavelmente tenha...Mas se quiser qualidade tenho uma indicação pra te fazer com FreeBSD proxy+cache+balance que fica PERFECT!
    Se quiser o contato me envie PVT que te passo os telefones!
    Abraço
    cara me interessei tambem !!!

  4. #4

    Padrão Re: 2 Links - 1 Navegação e outro para download como fazer isso no mikrotik

    bom rodrigo já que ninguem te judou taí minha contribuiçao...

    /ip firewall address-list
    add address=208.65.153.0/24 comment=YOUTUBE disabled=no list=youtube
    add address=64.15.0.0/16 comment="" disabled=no list=youtube
    add address=209.85.239.0/24 comment="" disabled=no list=youtube
    add address=74.125.0.0/16 comment="" disabled=no list=youtube
    add address=200.149.119.0/24 comment="" disabled=no list=youtube
    add address=208.117.254.0/24 comment="" disabled=no list=youtube

    /ip firewall mangle
    add action=mark-connection chain=prerouting comment=\
    ";;;;;;; QOS YOUTUBE ;;;;;;;" disabled=no dst-address-list=youtube \
    new-connection-mark=youtube-conexao passthrough=yes
    add action=mark-packet chain=prerouting comment="" connection-mark=\
    youtube-conexao disabled=no dst-address-list=youtube new-packet-mark=\
    YouTube-Pacotes passthrough=yes
    add action=mark-routing chain=prerouting comment="" connection-mark=\
    youtube-conexao disabled=no new-routing-mark=rota_youtube packet-mark=\
    YouTube-Pacotes passthrough=no

    Aqui vc define por onde cada serviço ira sair
    /ip route
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    pppoe-out1 routing-mark=rota_youtube scope=30 target-scope=10
    Onde estar em vermelho vc troca pelo nome do discador caso seu modem esteja em bridge, se estiver roteado é so colocar o gatway,

    e na regra a baixo vc pode colocar um limite maximo para o consumo do yputube caso queira ou se não quiser nem precisa adicionar esta regra, ex. se seu link for de 6M vc pode limitar uma banda para o youtube de 2M no maximo vamos dizer, e mesmo que ninguem esteja utilizando a internet o maximo que o youtube ira utilizar é 2M, logico caso ninguem esteja no youtube a banda sera liberada para outros serviços.
    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=2M name=Youtube packet-mark=YouTube-Pacotes parent=global-total \
    priority=8 queue=default
    para outros serviços da internet tipo orkut é so criar uma lista de endereços, e duplicar as regras com os devidos nomes indentificando cada e em rotas definir por qual ip deve sair,
    para pegar o ip de um site é so digitar no terminal ping [Você precisa estar registrado e conectado para ver este link.] e correr para o abraço.



  5. #5

    Padrão Re: 2 Links - 1 Navegação e outro para download como fazer isso no mikrotik

    Alguém ai testou e funcionou??

  6. #6

    Padrão Re: 2 Links - 1 Navegação e outro para download como fazer isso no mikrotik

    Citação Postado originalmente por wondernetwork Ver Post
    bom rodrigo já que ninguem te judou taí minha contribuiçao...

    /ip firewall address-list
    add address=208.65.153.0/24 comment=YOUTUBE disabled=no list=youtube
    add address=64.15.0.0/16 comment="" disabled=no list=youtube
    add address=209.85.239.0/24 comment="" disabled=no list=youtube
    add address=74.125.0.0/16 comment="" disabled=no list=youtube
    add address=200.149.119.0/24 comment="" disabled=no list=youtube
    add address=208.117.254.0/24 comment="" disabled=no list=youtube

    /ip firewall mangle
    add action=mark-connection chain=prerouting comment=\
    ";;;;;;; QOS YOUTUBE ;;;;;;;" disabled=no dst-address-list=youtube \
    new-connection-mark=youtube-conexao passthrough=yes
    add action=mark-packet chain=prerouting comment="" connection-mark=\
    youtube-conexao disabled=no dst-address-list=youtube new-packet-mark=\
    YouTube-Pacotes passthrough=yes
    add action=mark-routing chain=prerouting comment="" connection-mark=\
    youtube-conexao disabled=no new-routing-mark=rota_youtube packet-mark=\
    YouTube-Pacotes passthrough=no

    Aqui vc define por onde cada serviço ira sair
    /ip route
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    pppoe-out1 routing-mark=rota_youtube scope=30 target-scope=10
    Onde estar em vermelho vc troca pelo nome do discador caso seu modem esteja em bridge, se estiver roteado é so colocar o gatway,

    e na regra a baixo vc pode colocar um limite maximo para o consumo do yputube caso queira ou se não quiser nem precisa adicionar esta regra, ex. se seu link for de 6M vc pode limitar uma banda para o youtube de 2M no maximo vamos dizer, e mesmo que ninguem esteja utilizando a internet o maximo que o youtube ira utilizar é 2M, logico caso ninguem esteja no youtube a banda sera liberada para outros serviços.
    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=2M name=Youtube packet-mark=YouTube-Pacotes parent=global-total \
    priority=8 queue=default
    para outros serviços da internet tipo orkut é so criar uma lista de endereços, e duplicar as regras com os devidos nomes indentificando cada e em rotas definir por qual ip deve sair,
    para pegar o ip de um site é so digitar no terminal ping [Você precisa estar registrado e conectado para ver este link.] e correr para o abraço.
    Atualizando.
    Consegui fazer funcionar aqui, tinha errado uma das regras.
    Realizando os testes.

    Valeu cara.


    Meu cenario aqui:
    Link Dedicado 50MB
    Link ADSL 50MB

    Preciso fazer exatamente esta regra, colocar apenas alguns serviços (sites) para sair pela ADSL.
    Se alguem souber eu agradeço.

    Vou tentar novamente por garantia.
    Última edição por frantiesco; 28-08-2012 às 14:52.



  7. #7

    Padrão Re: 2 Links - 1 Navegação e outro para download como fazer isso no mikrotik

    Citação Postado originalmente por frantiesco Ver Post
    Atualizando.
    Consegui fazer funcionar aqui, tinha errado uma das regras.
    Realizando os testes.

    Valeu cara.
    Funcionando tranquilo aqui.
    Mas pelos testes existe um pequeno detalhe.
    Quando o link da adsl para, os sites que estão no address-list configurados pare esse link, param de funcionar.

    Como faço para que caso isso ocorra os sites voltem a sair pelo link dedicado?

    Valeu.

  8. #8

    Padrão Re: 2 Links - 1 Navegação e outro para download como fazer isso no mikrotik

    Citação Postado originalmente por frantiesco Ver Post
    Funcionando tranquilo aqui.
    Mas pelos testes existe um pequeno detalhe.
    Quando o link da adsl para, os sites que estão no address-list configurados pare esse link, param de funcionar.

    Como faço para que caso isso ocorra os sites voltem a sair pelo link dedicado?

    Valeu.
    Me enganei, infelizmente só resolve o problema se a interface do adsl for desativada.
    Ainda sem solução


    Resolvido mais esse problema.
    Basta adicionar uma outra regra de rota, apontado para o link Dedicado, mas com distancia 2.

    /ip route
    add comment="" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=\
    pppoe-out1 routing-mark=rota_youtube scope=30 target-scope=10

    No lugar do "pppoe-out1" colocar o gateway do link dedicado.
    Com isso não existe o risco de parar o acesso aos sites que estão no address-list.