Página 1 de 3 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. Olá pessoal! Antes de qualquer coisa só quero deixar claro que já revirei muito os tópicos e não encontrei o que preciso!

    E o que preciso é fácil de descrever e acredito que pra quem saiba, é fácil de resolver também.
    Preciso desabilitar um cliente específico da access-list. Como não entendo muito, não sei como trabalhar com o comando "set",
    dai tentei remover buscando o MAC especificado e depois adiciona-lo com estado "disabled".

    Qualquer maneira dita acima me seria de muita utilidade! Abraços!

  2. Citação Postado originalmente por leopaolo Ver Post
    Preciso desabilitar um cliente específico da access-list. Como não entendo muito, não sei como trabalhar com o comando "set", dai tentei remover buscando o MAC especificado e depois adiciona-lo com estado "disabled".
    Bom dia.

    Removendo um usuário, com base no endereço físico:

    Código :
    /interface wireless access-list remove [find where mac-address="55:55:55:66:66:66"]
    A tradução literal, em linguagem natural (humana), da regra acima, é:
    Nas listas de acesso de rede sem fio, remover a entrada com identificação que coincida com o endereço físico 55:55:55:66:66:66.
    Se você quiser desabilitar uma entrada específica, com base no endereço físico, você pode usar:
    Código :
    /interface wireless access-list set [find where mac-address="55:55:55:66:66:66"] disabled=yes
    A tradução literal, em linguagem natural (humana), da regra acima, é:
    Nas listas de acesso de rede sem fio, (re)definir a entrada com endereço físico que coincida com 55:55:55:66:66:66, para o estado desabilitado.
    Você também pode usar como indexador da sua busca, o campo comentário.
    Código :
    /interface wireless access-list set [find where comment="contrato-1345"] mac-address="777777888888"
    A tradução literal, em linguagem natural (humana), da regra acima, é:
    Nas listas de acesso de rede sem fio, (re)definir a entrada com comentário que coincida com o texto "contrato-1345", alterando o endereço físico para "77:77:77:88:88:88".
    Mostrado como funcionam os comandos set, find e where, você só precisa fazer as chamadas de API, com base nesses comandos.

    Enfim, espero ter ajudado.

    Saudações,

    Trober
    -
    -
    -
    -
    -
    Última edição por trober; 27-02-2012 às 09:58. Razão: Correção ortográfica e ajuste de formatação



  3. Obrigado por responder!

    Mas infelizmente não consegui. Tanto o set quanto o remove retornam "=message=no such command". E o add funciona normalmente. Só dá falha nesse comando. O que pode ser?! No php a linha ficou dessa forma:

    Código :
    $API->write("/interface/wireless/access-list/set [find where mac-address=$mac] disabled=yes");

    e

    Código :
    $API->write("/interface/wireless/access-list/remove [find where mac-address=$mac]");
    Última edição por leopaolo; 27-02-2012 às 11:03. Razão: Correção

  4. Citação Postado originalmente por leopaolo Ver Post
    ...Mas infelizmente não consegui. Tanto o set quanto o remove retornam "=message=no such command". E o add funciona normalmente. Só dá falha nesse comando. O que pode ser?...
    Qual a versão do seu RouterOS? Fiz testes com 5.12 e 5.14. Os exemplos que passei talvez não funcionem em versões anteriores.

    Outra coisa. Veja se sua variável $mac está sendo processada, uma vez que, ao que parece, está sendo tratada como parte do string inteiro, e nao como variável, portanto, sem retornando um valor.

    Saudações,

    Trober
    -
    -
    -
    -
    -



  5. Então, esqueci desse problema das versões. Vou atualizar e testar. Quanto a variavel, eu já conferi e está certo. Inclusive testei com o mac inserido diretamente na linha.
    Obrigado!






Tópicos Similares

  1. Mikrotik API + PHP + Mysql
    Por muriloc4 no fórum Linguagens de Programação
    Respostas: 11
    Último Post: 19-08-2015, 21:12
  2. Respostas: 2
    Último Post: 09-11-2011, 12:21
  3. Respostas: 3
    Último Post: 18-08-2009, 09:27
  4. Respostas: 5
    Último Post: 12-09-2008, 12:47
  5. como fazer um cliente pre pago no mikrotik ???
    Por ROLLER1NLINE no fórum Redes
    Respostas: 4
    Último Post: 26-04-2007, 19:27

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L