Página 1 de 3 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. Bom dia, estou com um script aqui, quase pronto e não consigo faze-lo funcionar, basicamente, ele monitora uma interface da qual eu tenho um modem conectado nela.
    quando falta energia, o status desta interface muda e então o script envia um email para mim, até ai tudo certo.

    Porem não estou conseguindo ajustar este script, alguém mode ver o que esta de errado com o script?

    segue:

    /interface ethernet monitor HUB do {
    :if ($status != "link-ok") do {
    /tool e-mail send to="monitorrb5@bol.com.br" subject="faltou_enegia $data as $hora" body="faltou_enegia $hora de $data."
    :log info "EMAIL ENVIADO COM SUSSESSO!"

    Lembrando que ja tenho outros scripts que enviam email, de backup automáticos, tudo funcionando certo.

    Se alguém me ajudar fico muito grato.

  2. vamos la pessoal. me ajudem por favor.



  3. Consegui fazer funcionar lembrando que este script é para MK 3.x
    testado e aprovado.

    segue script completo, qualquer duvida é só perguntar.




    Em System > NTP Cliente:


    Mode: unicast
    Primary NTP Server: 200.160.0.8
    Secondary NTP Server: 200.160.0.8
    Marque o: enable


    Depois em System > Clock:


    Time Zone Name: Coloque America/são paulo para fazer o devido ajuste sobre a hora obtida no NTP, que no caso é mundial.




    Configure o email em: tool > email:


    Server: smtp.bol.com.br
    Port: 25
    From: bol@bol.com.br
    User: bol@bol.com.br
    Password: minha senha do email






    MONITORAMENTO DE ENERGIA.


    EM UMA ETHERNET VC COLOCA UMA MODEM OU UM HUB, QUALQUER COISA, PARA QUE FIQUE
    CONECTADO COM UMA INTERFACE DO MIKROTIK.


    ESTE TEM QEU ESTAR LIGADO DIRETO NA ENERGIA, POIS QUANDO FALTAR ENERGIA,
    O MK VAI EXECUTAR O SCRIPT E VAI VER QEU A INTERFACE DO MODEM ESTA DESCONECTADO, E ENVIARA O EMAIL AUTOMATICAMENTE.








    SEGUE O SCRIPT.




    /interface ethernet monitor NOME_DA_ETHERNET once do {
    :if ($status != "link-ok") do {
    :delay 2s
    :global data [/system clock get date]
    :global hora [/system clock get time]
    /tool e-mail send to="bol@iclaro.com.br" subject="sem_energia" body="sem_energia AS: $hora de $data."
    /tool e-mail send to="bol@bol.com.br" subject="sem_energia AS: $hora de $data." body="sem_energia AS: $hora de $data."
    :log info "EMAIL ENVIADO COM SUSSESSO!"
    }
    }









    CRIE UM EMAIL NA CLARO, POIS A CLARO TEM A OPÇÃO DE ENVIAR UM AVISO SMS PARA O CELULAR QUE CHEGOU UM EMAIL.
    DESTA FORMA VC PODE MONITORAR TODA SUA REDE.






    AVISO por assunto da claro.


    site da claro: https://www.iclaro.com.br/


    EM ASSUNTO VAI NOTIFICAR:


    sem_energia

  4. Boa amigo.. Estrelinha pra vc..
    Alguem conhece alguma forma transformar 24v pra 12v...
    Desde ja agradeço...



  5. Use um circuito integrado 7812,
    é um regulador de voltagem para 12v 1A.






Tópicos Similares

  1. Respostas: 9
    Último Post: 02-02-2013, 14:25
  2. RB450G - Travada após Upgrade (falta de energia)
    Por francistomba no fórum Redes
    Respostas: 7
    Último Post: 15-11-2011, 17:54
  3. monitor desliga (economia de energia (Energystar))
    Por cesargodoy no fórum Servidores de Rede
    Respostas: 7
    Último Post: 25-05-2005, 16:37
  4. Gerenciador de energia do monitor?
    Por Hacinn no fórum Servidores de Rede
    Respostas: 1
    Último Post: 15-09-2004, 07:51
  5. script para criação de contas
    Por no fórum Linguagens de Programação
    Respostas: 1
    Último Post: 08-02-2003, 16:08

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L