Página 1 de 3 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Question Ajuda com P2P / Mikrotik

    Olá, estou com pesquisando a vários dias, já tentei utilizar o manual feito pelo catvbrasil, já visitei varios topicos (https://under-linux.org/f143/control...-jeito-130846/) ( https://under-linux.org/f226/limitar...60/index2.html ) (entre outros) e em nenhuma das alternativas dadas eu conseguir limitar o p2p no mikrotik, simplesmente não funciona. Meu mikrotik esta em bridge, ativei o firewall em "bridge/ settings". A minha ideia era limitar o numero de conexões p2p por cliente, minha rede é mais ou menos assim:

    Cliente ---- RB433ah (routeros 5.11) em bridge ------- linux slackware (autenticação dos clientes (hotspot) / limitação da banda / etc...)


    Caso alguem possa me ajudar, indicar uma leitura ou algo do tipo, por favor!



    Obrigado.

  2. #2

    Padrão Re: Ajuda com P2P / Mikrotik

    Ja utilizei essa regra em testes e funcionou bem amigo ...ela reduz para 100k a velocidade se quiser alterar a velocidade mude o 100k para outro valor ..e so copiar e colar no new terminal..

    /ip firewall mangle
    add action=mark-connection chain=prerouting comment=P2P_IN disabled=no \
    new-connection-mark=conn_p2p_in p2p=all-p2p passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting connection-mark=conn_p2p_in disabled=no \
    new-packet-mark=p2p_in passthrough=no
    add action=mark-connection chain=postrouting comment=P2P_OUT disabled=no \
    new-connection-mark=conn_p2p_out p2p=all-p2p passthrough=yes protocol=tcp
    add action=mark-packet chain=postrouting connection-mark=conn_p2p_out disabled=\
    no new-packet-mark=p2p_out passthrough=yes

    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=100k name=p2p_in packet-mark=p2p_in parent=global-in priority=8 \
    queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=100k name=p2p_out packet-mark=p2p_out parent=global-out priority=\
    8 queue=default



  3. #3
    Analista de Suporte em TI Avatar de paullsoftware
    Ingresso
    Apr 2011
    Localização
    Cabo de Santo Agostinho / Pernambuco
    Posts
    530

    Padrão Re: Ajuda com P2P / Mikrotik

    Citação Postado originalmente por jailtonnetlink Ver Post
    Ja utilizei essa regra em testes e funcionou bem amigo ...ela reduz para 100k a velocidade se quiser alterar a velocidade mude o 100k para outro valor ..e so copiar e colar no new terminal..

    /ip firewall mangle
    add action=mark-connection chain=prerouting comment=P2P_IN disabled=no \
    new-connection-mark=conn_p2p_in p2p=all-p2p passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting connection-mark=conn_p2p_in disabled=no \
    new-packet-mark=p2p_in passthrough=no
    add action=mark-connection chain=postrouting comment=P2P_OUT disabled=no \
    new-connection-mark=conn_p2p_out p2p=all-p2p passthrough=yes protocol=tcp
    add action=mark-packet chain=postrouting connection-mark=conn_p2p_out disabled=\
    no new-packet-mark=p2p_out passthrough=yes

    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=100k name=p2p_in packet-mark=p2p_in parent=global-in priority=8 \
    queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=100k name=p2p_out packet-mark=p2p_out parent=global-out priority=\
    8 queue=default
    eu usei e funcionou comigo...

  4. #4

    Padrão Re: Ajuda com P2P / Mikrotik

    Olá, bom dia! Adicionei essas regras e o download (usando o utorrent) simplesmente vai a mais de 700kb por segundo! e nas estatisticas das regras do queue fica tudo zerado!


    Alguem tem ideia??? de principio eu pensei em apenas limitar o numero de conexoes p2p (levando em consideração que a limitação de banda é feita no servidor, iria apenas diminuir as conexões)


    Se alguem mais puder me ajudar!


    Obrigado.



  5. #5

    Padrão Re: Ajuda com P2P / Mikrotik

    Citação Postado originalmente por zoom18 Ver Post
    Olá, bom dia! Adicionei essas regras e o download (usando o utorrent) simplesmente vai a mais de 700kb por segundo! e nas estatisticas das regras do queue fica tudo zerado!


    Alguem tem ideia??? de principio eu pensei em apenas limitar o numero de conexoes p2p (levando em consideração que a limitação de banda é feita no servidor, iria apenas diminuir as conexões)


    Se alguem mais puder me ajudar!


    Obrigado.
    Ja olhou se ja nao existe outra regra para essa limitaçao ai?..em queues ela sempre fica em vermelho o controle, da uma olhada ai ...outra limitar a quantidade isso ai nao e nada profissional vc esta tirando a liberdade do seu cliente,e isso facilmente se repercute (internet e ruim nao baixa nada essas coisas)reveja a regra e tente limitar a velocidade

  6. #6
    Analista de Suporte em TI Avatar de paullsoftware
    Ingresso
    Apr 2011
    Localização
    Cabo de Santo Agostinho / Pernambuco
    Posts
    530

    Padrão Re: Ajuda com P2P / Mikrotik

    Eu adicionei aqui as regras e filtraram tranquilo as conexões da turma... estranho ai não ter funcionado...
    Clique na imagem para uma versão maior

Nome:	         p2p.jpg
Visualizações:	362
Tamanho: 	30,4 KB
ID:      	33915



  7. #7
    Analista de Suporte em TI Avatar de paullsoftware
    Ingresso
    Apr 2011
    Localização
    Cabo de Santo Agostinho / Pernambuco
    Posts
    530

    Padrão Re: Ajuda com P2P / Mikrotik

    Eu adicionei aqui as regras e filtraram tranquilo as conexões da turma... estranho ai não ter funcionado...
    Clique na imagem para uma versão maior

Nome:	         p2p.jpg
Visualizações:	362
Tamanho: 	30,4 KB
ID:      	33915
    abraços

  8. #8

    Padrão Re: Ajuda com P2P / Mikrotik

    Entendo, aqui ela não fica em vermelho como esta ai, ficam apenas verdes! eu verifiquei aqui e não, não há outras regras adicionadas!



  9. #9

    Padrão Re: Ajuda com P2P / Mikrotik

    Citação Postado originalmente por zoom18 Ver Post
    Entendo, aqui ela não fica em vermelho como esta ai, ficam apenas verdes! eu verifiquei aqui e não, não há outras regras adicionadas!
    Qual e a versao do mk que esta usando ai ...e routerboard ou pc?

  10. #10

    Padrão Re: Ajuda com P2P / Mikrotik

    É uma RB433AH, com o 5.10



  11. #11

    Padrão Re: Ajuda com P2P / Mikrotik

    estranho esse estouro da banda ai foi em algum cliente ou foi algum teste que fez ai pois ele limita torrent tbm ...
    pois se foi cliente verifica se nao tem acelerador de velocidade
    e se possivel verifica essa regra em outra rb que esta livre de firewell pois ainda deve ter alguma regra ai que esta impedindo ..testa ai para tirar essa duvida ok qualquer coisa fala ai para nos boa sorte

  12. #12
    Analista de Suporte em TI Avatar de paullsoftware
    Ingresso
    Apr 2011
    Localização
    Cabo de Santo Agostinho / Pernambuco
    Posts
    530

    Padrão Re: Ajuda com P2P / Mikrotik

    A minha foi na RB 750, Ver. 4.11



  13. #13

    Padrão Re: Ajuda com P2P / Mikrotik

    Bom, testei em outra RB433 (essa não AH) e tambem não funcionou (tambem na versão 5.10). O mais estranho é que como disseram, funciona com varias pessoas!

  14. #14

    Padrão Re: Ajuda com P2P / Mikrotik

    entao vai ter que ser na unha rsrs ...segue ai e depois nos conta como foi

    http://www.techvoice.com.br/img_adm/...2007124944.pdf



  15. #15

    Padrão Re: Ajuda com P2P / Mikrotik

    Cara, fiz as regras, porem não limita! continuo fazendo download a altas taxas (400kbps)

    Clique na imagem para uma versão maior

Nome:	         imagem.jpg
Visualizações:	140
Tamanho: 	36,7 KB
ID:      	33943

  16. #16

    Padrão Re: Ajuda com P2P / Mikrotik

    tenta esta aqui ...em firewall filter deixe elas na primeira fila das regras (no topo) ok

    / ip firewall filter add chain=forward src-address=192.168.0.0/16 protocol=tcp src-port=0 action=drop comment="CONTROLE P2P Warez E \ Semelhantes" disabled=no add chain=forward src-address=192.168.0.0/16 protocol=tcp dst-port=0 action=drop comment="" disabled=no add chain=forward src-address=192.168.0.0/16 protocol=udp src-port=0 action=drop comment="" disabled=no add chain=forward src-address=192.168.0.0/16 protocol=udp dst-port=0 action=drop comment="" disabled=no add chain=forward src-address=192.168.0.0/16 p2p=warez action=drop comment="" disabled=no






  17. #17

    Padrão Re: Ajuda com P2P / Mikrotik

    /ip firewall mangle
    add action=mark-connection chain=prerouting comment=P2P_IN disabled=no \
    new-connection-mark=conn_p2p_in p2p=all-p2p passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting connection-mark=conn_p2p_in disabled=no \
    new-packet-mark=p2p_in passthrough=no
    add action=mark-connection chain=postrouting comment=P2P_OUT disabled=no \
    new-connection-mark=conn_p2p_out p2p=all-p2p passthrough=yes protocol=tcp
    add action=mark-packet chain=postrouting connection-mark=conn_p2p_out disabled=\
    no new-packet-mark=p2p_out passthrough=yes

    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=100k name=p2p_in packet-mark=p2p_in parent=global-in priority=8 \
    queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=100k name=p2p_out packet-mark=p2p_out parent=global-out priority=\
    1 queue=default


    nesta regra em queue tree com pode ver alterei a prioridade ..deixei em 1 ve se funciona

  18. #18

    Padrão Re: Ajuda com P2P / Mikrotik

    Citação Postado originalmente por zoom18 Ver Post
    ...A minha ideia era limitar o numero de conexões p2p por cliente, minha rede...
    Fala Zoom18! 100%? Muito Python + Paramiko aí?

    Cara, sugiro abandonar esses interpretadores de camada 7, que vem embutidos no RouterOS. Isso só serve para comer processamento, e não é totalmente funcional com P2P.

    Quer a prova? Vários clientes de Torrent tem requisições criptografadas em RC4[1] (ou algoritmos mais forte ainda). Tem vários wiki[2] monstrando como burlar shapers de camada 7, tipo esse do RouterOS, que não funciona com RC4.

    Na maioria dos casos, em que as regras de P2P parecem funcionar, é por ter a sorte de não ter usuários/clientes tão espertos na rede, que saibam ler manual e ativar a criptografia na aplicação Torrent Client.

    [1] http://en.wikipedia.org/wiki/BitTorr...col_encryption
    [2] http://wiki.vuze.com/w/Avoid_traffic_shaping

    Saudações,

    Trober
    -
    -
    -
    -
    -



  19. #19

    Padrão Re: Ajuda com P2P / Mikrotik

    Sera que o caso dele trober ......
    pois no meu nunca tive problemas ...mas entao a duvida pode esta no utorrent ..tenta com outro programa p2p

  20. #20

    Padrão Re: Ajuda com P2P / MikroTik

    Citação Postado originalmente por jailtonnetlink Ver Post
    pois no meu nunca tive problemas ...mas entao a duvida pode esta no utorrent ..tenta com outro programa p2p
    Olá Jailton.

    Que fique claro que de forma alguma estou dizendo que as regras que os demais colegas postaram estejam erradas. Essa incapacidade de controlar banda, baseado em filtros P2P, é limitação da maioria dos firewalls L7 (no qual o está incluso o filtro P2P do RouterOS). Aliada à incapacidade do filtro L7, tem a "malandragem" do RC4

    Quanto à obfuscuração, há vários clientes Torrent com essas características. O que recomendo, é fazer os seguintes testes:

    1) Instalar 10 clientes de Torrent no computador.
    2) Testar o tráfego dos 10 clientes, um de cada vez, com a criptografia (obfuscuração) desligada.
    3) Documentar os resultados.
    4) Testar o tráfego dos 10 clientes, um de cada vez, com a criptografia (obfuscuração) ligada.
    5) Documentar os resultados.
    6) Comparar resultados.

    O administrador que controla a banda, não pode presupor quais clientes de Torrent seus usuários irão (ou não) usar. Logo, filtrar por P2P, na esperança que a obfuscuração esteja desligada, é uma otimismo muito grande.

    Saudações,

    Trober
    -
    -
    -
    -
    -