Página 8 de 9 PrimeiroPrimeiro ... 3456789 ÚltimoÚltimo
+ Responder ao Tópico



  1. Citação Postado originalmente por jailtonnetlink Ver Post
    ...se nao for pedir demais para explicar a importancia do udp tbm nos clientes e em servidores ...fico grato
    Jailton, é uma resposta muito ampla, mas vou sintetizar de forma bem simples. Vou considerar a restrição geral de UDP (exceto 53) em provedores, que vendem planos aos respectivos clientes. O que podemos encontrar em clientes:

    Cenário 1:
    O cliente jogando Combat Arms[1], da Nexon[2]. O jogo usa algumas portas TCP, e várias outras UDP[3].

    Cenário 2:
    O cliente estabeleceu um túnel L2TP[4]. Usa as portas 1701, podendo também usar 500 e 4500 (vide IKE, IPSec,...).

    Cenário 3:
    O cliente conversando com seus contatos, usando VoIP[5]. Com exceção da 5060 (ou 5061) TCP, todas as demais portas são UDP.

    Agora imagina tratar tudo isso como P2P, como a regra propôs (aquela do "exceto 53"). É ser muito generalista.

    Tem o caso do NTP, já citado antes. Mesmo que o protocolo NTP tenha uma estimativa de correção de frequência de erro (drift file), isso não significa poder "penalizar" esse serviço, com base no "P2P generalista".

    Espero ter ajudado.

    [1] http://combatarms.nexon.net
    [2] http://www.nexon.net
    [3] http://combatarms.nexon.net/News/Vie...ontentNo=005p5
    [4] http://en.wikipedia.org/wiki/Layer_2_Tunneling_Protocol
    [5] http://en.wikipedia.org/wiki/Session...ation_Protocol

    Saudações,

    Trober
    -
    -
    -
    -
    -

  2. Caro Trober,

    Coloquei sua regra para controle p2p e aqui funcionou, só ainda não sei o efeito colateral, gostaria de saber se por acaso tenha alguma dica para ter um controle melhor sem afetar serviço essências.

    Na marcação de pacote coloquei estas portas UDP que mencionou para não marca.

    att...



  3. Citação Postado originalmente por nikollas Ver Post
    Caro Trober,

    Coloquei sua regra para controle p2p e aqui funcionou...
    Opa! Acredito que há um equívoco. Não postei nenhuma regra de controle de P2P. Inclusive fiz o contrário, expondo argumentos para desencorajar a prática de controle de P2P, por não ser eficiente.

    Citação Postado originalmente por trober Ver Post
    Cara, sugiro abandonar esses interpretadores de camada 7, que vem embutidos no RouterOS. Isso só serve para comer processamento, e não é totalmente funcional com P2P.
    Citação Postado originalmente por trober Ver Post
    Essa incapacidade de controlar banda, baseado em filtros P2P, é limitação da maioria dos firewalls L7 (no qual o está incluso o filtro P2P do RouterOS). Aliada à incapacidade do filtro L7, tem a "malandragem" do RC4
    Saudações,

    Trober

  4. mesmo assim flw pelo resposta, grato...



  5. Citação Postado originalmente por nikollas Ver Post
    mesmo assim flw pelo resposta, grato...
    Uso esta regra,tambem estava sofrendo deste mal de p2p,agora ja estou um pouco aliviado.


    Copiar e colar no terminal:

    /ip firewall layer7-protocol
    add name=bittorrent regexp="^(\13bittorrent protocol|azver\01\$|get/scrape\\\?info_hash=)|d1:ad2:id20:|\08'7P\\)[RP]"
    add name=ares regexp="^\03[]Z].\?.\?\05\$"

    /ip firewall mangle
    add action=mark-connection chain=prerouting comment=P2P_IN Ares disabled=no \
    new-connection-mark=conn_p2p_in p2p=all-p2p passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting connection-mark=conn_p2p_in disabled=no \
    new-packet-mark=p2p_in passthrough=no
    add action=mark-connection chain=postrouting comment=P2P_OUT Ares disabled=no \
    new-connection-mark=conn_p2p_out p2p=all-p2p passthrough=yes protocol=tcp
    add action=mark-packet chain=postrouting connection-mark=conn_p2p_out disabled=\
    no new-packet-mark=p2p_out passthrough=yes

    /ip firewall mangle
    add action=mark-connection chain=prerouting comment=P2P_IN Bittorrent disabled=no \
    new-connection-mark=conn_p2p_in p2p=all-p2p passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting connection-mark=conn_p2p_in disabled=no \
    new-packet-mark=p2p_in passthrough=no
    add action=mark-connection chain=postrouting comment=P2P_OUT Bittorrent disabled=no \
    new-connection-mark=conn_p2p_out p2p=all-p2p passthrough=yes protocol=tcp
    add action=mark-packet chain=postrouting connection-mark=conn_p2p_out disabled=\
    no new-packet-mark=p2p_out passthrough=yes

    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=64k name=p2p_in packet-mark=p2p_in parent=global-in priority=8 \
    queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=64k name=p2p_out packet-mark=p2p_out parent=global-out priority=\
    8 queue=default

    Agora tem que ser na unha,pois sou leigo e não sei fazer a regra pelo terminal:

    vai em ip/firewall/mangle 2 cliques na regra P2P_IN Ares,na aba advanced localize a opção Layer7 protocol selecione "ares" e clique em apply.
    vai em ip/firewall/mangle 2 cliques na regra P2P_OUT Ares,na aba advanced localize a opção Layer7 protocol selecione "ares" e clique em apply.
    vai em ip/firewall/mangle 2 cliques na regra P2P_IN Bittorrent,na aba advanced localize a opção Layer7 protocol selecione "bittorrent" e clique em apply.
    vai em ip/firewall/mangle 2 cliques na regra P2P_OUT Bittorrent,na aba advanced localize a opção Layer7 protocol selecione "bittorrent" e clique em apply.

    *Não alterar a regra mark packet,somente mark connection.

    Pronto!






Tópicos Similares

  1. Preciso de ajuda com Routerboard Mikrotik 750
    Por juniorlealdade no fórum Redes
    Respostas: 13
    Último Post: 03-07-2011, 21:59
  2. ajuda com servidor mikrotik
    Por raswilson no fórum Redes
    Respostas: 1
    Último Post: 30-07-2010, 19:03
  3. Preciso de Ajuda com o Mikrotik
    Por upgradealpha no fórum Redes
    Respostas: 5
    Último Post: 16-10-2009, 06:04
  4. Preciso de ajuda com o Mikrotik
    Por Machinerlz no fórum Redes
    Respostas: 1
    Último Post: 17-03-2007, 09:45
  5. ***AJUDA COM DUDE MIKROTIK***
    Por Alessilv no fórum Redes
    Respostas: 1
    Último Post: 03-08-2006, 13:58

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L