Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Túneis TE Vs VPLS...

    Boa Tarde!!
    Alguém pode me ajudar nesse impasse??
    Qual a melhor opção de Tunelamento... Túnel TE ou VPLS??
    Estou tendo um problema para criar os túneis TE....

    Obrigada!!

  2. #2

    Padrão Re: Túneis TE Vs VPLS...

    acompanhado ...



  3. #3
    Moderador Avatar de gamineiro
    Ingresso
    Jan 2008
    Localização
    RS
    Posts
    423
    Posts de Blog
    2

    Padrão Re: Túneis TE Vs VPLS...

    Bom dia,

    Nos dê mais detalhes de sua rede. Você usa OSPF, IBGP, etc.. Qual a finalidade dos tuneis?

    Abraço

  4. #4

    Padrão Re: Túneis TE Vs VPLS...

    Bom Dia... Vamos lá....
    Temos 4 RBs 1100 e 1 RB 450 formando essa rede... usando OSPF

    A eth1 da RB1 é Ligada na eth2 da RB2 (Rede 0)
    A eth1 da RB2 é Ligada na eth2 da RB4 (Rede 4)
    A eth1 da RB4 é Ligada na eth2 da RB5 (Rede 8)
    A eth1 da RB5 é Ligada na eth2 da RB1 (Rede 12)
    E a eth3 da RB2 é ligada na eth1 da RB3 (Rede 16)

    Os túneis são para separar os tipos de tráfego e fazer controle de banda, no nosso caso, usaremos 3 túneis um sei que é para voIp, e os outros 2 ainda não sei....

    Já criei todos os túneis.... são eles
    3 túneis TE da RB1 para a RB5
    3 túneis TE da RB1 para a RB4
    3 túneis TE da RB1 para a RB2
    3 túneis TE da RB5 para a RB1
    3 túneis TE da RB4 para a RB1
    3 túneis TE da RB2 para a RB1

    O meu problema está em criar da RB1 para a RB3 e Vice-versa....

    Não sei como fazer.....

    Obrigada por enquanto =)

    Abraço!



  5. #5
    Moderador Avatar de gamineiro
    Ingresso
    Jan 2008
    Localização
    RS
    Posts
    423
    Posts de Blog
    2

    Padrão Re: Túneis TE Vs VPLS...

    Mas eles já estão funcionando? Como você fez para criar?

    Você precisa fazer com que os tuneis VPLS usem o transporte TE para que funcione corretamente. Existem configurações para fazer nas instâncias OSPF, MPLS, Tunnel Path, etc. Para que eu possa te ajudar, preciso saber exatamente o que não está funcionando, com a configuração de cada roteador.

    Vamos falando..

  6. #6

    Padrão Re: Túneis TE Vs VPLS...

    Bom... eles funcionam... exceto o túnel da RB1 para a 3 e o caminho inverso da RB3 para a 1 que eu não estou conseguindo montar... vou falar como está o caminho da RB1 para a 5 e vice versa pra vc ter uma ideia...

    A RB1 (1100) Tem os seguintes ips nas interfaces....
    ether1 = 192.168.100.1/30
    ether2 = 192.168.100.14/30
    ether6 = 192.168.10.1/24
    Loopback Bridge = 10.0.1.1/32

    A RB2 (1100)
    ether1 = 192.168.100.5/30
    ether2 = 192.168.100.2/30
    ether3 = 192.168.100.17/30
    ether6 = 192.168.20.1/24
    Loopback Bridge = 10.0.1.2/32

    A RB3 (450)
    ether1 = 192.168.100.18/30
    ether3 = 192.168.30.1/24
    Loopback Bridge = 10.0.1.3

    A RB4 (1100)
    ether1 = 192.168.100.9/30
    ether2 = 192.168.100.6/30
    ether6 = 192.168.40.1/24
    Loopback Bridge = 10.0.1.4/32

    A RB5 (1100)
    ether1 = 192.168.100.13/30
    ether2 = 192.168.100.10/30
    ether6 = 192.168.50.1/24
    Loopback Bridge = 10.0.1.5/32

    O OSPF está funcionando e o MPLS está ativo em todas as RBs...

    Todas tem as seguintes configurações nas interfaces...

    /mpls traffic-eng interfaceadd bandwidth=90Mbps interface=etherX
    add bandwidth=90Mbps interface=etherY


    O Túnel TE que vai da RB1 até a RB5 tem o seguinte caminho....

    /mpls traffic-eng tunnel-path
    add disabled=no hops="192.168.1.2:strict,192.168.1.5:strict,192.168.1.6:strict,192.168.1.9:strict,192.168.1.10:strict" name=ToRB5 use-cspf=no
    add disabled=no name=dyn use-cspf=yes

    /interface traffic-eng
    add bandwidth=5Mbps bandwidth-limit=110% from-address=10.0.1.1 name=Tunel-1-RB5 primary-path=ToRB5 record-route=yes secondary-paths=dyn to-address=10.0.1.5

    O Caminho inverso é este

    O Túnel TE que vai da RB1 até a RB5 tem o seguinte caminho....

    /mpls traffic-eng tunnel-path
    add disabled=no hops="192.168.1.9:strict,192.168.1.6:strict,192.168.1.5:strict,192.168.1.2:strict,192.168.1.1:strict" name=ToRB1 use-cspf=no
    add disabled=no name=dyn use-cspf=yes

    /interface traffic-eng
    add bandwidth=5Mbps bandwidth-limit=110% from-address=10.0.1.5 name=Tunel-1-RB1 primary-path=ToRB1 record-route=yes secondary-paths=dyn to-address=10.0.1.1

    São 3 túneis iguais a este na RB1 e 3 na RB5...
    Nas RB4 e 2 o caminho é praticamente o mesmo... só diminuem os hops...

    Da RB1 para a RB3 estou tentando usar o seguinte caminho....

    /mpls traffic-eng tunnel-path
    add disabled=no hops="192.168.1.2:strict,192.168.1.17:strict,192.168.1.18:strict" name=ToRB3 use-cspf=no
    add disabled=no name=dyn use-cspf=yes

    /interface traffic-eng
    add bandwidth=5Mbps bandwidth-limit=110% from-address=10.0.1.1 name=Tunel-1-RB3 primary-path=ToRB3 record-route=yes secondary-paths=dyn to-address=10.0.1.3

    E o Caminho Inverso é este...

    /mpls traffic-eng tunnel-path
    add disabled=no hops="192.168.1.17:strict,192.168.1.2:strict,192.168.1.1:strict" name=ToRB1 use-cspf=no
    add disabled=no name=dyn use-cspf=yes

    /interface traffic-eng
    add bandwidth=5Mbps bandwidth-limit=110% from-address=10.0.1.3 name=Tunel-1-RB1 primary-path=ToRB1 record-route=yes secondary-paths=dyn to-address=10.0.1.1

    Na hora de colocar os ips nos túneis de todas as RBs eles funcionam...
    exceto da RB1 para a 3 e vice-versa... fica em itálico e no estado "unreachable".... não sei mais o que fazer....

    Obrigada =)



  7. #7
    Moderador Avatar de gamineiro
    Ingresso
    Jan 2008
    Localização
    RS
    Posts
    423
    Posts de Blog
    2

    Padrão Re: Túneis TE Vs VPLS...

    Agora melhorou!! hehehe

    Voce sabe usar tuneis dinamicos? Já tentou?

    Pode fazer em todos os roteadores.
    /mpls traffic-eng tunnel-path add name=dinamico use-cspf=yes record-route=yes
    /interface traffic-eng add from-address=1.1.1.1 to-address=2.2.2.2 bandwidth=10M bandwidth-limit=110 primary-path=dinamico

    Assim, os tuneis-path serão criados automaticamente, baseados nas rotas do OSPF. Voce pode criar tuneis manualmente para melhor balancear o trafego, e criar tuneis secundarios dinamicos, para redundância, caso o link pricipal fique indisponivel.

    Obs.: Você tem essa opção configurada?
    /routing ospf instance set 0 mpls-te-area=backbone

    Abraço

  8. #8

    Padrão Re: Túneis TE Vs VPLS...

    Essa Opção já estava configurada...
    No Router Id está o ip da Loopback Bridge...
    No Mpls-te-area esta backbone e no Mpls Te router Id está Loopback Bridge..

    esses ips que vc colocou 1.1.1.1 e 2.2.2.2 se referem q que endereço??

    Abraço



  9. #9
    Moderador Avatar de gamineiro
    Ingresso
    Jan 2008
    Localização
    RS
    Posts
    423
    Posts de Blog
    2

    Padrão Re: Túneis TE Vs VPLS...

    OK.

    Sim, coloquei apenas como teste. Você pode colocar os ips das loopbacks dos routes que irão fechar o tunel.

  10. #10

    Padrão Re: Túneis TE Vs VPLS...

    A RB1 vai ter 12 Túneis, sendo 3 para cada destino... as demais terão apenas 3 direcionados para a RB1... funcionaria do mesmo jeito??
    Tô perguntando pq depois de feitos os túneis eu vou ter q fechar eles com redes /30 pra cada túnel.... porexemplo..

    Na RB1 seria isso nos túneis para a RB5
    /ip address
    add address=10.10.50.1/30 disabled=no interface=Tunel-1-R5
    add address=10.10.50.5/30 disabled=no interface=Tunel-2-R5
    add address=10.10.50.9/30 disabled=no interface=Tunel-3-R5

    Na RB5 seria isso nos túneis para a RB1
    /ip address
    add address=10.10.50.2/30 disabled=no interface=Tunel-1-R1
    add address=10.10.50.6/30 disabled=no interface=Tunel-2-R1
    add address=10.10.50.10/30 disabled=no interface=Tunel-3-R1

    Teeeensoo rss



  11. #11
    Moderador Avatar de gamineiro
    Ingresso
    Jan 2008
    Localização
    RS
    Posts
    423
    Posts de Blog
    2

    Padrão Re: Túneis TE Vs VPLS...

    Pode ser. Depois de fechado o tunel, você pode configurá-lo como roteamento ou bridge pura.

  12. #12

    Padrão Re: Túneis TE Vs VPLS...

    Obrigada!! Vou Tentar isso e falo se deu certo =)

    Abraço!!



  13. #13

    Padrão Re: Túneis TE Vs VPLS...

    Eu to utilizando a 1ano OSPF com EOIP com Gateway gerenciando os Tuuneis (EOIP) ta rodando perfeito!, não encontrei material melhor para mudar para o VPLS.

  14. #14

    Padrão Re: Túneis TE Vs VPLS...

    eoip eh meio "gambiarra" em um cenario igual este exposto.. eoip consome mta cpu e causa um overhead ...



  15. #15

    Padrão Re: Túneis TE Vs VPLS...

    Qual seria a evolução da "Gambiarra"?

  16. #16

    Padrão Re: Túneis TE Vs VPLS...

    tuneis TE, VPLS .. só ler ai o assunto do tópico !!



  17. #17

    Padrão Re: Túneis TE Vs VPLS...

    to Achando estranho ALEXANDRE ki eu paguei 600,00 pra vc a 1 ano pra fazer meu primeiro EOIP! , que o sergio tinha me indicado vc!

  18. #18

    Padrão Re: Túneis TE Vs VPLS...

    exatamente... EoIP nas ultimas versoes do ROS ficou CAOS, era uma coisa boa... agora virou uma gambiarra só !! principalmente quando possuem versoes divergentes (4x e 5.x) !!



  19. #19

    Padrão Re: Túneis TE Vs VPLS...

    blza, tudo bem é possivel vc enviar um modelo de VPLS , lembrando que ja utilizo o OSPF e tenho um gateway gerenciando os tuneis EOIP, com redundância !

  20. #20

    Padrão Re: Túneis TE Vs VPLS...

    ativa mpls nos routers "interessados", e crie as vpls entre eles..