Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Envio de backup por e-mail

    Ola amigos tenho um PC com Mk instalado e rodando bonitinho implantei as regras para gerar backup e enviar por e-mail e tudo funciona perfeito, porem em minhas RB750 e RB450G não funciona alguém tem a regra para as RBs segue as regras que estou usando.


    /system scheduler
    add disabled=no interval=1d name=enviar_backup_para_mail on-event="/system script run send_backup_to_mail" policy=\
    reboot,read,write,policy,test,password,sniff,sensitive start-time=startup
    add disabled=no interval=23h name="backup automatico" on-event="/system backup save name=Backup.backup" policy=\
    reboot,read,write,policy,test,password,sniff,sensitive start-time=startup
    [[email protected]_POP_Fabio] > system script export
    # apr/09/2012 14:59:12 by RouterOS 5.14

    /system script
    add name=send_backup_to_mail policy=ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source=\

    /tool e-mail send [email protected] subject=Backup_rb450g_Mikrotik file=Backup.backup"
    [[email protected]_POP_Fabio] > tool e-mail export
    # apr/09/2012 14:59:34 by RouterOS 5.14


    /tool e-mail
    set address=000.000.00.000 from=<[email protected]> password=minha senha port=25 [email protected]

  2. #2

    Padrão Re: Envio de backup por e-mail

    Ollenini tenta outra porta no e-mail tipo a 587 e o ip de serviço tipo 200.147.99.132 blz. qquer coisa eu tenho um script que utilizo aki nas minhas rbs.



  3. #3

    Padrão Re: Envio de backup por e-mail

    Ola Aurio
    Tentei com a porta 587 mas da o mesmo erro (invalid FROM address) o mais engraçado que no meu PC funciona belezinha acredito que deve ser algo com a versão no PC tenho a 3.30 agora nas RBs 5.14.
    me manda as configurações que vc tem por favor.

  4. #4
    Suporte em Mikrotik Avatar de Genis
    Ingresso
    Nov 2006
    Localização
    INTERIOR-SP
    Posts
    1.591

    Padrão Re: Envio de backup por e-mail

    isso esta aparecendo que não tem navegação tenta pingar para o IP 200.147.99.132 se não estiver navegando ativa o NAT de cada RB.



  5. #5
    Suporte em Mikrotik Avatar de Genis
    Ingresso
    Nov 2006
    Localização
    INTERIOR-SP
    Posts
    1.591

    Padrão Re: Envio de backup por e-mail

    usa estas configurações .: em System Script +
    Nome = Email-Backup
    Policy = Reboot, Read, write, policy, test, password, snff, sensitive
    Soucer = :log info messagem="enviado Backup por email" :global data [/sy clock get date] :global hora [/sy clock get time] /tool e-mail send to="seu [email protected] provedor.com.br" subject="o nome da RB $data $hora" file= o nome do arquivo gerado dentro da sua RB.backup tls=yes

    em Tool Email -> se o seu email for do google pode colocar estas configurações
    Sever 74.125.157.109 Port 587 From o seu email User o seu email em Password coloca a senha do seu email

    lembrando que deve criar um script para gerar os arquivo de backup, eu configurei para gerar a cada 4 hora, e cada 4 hora manda para o meu email do google.

  6. #6

    Padrão Re: Envio de backup por e-mail

    Amigos continua o mesmo erro e tem navegação normal

































































    MMM MMM KKK TTTTTTTTTTT KKK
    MMMM MMMM KKK TTTTTTTTTTT KKK
    MMM MMMM MMM III KKK KKK RRRRRR OOOOOO TTT III KKK KKK
    MMM MM MMM III KKKKK RRR RRR OOO OOO TTT III KKKKK
    MMM MMM III KKK KKK RRRRRR OOO OOO TTT III KKK KKK
    MMM MMM III KKK KKK RRR RRR OOOOOO TTT III KKK KKK


    MikroTik RouterOS 5.14 (c) 1999-2012 MikroTik Routers and Wireless










    +-----------------------------------------------------------------------+
    > BANDALARGACOTIA <
    > ...:: Banda larga em Cotia e Regi <
    +-----------------------------------------------------------------------+
    < (11) 8989-9725 [email protected] >
    +-----------------------------------------------------------------------+
    [[email protected]_POP_Fabio] > ping 200.147.99.132
    HOST SIZE TTL TIME STATUS
    200.147.99.132 56 55 4ms
    200.147.99.132 56 55 9ms
    200.147.99.132 56 55 12ms
    200.147.99.132 56 55 12ms
    200.147.99.132 56 55 10ms
    200.147.99.132 56 55 18ms
    200.147.99.132 56 55 4ms
    sent=7 received=7 packet-loss=0% min-rtt=4ms avg-rtt=9ms max-rtt=18ms


    [[email protected]_POP_Fabio] >



  7. #7

    Padrão Re: Envio de backup por e-mail

    Ola amigos,
    Realmente após atualizar a RB para a versao 5.14 aconteceu isso.
    Sempre tive os log's e backups sendo enviados sem problemas, mas depois que li esse tópico fui verificar e acabei vendo que desde o dia que atualizei nao envia mais.
    Alguém ta rodando a versao 5.14 e esta conseguindo usar o envio de backup?
    Se sim, postem as config`s para gente.
    Outra coisa,, fiz um balanceamento com 2 links dedicados no mesmo dia da atualizacao de versao.... Minha pergunta é... O Balanceamento tem haver com isso?

  8. #8

    Padrão Re: Envio de backup por e-mail

    Amigo não deve ter nada relacionado ao balance pois nao estou usando balance.
    Mas gostaria muito de resolver a questao do backup.

    procuro também um script para checagem de link ou seja uma regra que teste se o link esta up e envie um resumo de ping por exemplo.



  9. #9

    Post Re: Envio de backup por e-mail

    Boa tarde Ollenini desculpa a demora o agendamento e o script que vou mandar pra vc é da versão 5.7 pra vc testar.

    /system scheduler
    add disabled=no interval=6d name=Agendamento-backup-log on-event=\
    fazer-e-enviar-log policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api \
    start-date=nov/14/2011 start-time=18:00:37
    add disabled=no interval=6d name=Agendamento-backup-mk on-event=\
    fazer-e-enviar-backup policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api \
    start-date=nov/14/2011 start-time=18:00:20

    /system script
    add name=fazer-e-enviar-backup policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api \
    source="/export file=([/system identity get name] . \"-\" . \\\
    \n[:pick [/system clock get date] 7 11] . [:pick [/system clock get date] \
    0 3] . [:pick [/system clock get date] 4 6]); \\\
    \n/tool e-mail send to=\"[email protected]\" subject=([/system identity\
    \_get name] . \" Backup \" . \\\
    \n[/system clock get date]) file=([/system identity get name] . \"-\" . [:\
    pick [/system clock get date] 7 11] . \\\
    \n[:pick [/system clock get date] 0 3] . [:pick [/system clock get date] 4\
    \_6] . \".rsc\"); :delay 40; \\\
    \n/file rem [/file find name=([/system identity get name] . \"-\" . [:pick\
    \_[/system clock get date] 7 11] . \\\
    \n[:pick [/system clock get date] 0 3] . [:pick [/system clock get date] 4\
    \_6] . \".rsc\")]; \\\
    \n:log info (\"System Backup emailed at \" . [/sys cl get time] . \" \" . \
    [/sys cl get date])"

  10. #10

    Padrão Re: Envio de backup por e-mail

    Citação Postado originalmente por Aurio Ver Post
    Boa tarde Ollenini desculpa a demora o agendamento e o script que vou mandar pra vc é da versão 5.7 pra vc testar.
    Boa tarde Aurio.

    Use a formatação para definir a área de código, com as TAGS tipo CODE. Por algum motivo macabro, a ferramenta WYSIWYG do Under-Linux, coloca espaços em branco onde não deveriam existir. Veja por exemplo em:

    Código :
    .                          espaço que                         espaço que
    .                         não deveria                         não deveria
    .                           existir!!!                           existir!!!
    .                             |                               |
    ftp,reboot,read,write,policy,t  est,winbox,password,sniff,sens  itive,api \
        start-date=nov/14/2011 start-time=18:00:37

    Se você executar o código acima, por mais correto que esteja, no momento que você colou, a ferramenta WYSIWYG vai deformar, com espaços "fantasmas", gerando vários erros de sintaxe. Definindo seu texto de código como CODE, isso não acontece, além de deixar mais elegante seu post

    Saudações,

    Trober



  11. #11
    Under-linux.Org Team Avatar de MarcusMaciel
    Ingresso
    Dec 2000
    Localização
    Boston
    Posts
    1.969
    Posts de Blog
    44

    Padrão Re: Envio de backup por e-mail

    Trober,

    qualquer tipo de codigo ou script deve ser colocado dentro da TAG CODE
    Código :
     e

  12. #12

    Padrão Re: Envio de backup por e-mail

    Citação Postado originalmente por MarcusMaciel Ver Post
    Trober, qualquer tipo de codigo ou script deve ser colocado dentro da TAG CODE
    E não foi o que eu já orientei no post anterior?

    De qualquer forma, grato pelo reforço da informação aos demais colegas participantes deste tópico.

    Sucesso a todos.

    Saudações,

    Trober



  13. #13

    Padrão Re: Envio de backup por e-mail

    Aurio nao deu certo agora nem erro mostra e tao pouco gera o arquivo de backup acredito que estou errando em alguma coisa

  14. #14

    Padrão Re: Envio de backup por e-mail

    Aurio vc pode enviar por e-mail?



  15. #15

    Padrão Re: Envio de backup por e-mail

    Aurio Muito obrigado por sua ajuda resolveu meu problema.
    Caso alguem queira é so falar com o Dr Aurio

  16. #16

    Padrão Re: Envio de backup por e-mail

    Estamos ai para ajudar e ser ajudado blz abraço.



  17. #17

    Padrão Re: Envio de backup por e-mail

    Citação Postado originalmente por Aurio Ver Post
    Estamos ai para ajudar e ser ajudado blz abraço.
    Qual foi a solução?

  18. #18

    Padrão Re: Envio de backup por e-mail

    Citação Postado originalmente por Claudineibj Ver Post
    Qual foi a solução?

    Qual a versão do seu MK ?



  19. #19

    Padrão Re: Envio de backup por e-mail

    Citação Postado originalmente por Ollenini Ver Post
    Qual a versão do seu MK ?
    Olá meu amigo me da uma ajuda a versão do meu Mk é a 5.17 como ficaria o script para envio do backup por e-mail...

    tem como postar ai para tudo terem acesso?

    Desde já agradeço

    Fica com DEUS

    Amém

  20. #20

    Padrão Re: Envio de backup por e-mail

    Ola segue a s regras
    Recomendo que vc crie uma conta no ” bol” pois em outros provedor comigo não deu muito certo.
    Observações;
    Em /tool e-mail
    O Ip já esta certo para o bol caso for utilizar outro altere usando o IP do server SMTP

    Em /system scheduler
    A única coisa que vc pode alterar se desejar é start data e start time mas não recomendo antes de testar

    Em /system script
    Você deve alterar somente o endereço de e-mail o qual vai receber o backup por e-mail esta na quinta linha
    IMPORTANTE cuidado para não alterar o arquivo com espaços e ou caracteres pois caso altere a regra não vai funcionar

    Bom é so isso altere tudo copie uma regra por vez e cole na ordem e teste qualquer coisa manda um e-mail.
    Lembre-se da estrelinha abaixo.Regras para gerar e enviar backup por e-mail.txt