+ Responder ao Tópico



  1. #1

    Padrão Ruralweb não funciona em Linux

    Eu tenho dois links de internet da Ruralweb, e eles funcionam perfeitamente no Windows, mas quando ligo eles no Linux, no meu caso Mikrotik o link funciona por alguns instantes e para, só funciona novamente se eu reiniciar o Mikrotik, já tentei Debian, Coyote, etc., em todos tenho o mesmo problema, segundo eles isso ocorre porque o Linux trabalha com FIFO, queria saber que tipo de fila o Windows utiliza e se eu posso utilizar dessa mesma forma no Mikrotik, no site deles tem um texto falando sobre isso, segue abaixo:

    "Numa rede liberal, programas como o EMule ou o Kazaa poderão causar um enorme congestionamento. Um único EMule instalado em um computador da rede poderá abrir dezenas de conexões simultâneas. Com isso, caso algum outro usuário, em outro computador, deseje visitar o GMail, por exemplo, teremos uma máquina, estabelecendo uma conexão, lutando contra outro computador com 60 conexões (apenas um exemplo). Teremos, em outras palavras, 01 contra 60. É óbvio que haverá uma grande desvantagem para um dos dois. Isso ocorre porque, da forma como o Kernel Linux trabalha, normalmente, os pacotes são enfileirados em um buffer e saem na mesma ordem em que chegaram (FIFO, para os mais experientes). Aumentar o link, ao contrário do que muitos desinformados pensam, não resolveria o caso, pois só estaríamos dando mais “poder de fogo” ao usuário do EMule e continuaríamos sendo o 60º da fila. O que fazer então? Três soluções possíveis:


    • Bloquear o EMule, tornando-se um administrador radical e forçando o usuário de tal programa a achar uma forma de burlar o controle (sempre há uma forma de fazer isso). Ainda, o EMule foi bloqueado mas outros programas similares não. Existem centenas deles.




    No Windows controlo a velocidade dos clientes com o ISA server.

  2. #2

    Padrão Re: Ruralweb não funciona em Linux

    marcelbentes, já usei starone, rural, answer, em 2003 usei a rural com um servidor com ubuntu, na epoca precisava de um programa rpa2211, CJB.NET, mas parece o site não existe mais.

    vou dar uma pesquisa depois eu retorno.

    Das via satelite a rural web é a pior.



  3. #3

    Padrão Re: Ruralweb não funciona em Linux

    No windows server 2003 ela funciona muito bem, cada link é de 1 mega e difícilmente cai abaixo disso, mas isso é no windows, se colocar no mikrotik fica uma merda, valeu ai pela ajuda.

  4. #4

    Padrão Re: Ruralweb não funciona em Linux

    cara é um proxy instala no windows e da netstat -nb para saber a porta estabilizada, dai vc seta e je era, basta configurar para ler o socket ou um peerproxy



  5. #5

    Padrão Re: Ruralweb não funciona em Linux

    Eu sei que a Ruralweb tem um proxy que eles usam, é o RPA, o meu problema é que quando ligo o link deles em qualquer linux, o link não funciona, e segundo eles é pelo modo de enfileiramento que o linux utiliza (FIFO).

  6. #6

    Padrão Re: Ruralweb não funciona em Linux

    pois é, amigo tem um rpa pro linux antes eu baixava no "http://www.rpa2211.cjb.net/", só q não encontrei em lugar nenhum, olha no site da rural pra ver se eles mesmo não fornece.



  7. #7

    Padrão Re: Ruralweb não funciona em Linux

    Certo, entendi, o problema é que preciso do Mikrotik para gerenciar a rede, e nele não tem como instalar o RPA.

  8. #8

    Padrão Re: Ruralweb não funciona em Linux

    o jeito é colocar um pc antes mk.
    vc pode fazer um server com linux e gerenciar a rede deixando o mk em modo ap

    se vc qser mando uma imagem já com ubuntu squid,apache, php, mysql, mysar, videocache, e um programa feito em delphi pra vc cadastrar os clientes, sem muita função, só cadastra amarra o mac e ip dos clientes.

    dar pra fazer no windows também só com squid,apache, php, mysql e o programa pra vc cadastrar os clientes.



  9. #9

    Padrão Re: Ruralweb não funciona em Linux

    Já utilizei o pfsense por um bom período, como load balance e para gerenciar a rede, mas o meu link da ruralweb não ficou legal com ele também, na verdade o meu problema é o link da ruralweb e não o sistema que gerencia, pois tenho links de outras empresas que funcionam muito bem no mikrotik ou em qualquer outro linux, mas nenhum dos meus outros links mantém a velocidade contratada durante praticamente o dia inteiro, apenas os links da ruralweb, por isso não quero me desfazer deles, queria apenas descobrir porque eles funcionam bem em windows e em qualquer outro sistema linux não.