+ Responder ao Tópico



  1. #1

    Padrão Burlar Simple-qeue para usar limite do Qeue-tree

    Bom estou com uma dificuldade em fazer uma marcação de content ficar fora da velocidade que o cliente tem em Simple-queue quando ele loga no hotspot é criado automaticamente a simple-queue, quero uma forma que para os sites marcados fiquem com a velocidade que estão em queue-tree ultrapassando a velocidade que o cliente tem em simple-qeue, há alguma forma de executar isso no MK 5.14? Obrigado a todos e segue abaixo a regra que estou usando para marcar os sites:

    /ip firewall mangle
    add action=mark-connection chain=prerouting comment="QoS orkut" content=www.orkut.com disabled=no new-connection-mark=PKT_ORKUT passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting connection-mark=PKT_ORKUT disabled=no new-packet-mark=ORKUT_PKT passthrough=yes
    /queue tree add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=1M max-limit=2M name=ORKUT packet-mark=ORKUT_PKT parent=global-total priority=8 queue=default

  2. #2

    Padrão Re: Bular Simple-qeue para usar limite do Qeue-tree

    É uma boa pergunta essa! Mas segundo o wiki da Mikrotik, a queue simple tem preferência no tratamento do tráfego.

    Also it is possible to have double queuing (examplerioritization of traffic in global-in or global-out, limitation per client on the outgoing interface) If you have simple queues and queue tree in the same HTB - simple queues will get traffic first.

    fonte: wiki - mikrotik



  3. #3

    Padrão Re: Bular Simple-qeue para usar limite do Qeue-tree

    Isso que acontece aqui, pq essa regra marca certinho o site que quero faço o tanto de banda que será usado no site, mais como o cara tem um simple-queue feito pelo hotspot ele nao usa com a velocidade total.

  4. #4

    Padrão Re: Bular Simple-qeue para usar limite do Qeue-tree

    E se fizer uma queue simple estática, parecida com essa, e utilizando as router-mark para aplicação da regra? Como as dinâmicas seriam criadas depois, a estática teria preferência sobre esse tráfego.



  5. #5

    Padrão Re: Bular Simple-qeue para usar limite do Qeue-tree

    Vo testar agora e já te falo se ficou bom... Não tinha pensado nisso ainda rsrsrs

  6. #6

    Padrão Re: Bular Simple-qeue para usar limite do Qeue-tree

    Fiz o teste e aparentimente funcionou, veja na imagem abaixo que mesmo com perfil de 256k ele estava trafegando a 2.8M, mais agora vem outra coisa como faria para essa queue ficar sempre acima das demais criada pelo hotspot?Clique na imagem para uma versão maior

Nome:	         QOS YOUTUBE.jpg
Visualizações:	51
Tamanho: 	39,3 KB
ID:      	34839



  7. #7

    Padrão Re: Bular Simple-qeue para usar limite do Qeue-tree

    Eu particularmente não uso hotspot. Mas como as queues são dinâmicas, a tendência é elas serem criadas depois das estáticas. Com pppoe pelo menos é assim. Creio que deva funcionar de forma similiar no hotspot. É só deixá-la em primeiro na lista de queue simple.

  8. #8

    Padrão Re: Bular Simple-qeue para usar limite do Qeue-tree

    Sim amigo agora consegui fazer tudo certinho, criei um script no mikrotik pra rodar a cada 1min contendo isso ----> :foreach i in=[/queue simple find dynamic=yes] do={ /queue simple move $i} <-----
    dai faz a queue ficar em primeira pq se não quando o cliente loga a simple queue criada fica acima da que eu fiz anteriormente... Agora sim ta rodando certinho...



  9. #9

    Padrão Re: Bular Simple-qeue para usar limite do Qeue-tree

    Bacana! Show de bola! Isso vai me ajudar por aqui também, rsrs... estou atarefado com umas otimizações na rede, mas depois vou implementar isso. Porque se o youtube estiver funcionando, para o cliente a internet está inteira funcionando, rs.

  10. #10

    Padrão Re: Bular Simple-qeue para usar limite do Qeue-tree

    Aqui colocando na simple queue exemplo 512k de up e 2M down não passa de 512k tbm o download pq será? add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s direction=both \ disabled=no interface=all limit-at=0/0 max-limit=512k/5M name="QOS TWITTER" \
    packet-marks=TWITTER_PKT parent=none priority=8 queue=\
    default-small/default-small target-addresses=0.0.0.0/0 total-queue=\
    default-small



  11. #11

    Padrão Re: Bular Simple-qeue para usar limite do Qeue-tree

    Não sei amigão, nem testei ainda... só vou conseguir ver isso outro dia, tô reconfig meu OSPF agora.

  12. #12

    Padrão Re: Bular Simple-qeue para usar limite do Qeue-tree

    Citação Postado originalmente por peritinaicos Ver Post
    Aqui colocando na simple queue exemplo 512k de up e 2M down não passa de 512k tbm o download pq será?
    Amigão, até fiz uns testes este fim-de-semana, e fiz um QoS para o que o pessoal usa mais, tipo: facebook, twitter, youtube, orkut e windows update. Funcionou bem, mas confesso que não testei o upload. para ver o comportamento. Coloquei o QoS como pcq, para ninguém entrar e pegar toda a banda e continuar lento para os outros. Até porque como todo esse tráfego estará passando ali, se ficar lento, será para todos afetados pela queue.

    Mas no teste prático gostei do benefício, melhorou muito a navegação dos clientes com pouca banda, do plano econômico. E mesmo assim as queues não ficaram esgoeladas. Essa semana vou configurar em torres com mais clientes para testar e ajustar os valores das queues.



  13. #13

    Padrão Re: Bular Simple-qeue para usar limite do Qeue-tree

    Bom aqui está funcionando perfeitamente, mais não consegui fazer com que a queue funcionasse o limite de up diferente do limite de down... Quando coloco ex: 512k/2M o limite de down fica em 512k tbm, dai quando coloco 2M/2M ai fica o down a 2M... Estranho né.

  14. #14

    Padrão Re: Bular Simple-qeue para usar limite do Qeue-tree

    Bem estranho, eu notei que o consumo dos 2 sentidos fica muito próximo, tanto o up como o down.

    Mas por aqui também funcionou a contento.