Página 1 de 4 1234 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Ospf Dando Erro

    Ola a todos!

    Estou implantando OSPF em laboratorio para entender melhor como funciona, venho estudando o protocolo e seu funcionamento.

    Na bancada tenho 2 RB e duas SXT Mikrotik.
    Cenario

    RB 1 ETH1 172.20.0.1/30
    ETH5 172.20.0.14/30

    RB 2 ETH 1 172.20.0.13/30
    ETH 5 GATEWAY

    SXT 1 ETH 172.20.0.2/30
    WLAN 172.20.0.5/30

    SXT 2 ETH 172.20.0.10
    WLAN 172.20.0.6/30

    Entre a RB 1 e RB 2 fiz OSPF nas interfaces e criou uma rota dinamica entre as duas funcionando normal.

    Entre a RB 1 e SXT 1 quando crio o OSPF entre as interfaces fica dando erro
    discarting packet locally originated
    src adrress=172.20.0.2

    A SXT pinga nas RB mas fica dando esse erro.

    Estou tentando fechar um anel com esses 4 equipamentos.

  2. #2

    Padrão re: Ospf Dando Erro

    exporte seus arquivos de configurações para podermos entender as configurações execultadas e podermos te ajudar



  3. #3
    Analista de Suporte em TI Avatar de demattos
    Ingresso
    Jul 2011
    Localização
    Criciuma/SC
    Posts
    1.923
    Posts de Blog
    3

    Padrão re: Ospf Dando Erro

    poderia fazer um esquema de ligacao para nos entender melhor como vc esta tentando fazer esta rede em anel e qual equipamento vc esta usando para sair e chegar este anel, vc poderia usar o dude para desenhar e salvar e passar para nos, desta forma consegueriamos tem uma visao da rede que vc pretende.

  4. #4

    Padrão re: Ospf Dando Erro

    Montei um desenho pra ficar mais claro.Clique na imagem para uma versão maior

Nome:	         REDE.jpg
Visualizações:	519
Tamanho: 	21,3 KB
ID:      	35129



  5. #5

    Padrão re: Ospf Dando Erro

    Monteoi um desenho pra melhor entenderClique na imagem para uma versão maior

Nome:	         REDE.jpg
Visualizações:	229
Tamanho: 	21,3 KB
ID:      	35130

  6. #6

    Padrão re: Ospf Dando Erro

    Ta meio complicado de entender....tente colocar as especificacoes das configuracoes que voce setou.



  7. #7

    Padrão re: Ospf Dando Erro

    Vou detaljhar as config se ainda assim ficar estranho vou tentar exportar as configurações.
    Setei os ips conforme no desenho;
    RB 1 Fui em routing - OSPF- NETWORKS, e coloquei as redes 172.20.0.0; 172.20.0.12. Quando faço isso cria uma rota dinamica na interface eth1 e eth5

    RB 2 Fui em routing - OSPF- NETWORKS, e coloquei as redes 172.20.0.8; 172.20.0.12. Quando faço isso cria uma rota dinamica na interface eth1 e eth5
    eth4 coloquei um link com ip fixo.

    SXT 1 Fui em routing - OSPF- NETWORKS, e coloquei as redes 172.20.0.0; 172.20.0.4 Quando faço isso cria uma rota dinamica na interface eth1 e wlan

    SXT 2 Fui em routing - OSPF- NETWORKS, e coloquei as redes 172.20.0.4; 172.20.0.8 Quando faço isso cria uma rota dinamica na interface eth1 e wlan

    Todas as intances estão setados
    "redistribute Defaut Route "= never
    "redistribute connected routes" = as type1

    Exeto onde tem o link que esta
    "redistribute Defaut Route "= (always) as type1)
    "redistribute connected routes" = as type1

    Com essa config as RBs se falam sem problema e nao existe pacotes perdidos até por que mesmo sem rota elas se comunicariam. Mas a RB2 consegue pingar na SXT 1 so que entre a SXT1 e a RB1 fica dando erro de discartando pacote na rede 172.20.0.1 e os pings para rb falham nessa hora.

  8. #8

    Padrão re: Ospf Dando Erro

    Citação Postado originalmente por salvato Ver Post
    Vou detaljhar as config se ainda assim ficar estranho vou tentar exportar as configurações.
    Setei os ips conforme no desenho;
    RB 1 Fui em routing - OSPF- NETWORKS, e coloquei as redes 172.20.0.0; 172.20.0.12. Quando faço isso cria uma rota dinamica na interface eth1 e eth5

    RB 2 Fui em routing - OSPF- NETWORKS, e coloquei as redes 172.20.0.8; 172.20.0.12. Quando faço isso cria uma rota dinamica na interface eth1 e eth5
    eth4 coloquei um link com ip fixo.

    SXT 1 Fui em routing - OSPF- NETWORKS, e coloquei as redes 172.20.0.0; 172.20.0.4 Quando faço isso cria uma rota dinamica na interface eth1 e wlan

    SXT 2 Fui em routing - OSPF- NETWORKS, e coloquei as redes 172.20.0.4; 172.20.0.8 Quando faço isso cria uma rota dinamica na interface eth1 e wlan

    Todas as intances estão setados
    "redistribute Defaut Route "= never
    "redistribute connected routes" = as type1

    Exeto onde tem o link que esta
    "redistribute Defaut Route "= (always) as type1)
    "redistribute connected routes" = as type1

    Com essa config as RBs se falam sem problema e nao existe pacotes perdidos até por que mesmo sem rota elas se comunicariam. Mas a RB2 consegue pingar na SXT 1 so que entre a SXT1 e a RB1 fica dando erro de discartando pacote na rede 172.20.0.1 e os pings para rb falham nessa hora.
    Boa tarde.

    1) Vamos dar nome e endereço de loopback aos roteadores.

    rtr-a 172.30.0.1/32, antes chamado de "RB 2".
    rtr-b 172.30.0.2/32, antes chamado de "SXT 2".
    rtr-c 172.30.0.3/32, antes chamado de "SXT 1".
    rtr-d 172.30.0.4/32, antes chamado de "RB 1".

    Recomendo fortemente não usar espaços e caracteres especiais em nomes de roteadores.

    2) Estabeleça comunicação entre esses roteadores, dispostos de forma circular, usando endereços /30.

    rtr-a tem ether1=172.20.0.13/30 e ether5=172.20.0.10/30.
    rtr-b tem ether1=172.20.0.9/30 e wlan1=172.20.0.6/30.
    rtr-c tem ether1=172.20.0.2/30 e wlan1=172.20.0.5/30.
    rtr-d tem ether1=172.20.0.1/30 ether5=172.20.0.14/30.

    Com isso, os roteadores que são adjacentes já tem comunicação. Mas como não tem rotas, além das locais, rtr-a não tem contato com rtr-c, nem rtr-b tem contato com rtr-d.

    3) Defina, conforme abaixo, as interfaces que serão usadas para roteamento OSPF. Todas as demais interfaces, serão declaradas como passivas.

    rtr-a, adicionar ether1 e ether5, todas as demais interfaces serão declaradas como passivas.
    rtr-b, adicionar ether1 e wlan1, todas as demais interfaces serão declaradas como passivas.
    rtr-c, adicionar ether1 e wlan1, todas as demais interfaces serão declaradas como passivas.
    rtr-d, adicionar ether1 e ether5, todas as demais interfaces serão declaradas como passivas.

    4) Defina o router-id na instância de cada roteador, atribuido o mesmo o valor igual ao número de endereço loopback. Não mude qualquer outro parâmetro, exceto em rtr-a, que você marcará a opção Redistritute Default Route como always as type 1. Repetindo, somente em rtr-a, em todos os demais roteadores, só muda o valor de router-id, que é igual ao valor de loopback.

    Essa alteração é necessária em rtr-a, pois é o roteador que terá rota padrão para a saída para a internet, por meio da interface ether4. O roteador rtr-a será o único a ter uma rota estática.

    Fique atento para não ter roteadores com router-id repetido na rede.

    5) Em cada roteador, você anunciará as redes locais, conforme segue abaixo:

    rtr-a 172.30.0.1/32, 172.20.0.8/30 e 172.20.0.12/30.
    rtr-b 172.30.0.2/32, 172.20.0.4/30 e 172.20.0.8/30.
    rtr-c 172.30.0.3/32, 172.20.0.4/30 e 172.20.0.0/30.
    rtr-d 172.30.0.4/32, 172.20.0.0/30 e 172.20.0.12/30.

    Para cada rede nova em algum roteador, como por exemplo, 192.168.17.0/25 na ether3 de rtr-d, você precisará fazer um novo anúncio. É aqui que muita gente se perde, já que tem o costume de anunciar qualquer rede conectada, já que é mais fácil apenas clicar num checkbox. Essa facilidade pode ser muito perigosa, mas não abordarei aqui os riscos.

    6) Se seguida corretamente as orientações, está pronto (salvo algum esquecimento meu, hehehe)

    Todos os roteadores receberão rota padrão, herdado de rtr-a (lembra da distribuição de rota padrão, somente em rtr-a?).

    Você pode usar pesos para fazer a rede sempre "rodar" em sentido horário, se assim quiser.

    Certifique-se que você não tem NAT em nenhum roteador com OSPF. É possível um convívio entre essas duas funcionalidades, mas não é o caso do tópico, já que seu gateway está na ether4 de rtr-a. Estou supondo que o NAT está sendo feito no gateway.

    Espero ter ajudado.
    Última edição por trober; 15-10-2015 às 09:56.



  9. #9
    Moderador Avatar de gamineiro
    Ingresso
    Jan 2008
    Localização
    RS
    Posts
    423
    Posts de Blog
    2

    Padrão re: Ospf Dando Erro

    Citação Postado originalmente por trober Ver Post
    Boa tarde.

    1) Vamos dar nome e endereço de loopback aos roteadores.

    rtr-a 172.30.0.1/32, antes chamado de "RB 2".
    rtr-b 172.30.0.2/32, antes chamado de "SXT 2".
    rtr-c 172.30.0.3/32, antes chamado de "SXT 1".
    rtr-d 172.30.0.4/32, antes chamado de "RB 1".

    Recomendo fortemente não usar espaços e caracteres especiais em nomes de roteadores.

    2) Estabeleça comunicação entre esses roteadores, dispostos de forma circular, usando endereços /30.

    rtr-a tem ether1=172.20.0.13/30 e ether5=172.30.0.10/30.
    rtr-b tem ether1=172.30.0.9/30 e wlan1=172.30.0.6/30.
    rtr-c tem ether1=172.30.0.2/30 e wlan1=172.30.0.5/30.
    rtr-d tem ether1=172.30.0.1/30 ether5=172.30.0.14/30.

    Com isso, os roteadores que são adjacentes já tem comunicação. Mas como não tem rotas, além das locais, rtr-a não tem contato com rtr-c, nem rtr-b tem contato com rtr-d.

    3) Defina, conforme abaixo, as interfaces que serão usadas para roteamento OSPF. Todas as demais interfaces, serão declaradas como passivas.

    rtr-a, adicionar ether1 e ether5, todas as demais interfaces serão declaradas como passivas.
    rtr-b, adicionar ether1 e wlan1, todas as demais interfaces serão declaradas como passivas.
    rtr-c, adicionar ether1 e wlan1, todas as demais interfaces serão declaradas como passivas.
    rtr-d, adicionar ether1 e ether5, todas as demais interfaces serão declaradas como passivas.

    4) Defina o router-id na instância de cada roteador, atribuido o mesmo o valor igual ao número de endereço loopback. Não mude qualquer outro parâmetro, exceto em rtr-a, que você marcará a opção Redistritute Default Route como always as type 1. Repetindo, somente em rtr-a, em todos os demais roteadores, só muda o valor de router-id, que é igual ao valor de loopback.

    Essa alteração é necessária em rtr-a, pois é o roteador que terá rota padrão para a saída para a internet, por meio da interface ether4. O roteador rtr-a será o único a ter uma rota estática.

    Fique atento para não ter roteadores com router-id repetido na rede.

    5) Em cada roteador, você anunciará as redes locais, conforme segue abaixo:

    rtr-a 172.30.0.1/32, 172.20.0.8/30 e 172.20.0.12/30.
    rtr-b 172.30.0.2/32, 172.20.0.4/30 e 172.20.0.8/30.
    rtr-c 172.30.0.3/32, 172.20.0.4/30 e 172.20.0.0/30.
    rtr-d 172.30.0.4/32, 172.20.0.0/30 e 172.20.0.12/30.

    Para cada rede nova em algum roteador, como por exemplo, 192.168.17.0/25 na ether3 de rtr-d, você precisará fazer um novo anúncio. É aqui que muita gente se perde, já que tem o costume de anunciar qualquer rede conectada, já que é mais fácil apenas clicar num checkbox. Essa facilidade pode ser muito perigosa, mas não abordarei aqui os riscos.

    6) Se seguida corretamente as orientações, está pronto (salvo algum esquecimento meu, hehehe)

    Todos os roteadores receberão rota padrão, herdado de rtr-a (lembra da distribuição de rota padrão, somente em rtr-a?).

    Você pode usar pesos para fazer a rede sempre "rodar" em sentido horário, se assim quiser.

    Certifique-se que você não tem NAT em nenhum roteador com OSPF. É possível um convívio entre essas duas funcionalidades, mas não é o caso do tópico, já que seu gateway está na ether4 de rtr-a. Estou supondo que o NAT está sendo feito no gateway.

    Espero ter ajudado, e ficarei muito feliz se quiser usar os mecanismos de qualificação aqui do Under-Linux

    Saudações,

    Trober
    -
    -
    -
    -
    -

    Muito bem detalhado, parabéns.

    obs.: "Mega" perigoso o redistribute-connected. asuhahsuhahsahsuhauh Melhor nunca usar.

    Abraço

  10. #10

    Padrão re: Ospf Dando Erro

    Ta ae amigo, tanto o Trober como o Gamineiro deram a aula.
    Abs



  11. #11

    Padrão re: Ospf Dando Erro

    Vou testar hoje muito obrigado a todos!

  12. #12

    Padrão re: Ospf Dando Erro

    Citação Postado originalmente por trober Ver Post
    Boa tarde.

    1) Vamos dar nome e endereço de loopback aos roteadores.

    rtr-a 172.30.0.1/32, antes chamado de "RB 2".
    rtr-b 172.30.0.2/32, antes chamado de "SXT 2".
    rtr-c 172.30.0.3/32, antes chamado de "SXT 1".
    rtr-d 172.30.0.4/32, antes chamado de "RB 1".

    Recomendo fortemente não usar espaços e caracteres especiais em nomes de roteadores.

    2) Estabeleça comunicação entre esses roteadores, dispostos de forma circular, usando endereços /30.

    rtr-a tem ether1=172.20.0.13/30 e ether5=172.30.0.10/30.
    rtr-b tem ether1=172.30.0.9/30 e wlan1=172.30.0.6/30.
    rtr-c tem ether1=172.30.0.2/30 e wlan1=172.30.0.5/30.
    rtr-d tem ether1=172.30.0.1/30 ether5=172.30.0.14/30.

    Com isso, os roteadores que são adjacentes já tem comunicação. Mas como não tem rotas, além das locais, rtr-a não tem contato com rtr-c, nem rtr-b tem contato com rtr-d.

    3) Defina, conforme abaixo, as interfaces que serão usadas para roteamento OSPF. Todas as demais interfaces, serão declaradas como passivas.

    rtr-a, adicionar ether1 e ether5, todas as demais interfaces serão declaradas como passivas.
    rtr-b, adicionar ether1 e wlan1, todas as demais interfaces serão declaradas como passivas.
    rtr-c, adicionar ether1 e wlan1, todas as demais interfaces serão declaradas como passivas.
    rtr-d, adicionar ether1 e ether5, todas as demais interfaces serão declaradas como passivas.

    4) Defina o router-id na instância de cada roteador, atribuido o mesmo o valor igual ao número de endereço loopback. Não mude qualquer outro parâmetro, exceto em rtr-a, que você marcará a opção Redistritute Default Route como always as type 1. Repetindo, somente em rtr-a, em todos os demais roteadores, só muda o valor de router-id, que é igual ao valor de loopback.

    Essa alteração é necessária em rtr-a, pois é o roteador que terá rota padrão para a saída para a internet, por meio da interface ether4. O roteador rtr-a será o único a ter uma rota estática.

    Fique atento para não ter roteadores com router-id repetido na rede.

    5) Em cada roteador, você anunciará as redes locais, conforme segue abaixo:

    rtr-a 172.30.0.1/32, 172.20.0.8/30 e 172.20.0.12/30.
    rtr-b 172.30.0.2/32, 172.20.0.4/30 e 172.20.0.8/30.
    rtr-c 172.30.0.3/32, 172.20.0.4/30 e 172.20.0.0/30.
    rtr-d 172.30.0.4/32, 172.20.0.0/30 e 172.20.0.12/30.

    Para cada rede nova em algum roteador, como por exemplo, 192.168.17.0/25 na ether3 de rtr-d, você precisará fazer um novo anúncio. É aqui que muita gente se perde, já que tem o costume de anunciar qualquer rede conectada, já que é mais fácil apenas clicar num checkbox. Essa facilidade pode ser muito perigosa, mas não abordarei aqui os riscos.

    6) Se seguida corretamente as orientações, está pronto (salvo algum esquecimento meu, hehehe)

    Todos os roteadores receberão rota padrão, herdado de rtr-a (lembra da distribuição de rota padrão, somente em rtr-a?).

    Você pode usar pesos para fazer a rede sempre "rodar" em sentido horário, se assim quiser.

    Certifique-se que você não tem NAT em nenhum roteador com OSPF. É possível um convívio entre essas duas funcionalidades, mas não é o caso do tópico, já que seu gateway está na ether4 de rtr-a. Estou supondo que o NAT está sendo feito no gateway.

    Espero ter ajudado, e ficarei muito feliz se quiser usar os mecanismos de qualificação aqui do Under-Linux

    Saudações,

    Trober
    -
    -
    -
    -
    -
    Amigo muito obrigado deu certo e as mensagens de erro sumirão, só uma pergunta voce disse para na instacia deixar tudo como estava exeto na router onde tem o link, mas a outras rb so funcionaram o link apos deixar na instacia como
    "REDISTRIBUTE CONNECTED ROUTES" = as type1

    È ISSO MESMO?



  13. #13

    Padrão re: Ospf Dando Erro

    Citação Postado originalmente por salvato Ver Post
    Amigo muito obrigado deu certo e as mensagens de erro sumirão
    Que bom! Fico contente com a notícia

    Citação Postado originalmente por salvato Ver Post
    só uma pergunta voce disse para na instacia deixar tudo como estava exeto na router onde tem o link, mas a outras rb so funcionaram o link apos deixar na instacia como
    "REDISTRIBUTE CONNECTED ROUTES" = as type1

    È ISSO MESMO?
    Não. Conforme comentei em post anterior, e o colega Gabriel Mineiro também reforçou, o uso de Redistribute Connected Routes não deve ser usado (apesar de existir a possibilidade de uso). O que você precisa fazer é "anunciar" as redes que você tem, de forma explícita, ou seja "não mão", ou "no braço", como alguns preferem chamar.

    Uma dica simples que dou, mas que não deve ser usada como regra geral, é adicionar em /routing ospf networks, todas as redes que você tem em /ip address print

    Faça isso, e não precisará usar a venenosa redistribuição de rota conectadas

    Testa lá e nos avisa.

    Saudações,

    Trober

  14. #14

    Padrão re: Ospf Dando Erro

    Citação Postado originalmente por trober Ver Post
    Que bom! Fico contente com a notícia



    Não. Conforme comentei em post anterior, e o colega Gabriel Mineiro também reforçou, o uso de Redistribute Connected Routes não deve ser usado (apesar de existir a possibilidade de uso). O que você precisa fazer é "anunciar" as redes que você tem, de forma explícita, ou seja "não mão", ou "no braço", como alguns preferem chamar.

    Uma dica simples que dou, mas que não deve ser usada como regra geral, é adicionar em /routing ospf networks, todas as redes que você tem em /ip address print

    Faça isso, e não precisará usar a venenosa redistribuição de rota conectadas

    Testa lá e nos avisa.

    Saudações,

    Trober
    Verdade adicionei a rede e desabilitei a redistribuição de rota e a net continuou funcionando.

    Ai efetuei outro teste, tirei o cabo que ficava entre a RTR-D e a RTR-A, e a RTR-D que antes pingava em todas as redes, parou de pingar a RTR-A.
    Eu imaginei que o OSPF quando identifica-se que o link entre RTR-D e RTR-A ficasse down, automaticamente ele procuraria a rede no sentido contrario.



  15. #15

    Padrão re: Ospf Dando Erro

    Citação Postado originalmente por salvato Ver Post
    Verdade adicionei a rede e desabilitei a redistribuição de rota e a net continuou funcionando.
    Beleza!

    Citação Postado originalmente por salvato Ver Post
    Ai efetuei outro teste, tirei o cabo que ficava entre a RTR-D e a RTR-A, e a RTR-D que antes pingava em todas as redes, parou de pingar a RTR-A.
    Eu imaginei que o OSPF quando identifica-se que o link entre RTR-D e RTR-A ficasse down, automaticamente ele procuraria a rede no sentido contrario.
    1) Você estava "pingando" o endereço de loopback?
    2) Você perdeu conexão com a internet ou só parou de pingar rtr-a, em um endereço que não é de loopback?

    As duas perguntas acima são importantes, para eu poder compor a resposta sobre o "sentido contrário".

    Saudações,

    Trober

  16. #16

    Padrão re: Ospf Dando Erro

    1) Eu estava pingando o ip da interface.
    2) Sim perdeu a conexão com a internet.



  17. #17

    Padrão re: Ospf Dando Erro

    Citação Postado originalmente por salvato Ver Post
    1) Eu estava pingando o ip da interface.
    2) Sim perdeu a conexão com a internet.
    Cara, não era para ter perdido a conexão com a internet.

    Vamos fazer o seguinte: Eu tenho aqui algumas RBs de backup. Vou simular a sua estrutura física da sua rede usando duas RB750G, duas RB751G-2HnD, formando círculo.

    Para deixar mais didático o material, não usarei seus endereços IP. Feito isso, publico aqui os exports, já servindo de referência para outros colegas

    Não garanto resposta para hoje. Se eu demorar, me chama aí

    Saudações,

    Trober

  18. #18

    Padrão re: Ospf Dando Erro

    Citação Postado originalmente por trober Ver Post
    Não garanto resposta para hoje. Se eu demorar, me chama aí...
    Opa! Concluí aqui

    Vamos a nomenclatura dos ativos:

    rtr-internet: É o roteador (FreeBSD) que está conectado à internet. O único da rede toda que tem NAT. As redes previstas no RFC1918 estão sendo encaminhadas estaticamente para rtr-a. Eu poderia fazer OSPF no FreeBSD, mas não é o foco da demonstração.

    rtr-a: Uma RB750G, ao norte do círculo, com três interfaces, sendo ether5 voltada para o servidor FreeBSD (nosso gateway com NAT). As ethernets de cada RB representam um segmento (perna) de rede. Veja que ether1 de rtr-a conversa com ether1 de rtr-b. Já a ether2 de rtr-b conversa com ether2 de rtr-c. E assim sucessivamente, para demonstrar, de forma mais didática, cada "perna" de rede (ou braço, vai do apelido que cada um prefere dar. Eu sou mais fã de "segmento").

    rtr-b: Uma RB750G, ao leste do diagrama. Conversa com rtr-a e rtr-c.

    rtr-c: Uma RB751G-2HnD, ao sul do diagrama. Conversa com rtr-b, rtr-d e também uma estação de teste, chamada wks-test, de endereço 192.168.140.5/24, simulando o extremo da rede, a ser provida com redundância.

    rtr-d: Uma RB751G-2HnD, que desempenha o mesmo papel de rtr-b, só que do lado oeste do circuito, conversando com rtr-c e rtr-a.

    wks-test: Uma estação de teste. Um notebook rodando PC-BSD. Tem endereço IP 192.168.140.5/24, e gateway 192.168.140.3.

    Abaixo, o diagrama

    Código :
     
    .                              (200.200.200.2/30)
    .                              [rtr-internet] 
    .                              (192.168.250.1) 
    .                                     | 
    .                                     | 
    .                                     | 
    .                                     | 
    .                               192.168.250.100 
    .                                   ether5 (lo1 172.30.0.1) 
    .               (172.17.4.1) ether4 [rtr-a] ether1 (172.17.1.1) 
    .                            |                   | 
    .                            |                   | 
    .                            |                   | 
    .                            |                   | 
    .                            |                   | 
    .                            |                   | 
    .          (172.17.4.4) ether4                   ether1 (172.17.1.2) 
    .(lo1 172.30.0.4) [rtr-d]                             [rtr-b] (lo1 172.30.0.2) 
    .          (172.17.3.4) ether3                   ether2 (172.17.2.2) 
    .                            |                   | 
    .                            |                   | 
    .                            |                   | 
    .                            |                   | 
    .                            |                   | 
    .                            |                   | 
    .               (172.17.3.3) ether3 [rtr-c] ether2 (172.17.2.3) 
    .                                   ether5 (lo1 172.30.0.3) 
    .                              (192.168.140.3) 
    .                                     | 
    .                                     | 
    .                                     | 
    .                                [wks-test] 
    .                              (192.168.140.5) 
    . 
    . 
    . 
    . 
    .
    .
    .
    .
    .
    .
    .

    A circularidade funciona 100%. Desconecta de um lado, o lado oposto assume. Perde uma ou duas sequências ICMP, sendo quase imperceptível ao usuário final.

    Aqui vai o código de rtr-a:
    Código :
    # rtr-a
    # 
    #
     
    /interface bridge add name=loopback
     
    /routing ospf instance set [ find default=yes ] distribute-default=always-as-type-1 router-id=172.30.0.1
     
    /ip address add address=172.30.0.1/32 interface=loopback network=172.30.0.1
    /ip address add address=172.17.1.1/29 interface=ether1
    /ip address add address=172.17.4.1/29 interface=ether4
    /ip address add address=192.168.250.210/24 interface=ether5
     
    /ip dns set servers=192.168.250.1
     
    /ip route add distance=1 gateway=192.168.250.1
     
    /routing ospf interface add interface=loopback network-type=broadcast passive=yes
    /routing ospf interface add interface=ether1 network-type=broadcast
    /routing ospf interface add interface=ether4 network-type=broadcast
    /routing ospf interface add interface=ether5 network-type=broadcast passive=yes
     
    /routing ospf network add area=backbone network=172.30.0.1/32
    /routing ospf network add area=backbone network=172.17.1.0/29
    /routing ospf network add area=backbone network=172.17.4.0/29
     
     
     
     
    /system identity set name=rtr-a
     
     
     
     
     
    #
    Aqui vai o código de rtr-b:
    Código :
    # rtr-b
    #
    #
     
    /interface bridge add name=loopback
     
    /routing ospf instance set [ find default=yes ] router-id=172.30.0.2
     
    /ip address add address=172.30.0.2/32 interface=loopback network=172.30.0.2
    /ip address add address=172.17.1.2/29 interface=ether1
    /ip address add address=172.17.2.2/29 interface=ether2
     
     
    /ip dns set servers=192.168.250.1
     
     
     
    /routing ospf interface add interface=loopback network-type=broadcast passive=yes
    /routing ospf interface add interface=ether1 network-type=broadcast
    /routing ospf interface add interface=ether2 network-type=broadcast
     
     
    /routing ospf network add area=backbone network=172.30.0.2/32
    /routing ospf network add area=backbone network=172.17.1.0/29
    /routing ospf network add area=backbone network=172.17.2.0/29
     
     
     
     
    /system identity set name=rtr-b
     
     
     
     
     
    #
    Aqui vai o código de rtr-c:
    Código :
    # rtr-c
    #
    #
     
    /interface bridge add name=loopback
     
    /routing ospf instance set [ find default=yes ] router-id=172.30.0.3
     
    /ip address add address=172.30.0.3/32 interface=loopback network=172.30.0.3
    /ip address add address=172.17.2.3/29 interface=ether2
    /ip address add address=172.17.3.3/29 interface=ether3
    /ip address add address=192.168.140.3/24 interface=ether5
     
    /ip dns set servers=192.168.250.1
     
     
     
    /routing ospf interface add interface=loopback network-type=broadcast passive=yes
    /routing ospf interface add interface=ether2 network-type=broadcast
    /routing ospf interface add interface=ether3 network-type=broadcast
    /routing ospf interface add interface=ether5 network-type=broadcast passive=yes
     
    /routing ospf network add area=backbone network=172.30.0.3/32
    /routing ospf network add area=backbone network=172.17.2.0/29
    /routing ospf network add area=backbone network=172.17.3.0/29
    /routing ospf network add area=backbone network=192.168.140.0/24
     
     
     
    /system identity set name=rtr-c
     
     
     
     
     
    #
    Aqui vai o código de rtr-d:
    Código :
    # rtr-d
    #
    #
     
    /interface bridge add name=loopback
     
    /routing ospf instance set [ find default=yes ] router-id=172.30.0.4
     
    /ip address add address=172.30.0.4/32 interface=loopback network=172.30.0.4
    /ip address add address=172.17.3.4/29 interface=ether3
    /ip address add address=172.17.4.4/29 interface=ether4
     
     
    /ip dns set servers=192.168.250.1
     
     
     
    /routing ospf interface add interface=loopback network-type=broadcast passive=yes
    /routing ospf interface add interface=ether3 network-type=broadcast
    /routing ospf interface add interface=ether4 network-type=broadcast
    /routing ospf interface add interface=ether5 network-type=broadcast passive=yes
     
    /routing ospf network add area=backbone network=172.30.0.4/32
    /routing ospf network add area=backbone network=172.17.3.0/29
    /routing ospf network add area=backbone network=172.17.4.0/29
     
     
     
     
    /system identity set name=rtr-d
     
     
     
     
     
    #

    Observações importantes:

    Lá em rtr-c, você ao ter o círculo fechado, você terá uma rota padrão ECMP (Equal Cost Multi Path), ou seja, com dois gateways de mesmo custo.

    Outra coisa muito importante. O OSPF tem um tempo de convergência. Então não pense em ficar "fapando cabo" (hehehe) na porta, a cada 5 segundos, achando que terá convergência em tempo real. Detectar queda é instantâneo. Detectar retorno leva não menos que 10 segundos, tempo do Hello Interval. Aqui é entra a questão de atualização entre roteadores e tal, e a conversa vai longe, não sendo o propósito inicial desse tópico.

    Para finalizar, funcionou aqui 100% e funciona em todos o provedores, prefeituras e mais um pool de cliente que tenho em produção

    Espero ter sido útil o material a você e demais colegas do Under-Linux.

    Saudações,

    Trober



  19. #19

    Padrão re: Ospf Dando Erro

    Citação Postado originalmente por trober Ver Post
    Opa! Concluí aqui

    Vamos a nomenclatura dos ativos:

    rtr-internet: É o roteador (FreeBSD) que está conectado à internet. O único da rede toda que tem NAT. As redes previstas no RFC1918 estão sendo encaminhadas estaticamente para rtr-a. Eu poderia fazer OSPF no FreeBSD, mas não é o foco da demonstração.

    rtr-a: Uma RB750G, ao norte do círculo, com três interfaces, sendo ether5 voltada para o servidor FreeBSD (nosso gateway com NAT). As ethernets de cada RB representam um segmento (perna) de rede. Veja que ether1 de rtr-a conversa com ether1 de rtr-b. Já a ether2 de rtr-b conversa com ether2 de rtr-c. E assim sucessivamente, para demonstrar, de forma mais didática, cada "perna" de rede (ou braço, vai do apelido que cada um prefere dar. Eu sou mais fã de "segmento").

    rtr-b: Uma RB750G, ao leste do diagrama. Conversa com rtr-a e rtr-c.

    rtr-c: Uma RB751G-2HnD, ao sul do diagrama. Conversa com rtr-b, rtr-d e também uma estação de teste, chamada wks-test, de endereço 192.168.140.5/24, simulando o extremo da rede, a ser provida com redundância.

    rtr-d: Uma RB751G-2HnD, que desempenha o mesmo papel de rtr-b, só que do lado oeste do circuito, conversando com rtr-c e rtr-a.

    wks-test: Uma estação de teste. Um notebook rodando PC-BSD. Tem endereço IP 192.168.140.5/24, e gateway 192.168.140.3.

    Abaixo, o diagrama

    Código :
     
    .                              (200.200.200.2/30)
    .                              [rtr-internet] 
    .                              (192.168.250.1) 
    .                                     | 
    .                                     | 
    .                                     | 
    .                                     | 
    .                               192.168.250.100 
    .                                   ether5 (lo1 172.30.0.1) 
    .               (172.17.4.1) ether4 [rtr-a] ether1 (172.17.1.1) 
    .                            |                   | 
    .                            |                   | 
    .                            |                   | 
    .                            |                   | 
    .                            |                   | 
    .                            |                   | 
    .          (172.17.4.4) ether4                   ether1 (172.17.1.2) 
    .(lo1 172.30.0.4) [rtr-d]                             [rtr-b] (lo1 172.30.0.2) 
    .          (172.17.3.4) ether3                   ether2 (172.17.2.2) 
    .                            |                   | 
    .                            |                   | 
    .                            |                   | 
    .                            |                   | 
    .                            |                   | 
    .                            |                   | 
    .               (172.17.3.3) ether3 [rtr-c] ether2 (172.17.2.3) 
    .                                   ether5 (lo1 172.30.0.3) 
    .                              (192.168.140.3) 
    .                                     | 
    .                                     | 
    .                                     | 
    .                                [wks-test] 
    .                              (192.168.140.5) 
    . 
    . 
    . 
    . 
    .
    .
    .
    .
    .
    .
    .

    A circularidade funciona 100%. Desconecta de um lado, o lado oposto assume. Perde uma ou duas sequências ICMP, sendo quase imperceptível ao usuário final.

    Aqui vai o código de rtr-a:
    Código :
    # rtr-a
    # 
    #
     
    /interface bridge add name=loopback
     
    /routing ospf instance set [ find default=yes ] distribute-default=always-as-type-1 router-id=172.30.0.1
     
    /ip address add address=172.30.0.1/32 interface=loopback network=172.30.0.1
    /ip address add address=172.17.1.1/29 interface=ether1
    /ip address add address=172.17.4.1/29 interface=ether4
    /ip address add address=192.168.250.210/24 interface=ether5
     
    /ip dns set servers=192.168.250.1
     
    /ip route add distance=1 gateway=192.168.250.1
     
    /routing ospf interface add interface=loopback network-type=broadcast passive=yes
    /routing ospf interface add interface=ether1 network-type=broadcast
    /routing ospf interface add interface=ether4 network-type=broadcast
    /routing ospf interface add interface=ether5 network-type=broadcast passive=yes
     
    /routing ospf network add area=backbone network=172.30.0.1/32
    /routing ospf network add area=backbone network=172.17.1.0/29
    /routing ospf network add area=backbone network=172.17.4.0/29
     
     
     
     
    /system identity set name=rtr-a
     
     
     
     
     
    #
    Aqui vai o código de rtr-b:
    Código :
    # rtr-b
    #
    #
     
    /interface bridge add name=loopback
     
    /routing ospf instance set [ find default=yes ] router-id=172.30.0.2
     
    /ip address add address=172.30.0.2/32 interface=loopback network=172.30.0.2
    /ip address add address=172.17.1.2/29 interface=ether1
    /ip address add address=172.17.2.2/29 interface=ether2
     
     
    /ip dns set servers=192.168.250.1
     
     
     
    /routing ospf interface add interface=loopback network-type=broadcast passive=yes
    /routing ospf interface add interface=ether1 network-type=broadcast
    /routing ospf interface add interface=ether2 network-type=broadcast
     
     
    /routing ospf network add area=backbone network=172.30.0.2/32
    /routing ospf network add area=backbone network=172.17.1.0/29
    /routing ospf network add area=backbone network=172.17.2.0/29
     
     
     
     
    /system identity set name=rtr-b
     
     
     
     
     
    #
    Aqui vai o código de rtr-c:
    Código :
    # rtr-c
    #
    #
     
    /interface bridge add name=loopback
     
    /routing ospf instance set [ find default=yes ] router-id=172.30.0.3
     
    /ip address add address=172.30.0.3/32 interface=loopback network=172.30.0.3
    /ip address add address=172.17.2.3/29 interface=ether2
    /ip address add address=172.17.3.3/29 interface=ether3
    /ip address add address=192.168.140.3/24 interface=ether5
     
    /ip dns set servers=192.168.250.1
     
     
     
    /routing ospf interface add interface=loopback network-type=broadcast passive=yes
    /routing ospf interface add interface=ether2 network-type=broadcast
    /routing ospf interface add interface=ether3 network-type=broadcast
    /routing ospf interface add interface=ether5 network-type=broadcast passive=yes
     
    /routing ospf network add area=backbone network=172.30.0.3/32
    /routing ospf network add area=backbone network=172.17.2.0/29
    /routing ospf network add area=backbone network=172.17.3.0/29
    /routing ospf network add area=backbone network=192.168.140.0/24
     
     
     
    /system identity set name=rtr-c
     
     
     
     
     
    #
    Aqui vai o código de rtr-d:
    Código :
    # rtr-d
    #
    #
     
    /interface bridge add name=loopback
     
    /routing ospf instance set [ find default=yes ] router-id=172.30.0.4
     
    /ip address add address=172.30.0.4/32 interface=loopback network=172.30.0.4
    /ip address add address=172.17.3.4/29 interface=ether3
    /ip address add address=172.17.4.4/29 interface=ether4
     
     
    /ip dns set servers=192.168.250.1
     
     
     
    /routing ospf interface add interface=loopback network-type=broadcast passive=yes
    /routing ospf interface add interface=ether3 network-type=broadcast
    /routing ospf interface add interface=ether4 network-type=broadcast
    /routing ospf interface add interface=ether5 network-type=broadcast passive=yes
     
    /routing ospf network add area=backbone network=172.30.0.4/32
    /routing ospf network add area=backbone network=172.17.3.0/29
    /routing ospf network add area=backbone network=172.17.4.0/29
     
     
     
     
    /system identity set name=rtr-d
     
     
     
     
     
    #

    Observações importantes:

    Lá em rtr-c, você ao ter o círculo fechado, você terá uma rota padrão ECMP (Equal Cost Multi Path), ou seja, com dois gateways de mesmo custo.

    Outra coisa muito importante. O OSPF tem um tempo de convergência. Então não pense em ficar "fapando cabo" (hehehe) na porta, a cada 5 segundos, achando que terá convergência em tempo real. Detectar queda é instantâneo. Detectar retorno leva não menos que 10 segundos, tempo do Hello Interval. Aqui é entra a questão de atualização entre roteadores e tal, e a conversa vai longe, não sendo o propósito inicial desse tópico.

    Para finalizar, funcionou aqui 100% e funciona em todos o provedores, prefeituras e mais um pool de cliente que tenho em produção

    Espero ter sido útil o material a você e demais colegas do Under-Linux.

    Saudações,

    Trober
    Muito obrigado, vou testar hoje mesmo, e posto resultados.

  20. #20

    Padrão re: Ospf Dando Erro

    Ola amigo tudo bem?
    Efetuei as configurações aqui de duas formas.
    1) Usando 3 Rbs 450g e duas SXT.
    Essa não deu certo pois as SXT não permite passar a rota formando o circulo não entendi por que.

    2) Usando as 3 Rbs 450g o circulo funcionou perfeito.

    Muito obrigado, por tudo vou continuar estudando aqui pra entender bem esse OSPF, qualquer material sobre o protocolo que voce tiver ou onde posso ler sobre ele será muito util.

    Mas uma vez aprendi bastante aqui.

    Obrigado mais uma vez e tenha muito sucesso.