Página 1 de 3 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. Ola a todos.
    recentemente ando enfrentando um problema em minha rede.

    possuo uma 750 que recebe o link do net virtua via dhcp cliente.
    ate ai tudo bem, so oque ocorre e que de vez em quando o virtua troca de ip, e o dhcp cliente do router não intende isso e não recebe o novo ip do virtua. Fica contando o tempo de expired time, so recebe o ip se eu der reboot na RB.

    Oque eu gostaria e de um script que monitorasse um host externo (tipo 8.8.8.8) e se não tivesse resposta, rodaria um reboot no sistema.

    tentei colocar esses

    /tool netwatch
    add disabled=no down-script=reboot host=8.8.8.8 interval=2m timeout=1s \
    up-script=""


    /system script
    add name=reboot policy=ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="/system reboot"


    ate dar certo, se o host não responde ele reinicia, só que entra em um loop eterno de reboot na volta, (ele liga e em seguida ja reboot denovo, so para se resetar o equipamento.

    grato a todos pela atenção.

  2. Coloca o script para ser executado de X em X tempo, de 5 em 5 minutos, por exemplo. Aí você não vai ter esse problema.

    Se ajudei, estrelinha pra mim!



  3. Voce poderia me explicar qual script eu alteron o tempo?

    Já tentei alterar o tempo em /tool netwatch. O monitoramento funciona perfeitamente, se o hostil não responde ele roda o reboot. Só que quando reinicia ele volta a reboota a novamente num loop sem fim.
    tem que haver uma maneira de que quando reiniciar ele esperar os 5 min para monitorar o host novamente.

  4. não vi \systen scheduler nas tuas regras ,á função do scheduler é essa .(marcar tempo para aplcar ás regras)



  5. Citação Postado originalmente por tigreinformatica Ver Post
    não vi \systen scheduler nas tuas regras ,á função do sheduler é essa .(marcar tempo para aplcar ás regras)
    acho que e nisso que estou errando. Não sei como colocar o agendador para rodar o script. Teria como você mim dar uma forcinha para formular essas regras






Tópicos Similares

  1. Liberação de rota para host externo
    Por osnilf no fórum Redes
    Respostas: 3
    Último Post: 23-01-2015, 09:42
  2. Respostas: 12
    Último Post: 18-01-2010, 09:52
  3. Problema ao rodar script de backup no Crontab
    Por jbenini no fórum Servidores de Rede
    Respostas: 11
    Último Post: 24-10-2008, 07:19
  4. Execução de script após reboot
    Por maleficavatar no fórum Redes
    Respostas: 6
    Último Post: 05-09-2007, 20:43
  5. Script Pra ver Se host Esta ativo.
    Por patrickcanton no fórum Servidores de Rede
    Respostas: 1
    Último Post: 12-10-2004, 20:55

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L