Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Olá pessoal,

    Estou testando nas RB, por um script que quando cair minha conexão com a internet, subir uma regra no firewall pra transferir todo o meu trafego oriundo da rede interna na porta 80 para um ip interno onde contenha uma página de aviso.

    Quando ativo a regra manualmente funciona perfeitamente, mas quando a conexão com a internet cai, simplesmente não funciona, e como se dependesse de internet pra resolver o nome do site solicitado para que depois ele (mikrotik) faça o redirecionamento.

    Ex: o cliente acessa www.globo.com e ele o direciona pra um ip 10.20.30.2 rodando um página web.

    Alguém tem ideia de como solucionar isso?

    Att.

  2. Existe uma função dentro do Mikrotik chamada Netwatch que cuida desta verificação se o IP está disponível ou não e executando 2 funções distintas em caso de UP (respondendo) ou DOWN (sem resposta).

    O exemplo de script poderia ser:

    /ip firewall nat
    add chain=dstnat src-nat=ClasseIPLAN action=dst-nat to-address=10.20.30.2 to-port=80 comment="Falha Internet"

    Script netwatch

    Em caso de down:
    /ip firewall nat set [find commen="Falha Internet"] disabled=no

    Em caso de up:
    /ip firewall nat set [find commen="Falha Internet"] disabled=yes


    Att.



  3. Olá luock, essa parte do script eu já tenho implementado.

    O script sobe normalmente, porém a regra não funciona.

    Se eu ativar a regra manualmente tendo conexão com a internet, funciona.

    Se eu ativar manualmente ou via netwatch sem conexão com a internet, o NAT não funciona, compreendeste?

  4. Não funciona porque para redirecionar você precisaria ter roteamento, por isso a regra não funciona, como você está sem internet você não chega nem a resolver dns, abrir conexão, nada, então por isso a regra não funciona, tem uma solução para isso, mas não estou lembrado onde vi, vou procurar e assim que achar posto aqui pra você.



  5. marcelbentes, vou ficar aguardando então!






Tópicos Similares

  1. erro de logon no samba
    Por TonTux no fórum Servidores de Rede
    Respostas: 3
    Último Post: 26-08-2003, 20:08
  2. erro de instalação no conectiva 9
    Por Trapper no fórum Servidores de Rede
    Respostas: 2
    Último Post: 22-08-2003, 13:02
  3. erro de dns no squid
    Por no fórum Servidores de Rede
    Respostas: 3
    Último Post: 27-06-2003, 08:54
  4. Erro de parâmetro no Script logon.bat
    Por ATNunes no fórum Servidores de Rede
    Respostas: 4
    Último Post: 06-12-2002, 10:35
  5. Erro de arquivo no linux
    Por Claudemir no fórum Servidores de Rede
    Respostas: 1
    Último Post: 28-10-2002, 11:29

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L