Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Procurando achei que alguns estão conseguindo utilizar o Dyndns no Mikrotik porem no meu está dando erro:

    [admin@MikroTik] > system script run Dyndns
    interrupted
    Authentication Failure

    Porem o usuário e senha estão corretos pois claro que logando diretamente no site do dyndns.org estão funcionando.


    Segue meu Script Dyndns:

    :global ddnsuser "conta"
    :global ddnspass "senha"
    :global ddnshost "cliente.dyndns.org"


    :global ddnssystem ("mt-" . [/system package get [/system package find name=system] version] )
    :global ddnsip [ /ip address get [/ip address find interface=$ddnsinterface] address ]
    :global ddnslastip


    :if ([:len [/interface find name=$ddnsinterface]] = 0 ) do={ :log info "DDNS: No interface named $ddnsinterface, please check configuration." }


    :if ([ :typeof $ddnslastip ] = "nothing" ) do={ :global ddnslastip 0.0.0.0/0 }


    :if ([ :typeof $ddnsip ] = "nothing" ) do={


    :log info ("DDNS: No ip address present on " . $ddnsinterface . ", please check.")


    } else={


    :if ($ddnsip != $ddnslastip) do={


    :log info "DDNS: Sending UPDATE!"
    :log info [ ut [/tool dns-update name=$ddnshost address=[ick $ddnsip 0 [:find $ddnsip "/"] ] key-name=$ddnsuser key=$ddnspass ] ]
    :global ddnslastip $ddnsip


    } else={


    :log info "DDNS: No changes necessary."


    }


    }



    Não achei ninguém falando sobre: Authentication Failure

    Abraços.

  2. Nuss procurei em ... vejo que em cada Atualização da RB muda algumas coisas, bem estou utilizando a v5.15 e funcionou com o seguinte script:

    # Set needed variables
    :local username "conta"
    :local password "senha"
    :local hostname "cliente.dyndns.org"


    :global dyndnsForce


    # print some debug info
    #:log info ("UpdateDynDNS: username = $username")
    #:log info ("UpdateDynDNS: password = $password")
    #:log info ("UpdateDynDNS: hostname = $hostname")


    # get the current IP address from the internet (in case of double-nat)
    /tool fetch mode=http address="checkip.dyndns.org" src-path="/" dst-path="/dyndns.checkip.html"
    :local result [/file get dyndns.checkip.html contents]


    # parse the current IP result
    :local resultLen [:len $result]
    :local startLoc [:find $result ": " -1]
    :set startLoc ($startLoc + 2)
    :local endLoc [:find $result "</body>" -1]
    :local currentIP [ick $result $startLoc $endLoc]
    :log info "UpdateDynDNS: currentIP = $currentIP"


    #get IP from DynDNS for our hostname
    :local resolvedIP [:resolve $hostname]
    :log info ("UpdateDynDNS: resolved IP =$resolvedIP")


    # Remove the # on next line to force an update every single time - useful for debugging, but you could end up getting blacklisted by DynDNS!
    #:set dyndnsForce true


    # Determine if dyndns update is needed
    # more dyndns updater request details available at http://www.dyndns.com/developers/specs/syntax.html
    :if (($currentIP != $resolvedIP) || ($dyndnsForce = true)) do={
    :set dyndnsForce false
    /tool fetch user=$username password=$password mode=http address="members.dyndns.org" src-path="/nic/update?hostname=$hostname&myip=$currentIP" dst-path="/dyndns.txt"
    :local result [/file get dyndns.txt contents]
    :log info ("UpdateDynDNS: Dyndns update needed")
    :log info ("UpdateDynDNS: Dyndns Update Result: ".$result)
    ut ("Dyndns Update Result: ".$result)
    } else={
    :log info ("UpdateDynDNS: No dyndns update needed")
    }



  3. Use um simples

    este aqui funciona 100%

    coloca o nome run DDNS

    #int-DDNS.Info
    /tool dns-update name=dominio ddns address=127.0.0.255 key-name=login dns key="senha dns"



    logo depois disso vc vai em

    Scheduler
    Name: DNS
    Interval: (coloca o tempo que quer meu caso 00:05:00

    On Event: /system script run DDns

    ai a cada 5 minutos o seu mk irá fazer a consulta ddns
    utilize o changeip

  4. Aqui no meu funciona usando o changeip.com, já testei em várias rbs e todas estão funcionando, sem dizer que o script é bem simples e funcional.
    Minha versão: 4.11 rb750g


    /tool dns-update name=seu_endereco.changeip.net address=127.0.0.255 key-name=LOGIN key="SENHA"
    [/tool dns-update]



  5. Citação Postado originalmente por Idevaldo Ver Post
    Aqui no meu funciona usando o changeip.com, já testei em várias rbs e todas estão funcionando, sem dizer que o script é bem simples e funcional.
    Minha versão: 4.11 rb750g

    /tool dns-update name=seu_endereco.changeip.net address=127.0.0.255 key-name=LOGIN key="SENHA"
    [/tool dns-update]

    Amigo para não ficar poluindo topico com respostas repetidas, de uma olhada na regra que postei, sempre leia a regra que vai utilizar ou vai informar outro companheiro,
    é a mesma regra, apenas duplicou






Tópicos Similares

  1. DynDNS NO MIKROTIK COM DOIS MODENS ROTEADOS
    Por Aislan no fórum Redes
    Respostas: 6
    Último Post: 03-07-2015, 15:49
  2. Respostas: 14
    Último Post: 18-06-2008, 10:34
  3. Dyndns No-IP no Mikrotik teria como
    Por Jonatanmcc no fórum Redes
    Respostas: 2
    Último Post: 01-05-2008, 00:59
  4. DynDNS ou NO-IP no Mikrotik.... como??
    Por alanvictorjp no fórum Redes
    Respostas: 51
    Último Post: 23-03-2008, 21:20
  5. 2 link no Mikrotik
    Por fleubert no fórum Redes
    Respostas: 8
    Último Post: 13-10-2005, 19:14

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L