+ Responder ao Tópico



  1. #1

    Padrão Como descobrir qual mascara de rede usar para um determinado IP

    Seguinte com o loadbalance sei que é necessário adicionar alguns serviços por rotas estáticas principalmente os serviços de bancos e vi aqui no forum que a melhor forma de fazer esse procedimento é configurando por IP. Bom o problema é que existem diferentes serviços e eles usam diferentes IPs e Mascaras ai é que entra a minha dúvida. Como fazer para descobrir se a mascara de um determinado IP é /24 ou /16.
    Ex: O bradesco utiliza da seguinte forma 200.155.0.0/16 e o globo vídeos 201.7.176.0/20 e essa 186.192.82.0/24.

    Então eu pergunto como faço pra saber a mascara de um IP > 69.171.242.74 que é do (www.facebook.com) que tipo de mascara seria atribuida a este tipo de IP ( 16/ 24 30 e etc)?

  2. #2

    Padrão Re: Como descobrir qual mascara de rede usar para um determinado IP

    Se você usa Linux, FreeBSD ou OSX é simples:
    Primeiro:
    Código :
    ping www.facebook.com
    Anote o ip e depois:
    Código :
    whois 69.171.247.37
    Resultado parcial:
    Código :
    NetRange:       69.171.224.0 - 69.171.255.255
    CIDR:           69.171.224.0/19



  3. #3

    Padrão Re: Como descobrir qual mascara de rede usar para um determinado IP

    Ou use em seu Windows no navegador o site http://tools.whois.net/whoisbyip/ coloca o IP e verá
    NetRange: 69.171.224.0 - 69.171.255.255CIDR: 69.171.224.0/19

    /19 viu ai.... Abraço

  4. #4

    Padrão Re: Como descobrir qual mascara de rede usar para um determinado IP

    Perdão galera esqueci de especificar uso o Mikrotik e em especial uma RB 750 fazendo loadbalance.

    Mais o que estou precisando é justamente essa ferramenta que está nesse site que o leoservice postou..

    vou testar e posto os resultados.

    Obrigado a todos..



  5. #5

    Padrão Re: Como descobrir qual mascara de rede usar para um determinado IP

    Então galera estou testando aqui há alguns minutos e está funcionando como eu esperava. O que precisva era saber o endereço de rede do serviço para que eu definisse uma rota estática para tal, em anexo uns prints.
    Clique na imagem para uma versão maior

Nome:	         1 Marcar Rotas.jpg
Visualizações:	286
Tamanho: 	27,6 KB
ID:      	37228Clique na imagem para uma versão maior

Nome:	         2 Marcar Rostas.jpg
Visualizações:	301
Tamanho: 	31,9 KB
ID:      	37229Clique na imagem para uma versão maior

Nome:	         3 Marcas Rotas.jpg
Visualizações:	219
Tamanho: 	18,3 KB
ID:      	37230

  6. #6

    Padrão Re: Como descobrir qual mascara de rede usar para um determinado IP

    Mais uma vez obrigado a todos



  7. #7

    Padrão Re: Como descobrir qual mascara de rede usar para um determinado IP

    Que bom que deu certo, no que precisar tamos ai! Obrigado pela reputação

  8. #8

    Padrão Re: Como descobrir qual mascara de rede usar para um determinado IP

    Um Serviço Legal
    http://www.robtex.com/



  9. #9

    Padrão Re: Como descobrir qual mascara de rede usar para um determinado IP

    veja esse link ai meu rei eu sempre vou no cmd, dou um ping para o site, pego o ip, e coloco para buscar nesse site bgp http://bgp.he.net/ip

  10. #10

    Padrão Re: Como descobrir qual mascara de rede usar para um determinado IP

    Vi aqui, bom também o http://tools.whois.net/whoisbyip/ que o leoservice postou acima funciona assim também, o chato é só ter que ficar pingando pra ver as alterações de ip que tem mais ta ai. funcionou... e se fosse fácil não teria graça não é ??

    Obrigado pela dica, esse site também vai ficar aqui nos favoritos..
    ABraço!!



  11. #11

    Padrão Re: Como descobrir qual mascara de rede usar para um determinado IP

    Muito bom esse Robotex também ele tabalha bem os serviços em cada IP.

  12. #12
    Moderador Avatar de gamineiro
    Ingresso
    Jan 2008
    Localização
    RS
    Posts
    423
    Posts de Blog
    2

    Padrão Re: Como descobrir qual mascara de rede usar para um determinado IP

    Citação Postado originalmente por duh182 Ver Post
    veja esse link ai meu rei eu sempre vou no cmd, dou um ping para o site, pego o ip, e coloco para buscar nesse site bgp http://bgp.he.net/ip
    Bom dia,

    Para quem trabalha com BGP, é praticamente impressindível visitar esse site. Nele você encontra tudo sobre o esquema de roteamento de todos os ASs do mundo.

    Quem está ligado em quem, quais os prefixos anunciados, quais os clientes AS, qual a política de roteamento. Muito interessante mesmo.

    Segue um exemplo do mapa da Embratel.

    http://bgp.he.net/AS4230#_graph4

    Abraço



  13. #13

    Padrão Re: Como descobrir qual mascara de rede usar para um determinado IP

    Bom dia amigao BitPC, muito interessante seu post. Vou ti falar meu problema aqui.
    Ja uso as rotas estaticas p/ alguns sites, como o da globo.com como voce citou. Acontece que, o primeiro video, toda de boa, normalmente, ai, nao sei se voce ja reparou mais logo abaixo do video que voce esta assistindo, tem outros videos relacionados, ai quando quando clico em um desses videos relacionados, da um erro na pagina, Bad Gateway.

    Nao sei se tem alguma coisa relacionado c/ o balance ou algum coisa c/ o site.

    Obrigado.

  14. #14

    Padrão Re: Como descobrir qual mascara de rede usar para um determinado IP

    Velho aqui funciona normal, tive problema quando estava testando o speedr cache mais foi só tirar e voltou ao normal.

    Eu uso esses regras aqui para o globo vídeos

    /ip firewall mangle
    add action=mark-routing chain=prerouting comment="Globo Videos" disabled=no \
    dst-address=201.7.176.0/20 new-routing-mark=globo_videos passthrough=yes
    add action=mark-routing chain=prerouting disabled=no dst-address=\
    186.192.82.0/24 new-routing-mark=globo_videos passthrough=yes
    add action=mark-routing chain=prerouting disabled=no dst-address=\
    186.192.80.0/24 new-routing-mark=globo_videos passthrough=yes
    add action=mark-routing chain=prerouting disabled=no dst-address=\
    74.209.160.0/24 new-routing-mark=globo_videos passthrough=yes


    /ip route
    add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.10.1
    routing-mark=globo_videos scope=30 target-scope=10


    Dá uma olhada ae e dê uma verificada também caso você use algum cache pode ser ele também...



  15. #15

    Padrão Re: Como descobrir qual mascara de rede usar para um determinado IP

    Obrigado por responder amigão!

    Essa rota aqui: /ip route
    add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.10.1
    routing-mark=globo_videos scope=30 target-scope=10

    A parte em vermelho que destaquei, o gateway. É o que exatamente, o ip de saida p/ o servidor mikrotik ?

    Agradeço...

  16. #16

    Padrão Re: Como descobrir qual mascara de rede usar para um determinado IP

    Não esse é um dos IPs de saída de um dos links... vai pra um modem...



  17. #17

    Padrão Re: Como descobrir qual mascara de rede usar para um determinado IP

    Ah tah entendi. Então no meu caso, vou direcionar a rota p/ meu link dedicado, apontando o gateway dele.

    Valeu amigão, obrigado.
    Abraço...

  18. #18

    Padrão Re: Como descobrir qual mascara de rede usar para um determinado IP




  19. #19

    Padrão Re: Como descobrir qual mascara de rede usar para um determinado IP

    Bom galera, testei ambos os sites sugeridos por todos:
    http://tools.whois.net/whoisbyip/
    http://www.robtex.com/
    http://bgp.he.net/ip
    http://ipcalc.com.br

    Na minha opinião o mais eficiênte foi o sugerido pelo amigo RickBrito, o www.ipcalc.com.br

    Acho que é até o mais indicado p/ nós que somos clientes das operadoras nacionais.

    Abraço...