+ Responder ao Tópico



  1. #1

    Padrão Mikrotik Script Monitorar velocidade da interface e mandar alerta por e-mail

    Bom dia,

    Quem usa produtos UBNT saberá a necessidade deste script. Utilizo Routerboards RB 1100 em todas as minhas torres, os rádios são UBNT rocket M5. Acontece que do nada a interface do Mikrotik cai para 10Mbps e os clientes começam a reclamar de lentidão, já tentei setar no ubnt fixo em 100 mbps, mas quando faço isso o rádio trava de vez e ainda é pior.

    Pensei o seguinte...

    Um script que roda de 10 em 10 minutos varrendo as interfaces, quando encontrar alguma em 10Mbps ele cria um log e envia por email....

    Alguém poderia me ajudar...? de forma voluntário ou comercial mesmo.

  2. #2

    Padrão Re: Mikrotik Script Monitorar velocidade da interface e mandar alerta por e-mail

    Olha eu não tenho este script... acredito que até seja possivel de implementar, mas acho melhor você ir diretamente na causa:

    - Cabo de rede de má qualidade, ou não apropriado para tal aplicação;
    - Conectores RJ-45, idem item acima;
    - TOMADA, a fase necessariamente deverá estar do lado direito da tomada.

    Quando ao cabo e conector, procure usar da Ubiquiti ou AMP e aterre-os.

    95% de chance de resolver seus problemas.



  3. #3

    Padrão Re: Mikrotik Script Monitorar velocidade da interface e mandar alerta por e-mail

    pode ser fonte poe com problema fazer script nao resolve o problema.

  4. #4
    Pronto Para Ajudar!!! Avatar de mjmmarcus2
    Ingresso
    Jun 2012
    Localização
    Paulista Pernambuco
    Posts
    428

    Padrão Re: Mikrotik Script Monitorar velocidade da interface e mandar alerta por e-mail

    Conflito de IP tambem causa esse tipo de problema, revise os ips de seus equipamentos, todos devem estar diferentes.



  5. #5

    Padrão Re: Mikrotik Script Monitorar velocidade da interface e mandar alerta por e-mail

    Caro Mauricio,

    Tive este mesmo tipo de problema, sendo que ele foi sanado com a nova versão de firmeware dos equipamentos UBNT, experimente atualizar o seu equipamento para a versão mas estável.

  6. #6

    Padrão Re: Mikrotik Script Monitorar velocidade da interface e mandar alerta por e-mail

    Vejam bem, tudo que foi recomendado já foi testado, inclusive uso cabos da UBNT com conectores aterrados, com fonte original, com fonte alternativa.. e conclui que este problema é recorrente (com poucas incidências, mas existem). Com swcthi isso quase não existe mas ainda sim acontece.

    O script é apenas um alerta que me avisará quando interface entrar em modo 10Mbps, não é resolver o problema, é apenas para alarmar por email que o problema esta ocorrendo, e demandar um ajuste mais preciso...

    Até eletroduto de carbono eu já usei para se ter uma idéia. Mas vez ou outra o problema acontece. Já testei com PathPanel com cabo de 100 pares.

    Este é um problema e pronto. E o problema não é na iface do mikrotik, e sim na iface do Rocket. Pois só conectar e desconectar que volta a funcionar normalmente, continuo investigando as possíveis causas. Tanto em ambientes moderados como em ambientes hostis onde tenho torre.

    Mas no momento antes de encontrar uma solução eu preciso monitorar as interfaces... Alguém pode me ajudar ai?



  7. #7
    André Andrade*MikrotikRio Avatar de interhome
    Ingresso
    Oct 2008
    Localização
    Brasil.
    Posts
    1.094
    Posts de Blog
    15

    Padrão Re: Mikrotik Script Monitorar velocidade da interface e mandar alerta por e-mail

    Segue uma dica:

    /tool netwatch

    add comment="Testa Comunicacao com Ubnt" disabled=no down-script="/interface e\
    thernet disable ether3-ubnt;\r\
    \n:log error \"INTERFACE UBNT PERDENDO PACOTE ESTA SENDO DESATIVADA\";\r\
    \n\r\
    \n/interface ethernet enable ether3-ubnt;\r\
    \n:log warning \"INTERFACE UBNT ATIVADA\";" host=3.3.3.3 interval=1m \
    timeout=1s up-script=""

    Instrução:
    host=3.3.3.3 ---> coloque o Ip do seu equipamento ligado ao mikrotik
    ether3-ubnt ---> Coloque o nome da interface mikrotik a ser testada

    Raciocinio:
    Quando a sua situação fica em estado critico. A latência aumenta. Nesta hora desabilitamos, jogamos uma mensagem no Log em vermelho.
    Apos, Habilitamos e jogamos outra mensagem no Log em azul.
    Manipule o Timeout conforme a sua necessidade.

    Atendendo essa sua necessidade, fazemos com que seja enviada por email.

    Espero que lhe ajude.

  8. #8

    Padrão Re: Mikrotik Script Monitorar velocidade da interface e mandar alerta por e-mail

    Essa solução caro interhome não se aplica a minha necessidade. O que pretendo é identificar a velocidade da iface e não se ela esta ou não on-line.



  9. #9

    Padrão Re: Mikrotik Script Monitorar velocidade da interface e mandar alerta por e-mail

    Começando a desvendar a coisa, até aqui conseguimos identificar qual o rate da interface, mas ainda não é oq eu desejo.. estamos chegando lá. No script abaixo tenho que setar individualmente cada interface que desejo monitorar, no entanto como vou usar o script em diversas rbs preciso que ele seja genérico, que identifica as ifaces, varra as mesmas e encontrando as com rate 10 mande um email.

    :global u
    /interface ethernet monitor ether1, ether2 once do={ :set u $rate }
    :if ($u = "10Mbps") do={
    :log error message="interface LAN esta em 10Mbits"
    /tool e-mail send subject="Interface em 10Mbis" [email protected] body="interface LAN esta em 10Mbits" tls=yes
    }

  10. #10
    André Andrade*MikrotikRio Avatar de interhome
    Ingresso
    Oct 2008
    Localização
    Brasil.
    Posts
    1.094
    Posts de Blog
    15

    Padrão Re: Mikrotik Script Monitorar velocidade da interface e mandar alerta por e-mail

    Citação Postado originalmente por mauriciodelima Ver Post
    Essa solução caro interhome não se aplica a minha necessidade. O que pretendo é identificar a velocidade da iface e não se ela esta ou não on-line.
    Infelismente o Sr. não entendeu o raciocinio proposto.
    Conselho: Coloque na sua Rb que o mesmo funcionará como "anjo da guarda" fazendo com que haja uma nova negociação na interface que esta perdendo pacotes.
    De qualquer forma espero que no ao menos agradeça. Segue abaixo o seu serviço finalizado. Caso necessite de alguma melhoria, estou a disposição.
    #Script ETHERNET-Check v0.1
    #
    #Lista as ethernet que estao com velocidades negociadas igual u (10Mbps)
    #
    # Autor: Andre Andrade <[email protected]>
    # 15/08/2012 - 23:25pm
    #
    #Instrucoes de uso:
    # -- Adicionar o codigo completo em SYSTEM >> SCRIPTS
    # -- Por padrao o script nao vai derrubar nenhuma interface.
    # -- O script pode ser executado pelo botao "run script" ou via linha de comando.
    # "/ system script run <nome do script>
    # -- Testado nas versoes 5.13
    #
    #Informacoes:
    #
    #Variavel u -> valor que sera usado para rastreamento entre as interfaces ATIVAS.


    :global v
    :foreach i in=[ /interface ethernet find running] do={
    :local intname [ / interface ethernet get $i name ];
    :log warning (" Interface: " . $intname);
    /interface ethernet monitor $intname once do={ :set v $rate }
    :if ($v = "10Mbps") do={
    :log error message="interface LAN esta em 10Mbits";
    /tool e-mail send subject="Interface em 10Mbis" [email protected] body="interface LAN esta em 10Mbits" tls=yes
    };
    };



  11. #11

    Padrão Re: Mikrotik Script Monitorar velocidade da interface e mandar alerta por e-mail

    Primeiramente muito obrigado interhome, pelo empenho e no resultado do excelente trabalho. Abaixo dei uma pinceladinha no script para dar uma melhoramento estético e funcional na informação.

    #Script ETHERNET-Check v0.2
    #
    #Lista as ethernet que estao com velocidades negociadas igual u (10Mbps)
    #
    # Autor: Andre Andrade <[email protected]>
    # 15/08/2012 - 23:25pm
    #Colaborador Maurício de lima <[email protected]>
    #20/08/2012 - 10:52am
    #
    #Instrucoes de uso:
    # -- Adicionar o codigo completo em SYSTEM >> SCRIPTS
    # -- Por padrao o script nao vai derrubar nenhuma interface.
    # -- O script pode ser executado pelo botao "run script" ou via linha de comando.
    # "/ system script run <nome do script>
    # -- Testado nas versoes 5.13
    #
    #Informacoes:
    #
    #Variável v -> valor que sera usado para rastreamento entre as interfaces ATIVAS.




    :global v
    :global data [/system clock get date]
    :global hora [/system clock get time]
    :global host [/system identity get name]
    :foreach i in=[ /interface ethernet find running] do={
    :local intname [ / interface ethernet get $i name ];
    #:log warning (" Interface: " . $intname);




    /interface ethernet monitor $intname once do={ :set v $rate }
    :if ($v = "10Mbps") do={
    :log error message="interface $intname esta em 10Mbps";
    /tool e-mail send subject="Interface em 10Mbps em $host em $data ($hora)" [email protected] body="Corrigir interface LAN ($intname) que esta em 10Mbits" tls=yes
    };
    };
    O email esta chegando beleza, porém chega 1 email para cada interface listada com 10 mbps, e talvez fosse mais interessante se colocássemos para enviar um único email e no body listasse todas as iterfaces com problema, mas isso é o de menos. No resto ficou show de bola demais.