Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão quando ativo a regra do cache os clientes nao conectam.

    bom tarde galera,
    Estou mudando minha rede de bridge para roteada, ja fiz as rotas para as RBs na torres, todas estao autenticando com pppoe via radius e navegando normalmente. mas quando eu aplico a regra de redirecionamento para o cache (speedr) niguem consegue mais conectar nas RB's das torres, mas quem estiver conectado funciona normal, navegacao e cache, mas se o mesmo se desconectar e tentar reconectar nao consegue.
    Estou usando as mesmas regras q utilizava com o cache em bridge, e funcionava perfeitamente.
    uso as regras q esta no site do Speedr http://speedr.com.br/forum/view?id=352

    Com certeza tem algo errado nessas regras para minha topologia!
    alguem poderia me dar uma ajuda, desde ja agradeço.
    segue topologia da rede em anexo.
    att
    Marcelo

    Clique na imagem para uma versão maior

Nome:	         topologia rede.jpg
Visualizações:	480
Tamanho: 	23,0 KB
ID:      	38233

  2. #2

    Padrão Re: quando ativo a regra do cache os clientes nao conectam.

    Está utilizando TPROXY, IP Publico?
    Verifique as regras de NAT.
    Roteando corretamente os blocos dentro da rede?

    Não tem nada de errado nessa topologia, pode até mudar mas errado não.



  3. #3

    Padrão Re: quando ativo a regra do cache os clientes nao conectam.

    O problema são as regras, essas regras q o pessoal da speedr não estão corretas!!

  4. #4

    Padrão Re: quando ativo a regra do cache os clientes nao conectam.

    Citação Postado originalmente por rogeriodj Ver Post
    O problema são as regras, essas regras q o pessoal da speedr não estão corretas!!
    Será? Não trabalho com Speedr, pois sou consultor N!moc mas assim como nós consultores deixamos o cache funcionando, acredito que o pessoal de lá também faz isso!



  5. #5

    Padrão Re: quando ativo a regra do cache os clientes nao conectam.

    mto obrigado pela ajuda,
    nao utilizo t-proxy, acho q as regras de bloco estao certas, pq se eu desativar as regras de cache no servidor-mk tdo funciona normalmente.
    vou postar as regras:

    servidor-Mk: 10.0.0.1/30
    speedR: 10.10.10.2/30
    mk-auth: 172.31.255.2/30
    RB-2011: 10.0.0.2/30

    clientes: 20.0.0.2/24




    Servidor-MK

    /ip route
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    192.168.88.1 scope=30 target-scope=10
    add comment="" disabled=no distance=1 dst-address=20.0.0.1/32 gateway=\
    10.0.0.2 scope=30 target-scope=10

    /ip address
    add address=192.168.88.3/27 broadcast=192.168.88.31 comment="" disabled=no \
    interface=internet network=192.168.88.0
    add address=172.31.255.1/30 broadcast=172.31.255.3 comment="" disabled=no \
    interface=mk-auth network=172.31.255.0
    add address=10.10.10.1/30 broadcast=10.10.10.3 comment="" disabled=no \
    interface=cache network=10.10.10.0
    add address=10.0.0.1/30 broadcast=10.0.0.3 comment="" disabled=no interface=\
    cliente01 network=10.0.0.0

    /ip firewall address-list
    add address=10.0.0.0/16 comment="" disabled=no list=intranet
    add address=10.0.0.0/16 comment="" disabled=no list=speedr-redirect


    /ip firewall mangle
    add action=mark-connection chain=prerouting comment="Marca Conex\E3o SpeedR" \
    disabled=no dst-address-list=!intranet dst-port=80 new-connection-mark=\
    connmarkspeedr-redirect passthrough=yes protocol=tcp src-address-list=\
    speedr-redirect
    add action=mark-packet chain=postrouting comment="dscp-> 12" disabled=no \
    dscp=12 new-packet-mark=packet_speedr_HIT passthrough=no
    add action=mark-packet chain=postrouting comment="dscp-> 10" disabled=no \
    dscp=10 new-packet-mark=packet_speedr_HIT passthrough=no
    add action=mark-packet chain=postrouting comment="dscp-> 48" disabled=no \
    dscp=48 new-packet-mark=packet_speedr_HIT passthrough=no
    /ip firewall nat
    add action=masquerade chain=srcnat comment="Internet para Servidor-mk" \
    disabled=no out-interface=internet
    add action=dst-nat chain=dstnat comment="Redirect para SpeedR" \
    connection-mark=connmarkspeedr-redirect disabled=no dst-address-list=\
    !intranet protocol=tcp to-addresses=10.10.10.2 to-ports=3128
    add action=masquerade chain=srcnat comment="Mascaramento Intranet" disabled=\
    no dst-address=!10.10.10.2 src-address-list=intranet
    add action=masquerade chain=srcnat comment="Mascaramento SpeedR" disabled=no \
    dst-address-list=!intranet src-address=10.10.10.2





    ***************************************************
    RB-2011


    /ip route
    add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=10.0.0.1 scope=30 target-scope=10

    /ip address
    add address=10.0.0.2/30 disabled=no interface=link-servidorMK network=10.0.0.0
    add address=20.0.0.1/24 disabled=no interface=clientes network=20.0.0.0




    /ip firewall nat
    add action=masquerade chain=srcnat disabled=no out-interface=link-servidorMK




    mto obrigado novamente,

  6. #6

    Padrão Re: quando ativo a regra do cache os clientes nao conectam.

    Farias, eles fazem, mas custa 350,00 a consultoria.



  7. #7

    Padrão Re: quando ativo a regra do cache os clientes nao conectam.

    Se precisar de suporte me mande uma MP amigo, que resolvo pra vc bem mais enconta q eles !!
    Citação Postado originalmente por modorizzi Ver Post
    Farias, eles fazem, mas custa 350,00 a consultoria.

  8. #8

    Padrão Re: quando ativo a regra do cache os clientes nao conectam.

    Rogerio, vc tá querendo briga com o Henrique, hein??? Enfiou na cabeça que as regras do pessoal da Speedr não funcionam ou estão erradas.

    Uso o Speedr e as regras deles funcionam perfeitamente e, sinceramente, pra minha topologia, NÃO HÁ NADA DE ERRADO COM ELAS.

    Vou te dar um conselho: Faz isso não! Em vez disso, diz que você tem umas regras melhores ou que descobriu um redirecionamento mais otimizado pro Speedr.

    Ficar dizendo que os outros não sabem fazer e que fazem errado não vai te ajudar em nada.

    Abraços,
    Jonas Lima



  9. #9

    Padrão Re: quando ativo a regra do cache os clientes nao conectam.

    To não, mais isso é a realidade, ja cancei de pegar pessoas com rede parada ou lenta, e advinha, estava usando aquelas regras, como o amigo que abriu esse post.
    Será onde esta o erro?
    Simplismente mudei as regras e advinha, so sussego e rde rapida, mais vc ta certo, tenho de deixar isso pra la, se virem pessoal, ou pessam suporte a equipe do speedr!!

    Citação Postado originalmente por jlima2001 Ver Post
    Rogerio, vc tá querendo briga com o Henrique, hein??? Enfiou na cabeça que as regras do pessoal da Speedr não funcionam ou estão erradas.

    Uso o Speedr e as regras deles funcionam perfeitamente e, sinceramente, pra minha topologia, NÃO HÁ NADA DE ERRADO COM ELAS.

    Vou te dar um conselho: Faz isso não! Em vez disso, diz que você tem umas regras melhores ou que descobriu um redirecionamento mais otimizado pro Speedr.

    Ficar dizendo que os outros não sabem fazer e que fazem errado não vai te ajudar em nada.

    Abraços,
    Jonas Lima

  10. #10

    Padrão Re: quando ativo a regra do cache os clientes nao conectam.

    Li meio corrido mas creio que esteja redirecionando até o acesso do radius para o cache, e ele não está encontrando o servidor radius. Por isso que quem está conectado continua navegando.



  11. #11

    Padrão Re: quando ativo a regra do cache os clientes nao conectam.

    Citação Postado originalmente por rogeriodj Ver Post
    O problema são as regras, essas regras q o pessoal da speedr não estão corretas!!
    E verdade, com as regras do forum da speed so tive dor de cabeça, mas com regras de outros colegas a coisa rodou do jeito que tem que ser.

  12. #12

    Padrão Re: quando ativo a regra do cache os clientes nao conectam.

    Leandrovaranda, tbem acho q é isso, mas nao sei como fazer o acesso do radius passar por fora do cache, vc pode me dar uma dica, ou algum material sobre ?

    valeu, mto obrigado.

    jlima2011, concordo com vc, as regras do henrique nao tem nda de errado, pelo menos pra mim, sempre use aquelas regras em modo brigde e funcionava perfeitamente.



  13. #13

    Padrão Re: quando ativo a regra do cache os clientes nao conectam.

    Citação Postado originalmente por modorizzi Ver Post
    Leandrovaranda, tbem acho q é isso, mas nao sei como fazer o acesso do radius passar por fora do cache, vc pode me dar uma dica, ou algum material sobre ?

    valeu, mto obrigado.

    jlima2011, concordo com vc, as regras do henrique nao tem nda de errado, pelo menos pra mim, sempre use aquelas regras em modo brigde e funcionava perfeitamente.





    Parece que é só fazer um bypass, vou colar uma resposta de outro forúm.

    Na versão 0.8.0 RC4 é possível cadastrar na lista de excessões em Controle de acesso

    Respostas

    http://www.speedr.com.br/image.php?i...&cropratio=1:1
    Guilherme Alves

    Developer
    Há 4 mesesBasta nao redirecionaf o trafego que tenha como DESTINO seu bloco de IPs internos.



    http://www.speedr.com.br/image.php?i...&cropratio=1:1
    Henrique Fernandes Silveira

    Developer

    Há 4 mesesÉ bem simples, adicione este parâmetro ao comando da regra dst-nat:
    dst-address-list=!speedr-bypassAdiciona a regra de dst-nat com o parametro acima, depois basta adicionar os ips que quer fora do cache da address-list "speedr-bypass"!




    http://www.speedr.com.br/images/thumbs/n.gif
    Bruno Souza Queiros


    Há 2 anosseguem as regras RApahel====================================================================================== ip firewall nat add action=masquerade chain=srcnat comment="Masquerade intranet" disabled=no \ dst-address=!ip speedr dst-address-list=!no-cache src-address-list=\ intranet/ip firewall address-list add address=200.217.70.40 comment="" disabled=no list=intranet

    Ai qualquer url que der problema basta adiciona-lo ao no-cache.Abraços

    http://www.speedr.com.br/images/thumbs/n.gif
    Bruno Souza Queiros


    Há 2 anosCorrigindono final da regra gigante coloca no-cache

    http://www.speedr.com.br/images/thumbs/n.gif
    Rogério Vilar Portela Aguiar


    Há 2 anosMas se não me engane no speedr tem essa funcionalidade, nunca usei e nem sei se é mesmo, maaaass veja na foto anexa!Anexos: speed.PNG

    http://www.speedr.com.br/image.php?i...&cropratio=1:1
    Edmilson Almeida


    Há 2 anos( se seu redirecionamento for via NAT) coisa mais facil do mundo. Se precisar de suporte entre em contato./ip firewall nat add action=dst-nat chain=dstnat comment="" disabled=yes dst-address=!10.10.10.2 dst-address-list=NO_CACHE dst-port=80 \ protocol=tcp src-address=1.1.1.0/24 to-addresses=10.10.10.2 to-ports=3128/ip firewall address-list add address=www.ligadajustica.com.br comment=Nome do site disabled=no list=NO_CACHEIP THUNDER: 10.10.10.2RANGER DA REDE: 1.1.1.0/24Lembrando que isso é so um exemplo.
    Última edição por leandrovaranda; 18-08-2012 às 12:17. Razão: Acrescentar detalhes

  14. #14

    Padrão Re: quando ativo a regra do cache os clientes nao conectam.

    wesleydialmeida,

    vc conseguiu fazer funcionar o cache com o roteamento nas torres? vc poderia me como conseguiu ?
    obrigado



  15. #15

    Padrão Re: quando ativo a regra do cache os clientes nao conectam.

    Leandro valeu cara, vou testar ai posto se deu certo.
    mto obrigado

  16. #16

    Padrão Re: quando ativo a regra do cache os clientes nao conectam.

    Citação Postado originalmente por modorizzi Ver Post
    bom tarde galera,
    Estou mudando minha rede de bridge para roteada, ja fiz as rotas para as RBs na torres, todas estao autenticando com pppoe via radius e navegando normalmente. mas quando eu aplico a regra de redirecionamento para o cache (speedr) niguem consegue mais conectar nas RB's das torres, mas quem estiver conectado funciona normal, navegacao e cache, mas se o mesmo se desconectar e tentar reconectar nao consegue.
    Estou usando as mesmas regras q utilizava com o cache em bridge, e funcionava perfeitamente.
    uso as regras q esta no site do Speedr http://speedr.com.br/forum/view?id=352

    Com certeza tem algo errado nessas regras para minha topologia!
    alguem poderia me dar uma ajuda, desde ja agradeço.
    segue topologia da rede em anexo.
    att
    Marcelo

    Clique na imagem para uma versão maior

Nome:	         topologia rede.jpg
Visualizações:	480
Tamanho: 	23,0 KB
ID:      	38233


    tentei faser dessa regra aqui http://speedr.com.br/forum/view?id=352 e esta tudo errado , entao o rodrigo alve me deu uma força e feis as configuração , me passa o seu msn q eu te passo as regras , posso te mandas em tudi em Print, e ae fica melhor pra vc amigo mais lembrano eu estou usanoa qui mais nao estou gostano nao so sistema do speedr , eu acho q eu vou fica com o meu squid mesmo ,



  17. #17

    Padrão Re: quando ativo a regra do cache os clientes nao conectam.

    Citação Postado originalmente por alyssonbmx Ver Post
    tentei faser dessa regra aqui http://speedr.com.br/forum/view?id=352 e esta tudo errado , entao o rodrigo alve me deu uma força e feis as configuração , me passa o seu msn q eu te passo as regras , posso te mandas em tudi em Print, e ae fica melhor pra vc amigo mais lembrano eu estou usanoa qui mais nao estou gostano nao so sistema do speedr , eu acho q eu vou fica com o meu squid mesmo ,

    ow brother, mto grato pela força, - [email protected]
    quanto ao speedr esse é primeiro sistema de cache q estou usando, acho q agora sai um versao estavel, quero testar o n!moc em breve.
    vlw

  18. #18

    Padrão Re: quando ativo a regra do cache os clientes nao conectam.

    Citação Postado originalmente por modorizzi Ver Post
    ow brother, mto grato pela força, - [email protected]
    quanto ao speedr esse é primeiro sistema de cache q estou usando, acho q agora sai um versao estavel, quero testar o n!moc em breve.
    vlw
    cola a regra aqui para mais gente ver. Ou vai cobrar do cara a solução?



  19. #19

    Padrão Re: quando ativo a regra do cache os clientes nao conectam.

    Citação Postado originalmente por leandrovaranda Ver Post
    cola a regra aqui para mais gente ver. Ou vai cobrar do cara a solução?
    Leandro, estou esperando o Alysson me passar essas regras, vou testar e depois posto tudo aqui p ajudar o resto da cambada q esta com essa dificuldade.

  20. #20

    Padrão Re: quando ativo a regra do cache os clientes nao conectam.

    citei o cara errado, mas acho que deu para entender.
    Acho complicado essa questão da pessoa só responder via MP ou no e-mail de quem perguntou, quando vamos procurar no fórum achamos os tópicos relacionados, lemos ele inteiro e acabamos sem a resposta.
    Aprovo a atitude do modorizzi de colar a solução aqui.