+ Responder ao Tópico



  1. Iai galera do Under, blzura?!?!
    Preciso de um help. Por favor.
    Tenho uma RB 450G configurada com Load Balance PCC com dois links de 2MBs.

    Dados:
    Ether1 = WAN link ISP1
    Ether2 = WAN link ISP2
    Ether3 = LAN
    Ether4 = vaga
    Ether5 = vaga
    -------------------------------------------
    IPs do ISP1: /29
    200.216.202.xx8 = Rede
    200.216.202.xx9 = Gateway
    200.216.202.xx0 = IP válido
    200.216.202.xx1 = IP válido
    200.216.202.xx2 = IP válido
    200.216.202.xx3 = IP válido
    200.216.202.xx4 = IP válido
    200.216.202.xx5 = Broadcast
    -------------------------------------------
    IPs do ISP2: /29
    189.80.143.xx8 = Rede
    189.80.143.xx9 = Gateway
    189.80.143.xx0 = IP válido
    189.80.143.xx1 = IP válido
    189.80.143.xx2 = IP válido
    189.80.143.xx3 = IP válido
    189.80.143.xx4 = IP válido
    189.80.143.xx5 = Broadcast
    -------------------------------------------
    IPs LAN: 10.0.0.1/8
    --------------------------------------------
    Abaixo segue um desenho da minha atual infra.:
    Clique na imagem para uma versão maior

Nome:	         Cenário atual.jpg
Visualizações:	659
Tamanho: 	38,5 KB
ID:      	38238

    GRANDE PROBLEMA:

    - Segurança Zero, pois meus servidores com acesso externo estão ligados diretamente ao switch1 e meu Proxy está em meio a minha LAN e não na borda, ou seja, estou sem controle.


    Abaixo segue um desenho da infra que desejo.:
    Clique na imagem para uma versão maior

Nome:	         Cenário desejável.jpg
Visualizações:	323
Tamanho: 	42,5 KB
ID:      	38239

    DÚVIDAS:

    - É possível implementar tal cenário?
    Se sim:
    - Como faço para repassar os IPs Reais sem dividir a classe de IP e sem usar o redirecionamento por firewall, ou seja, configurar o IP Real no próprio servidor? Pois dividindo perco muitos IPs e redirecionando por firewall teria que habitar as regras manualmente toda vez que um link parar.
    - É possível fazer o Load Balance PCC para a rede interna colocando o Proxy antes da LAN e configurando IP Real no mesmo?
    Se não:
    - Qual seria minha solução? Sendo que preciso ter disponibilidade externa e segurança nos servidores e controle sobre a LAN.


    Configuração atual da minha RB 450G:

    /ip pool
    add name=dhcp_pool1 ranges=10.0.0.2-10.255.255.254

    /ip dhcp-server
    add add-arp=yes address-pool=dhcp_pool1 bootp-support=static disabled=no \
    interface=ether3 lease-time=3d name=DHCP_SERVER

    /ip dhcp-server config
    set store-leases-disk=5m

    /ip dhcp-server network
    add address=10.0.0.0/8 dhcp-option="" dns-server="" gateway=10.0.0.200 \
    ntp-server="" wins-server=""

    /ip address
    add address=200.216.202.xx0/29 comment=Link_Telemar disabled=no interface=\
    ether1 network=200.216.202.xx8
    add address=189.80.143.xx0/29 comment=Link_Pontenet disabled=no interface=\
    ether2 network=189.80.143.xx8
    add address=10.0.0.1/8 comment=Lan disabled=no interface=ether3 network=\
    10.0.0.0

    /ip dns
    set allow-remote-requests=no cache-max-ttl=1w cache-size=2048KiB \
    max-udp-packet-size=4096 servers=200.222.0.34,177.47.192.10

    /ip firewall address-list
    add address=10.0.0.xxx disabled=no list=Sem_Balance

    /ip firewall mangle
    add action=accept chain=prerouting comment=PCs_Sem_Load_Balance disabled=no \
    in-interface=ether3 src-address-list=Sem_Balance
    add action=mark-connection chain=prerouting comment=Load_Balance \
    connection-state=new disabled=no in-interface=ether3 new-connection-mark=\
    Con_Tel passthrough=yes per-connection-classifier=\
    both-addresses-and-ports:2/0
    add action=mark-connection chain=prerouting connection-state=new disabled=no \
    in-interface=ether3 new-connection-mark=Con_Pon passthrough=yes \
    per-connection-classifier=both-addresses-and-ports:2/1
    add action=mark-routing chain=prerouting connection-mark=Con_Tel disabled=no \
    in-interface=ether3 new-routing-mark=Rota_Tel passthrough=no
    add action=mark-routing chain=prerouting connection-mark=Con_Pon disabled=no \
    in-interface=ether3 new-routing-mark=Rota_Pon passthrough=no

    /ip firewall nat
    add action=masquerade chain=srcnat comment=NAT_Masquerad disabled=no \
    src-address=10.0.0.0/8

    /ip route
    add comment=Rota_Para_Balanceamento disabled=yes distance=1 dst-address=\
    0.0.0.0/0 gateway=200.216.202.xx9 routing-mark=Rota_Tel scope=30 \
    target-scope=10
    add disabled=yes distance=2 dst-address=0.0.0.0/0 gateway=189.80.143.xx9 \
    routing-mark=Rota_Pon scope=30 target-scope=10
    add comment=Rota_Tel_Para_PCs_Sem_Balanceamento disabled=no distance=3 \
    dst-address=0.0.0.0/0 gateway=200.216.202.xx9 scope=30 target-scope=10
    add comment=Rota_Pon_Para_PCs_Sem_Balanceamento disabled=no distance=3 \
    dst-address=0.0.0.0/0 gateway=189.80.143.xx9 scope=30 target-scope=10

    /system ntp client
    set enabled=yes mode=unicast primary-ntp=200.160.0.8 secondary-ntp=\
    200.189.40.8

    -------------------------------------------------------------------------------------------


    Galera, desde já agradeço a todos pela ajuda.

    Obrigado...!!!

  2. PCC ou per-connection-classifier, como o nome diz é direcionado a conexão, você pode fazer um PCC parcial para algumas portas ou determinado tipo de trafego/serviço e utilizar o balanceamento por rotas para disponibilizar os ips aos clientes.

    Ou ainda, utilizar o PCC como padrão geral, e manter alguns clientes fora do PCC utilizando rotas para que saiam por determinado IP/link.





  3. m4d3, vlw pela ajuda.

    Mas como faria o pcc somente para a LAN e ao mesmo tempo repassar IP válido para os servidores?
    Só pra constar, não sou expert em mikrotik, apenas o basico do basico. hehe

    Obrigado...!!!

  4. Opáa.. Iai galera, Mais alguém poderia me ajudar....???

    Estou precisando muito...

    Obrigado...






Tópicos Similares

  1. Load balance pcc com links ip dinamico , como fazer?
    Por julinribeiro no fórum Redes
    Respostas: 21
    Último Post: 25-10-2017, 08:41
  2. Respostas: 7
    Último Post: 19-10-2012, 09:13
  3. Repasse de IPs Validos
    Por emanochio no fórum Redes
    Respostas: 12
    Último Post: 09-11-2010, 07:30
  4. Servidor para Repasse de IP Válido
    Por UsadosMAC no fórum Redes
    Respostas: 5
    Último Post: 06-04-2010, 08:22
  5. Respostas: 7
    Último Post: 18-03-2008, 10:02

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L